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Warranty
The material contained in this document is 
provided "as is," and is subject to being 
changed, without notice, in future editions. 
Further, to the maximum extent permitted 
by applicable law, Keysight disclaims all 
warranties, either express or implied, with 
regard to this manual and any information 
contained herein, including but not limited 
to the implied warranties of 
merchantability and fitness for a particular 
purpose. Keysight shall not be liable for 
errors or for incidental or consequential 
damages in connection with the furnishing, 
use, or performance of this document or of 
any information contained herein. Should 
Keysight and the user have a separate 
written agreement with warranty terms 
covering the material in this document that 

conflict with these terms, the warranty 
terms in the separate agreement shall 
control.

Technology License

The hardware and/or software described in 
this document are furnished under a license 
and may be used or copied only in 
accordance with the terms of such license.

U.S. Government Rights
The Software is "commercial computer 
software," as defined by Federal Acquisition 
Regulation ("FAR") 2.101. Pursuant to FAR 
12.212 and 27.405-3 and Department of 
Defense FAR Supplement ("DFARS") 
227.7202, the U.S. government acquires 
commercial computer software under the 
same terms by which the software is 
customarily provided to the public. 
Accordingly, Keysight provides the Software 
to U.S. government customers under its 
standard commercial license, which is 
embodied in its End User License Agreement 
(EULA), a copy of which can be found at 
www.keysight.com/find/sweula. The 
license set forth in the EULA represents the 
exclusive authority by which the U.S. 
government may use, modify, distribute, or 
disclose the Software. The EULA and the 
license set forth therein, does not require or 
permit, among other things, that Keysight: 
(1) Furnish technical information related to 
commercial computer software or 
commercial computer software 
documentation that is not customarily 
provided to the public; or (2) Relinquish to, 
or otherwise provide, the government rights 
in excess of these rights customarily 
provided to the public to use, modify, 
reproduce, release, perform, display, or 
disclose commercial computer software or 
commercial computer software 
documentation. No additional government 
requirements beyond those set forth in the 
EULA shall apply, except to the extent that 
those terms, rights, or licenses are explicitly 
required from all providers of commercial 
computer software pursuant to the FAR and 
the DFARS and are set forth specifically in 
writing elsewhere in the EULA. Keysight 
shall be under no obligation to update, 
revise or otherwise modify the Software. 
With respect to any technical data as 
defined by FAR 2.101, pursuant to FAR 

12.211 and 27.404.2 and DFARS 227.7102, 
the U.S. government acquires no greater 
than Limited Rights as defined in FAR 27.401 
or DFAR 227.7103-5 (c), as applicable in any 
technical data.

Safety Notices
This product has been designed and tested 
in accordance with accepted industry 
standards, and has been supplied in a safe 
condition. The documentation contains 
information and warnings that must be 
followed by the user to ensure safe 
operation and to maintain the product in a 
safe condition.

CAUTION

A CAUTION notice denotes a hazard. 
It calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or 
adhered to, could result in damage 
to the product or loss of important 
data. Do not proceed beyond a 
CAUTION notice until the indicated 
conditions are fully understood and 
met.

WARNING

A WARNING notice denotes a 
hazard. It calls attention to an 
operating procedure, practice, or 
the like that, if not correctly 
performed or adhered to, could 
result in personal injury or death. 
Do not proceed beyond a WARNING 
notice until the indicated 
conditions are fully understood and 
met.

http://www.keysight.com/find/sweula
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InfiniiVision M9241/42/43A PXIe Oscilloscopes—At a Glance

The Keysight InfiniiVision M9241/42/43A PXIe oscilloscopes deliver these features:

• 200 MHz, 500 MHz, and 1 GHz bandwidth models.

• 2-channel digital storage oscilloscope (DSO) models.

• Interleaved 4 Mpts or non-interleaved 2 Mpts MegaZoom IV memory for the 
fastest waveform update rates, uncompromised.

• Trigger types: edge, edge then edge, pulse width, pattern, OR, rise/fall time, 
Nth edge burst, runt, setup & hold, video, NFC, and zone.

• Serial decode/trigger options for: CAN/CAN FD/LIN, CXPI, FlexRay, I2C, 
Manchester/NRZ, MIL-STD-1553/ARINC 429, SENT, UART/RS232, and 
USB PD. There is a Lister for displaying serial decode packets.

• Math waveforms: add, subtract, multiply, divide, d/dt, integrate, FFT 
(Magnitude), FFT (Phase), Ax+B, square, square root, absolute value, common 
logarithm, natural logarithm, exponential, base 10 exponential, low pass filter, 

Table 1 InfiniiVision M9241/42/43A PXIe Oscilloscope Models, Bandwidths, Sample Rates

Bandwidth 200 MHz 500 MHz 1 GHz

Sample Rate 5 GSa/s 5 GSa/s 5 GSa/s

2-Channel DSO M9241A M9242A M9243A
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high pass filter, averaged value, smoothing, envelope, magnify, maximum, 
minimum, peak-peak, max hold, min hold, and measurement trend.

• Reference waveform locations (2) for comparing with other channel or math 
waveforms.

• Many built-in measurements and a measurement statistics display.

• Built-in, license-enabled 1-channel waveform generator with: arbitrary, sine, 
square, ramp, pulse, DC, noise, sine cardinal, exponential rise, exponential fall, 
cardiac, and Gaussian pulse. Modulated waveforms on WaveGen except for 
arbitrary, pulse, DC, and noise waveforms.

• A Quick Help system is built into the oscilloscope. Click and hold the mouse 
button over any softkey label button to display Quick Help. Complete 
instructions for using the quick help system are given in "Access the Built-In 
Quick Help" on page 21.

For more information about InfiniiVision oscilloscopes, see: 
www.keysight.com/find/scope

http://www.keysight.com/find/scope
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In This Guide
This guide shows how to use the InfiniiVision M9241/42/43A PXIe oscilloscope's 
Soft Front Panel (SFP) user interface.

When first using the Soft Front Panel 
(SFP) user interface, see:

• Chapter 1, “Getting Started,” starting on page 19

When displaying waveforms and 
acquired data, see:

• Chapter 2, “Horizontal Controls,” starting on page 35

• Chapter 3, “Vertical Controls,” starting on page 51

• Chapter 4, “Math Waveforms,” starting on page 65

• Chapter 5, “Reference Waveforms,” starting on page 
101

• Chapter 6, “Serial Decode,” starting on page 109

• Chapter 7, “Display Settings,” starting on page 115

• Chapter 8, “Labels,” starting on page 127

When setting up triggers or changing 
how data is acquired, see:

• Chapter 9, “Triggers,” starting on page 133

• Chapter 10, “Trigger Mode/Coupling,” starting on 
page 175

• Chapter 11, “Acquisition Control,” starting on page 
183

Making measurements and analyzing 
data:

• Chapter 12, “Cursors,” starting on page 203

• Chapter 13, “Measurements,” starting on page 211

• Chapter 14, “Mask Testing,” starting on page 247

• Chapter 15, “Digital Voltmeter and Counter,” starting 
on page 261

• Chapter 16, “Frequency Response Analysis,” starting 
on page 267

When using the built-in license 
enabled waveform generator, see:

• Chapter 17, “Waveform Generator,” starting on page 
273

When saving or recalling, see: • Chapter 18, “Save/Email/Recall (Setups, Screens, 
Data),” starting on page 293

When using the oscilloscope's utility 
functions, see:

• Chapter 19, “Utility Settings,” starting on page 305
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For reference information, see: • Chapter 20, “Reference,” starting on page 319

When using licensed serial bus 
triggering and decode features, see:

• Chapter 21, “CAN/LIN Triggering and Serial Decode,” 
starting on page 333

• Chapter 22, “CXPI Triggering and Serial Decode,” 
starting on page 355

• Chapter 23, “I2C Triggering and Serial Decode,” 
starting on page 365

• Chapter 24, “Manchester/NRZ Triggering and Serial 
Decode,” starting on page 375

• Chapter 25, “MIL-STD-1553/ARINC 429 Triggering 
and Serial Decode,” starting on page 393

• Chapter 26, “SENT Triggering and Serial Decode,” 
starting on page 409

• Chapter 27, “UART/RS232 Triggering and Serial 
Decode,” starting on page 421

• Chapter 28, “USB PD Triggering and Serial Decode,” 
starting on page 431

TIP Abbreviated instructions for selecting menus and softkeys

Instructions for selecting a series of menus and softkey label buttons are written in an 
abbreviated manner. Instructions for selecting Menu Item1, Menu Item2, then Softkey1 and 
Softkey2 are abbreviated as follows:

Choose Main Menu > Menu Item1 > Menu Item2 > Softkey1 > Softkey2.

Softkey label buttons are the six buttons located at the bottom of the Soft Front Panel 
oscilloscope display.
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1 Getting Started
 

See the Startup Guide

See the Startup Guide for the following "getting started" topics:

• Installing oscilloscope modules into the PXIe chassis and installing software.

• Opening the M924xA oscilloscope Soft Front Panel (SFP)

• Connecting probes to the oscilloscope

• Inputting a signal

• Recalling the default oscilloscope setup

• Using Autoscale

• Compensating passive probes

• Learning the oscilloscope display

The Startup Guide also has this reference information:

• Environmental conditions

• Probes and accessories information

• Product specification and characteristics

For the latest version of the Startup Guide manual, see: 
www.keysight.com/manuals/M9241A

http://www.keysight.com/manuals/M9241A
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Using the Soft Front Panel (SFP) Interface

The Keysight InfiniiVision M924xA SFP has the same user interface as other 
benchtop Keysight InfiniiVision oscilloscopes. While benchtop oscilloscopes have 
keys, softkeys, and knobs—obviously different than the modular oscilloscopes—the 
display interface was also designed to be used with touch screens and connected 
USB mice, and it is just as easy to use with a mouse on the Windows operating 
system.

The main differences between using the interface on a benchtop oscilloscope and 
a modular oscilloscope are:

• Instead of pressing front panel keys to open softkey menus, you use the top-left 
blue (Menu) button.

• Instead of pressing softkeys, you click the softkey label buttons.

• Instead of turning knobs to adjust scales, offsets, delay positions, trigger levels, 
and cursor positions, there are clickable up/down, increase/decrease icon 
buttons that appear after clicking these values. Also, you can drag waveforms, 
trigger levels, and cursors. If there is a scroll wheel on the mouse, you can use it 
to make adjustments like a knob.

Access the Built-In Quick Help

Soft Front Panel (SFP) help for the PXIe oscilloscope is different than in a 
traditional Windows application. Instead of a Windows HTML Help file you access 
through a Help menu, the PXIe oscilloscope's SFP help is the same quick help 
information that is built-in to benchtop InfiniiVision oscilloscopes.

To access the built-in quick help, press and hold the left-mouse button over a 
softkey label button.
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1 Getting Started
 

Quick Help remains on the screen until you close the help dialog box or open 
another one.

Select the User Interface Language

Another benefit of having the same user interface as benchtop InfiniiVision 
oscilloscopes is that you have a localized user interface and built-in quick help.

To select the user interface language:

1 Choose (Menu) > Help Menu.

2 In the Help Menu, click the Language softkey label button.

3 In the Language popup menu, select the desired language.

The following languages are available: Czech, English, French, German, Italian, 
Japanese, Korean, Polish, Portuguese, Russian, Simplified Chinese, Spanish, Thai, 
Traditional Chinese, and Turkish.
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Differences Between PXIe and Benchtop Oscilloscopes

The Keysight InfiniiVision M9241/42/43A PXIe oscilloscope feature set is most 
similar to the InfiniiVision 3000T X-Series benchtop oscilloscope. For comparison, 
the differences in the M9241/42/43A PXIe oscilloscopes are:

• Two analog channels in a module (3000T X-Series oscilloscopes can have two 
or four analog channels).

• No digital channels (or pods, buses, or Bus Timing or Bus State math 
functions).

• No demo signals.

• Adds Ref I/O MMCX connector (like the 4000 X-Series oscilloscope's 10 MHz 
REF BNC connector).

• Adds the precision measurements and math functions feature.

• Transparent backgrounds for dialog boxes are not available.

• When saving screen images, invert and grayscale options are not available.

• No dedicated FFT function, but you can choose FFT math function operations.

• Adds FFT Phase math function (to previous FFT Magnitude math function).

• There are new analysis and measurement capabilities for the FFT Magnitude 
math function.

• No Line source for edge trigger.

• No USB triggering.

• No external input on pattern trigger (just the two analog channels).

• Single-lane decoding supported for IIC and UART/RS-232.

• No support for I2S, SPI, or FlexRay serial decode and triggering.

• No external source is allowed for serial bus sources (as compared to DSO 
models of the 3000T X-Series).

• The optional Frequency Response Analysis feature is available.

• No printer setup from within the SFP interface.

• In benchtop oscilloscopes, you can access internal storage memory or external 
memory on USB storage devices. In the PXIe oscilloscopes, all storage memory 
is on the chassis controller PC, and there is no distinction between internal and 
external storage locations.

• There is no Secure Erase feature in the PXIe oscilloscopes because non-volatile 
memory is on the chassis controller PC.

• System dates and times are set by the PXIe chassis controller PC.

• Calibration protect is a softkey control instead of a physical button.
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• Licenses are installed and managed using the Keysight License Manager. On 
benchtop oscilloscopes, licenses are loaded from .lic files on a USB storage 
device using the File Explorer.
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Learn the Mouse Controls

In the Soft Front Panel (SFP) user interface, you can control the oscilloscope with a 
mouse by clicking and dragging different areas of the user interface. You can:

• "Access Controls and Menus Using the Main Menu Icon" on page 25

• "Draw Rectangles for Waveform Zoom or Zone Trigger Set Up" on page 27

• "Drag to Scale, Position, and Change Offset" on page 27

• "Select Sidebar Information or Controls" on page 28

• "Undock Sidebar Dialog Boxes by Dragging" on page 29

• "Re-dock Sidebar Dialog Boxes to a Split Sidebar" on page 30

• "Select Dialog Box Menus and Close Dialog Boxes" on page 30

• "Drag Cursors" on page 30

• "Click Softkeys and Menus On the Screen" on page 31

• "Enter Names Using Alpha-Numeric Keypad Dialog Boxes" on page 31

• "Change Waveform Offsets By Dragging Ground Reference Icons" on page 32

• "Turn Channels On/Off and Open Scale/Offset Dialog Boxes" on page 32

• "Access the Horizontal Menu and Open the Scale/Delay Dialog Box" on 
page 33

• "Access the Trigger Menu, Change the Trigger Mode, and Open the Trigger 
Level Dialog Box" on page 33

Access Controls and Menus Using the Main Menu Icon

1 Click the upper-left menu icon to open the main menu.

2 Click left side controls to perform oscilloscope operations.
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3 Click menu items and submenu items to access menus and additional controls.
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Draw Rectangles for Waveform Zoom or Zone Trigger Set Up

1 Click the upper-right corner to select the rectangle draw mode.

2 Drag the mouse pointer across the screen to draw a rectangle.

3 Release the mouse key.

4 Click the desired option from the popup menu.

Drag to Scale, Position, and Change Offset

1 Click the upper-right corner to select the horizontal drag mode.
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2 When the waveform drag mode is selected, you can:

• Drag — drag the mouse pointer across the screen to change the horizontal 
delay. Drag a waveform up or down to change the vertical offset.

To select waveforms, click them. The waveform closest horizontally to the click 
location is selected. The selected waveform is indicated by the ground marker 
with the filled background (channel 1 in the following example).

Select Sidebar Information or Controls

1 Click the blue menu icon in the sidebar.

2 In the popup menu, click the type of information or controls you want to see in 
the sidebar.
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Undock Sidebar Dialog Boxes by Dragging

Sidebar dialog boxes can be undocked and placed anywhere on the screen.

1 Drag the sidebar dialog box title wherever you like.

This lets you view multiple types of information or controls at the same time.
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Re-dock Sidebar Dialog Boxes to a Split Sidebar

Sidebar dialog boxes can be re-docked to either half or full height of the sidebar.

1 Drag the dialog box title back to the desired sidebar target.

You can display two dialog boxes in the sidebar at the same time.

Select Dialog Box Menus and Close Dialog Boxes

• Click the blue menu icon in the dialog box for options.

• Click the red "X" icon to close a dialog box.

Drag Cursors

When "Manual" cursors mode is selected, you can drag the cursor name handles 
to position them.
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Click Softkeys and Menus On the Screen

• Click softkey label buttons to select them.

• When softkeys provide menus, click to select a menu item.

Enter Names Using Alpha-Numeric Keypad Dialog Boxes

Some softkey label buttons open alpha-numeric dialog boxes that let you enter 
names using a mouse or keyboard.
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Change Waveform Offsets By Dragging Ground Reference Icons

You can drag ground icons to change a waveform's vertical offset.

Turn Channels On/Off and Open Scale/Offset Dialog Boxes

• Click channel numbers to turn them on or off.
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• When channels are on, click the scale and offset values to access a dialog box 
for changing them.

Access the Horizontal Menu and Open the Scale/Delay Dialog Box

• Click "H" to access the Horizontal Menu.

• Click the horizontal scale and delay values to access a dialog box for changing 
them.

Access the Trigger Menu, Change the Trigger Mode, and Open the Trigger 
Level Dialog Box

• Click "T" to access the Trigger Menu.
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• Click the trigger level value(s) to access a dialog box for changing the level(s).

• Click "Auto" or "Trig'd" to quickly toggle the trigger mode.
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2 Horizontal Controls

To adjust the horizontal (time/div) scale / 37
To adjust the horizontal delay (position) / 38
Panning and Zooming Single or Stopped Acquisitions / 39
To change the horizontal time mode (Normal, XY, or Roll) / 40
To display the zoomed time base / 43
To change the horizontal scale coarse/fine adjustment setting / 45
To position the time reference (left, center, right, custom) / 46
Searching for Events / 47
Navigating the Time Base / 49

The horizontal controls include:

• The H button or Main Menu > Setup > Horizontal Menu menu item for accessing the 
Horizontal Menu.

• The horizontal scale and delay dialog box.

• The Main Menu > Setup > Zoom Mode menu item or Zoom softkey button for 
quickly enabling/disabling the split-screen zoom display.

• The Main Menu > Analyze > Waveform Search menu item for finding events on 
analog channels or in serial decode.

• The sidebar Navigate controls for navigating time, search events, or segmented 
memory acquisitions.

The following figure shows the Horizontal Menu which appears after choosing Main 
Menu > Setup > Horizontal Menu.
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The Horizontal Menu lets you enable Zoom, set the time base fine control (vernier), 
and specify the time reference.

The current sample rate is displayed in the Summary box in the right-side 
information area.

Figure 1 Horizontal Menu
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To adjust the horizontal (time/div) scale

1 Click the horizontal scale value to access a dialog box for changing it. See 
"Access the Horizontal Menu and Open the Scale/Delay Dialog Box" on 
page 33.

Notice how the time/div information in the status line changes.

The ∇ symbol at the top of the display indicates the time reference point.

Changing the horizontal scale works while acquisitions are running or when they 
are stopped. When running, adjusting the horizontal scale changes the sample 
rate. When stopped, adjusting the horizontal scale lets you zoom into acquired 
data. See "Panning and Zooming Single or Stopped Acquisitions" on page 39.

Note that there are separate horizontal scale controls in the Zoom display. See "To 
display the zoomed time base" on page 43.
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To adjust the horizontal delay (position)

1 Click the horizontal delay value to access a dialog box for changing it. See 
"Access the Horizontal Menu and Open the Scale/Delay Dialog Box" on 
page 33.

You can also drag a waveform horizontally to change its delay. See "Drag to 
Scale, Position, and Change Offset" on page 27.

The trigger point moves horizontally, pausing at 0.00 s (mimicking a 
mechanical detent), and the delay value is displayed in the status line.

Changing the delay time moves the trigger point (solid inverted triangle) 
horizontally and indicates how far it is from the time reference point (hollow 
inverted triangle ∇). These reference points are indicated along the top of the 
display grid.

Figure 1 shows the trigger point with the delay time set to 200 µs. The delay time 
number tells you how far the time reference point is located from the trigger point. 
When delay time is set to zero, the delay time indicator overlays the time reference 
indicator.

All events displayed left of the trigger point happened before the trigger occurred. 
These events are called pre-trigger information, and they show events that led up 
to the trigger point.

Everything to the right of the trigger point is called post-trigger information. The 
amount of delay range (pre-trigger and post-trigger information) available 
depends on the time/div selected and memory depth.

Changing the horizontal position works while acquisitions are running or when 
they are stopped. When running, adjusting the horizontal delay changes the 
amount of pre- and post-trigger information. When stopped, adjusting the 
horizontal position lets you pan acquired data. See "Panning and Zooming Single 
or Stopped Acquisitions" on page 39.

Note that there are separate horizontal scale controls in the Zoom display. See "To 
display the zoomed time base" on page 43.
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Panning and Zooming Single or Stopped Acquisitions

When the oscilloscope is stopped, use the horizontal scale and position controls to 
pan and zoom your waveform. The stopped display may contain several 
acquisitions worth of information, but only the last acquisition is available for pan 
and zoom.

The ability to pan (move horizontally) and scale (expand or compress horizontally) 
an acquired waveform is important because of the additional insight it can reveal 
about the captured waveform. This additional insight is often gained from seeing 
the waveform at different levels of abstraction. You may want to view both the big 
picture and the specific little picture details.

The ability to examine waveform detail after the waveform has been acquired is a 
benefit generally associated with digital oscilloscopes. Often this is simply the 
ability to freeze the display for the purpose of measuring with cursors or printing 
the screen. Some digital oscilloscopes go one step further by including the ability 
to further examine the signal details after acquiring them by panning through the 
waveform and changing the horizontal scale.

There is no limit imposed on the scaling ratio between the time/div used to acquire 
the data and the time/div used to view the data. There is, however, a useful limit. 
This useful limit is somewhat a function of the signal you are analyzing.

NOTE Zooming into stopped acquisitions

The screen will still contain a relatively good display if you zoom-in horizontally by a factor of 
1000 and zoom-in vertically by a factor of 10 to display the information from where it was 
acquired. Remember that you can only make automatic measurements on displayed data.
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To change the horizontal time mode (Normal, XY, or Roll)

1 Click the H button or choose Main Menu > Setup > Horizontal Menu.

2 In the Horizontal Menu, click Time Mode; then, select:

• Normal — the normal viewing mode for the oscilloscope.

In the Normal time mode, signal events occurring before the trigger are 
plotted to the left of the trigger point (▼) and signal events after the trigger 
plotted to the right of the trigger point.

• XY — XY mode changes the display from a volts-versus-time display to a 
volts-versus-volts display. The time base is turned off. Channel 1 amplitude 
is plotted on the X-axis and Channel 2 amplitude is plotted on the Y-axis.

You can use XY mode to compare frequency and phase relationships 
between two signals. XY mode can also be used with transducers to display 
strain versus displacement, flow versus pressure, volts versus current, or 
voltage versus frequency.

Use the cursors to make measurements on XY mode waveforms.

For more information about using XY mode for measurements, refer to "XY 
Time Mode" on page 40.

• Roll — causes the waveform to move slowly across the screen from right to 
left. It only operates on time base settings of 50 ms/div and slower. If the 
current time base setting is faster than the 50 ms/div limit, it will be set to 
50 ms/div when Roll mode is entered.

In Roll mode there is no trigger. The fixed reference point on the screen is 
the right edge of the screen and refers to the current moment in time. Events 
that have occurred are scrolled to the left of the reference point. Since there 
is no trigger, no pre-trigger information is available.

If you would like to pause the display in Roll mode, choose Main Menu > 
Single. To clear the display and restart an acquisition in Roll mode, choose 
Main Menu > Single again.

Use Roll mode on low-frequency waveforms to yield a display much like a 
strip chart recorder. It allows the waveform to roll across the display.

XY Time Mode

The XY time mode converts the oscilloscope from a volts-versus-time display to a 
volts-versus-volts display using two input channels. Channel 1 is the X-axis input, 
channel 2 is the Y-axis input. You can use various transducers so the display could 
show strain versus displacement, flow versus pressure, volts versus current, or 
voltage versus frequency.
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Example This exercise shows a common use of the XY display mode by measuring the phase 
difference between two signals of the same frequency with the Lissajous method.

1 Connect a sine wave signal to channel 1, and a sine wave signal of the same 
frequency but out of phase to channel 2.

2 Choose Main Menu > Autoscale.

3 Click the H button or choose Main Menu > Setup > Horizontal Menu.

4 In the Horizontal Menu, click Time Mode and select "XY".

5 Center the signal on the display with the channel 1 and 2 offset controls. Use 
the channel 1 and 2 volts/div controls and the channel 1 and 2 Fine option to 
expand the signal for convenient viewing.

The phase difference angle (θ) can be calculated using the following formula 
(assuming the amplitude is the same on both channels):

6 Choose Main Menu > Measure > Cursors.

7 Set the Y2 cursor to the top of the signal, and set Y1 to the bottom of the 
signal.

Note the ΔY value at the bottom of the display. In this example, we are using 
the Y cursors, but you could have used the X cursors instead.

8 Move the Y1 and Y2 cursors to the intersection of the signal and the Y axis. 
Again, note the ΔY value.

Figure 2 XY time mode signals, centered on display
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9 Calculate the phase difference using the formula below.

For example, if the first ΔY value is 2.297 and the second ΔY value is 1.319:

Figure 3 Phase difference measurements, automatic and using cursors

sinθ = second ΔY
first ΔY

= 1.319
2.297; θ = 35.05 degrees of phase shift

NOTE Z-Axis Input in XY Display Mode (Blanking)

When you select the XY display mode, the time base is turned off. Channel 1 is the X-axis 
input, channel 2 is the Y-axis input, and the EXT TRIG IN is the Z-axis input. If you only want to 
see portions of the Y versus X display, use the Z-axis input. Z-axis turns the trace on and off 
(analog oscilloscopes called this Z-axis blanking because it turned the beam on and off). 
When Z is low (<1.4 V), Y versus X is displayed; when Z is high (>1.4 V), the trace is turned off.
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To display the zoomed time base

Zoom, formerly called Delayed sweep mode, is a horizontally expanded version of 
the normal display. When Zoom is selected, the display divides in half. The top 
half of the display shows the normal time/div window and the bottom half displays 
a faster Zoom time/div window.

The Zoom window is a magnified portion of the normal time/div window. You can 
use Zoom to locate and horizontally expand part of the normal window for a more 
detailed (higher-resolution) analysis of signals.

To turn on (or off) Zoom:

1 Choose Main Menu > Setup > Zoom Mode (or in the Horizontal Menu, click the 
Zoom softkey button).

The area of the normal display that is expanded is outlined with a box and the rest 
of the normal display is ghosted. The box shows the portion of the normal sweep 
that is expanded in the lower half.

These markers show the
beginning and end of the
Zoom window
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To change the time/div for the Zoom window, click the horizontal zoom scale value 
to access a dialog box for changing it. As you change the zoom scale, the zoomed 
window time/div is highlighted in the status line above the waveform display area. 
The Horizontal zoom scale control controls the size of the box.

The Horizontal zoom delay control sets the left-to-right position of the zoom 
window. The delay value, which is the time displayed relative to the trigger point) is 
momentarily displayed in the upper-right portion of the display when the zoom 
delay control is adjusted.

Negative delay values indicate you're looking at a portion of the waveform before 
the trigger event, and positive values indicate you're looking at the waveform after 
the trigger event.

For information about using zoom mode for measurements, refer to "To isolate a 
pulse for Top measurement" on page 221 and "To isolate an event for frequency 
measurement" on page 228.
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To change the horizontal scale coarse/fine adjustment setting

1 Select or clear the Fine control in the horizontal scale dialog box (or the Fine 
softkey in the Horizontal Menu) to toggle between fine and coarse adjustment 
of the horizontal scale.

When Fine is enabled, adjusting the horizontal scale changes the time/div 
(displayed in the status line at the top of the display) in smaller increments. The 
time/div remains fully calibrated when Fine is on.

When Fine is turned off, adjusting the horizontal scale changes the time/div 
setting in a 1-2-5 step sequence.



46 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

2 Horizontal Controls
 

To position the time reference (left, center, right, custom)

Time reference is the reference point on the display for delay time (horizontal 
position).

1 Click the H button or choose Main Menu > Setup > Horizontal Menu.

2 In the Horizontal Menu, click Time Ref; then, select:

• Left — the time reference is set to one major division from the left edge of the 
display.

• Center — the time reference is set to the center of the display.

• Right — the time reference is set to one major division from the right edge of 
the display.

• Custom Location — lets you place the time reference location at a percent of 
the graticule width (where 0% is the left edge and 100% is the right edge).

A small hollow triangle (∇) at the top of the display grid marks the position of the 
time reference. When delay time is set to zero, the trigger point indicator (▼) 
overlays the time reference indicator.

The time reference position sets the initial position of the trigger event within 
acquisition memory and on the display, with delay set to 0.

Adjusting the horizontal scale (sweep speed) expands or contracts the waveform 
about the time reference point (∇). See "To adjust the horizontal (time/div) scale" 
on page 37.

Adjusting the horizontal position in Normal mode (not Zoom) moves the trigger 
point indicator (▼) to the left or right of the time reference point (∇). See "To 
adjust the horizontal delay (position)" on page 38.
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Searching for Events

You can use the Search Menu to search for Edge, Pulse Width, Rise/Fall Time, 
Runt, Frequency Peaks, and Serial events on the analog channels.

Setting up searches (see "To set up searches" on page 47) is similar to setting up 
triggers. In fact, except for Frequency Peaks and Serial events, you can copy 
search setups to trigger setups and vice-versa (see "To copy search setups" on 
page 47).

Searches are different than triggers in that they use the measurement threshold 
settings instead of trigger levels.

Found search events are marked with white triangles at the top of the graticule, 
and the number of events found is displayed in the menu line just above the 
softkey labels.

To set up searches

1 Choose Main Menu > Analyze > Waveform Search.

2 In the Search Menu, click Search; then, select the search type.

3 Use the remaining softkeys to set up the selected search type.

In most cases, setting up searches is similar to setting up triggers:

• For setting up Edge searches, see "Edge Trigger" on page 137.

• For setting up Pulse Width searches, see "Pulse Width Trigger" on 
page 141.

• For setting up Rise/Fall Time searches, see "Rise/Fall Time Trigger" on 
page 148.

• For setting up Runt searches, see "Runt Trigger" on page 154.

• For setting up Frequency Peak searches, see "Searching for FFT Peaks" on 
page 79.

• For setting up Serial searches, see "Serial Trigger" on page 170 and 
"Searching Lister Data" on page 113.

Remember that searches use the measurement threshold settings instead of 
trigger levels. Use the Thresholds softkey in the Search Menu to access the 
Measurement Threshold Menu. See "Measurement Thresholds" on page 239.

To copy search setups

Except for Frequency Peak and Serial event search setups, you can copy search 
setups to trigger setups and vice-versa.

1 Choose Main Menu > Analyze > Waveform Search.

2 In the Search Menu, click Search; then, select the search type.
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3 Click Copy.

4 In the Search Copy Menu:

• Click Copy to Trigger to copy the setup for the selected search type to the 
same trigger type. For example, if the current search type is Pulse Width, 
clicking Copy to Trigger copies the search settings to the Pulse Width trigger 
settings and selects the Pulse Width trigger.

• Click Copy from Trigger to copy the trigger setup for the selected search type 
to the search setup.

• To undo a copy, click Undo Copy.

The softkeys in the Search Copy Menu may not be available when one of the 
settings cannot be copied or there is no trigger type that corresponds to the 
search type.
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Navigating the Time Base

You can use the sidebar Navigate controls to navigate through:

• Captured data (see "To navigate time" on page 49).

• Search events (see "To navigate search events" on page 49).

• Segments, when segmented memory acquisitions are turned on (see "To 
navigate segments" on page 50).

See "Select Sidebar Information or Controls" on page 28.

To navigate time

When acquisitions are stopped, you can use the navigation controls to play 
through the captured data.

1 Click the blue menu icon in the sidebar.

2 In the popup menu, click Navigate.

3 Click the button at the top of the Navigate sidebar dialog box; then, click 
-> Navigate Menu.

4 In the Navigate Menu, click Navigate; then, select Time.

5 Click the  navigation buttons to play backward, stop, or play forward 

in time. You can click the  or  buttons multiple times to speed up the 
playback. There are three speed levels.

To navigate search events

When acquisitions are stopped, you can use the navigation controls to go to found 
search events (set using Waveform Search, see "Searching for Events" on 
page 47).

1 Click the blue menu icon in the sidebar.

2 In the popup menu, click Navigate.

3 Click the button at the top of the Navigate sidebar dialog box; then, click 
-> Navigate Menu.

4 In the Navigate Menu, click Navigate; then, select Search.

5 Click the  back and forward buttons to go to the previous or next search 
event.

When searching Serial decode:

• You can click the  stop button to set or clear a mark.

• The Auto Zoom softkey specifies whether the waveform display is automatically 
zoomed to fit the marked row as you navigate.
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To navigate segments

When the segmented memory acquisition is enabled and acquisitions are stopped, 
you can use the navigation controls to play through the acquired segments.

1 Click the blue menu icon in the sidebar.

2 In the popup menu, click Navigate.

3 Click the button at the top of the Navigate sidebar dialog box; then, click 
-> Navigate Menu.

4 In the Navigate Menu, click Navigate; then, select Segments.

5 Click Play Mode; then, select:

• Manual — to play through segments manually.

In the Manual play mode:

• Click the  back and forward buttons to go to the previous or next 
segment.

• Click the  softkey to go to the first segment.

• Click the  softkey to go to the last segment.

• Auto — to play through segments in an automated fashion.

In the Auto play mode:

• Click the  navigation buttons to play backward, stop, or play 

forward in time. You can click the  or  buttons multiple times to 
speed up the playback. There are three speed levels.
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To turn waveforms on or off (channel or math) / 53
To adjust the vertical scale / 54
To adjust the vertical position / 55
To specify channel coupling / 56
To specify channel input impedance / 57
To specify bandwidth limiting / 58
To change the vertical scale coarse/fine adjustment setting / 59
To invert a waveform / 60
Setting Analog Channel Probe Options / 61

The vertical controls include:

• The 1 or 2 buttons for turning a channel on or off and accessing the channel's 
softkey menu.

• The vertical scale and position dialog boxes for each analog channel.

The following figure shows the Channel 1 Menu that appears after clicking the 
channel 1 button.
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The ground level of the signal for each displayed analog channel is identified by 
the position of the  icon at the far-left side of the display.

Channel,
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level

Trigger
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Trigger level
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Channel 2
ground
level
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To turn waveforms on or off (channel or math)

1 Click channel numbers to turn them on or off. See "Turn Channels On/Off and 
Open Scale/Offset Dialog Boxes" on page 32.

When a channel is on, its button is filled with the appropriate color.

NOTE Turning channels off

You must be viewing the menu for a channel before you can turn it off. For example, if channel 
1 and channel 2 are turned on and the menu for channel 2 is being displayed, to turn channel 
1 off, click 1 to display the channel 1 menu; then, click 1 again to turn channel 1 off.
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To adjust the vertical scale

1 When channels are on, click the scale value to access a dialog box for changing 
it. See "Turn Channels On/Off and Open Scale/Offset Dialog Boxes" on 
page 32.

The vertical scale controls change the analog channel scale in a 1-2-5 step 
sequence (with a 1:1 probe attached) unless fine adjustment is enabled (see "To 
change the vertical scale coarse/fine adjustment setting" on page 59).

The analog channel Volts/Div value is displayed in the status line.

The default mode for expanding the signal when you adjust the vertical scale is 
vertical expansion about the ground level of the channel; however, you can change 
this to expand about the center of the display. See "To choose "expand about" 
center or ground" on page 307.
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To adjust the vertical position

1 When channels are on, click the offset value to access a dialog box for 
changing it. See "Turn Channels On/Off and Open Scale/Offset Dialog Boxes" 
on page 32.

You can also drag a waveform vertically to change its offset. See "Change 
Waveform Offsets By Dragging Ground Reference Icons" on page 32.

The offset voltage value represents the voltage difference between the vertical 
center of the display and the ground level ( ) icon. It also represents the voltage 
at the vertical center of the display if vertical expansion is set to expand about 
ground (see "To choose "expand about" center or ground" on page 307).
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To specify channel coupling

Coupling changes the channel's input coupling to either AC (alternating current) or 
DC (direct current).

1 Click the desired channel button.

2 In the Channel Menu, click the Coupling softkey to select the input channel 
coupling:

• DC — DC coupling is useful for viewing waveforms as low as 0 Hz that do not 
have large DC offsets.

• AC — AC coupling is useful for viewing waveforms with large DC offsets.

When AC coupling is chosen, you cannot select the 50 Ohm input 
impedance mode. This is done to prevent damage to the oscilloscope.

AC coupling places a 10 Hz high-pass filter in series with the input 
waveform that removes any DC offset voltage from the waveform.

Note that Channel Coupling is independent of Trigger Coupling. To change trigger 
coupling see "To select the trigger coupling" on page 178.

TIP If the channel is DC coupled, you can quickly measure the DC component of the signal by 
simply noting its distance from the ground symbol.

If the channel is AC coupled, the DC component of the signal is removed, allowing you to use 
greater sensitivity to display the AC component of the signal.
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To specify channel input impedance

1 Click the desired channel number button.

2 In the Channel Menu, click Impedance; then, select either:

• 50 Ohm — matches 50 ohm cables commonly used in making high frequency 
measurements, and 50 ohm active probes.

When 50 Ohm input impedance is selected, it is displayed with the channel 
information on-screen.

When AC coupling is selected (see "To specify channel coupling" on 
page 56) or excessive voltage is applied to the input, the oscilloscope 
automatically switches to 1M Ohm mode to prevent possible damage.

• 1M Ohm — is for use with many passive probes and for general-purpose 
measurements. The higher impedance minimizes the loading effect of the 
oscilloscope on the device under test.

This impedance matching gives you the most accurate measurements because 
reflections are minimized along the signal path.

See Also • For more information on probing, visit: www.keysight.com/find/scope_probes

• Information about selecting a probe can be found in document number 
Keysight Oscilloscope Probes and Accessories Selection Guide (part number 
5989-6162EN), available at www.keysight.com.

NOTE When you connect an AutoProbe, self-sensing probe, or a compatible InfiniiMax probe, the 
oscilloscope automatically configures the analog input channels to the correct impedance.

http://www.keysight.com/find/scope_probes
http://literature.cdn.keysight.com/litweb/pdf/5989-6162EN.pdf
http://www.keysight.com
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To specify bandwidth limiting

1 Click the desired channel number button.

2 In the Channel Menu, click BW Limit to enable or disable bandwidth limiting.

When bandwidth limit is on, the maximum bandwidth for the channel is 
approximately 20 MHz. For waveforms with frequencies below this, turning 
bandwidth limit on removes unwanted high frequency noise from the waveform. 
The bandwidth limit also limits the trigger signal path of any channel that has BW 
Limit turned on.
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To change the vertical scale coarse/fine adjustment setting

1 Select or clear the Fine control in the vertical scale dialog box (or the Fine 
softkey in the Channel Menu) to toggle between fine and coarse adjustment of 
the vertical scale.

When Fine adjustment is selected, you can change the channel's vertical sensitivity 
in smaller increments. The channel sensitivity remains fully calibrated when Fine is 
on.

The vertical scale value is displayed in the status line at the top of the display.

When Fine is turned off, adjusting the volts/division changes the channel 
sensitivity in a 1-2-5 step sequence.
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To invert a waveform

1 Click the desired channel number button.

2 In the Channel Menu, click Invert to invert the selected channel.

When Invert is selected, the voltage values of the displayed waveform are inverted.

Invert affects how a channel is displayed. However, when using basic triggers, the 
oscilloscope attempts to maintain the same trigger point by changing trigger 
settings.

Inverting a channel also changes the result of any math function selected in the 
Waveform Math Menu or any measurement.
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Setting Analog Channel Probe Options

1 Click the probe's associated channel number button.

2 In the Channel Menu, click Probe to display the Channel Probe Menu.

This menu lets you select additional probe parameters such as attenuation 
factor and units of measurement for the connected probe.

The Channel Probe Menu changes depending on the type of probe connected.

For passive probes (such as the N2862A/B, N2863A/B, N2889A, N2890A, 
10073C, 10074C, or 1165A probes), the Probe Check softkey appears; it guides 
you through the process of compensating probes.

For some active probes (such as InfiniiMax probes), the oscilloscope can 
accurately calibrate its analog channels for the probe. When you connect a 
probe that can be calibrated, the Calibrate Probe softkey appears (and the probe 
attenuation softkey may change). See "To calibrate a probe" on page 63.

See Also • "To specify the channel units" on page 61

• "To specify the probe attenuation" on page 61

• "To specify the channel external scaling" on page 62

• "To specify the probe skew" on page 63

To specify the channel units

1 Click the probe's associated channel number button.

2 In the Channel Menu, click Probe.

3 In the Channel Probe Menu, click Units; then, select:

• Volts — for a voltage probe.

• Amps — for a current probe.

Channel sensitivity, trigger level, measurement results, and math functions will 
reflect the measurement units you have selected.

To specify the probe attenuation

The probe attenuation is set automatically if the oscilloscope can identify the 
connected probe.

The probe attenuation factor must be set properly for accurate measurement 
results.
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If you connect a probe that is not automatically identified by the oscilloscope, you 
can manually set the attenuation factor as follows:

1 Click the channel number button.

2 In the Channel Menu, click Probe.

3 In the Channel Probe Menu, click the Probe softkey until you have selected how 
you want to specify the attenuation factor, choosing either Ratio or Decibels.

4 Click the Probe softkey again to open a keypad dialog box where you can set the 
attenuation factor for the connected probe.

When measuring voltage values, the attenuation factor can be set from 0.001:1 to 
10000:1 in a 1-2-5 sequence.

When measuring current values with a current probe, the attenuation factor can 
be set from 10 V/A to 0.0001 V/A.

When specifying the attenuation factor in decibels, you can select values from 
-20 dB to 80 dB.

If Amps is chosen as the units and a manual attenuation factor is chosen, then the 
units as well as the attenuation factor are displayed above the Probe softkey.

To specify the channel external scaling

External scaling lets you apply additional gain and offset to the input channel to 
account for additional attenuators, adapters, etc., in the probing system.

1 Click the channel number button.

2 In the Channel Menu, press Probe.

3 In the Channel Probe Menu, click External Scaling.

4 In the Channel External Scaling Menu:

• Click Units and select Volts or Amps (same as in the previous Channel Probe 
Menu).

• Click External Scaling to enable or disable external scaling.

• Click External Gain and choose either Ratio or Decibels to select how you want 
to specify the attenuation factor. Then, scroll the mouse wheel (or click the 
softkey again for a keypad entry dialog) to specify the external gain value.

• Click External Offset and scroll the mouse wheel (or click the softkey again for 
a keypad entry dialog) to specify the external offset value.
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To specify the probe skew

When measuring time intervals in the nanoseconds (ns) range, small differences in 
cable length can affect the measurement. Use Skew to remove cable-delay errors 
between any two channels.

1 Probe the same point with both probes.

2 Click one of the probe's associated channel number button.

3 In the Channel Menu, click Probe.

4 In the Channel Probe Menu, click Skew twice; then, enter the desired skew 
value.

Each analog channel can be adjusted ±100 ns in 10 ps increments for a total of 
200 ns difference.

The skew setting is not affected by choosing Default Setup or Autoscale.

To calibrate a probe

The Calibrate Probe softkey guides you through the process of calibrating probes.

For certain active probes, such as InfiniiMax probes, the oscilloscope can 
accurately calibrate its analog channels for the probe. When you connect a probe 
that can be calibrated, the Calibrate Probe softkey in the Channel Probe Menu 
becomes active.

To calibrate one of these probes:

1 First, connect your probe to one of the oscilloscope channels.

This could be, for example, an InfiniiMax probe amplifier/probe head with 
attenuators attached.

2 Connect the probe to the Probe Comp terminal, and the probe ground to the 
ground terminal.

3 Click the probe's associated channel number button to turn the channel on (if 
the channel is off).

4 In the Channel Menu, click the Probe softkey.

5 In the Channel Probe Menu, the second softkey from the left is for specifying 
your probe head (and attenuation). Repeatedly click this softkey until the probe 
head selection matches the attenuator you are using.

The choices are:

NOTE When calibrating a differential probe, connect the positive lead to the Probe Comp terminal 
and the negative lead to the ground terminal. You may need to connect an alligator clip to the 
ground lug to allow a differential probe to span between the Probe Comp test point and 
ground. A good ground connection ensures the most accurate probe calibration.
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• 10:1 single-ended browser (no attenuator).

• 10:1 differential browser (no attenuator).

• 10:1 (+6 dB Atten) single-ended browser.

• 10:1 (+6 dB Atten) differential browser.

• 10:1 (+12 dB Atten) single-ended browser.

• 10:1 (+12 dB Atten) differential browser.

• 10:1 (+20 dB Atten) single-ended browser.

• 10:1 (+20 dB Atten) differential browser.

6 Click Calibrate Probe and follow the instructions on the display.

For more information on InfiniiMax probes and accessories, see the probe's User's 
Guide.
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You can define two math functions. One math function waveform can be displayed 
at a time. The math function waveform is displayed in light purple.

Math functions can be performed on analog channels or they can be performed on 
lower math functions when using operators other than add, subtract, multiply, or 
divide.
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To display math waveforms

1 Choose Main Menu > Analyze > Waveform Math to display the Waveform Math 
Menu.

2 Click Display Math to select the math function you want to display. Then, click 
Display Math again to display the selected math function.

3 Use the Operator softkey to select an operator, transform, filter, or visualization.

For more information on the operators, see:

• "Math Operators" on page 70

• "Math Transforms" on page 72

• "Math Filters" on page 89

• "Math Visualizations" on page 92

4 Click the Source 1 softkey to select the analog channel, lower math function, or 
reference waveform on which to perform math.

Higher math functions can operate on lower math functions when using 
operators other than the simple arithmetic operations (+, -, *, /). For example, if 
Math 1 is set up as a subtract operation between channels 1 and 2, the Math 2 
function could be set up as a FFT operation on the Math 1 function. These are 
called cascaded math functions.

To cascade math functions, select the lower math function using the Source 1 
softkey.

5 If you selected an arithmetic operator for the math function, use the Source 2 
softkey to select the second source for the arithmetic operation.

6 To re-size and re-position the math waveform, see "To adjust the math 
waveform scale and offset" on page 68.

TIP When cascading math functions, to get the most accurate results, be sure to vertically scale 
lower math functions so that their waveforms take up the full screen without being clipped.
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TIP Math Operating Hints

If the analog channel or math function is clipped (not fully displayed on screen) the resulting 
displayed math function will also be clipped.

Once the function is displayed, the analog channel(s) may be turned off for better viewing of 
the math waveform.

The vertical scaling and offset of each math function can be adjusted for ease of viewing and 
measurement considerations.

The math function waveform can be measured using cursors and/or measurements.
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To adjust the math waveform scale and offset

1 Click the Scale and/or Offset buttons in the Waveform Math Menu.

2 Use the dialog box controls to make adjustments.

See Also • "Units for Math Waveforms" on page 69

NOTE Math Scale and Offset are Set Automatically

Any time the currently displayed math function definition is changed, the function is 
automatically scaled for optimum vertical scale and offset. If you manually set scale and offset 
for a function, select a new function, then select the original function, the original function will 
be automatically rescaled.
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Units for Math Waveforms

Units for each input channel can be set to Volts or Amps using the Units softkey in 
the channel's Probe Menu. Units for math function waveforms are:

A scale unit of U (undefined) will be displayed for math functions when two source 
channels are used and they are set to dissimilar units and the combination of units 
cannot be resolved.

Math function Units

add or subtract V or A

multiply V2, A2, or W (Volt-Amp)

d/dt V/s or A/s (V/second or A/second)

 dt Vs or As (V-seconds or A-seconds)

FFT See "FFT Units" on page 81.

√(square root) V1/2, A1/2, or W1/2 (Volt-Amp)
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Math Operators

Math operators perform arithmetic operations (like add, subtract, or multiply) on 
analog input channels.

• "Add or Subtract" on page 70

• "Multiply or Divide" on page 71

Add or Subtract

When you select add or subtract, the Source 1 and Source 2 values are added or 
subtracted point by point, and the result is displayed.

You can use subtract to make a differential measurement or to compare two 
waveforms.

If your waveforms' DC offsets are larger than the dynamic range of the 
oscilloscope's input channels you will need to use a differential probe instead.

See Also • "Units for Math Waveforms" on page 69

Figure 4 Example of Subtract Channel 2 from Channel 1
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Multiply or Divide

When you select the multiply or divide math function, the Source 1 and Source 2 
values are multiplied or divided point by point, and the result is displayed.

The divide by zero case places holes (that is, zero values) in the output waveform.

Multiply is useful for seeing power relationships when one of the channels is 
proportional to the current.

See Also • "Units for Math Waveforms" on page 69

Figure 5 Example of Multiply Channel 1 by Channel 2
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Math Transforms

Math transforms perform a transform function (like differentiate, integrate, FFT, or 
square root) on an analog input channel or on the result of an arithmetic operation.

• "Differentiate" on page 72

• "Integrate" on page 73

• "FFT Magnitude, FFT Phase" on page 75

• "Square Root" on page 83

• "Ax + B" on page 84

• "Square" on page 85

• "Absolute Value" on page 85

• "Common Logarithm" on page 86

• "Natural Logarithm" on page 86

• "Exponential" on page 87

• "Base 10 Exponential" on page 87

Differentiate

d/dt (differentiate) calculates the discrete time derivative of the selected source.

You can use differentiate to measure the instantaneous slope of a waveform. For 
example, the slew rate of an operational amplifier may be measured using the 
differentiate function.

Because differentiation is very sensitive to noise, it is helpful to set acquisition 
mode to Averaging (see "Selecting the Acquisition Mode" on page 190).

d/dt plots the derivative of the selected source using the "average slope estimate 
at 4 points" formula. The equation is:

Where:

• d = differential waveform.

• y = channel 1, 2, or Math 1 (lower math function) data points.

• i = data point index.

• Δt = point-to-point time difference.

di =
yi+4 + 2yi+2 − 2yi−2 − yi−4

8 Δ t
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See Also • "Units for Math Waveforms" on page 69

Integrate

 dt (integrate) calculates the integral of the selected source. It shows the 
accumulated amount of change.

You can use integrate to calculate the energy of a pulse in volt-seconds or 
measure the area under a waveform by measuring the difference in the integrate 
function value across the pulse or waveform.

 dt plots the integral of the source using the "Trapezoidal Rule". The equation is:

Where:

• I = integrated waveform.

• Δt = point-to-point time difference.

• y = channel 1, 2, or Math 1 (lower math function) data points.

• co = arbitrary constant.

• i = data point index.

Figure 6 Example of Differentiate Function

In = co + Δ t∑
i=0

n
yi
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The integrate operator provides an Offset softkey that lets you enter a DC offset 
correction factor for the input signal. Small DC offset in the integrate function 
input (or even small oscilloscope calibration errors) can cause the integrate 
function output to "ramp" up or down. This DC offset correction lets you level the 
integrate waveform.

Figure 7 Integrate Without Signal Offset

0 V level

Integrate
without
DC offset
correction
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When Initial Condition is enabled, the integrate math waveform is vertically 
centered in the screen. In other words, the top and bottom of the math waveform 
are equal distances from the top and bottom of the screen. When Initial Condition is 
disabled, the integrate math waveform starts at the zero-level reference on the left 
side of the screen.

See Also • "Units for Math Waveforms" on page 69

FFT Magnitude, FFT Phase

Using the Fast Fourier Transform (FFT), the FFT (Magnitude) math function 
displays the magnitudes of the frequency content that makes up the source 
waveform, and the FFT (Phase) math function shows the phase relationships of the 
frequency content. The FFT takes the digitized time record of the specified source 
and transforms it to the frequency domain.

The source of the FFT math functions can be analog input channels or a lower 
math function.

The horizontal axis of FFT math functions is frequency (Hertz). For the FFT 
(Magnitude) math function, the vertical axis is in decibels when Logarithmic 
vertical units are selected or V RMS when Linear vertical units are selected. For the 
FFT (Phase) math function, the vertical axis is in degrees or radians.

Figure 8 Integrate With Signal Offset

Integrate
with DC offset
correction
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Use the FFT (Magnitude) function to find crosstalk problems, to find distortion 
problems in analog waveforms caused by amplifier non-linearity, or for adjusting 
analog filters.

To display a FFT waveform:

1 Choose Main Menu > Analyze > Waveform Math to display the Waveform Math 
Menu.

2 Click Display Math and select the math function you want to display. Then, click 
Display Math again to display the selected math function.

3 Click Operator and select FFT (Magnitude) or FFT (Phase).

• Source 1 — selects the source for the FFT.

• Span/Center or Start Freq/Stop Freq — this pair of softkeys let you define the 
displayed frequency range. Click the softkeys to toggle between:

• Span/Center — Span specifies the frequency range represented by the 
width of the display. Divide span by 10 to calculate the frequency scale 
per division. Center specifies the frequency at the center vertical grid line 
of the display.

• Start Freq/Stop Freq — Start Freq specifies the frequency at the left side of 
the display. Stop Freq specifies the frequency at the right side of the 
display.

To set desired values, click the softkey label for a keypad entry dialog box.

• Scale — opens a dialog box for adjusting the math waveform's vertical scale.

• Offset — opens a dialog box for adjusting the math waveform's vertical offset.

• Bin Size, RBW (Resolution Bandwidth), Sample Rate — displays the FFT 
resolution in one of three different ways.

• More FFT — displays the More FFT Settings Menu.

4 Click More FFT to display additional FFT settings.

• Window— selects a window to apply to your FFT input signal:

• Hanning — window for making accurate frequency measurements or for 
resolving two frequencies that are close together.

• Flat Top — window for making accurate amplitude measurements of 
frequency peaks.
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• Rectangular — good frequency resolution and amplitude accuracy, but use 
only where there will be no leakage effects. Use on self-windowing 
waveforms such as pseudo-random noise, impulses, sine bursts, and 
decaying sinusoids.

• Blackman Harris — window reduces time resolution compared to a 
rectangular window, but improves the capacity to detect smaller 
impulses due to lower secondary lobes.

• Bartlett — (triangular, with end points at zero) window is similar to the 
Hanning window in that it is good for making accurate frequency 
measurements, but its higher and wider secondary lobes make it not 
quite as good for resolving frequencies that are close together.

• Vertical Units — For FFT (Magnitude), you can select Logarithmic (decibels) or 
Linear (V RMS). For FFT (Phase), you can select Degrees or Radians.

To adjust the FFT waveform vertical scale and offset, click the Scale and 
Offset buttons in the Waveform Math Menu.

• FFT Gating— When the zoomed time base is displayed, click this softkey to 
select:

• No Gating — the FFT is performed on the source waveform in the upper 
Main time base window.

• Gate By Zoom — the FFT is performed on the source waveform in the lower 
Zoom window.

• Detection Type— When the FFT (Magnitude) operator is selected, this softkey 
lets you set the FFT detector decimation type.

Detectors give you a way of manipulating the acquired data to emphasize 
different features of the data. Detectors reduce (decimate) the number of 
FFT points to at most the number of specified detector points. In this 
reduction, sampled FFT points are bucketized, that is, split into a number of 
groups that equals the specified number of detector points. Then, the points 
in each bucket are reduced to a single point according to the selected 
detection type. The detector types are:

• None — No detector is used.

• Sample — Takes the point nearest to the center of every bucket.

• + Peak — Takes the most positive point in every bucket.

• - Peak — Takes the most negative point in every bucket.

• Average — Takes the average of all points in every bucket.

• Normal — Implements a rosenfell algorithm. This method to picks either 
the minimum or maximum sample in every bucket depending on whether 
the data is monotonically increasing, decreasing, or varying. For details, 
see the Spectrum Analysis Basics application note at www.keysight.com.

When detectors are used, the FFT's output is decimated, and any analysis is 
performed on the reduced or detected data set.

http://literature.cdn.keysight.com/litweb/pdf/5952-0292.pdf
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• Points per Span — When the FFT (Magnitude) operator is selected and a 
detector is used, this softkey specifies the maximum number of points that 
detectors should decimate to. This is also the number of buckets that 
sampled FFT points are grouped into before the selected detection type 
reduction (decimation) is applied.

The minimum number of points is 640.

When precision analysis is off, the maximum number of points is the 
measurement record limit of 64K.

When precision analysis is on (see "Precision Measurements and Math" on 
page 246), the maximum number of points is 1/2 the power-of-two value 
needed to hold the precision analysis record length.

• Auto Setup — Sets the frequency Span and Center to values that will cause 
the entire available spectrum to be displayed. The maximum available 
frequency is half the FFT sample rate, which is a function of the time per 
division setting. The FFT resolution is the quotient of the sampling rate and 
the number of FFT points (fS/N). The current FFT Resolution is displayed 
above the softkeys.

• Zero Phase Ref — When the FFT (Phase) operator is selected, this softkey sets 
the reference point for calculating the FFT Phase function:

• Trigger — the FFT phase is measured from the trigger (time=0) point of the 
waveform.

• Entire Display — the FFT phase is measured from the beginning of the 
displayed waveform.

5 To make cursor measurements, choose Main Menu > Measure > Cursors and set 
the Source softkey to Math N.

Use the X1 and X2 cursors to measure frequency values and difference between 
two frequency values (ΔX). Use the Y1 and Y2 cursors to measure amplitude in 
dB and difference in amplitude (ΔY).

6 To make other measurements, choose Main Menu > Measure > Measurements, click 
Add Meas, and set the Source softkey to Math N.

NOTE Scale and offset considerations

If you do not manually change the FFT scale or offset settings, when you adjust the horizontal 
scale, the span and center frequency settings will automatically change to allow optimum 
viewing of the full spectrum.

If you do manually set scale or offset, adjusting the horizontal scale will not change the span 
or center frequency settings, allowing you see better detail around a specific frequency.

Clicking the FFT Auto Setup softkey will automatically rescale the waveform and span and 
center will again automatically track the horizontal scale setting.
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You can make peak-to-peak, maximum, minimum, and average dB 
measurements on the FFT waveform. You can also find the frequency value at 
the first occurrence of the waveform maximum by using the X at Max Y 
measurement.

The following FFT (Magnitude) spectrum was obtained by connecting a 2.5 V, 
100 kHz square wave to channel 1. Set the horizontal scale to 50 µs/div, vertical 
sensitivity to 1 V/div, Units/div to 20 dBV, Offset to -40.0 dBV, Center frequency to 
500 kHz, frequency Span to 1 MHz, and window to Hanning.

See Also • "Searching for FFT Peaks" on page 79

• "FFT Measurement Hints" on page 80

• "FFT Units" on page 81

• "FFT DC Value" on page 81

• "FFT Aliasing" on page 82

• "FFT Spectral Leakage" on page 83

• "Units for Math Waveforms" on page 69

Searching for FFT Peaks

To search for FFT math function frequency peaks:

1 Choose Main Menu > Analyze > Waveform Search.

2 In the Search Menu, click Search; then, select Frequency Peaks.

3 Click Source and select the FFT math function waveform to search.
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4 Click Max # Peaks and specify the maximum number of FFT peaks to find.

5 Click Threshold and specify the threshold level necessary to be considered a 
peak.

6 Click Excursion to specify the amplitude above the FFT waveform's noise floor 
necessary to be recognized as a peak.

Note that the FFT waveform's noise floor level differs when additional math 
functions are applied to the FFT:

• When Averaged Value, Max Hold, or Min Hold are applied, the FFT waveform's 
noise floor is more stable, and excursion level settings are more accurate.

• When no additional math functions are applied (normal), the FFT 
waveform's noise floor is less stable and excursion level settings are less 
accurate.

White arrowheads at the top of the graticule show where FFT peaks are found.

When acquisitions are stopped, you can use the sidebar Navigate controls and 
cursors to look at the search events found.

FFT Measurement Hints

The number of points acquired for the FFT record can be up to 65,536 (or more 
when the precision analysis record is used, see "Precision Measurements and 
Math" on page 246), and when frequency span is at maximum, all points are 
displayed. Once the FFT spectrum is displayed, the frequency span and center 
frequency controls are used much like the controls of a spectrum analyzer to 
examine the frequency of interest in greater detail. Place the desired part of the 
waveform at the center of the screen and decrease frequency span to increase the 
display resolution. As frequency span is decreased, the number of points shown is 
reduced, and the display is magnified.

While the FFT spectrum is displayed, use the Waveform Math Menu and Cursors 
Menu to switch between measurement functions and frequency domain controls in 
FFT Menu.

Decreasing the effective sampling rate by selecting a greater time/div setting will 
increase the low frequency resolution of the FFT display and also increase the 
chance that an alias will be displayed. The resolution of the FFT is the effective 
sample rate divided by the number of points in the FFT. The actual resolution of 
the display will not be this fine as the shape of the window will be the actual 

NOTE FFT Resolution

The FFT resolution is the quotient of the sampling rate and the number of FFT points (fS/N). 
With a fixed number of FFT points, the lower the sampling rate, the better the resolution.
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limiting factor in the FFTs ability to resolve two closely space frequencies. A good 
way to test the ability of the FFT to resolve two closely spaced frequencies is to 
examine the sidebands of an amplitude modulated sine wave.

For the best vertical accuracy on peak measurements:

• Make sure the probe attenuation is set correctly. The probe attenuation is set 
from the Channel Menu if the operand is a channel.

• Set the source sensitivity so that the input signal is near full screen, but not 
clipped.

• Use the Flat Top window.

• Set the FFT sensitivity to a sensitive range, such as 2 dB/division.

For best frequency accuracy on peaks:

• Use the Hanning window.

• Use Cursors to place an X cursor on the frequency of interest.

• Adjust frequency span for better cursor placement.

• Return to the Cursors Menu to fine tune the X cursor.

For more information on the use of FFTs please refer to Keysight Application Note 
243, The Fundamentals of Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf. Additional 
information can be obtained from Chapter 4 of the book Spectrum and Network 
Measurements by Robert A. Witte.

FFT Units

FFT (Magnitude)
Units

0 dBV is the amplitude of a 1 Vrms sinusoid.

When the FFT source is channel 1 or channel 2:

• FFT units will be displayed in dBV when channel units is set to Volts and 
channel impedance is set to 1 MΩ or the probe attenuation setting is something 
other than 1:1.

• FFT units will be displayed in dBm when channel units is set to Volts, channel 
impedance is set to 50Ω, and the probe attenuation setting is 1:1.

For all other FFT sources or when a source channel's units has been set to Amps, 
FFT units will be displayed as dB.

FFT (Phase) Units In this case, the vertical units are degrees or radians.

FFT DC Value

The FFT computation produces a DC value that is incorrect. It does not take the 
offset at center screen into account. The DC value is not corrected in order to 
accurately represent frequency components near DC.

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf


82 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

4 Math Waveforms
 

FFT Aliasing

When using FFTs, it is important to be aware of frequency aliasing. This requires 
that the operator have some knowledge as to what the frequency domain should 
contain, and also consider the sampling rate, frequency span, and oscilloscope 
vertical bandwidth when making FFT measurements. The FFT resolution (the 
quotient of the sampling rate and the number of FFT points) is displayed directly 
above the softkeys when the FFT Menu is displayed.

Aliasing happens when there are frequency components in the signal higher than 
half the sample rate. Because the FFT spectrum is limited by this frequency, any 
higher components are displayed at a lower (aliased) frequency.

The following figure illustrates aliasing. This is the spectrum of a 990 Hz square 
wave, which has many harmonics. The horizontal time/div setting for the square 
wave sets the sample rate and results in a FFT resolution of 3 Hz. The displayed 
FFT spectrum waveform shows the components of the input signal above the 
Nyquist frequency to be mirrored (aliased) on the display and reflected off the right 
edge.

NOTE Nyquist Frequency and Aliasing in the Frequency Domain

The Nyquist frequency is the highest frequency that any real-time digitizing oscilloscope can 
acquire without aliasing. This frequency is half of the sample rate. Frequencies above the 
Nyquist frequency will be under sampled, which causes aliasing. The Nyquist frequency is also 
called the folding frequency because aliased frequency components fold back from that 
frequency when viewing the frequency domain.
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Because the frequency span goes from ≈ 0 to the Nyquist frequency, the best way 
to prevent aliasing is to make sure that the frequency span is greater than the 
frequencies of significant energy present in the input signal.

FFT Spectral Leakage

The FFT operation assumes that the time record repeats. Unless there is an 
integral number of cycles of the sampled waveform in the record, a discontinuity is 
created at the end of the record. This is referred to as leakage. In order to minimize 
spectral leakage, windows that approach zero smoothly at the beginning and end 
of the signal are employed as filters to the FFT. The FFT Menu provides these 
windows: Hanning, Flat Top, Rectangular, Blackman-Harris, and Bartlett. For 
more information on leakage, see Keysight Application Note 243, The 
Fundamentals of Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf.

Square Root

Square root (√) calculates the square root of the selected source.

Where the transform is undefined for a particular input, holes (zero values) appear 
in the function output.

Figure 9 Aliasing

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf
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See Also • "Units for Math Waveforms" on page 69

Ax + B

The Ax + B function lets you apply a gain and offset to an existing input source.

Figure 10 Example of √ (Square Root)
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Use the Gain (A) softkey to specify the gain.

Use the Offset (B) softkey to specify the offset.

The Ax + B function differs from the Magnify math visualization function in that the 
output is likely different than the input.

See Also • "Magnify" on page 92

Square

The square function calculates the square of the selected source, point by point, 
and displays the result.

Press the Source softkey to select the signal source.

See Also • "Square Root" on page 83

Absolute Value

The absolute value function changes negative values in the input to positive values 
and displays the resulting waveform.

Figure 11 Example of Ax + B
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See Also • "Square" on page 85

Common Logarithm

The Common Logarithm (log) function performs a transform of the input source. 
Where the transform is undefined for a particular input, holes (zero values) appear 
in the function output.

See Also • "Natural Logarithm" on page 86

Natural Logarithm

The Natural Logarithm (ln) function performs a transform of the input source. 
Where the transform is undefined for a particular input, holes (zero values) appear 
in the function output.

Figure 12 Example of Absolute Value
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See Also • "Common Logarithm" on page 86

Exponential

The Exponential (e^x) function performs a transform of the input source.

See Also • "Base 10 Exponential" on page 87

Base 10 Exponential

The Base 10 Exponential (10^x) function performs a transform of the input source.

Figure 13 Example of Natural Logarithm
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See Also • "Exponential" on page 87

Figure 14 Example of Base 10 Exponential
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Math Filters

You can use math filters to create a waveform that is the result of a the filter on an 
analog input channel or on the result of an arithmetic operation.

• "High Pass and Low Pass Filter" on page 89

• "Band Pass Filter" on page 90

• "Averaged Value" on page 90

• "Smoothing" on page 91

• "Envelope" on page 91

High Pass and Low Pass Filter

The high-pass or low-pass filter functions apply the filter to the selected source 
waveform and display the result in the math waveform.

The high-pass filter is a single-pole high-pass filter.

The low-pass filter is a 4th order Bessel-Thompson filter.

Use the Bandwidth softkey to select the filter's -3 dB cutoff frequency.

NOTE The ratio of the input signal's Nyquist frequency and the selected -3 dB cutoff frequency 
affects how many points are available in the output, and under some circumstances, there are 
no points in the output waveform.
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Band Pass Filter

The band-pass filter function applies the filter to the selected source waveform 
and displays the result in the math waveform.

Use the Center softkey to enter the center frequency of the band-pass filter.

Use the Width softkey to enter the frequency width of the band-pass filter. This 
specifies the filter's -3 dB cutoff frequencies (center frequency minus half the 
width and center frequency plus half the width).

Averaged Value

When the Averaged Value operator is selected, the math waveform becomes the 
selected source waveform, averaged the selected number of times.

The source waveform can be one of the analog input channels or one of the 
previous math function waveforms.

Unlike acquisition averaging, the math averaging operator can be used to average 
the data on a single analog input channel or math function.

Figure 15 Example of Low Pass Filter

NOTE The ratio of the input signal's Nyquist frequency and the selected -3 dB cutoff frequencies 
affects how many points are available in the output, and under some circumstances, there are 
no points in the output waveform.
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If acquisition averaging is also used, the analog input channel data is averaged 
and the math function averages it again. You can use both types of averaging to 
get a certain number of averages on all waveforms and an increased number of 
averages on a particular waveform.

As with acquisition averaging, averages are calculated using a "decaying average" 
approximation, where:

next_average = current_average + (new_data - current_average)/N

Where N starts at 1 for the first acquisition and increments for each following 
acquisition until it reaches the selected number of averages, where it holds.

Press the Reset Count softkey to clear the number of waveforms evaluated.

See Also • "Averaging Acquisition Mode" on page 193

Smoothing

The resulting math waveform is the selected source with a normalized rectangular 
(boxcar) FIR filter applied.

The boxcar filter is a moving average of adjacent waveform points, where the 
number of adjacent points is specified by the Smoothing Points softkey. You can 
choose an odd number of points, from 3 up to half of the measurement record or 
precision analysis record.

The smoothing operator limits the bandwidth of the source waveform. The 
smoothing operator can be used, for example, to smooth measurement trend 
waveforms.

Envelope

The resulting math waveform shows the amplitude envelope for an amplitude 
modulated (AM) input signal.

This function uses a Hilbert transform to get the real (in-phase, I) and imaginary 
(quadrature, Q) parts of the input signal and then performs a square root of the 
sum of the real and imaginary parts to get the demodulated amplitude envelope 
waveform.
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Math Visualizations

You can apply visualization math functions that give you different ways of viewing 
captured data and measurement values.

• "Magnify" on page 92

• "Maximum/Minimum" on page 93

• "Peak-Peak" on page 93

• "Max/Min Hold" on page 93

• "Measurement Trend" on page 93

• "Chart Serial Signal" on page 95

Magnify

The magnify math function lets you display an existing input source at different 
vertical settings to provide more vertical detail.

See Also • "Ax + B" on page 84

Figure 16 Example of Magnify
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Maximum/Minimum

The Maximum operator is like the Max Hold operator without the hold. The 
maximum vertical values found at each horizontal bucket are used to build a 
waveform.

The Minimum operator is like the Min Hold operator without the hold. The 
minimum vertical values found at each horizontal bucket are used to build a 
waveform.

Peak-Peak

The Peak-Peak operator is like the Maximum operator minus the Minimum 
operator. At each horizontal bucket, the minimum vertical values found are 
subtracted from the maximum vertical values found to build a waveform.

Max/Min Hold

The Max Hold operator records the maximum vertical values found at each 
horizontal bucket across multiple analysis cycles and uses those values to build a 
waveform.

The Min Hold operator is the same, except it records the minimum vertical values.

When not used in a frequency analysis domain, these functions are often referred 
to as Max Envelope and Min Envelope.

Press the Reset Count softkey to clear the number of waveforms evaluated.

Measurement Trend

The measurement trend math function shows measurement values for a waveform 
(based on measurement threshold settings) as the waveform progresses across the 
screen. For every cycle, a measurement is made, and the value is displayed on the 
screen for the cycle.
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Press the Measurement softkey to select the previously added measurement whose 
trend you want to look at. You can display trend values for these measurements:

• Average

• RMS - AC

• Ratio

• Period

• Frequency

• +Width

• -Width

• +Duty Cycle

• -Duty Cycle

• Rise Time

• Fall Time

Use the Thresholds softkey to access the Measurement Threshold Menu. See 
"Measurement Thresholds" on page 239.

If a measurement cannot be made for part of a waveform, the trend function 
output is a hole (that is, no value) until a measurement can be made.

Figure 17 Example of Measurement Trend
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Chart Serial Signal

The Chart Serial Signal math function plots serial bus "signals". Signals are the 
values of defined bits within the data/payload field of CAN, LIN, or SENT protocols.

• Charting a CAN or LIN signal requires a symbolic data file be loaded into the 
oscilloscope.

• With CAN, symbolic data definitions are recalled from a *.dbc file.

• With LIN, symbolic data definitions are recalled from a *.ldf file.

The symbolic data file defines the information (or "signals") present in the 
data/payload field. From these definitions, you can select the "signal" to be 
charted.

• Charting a SENT signal requires that you define the bits and transfer function of 
the SENT signal in the serial decode's SENT > Settings > Fast Signals menu.

Use the Bus Source softkey to select the serial decode from which the symbolic 
data values come (either S1 or S2).

Softkeys in the fourth and fifth positions select the signal to plot:

• With the CAN serial decode (when its display setting is Symbolic), use the 
Message and Signal softkeys to select the message and signal you want to plot.

• With the LIN serial decode (when its display setting is Symbolic), use the Frame 
and Signal softkeys to select the frame and signal you want to plot.

Figure 18 Example of Chart Serial Signal
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• With the SENT serial decode (when its display setting is Transfer Function), use 
the SENT Signal softkey to select the SENT signal source you want to plot (Signal 
1-6).

The Time Mode softkey opens the Time menu.

In the Time menu:

• You can select the time mode:

• Normal — The signal data values are plotted per acquisition, in the same 
horizontal time scale as the other waveforms, and all waveform data is 
time-correlated.

In this mode, the oscilloscope's timebase (time/div) is typically set for a long 
acquisition time to capture multiple occurrences of the 
message/frame/packet that contains the signal to be charted.

If the timebase is set to longer than 200 ms/div for high-speed CAN or 
SENT, undersampling may occur due to limited acquisition memory and 
reduced sample rate. Timebase settings for LIN can usually be much longer.

• Roll — The signal data values are plotted at the right side of the display and 
roll across the display for a specified amout of time. This resulting math 
function waveform is not time-correlated with other waveforms on the 
display.

Roll mode establishes a second and typically much slower timebase and is 
useful for charting very slow changing signals (up to 1 hour), such as 
temperature or pressure.

Signal values are typically under-sampled (not every occurrence of a signal 
will be plotted). Signal values roll across the display as new signal values are 
received and plotted.

If charting a CAN or LIN signal in this mode, you should set up the 
oscilloscope to trigger on the message/frame that contains the signal.

If charting SENT, the oscilloscope should be set up to trigger on "Start of Fast 
Channel Message".

In Roll mode, the oscilloscope's main timebase setting is typically set to 
capture just a few messages.

• When the Roll time mode is selected, you can specify the Time Range and the 
Offset:

• Time Range — Defines the width across the display for the charted serial 
signal waveform.



Math Waveforms 4

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 97

 

• Offset — Shows the time value of the center of the display. When 
oscilloscope acquisitions are running, the offset is automatically set to the 
middle of the time range.

When oscilloscope acquisitions are stopped, you can adjust the Offset and Time 
Range to scroll and zoom the plotted signal values.

See Also • The CAN, LIN, and SENT decode options in "Serial Decode Options" on 
page 110
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The Measurement Record and Waveform Math

Keysight InfiniiVision oscilloscopes are designed to provide high waveform update 
rates which give you an increased probability of capturing infrequent events. With 
high waveform update rates, there is less "dead time" between acquisitions.

To provide high waveform update rates, there are some things the oscilloscope 
does with memory:

• When running, acquisition memory is split into two memories so that the 
processing of one acquisition can take place while another acquisition is being 
captured. For single acquisitions, the full memory is used. Waveform data in 
acquisition memory is called the raw acquisition record.

• There is a separate 65536 (64K) points maximum of eavesdrop memory that is 
used for making measurements and for calculating math functions. Data in this 
memory is a reduced-sample decimation of the data in the raw acquisition 
record. When a math function is turned on, eavesdrop memory is limited to 
62500 points maximum. Waveform data in eavesdrop memory is called the 
measurement record.

(If you want to calculate math functions on a longer record, you can save the 
raw acquisition record and use programs like Excel or MATLAB to perform the 
analysis.)

• On M9241/42/43A PXIe oscilloscopes, there is a third memory used to enable 
precision measurements and math functions at the expense of waveform 
update rate. The depth of this memory is user-selectable from 100k points to 
1M points. Using this "precision analysis" memory gives you better resolution 
on measurements and math waveforms (including FFT). Waveform data in this 
memory is called the precision analysis record.

Waveform data for the acquisition time (that is, the time per division setting 
multiplied by 10 divisions across the display) is saved to the memories. When the 
oscilloscope analog-to-digital converter's (ADC, or digitizer) sample period yields 
more data points than can be stored in the memory, some samples are thrown 
away (decimated), and the effective (or actual) sample rate is reduced. This is why, 
at greater time/div settings, the displayed sample rate decreases.

For example, suppose an oscilloscope's digitizer has a sample period of 1 ns 
(maximum sample rate of 1 GSa/s) and a 1 M memory depth. At that rate, memory 
is filled in 1 ms. If the acquisition time is 100 ms (10 ms/div), only 1 of every 100 
samples is needed to fill memory. The effective sample rate becomes 10 MSa/s.

The decimator is configured to provide a best-estimate of all the samples that 
each point in the record represents. There is no filtering in the decimation.
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FFT (Spectral)
Analysis of

Measurement
Record Data

When the FFT operator is turned on, the decimation from the raw acquisition 
record to the measurement record works on integer rate down-sampling. For 
example, a raw acquisition record of 2000000 points and a measurement record of 
62500 points are already set up with an integer rate decimation of 32 (2000000/32 
= 62500).

For FFT analysis, the decimated record is then zero-padded to 2(X+1) where 2X >= 
record length. For the above example, the power of 2 greater than the record 
length is 65536, so the record is zero-padded to 131072 points.

You can look at the FFT math function results on the oscilloscope to work 
backward and find the un-zero-padded decimated record length as well as the FFT 
length used after the zero-padding:

• First, we know:

• The FFT algorithm translates a time record of N equally spaced samples into 
N/2 equally spaced lines in the frequency domain.

• The width of the FFT on the display is the maximum frequency in the FFT. 
The maximum FFT frequency is also fS/2, where fS is the effective sample 
rate of the decimated data. (Use the center/span or start/stop frequency 
controls to display the maximum FFT frequency.)

• The FFT Resolution is displayed in the FFT menu. FFT resolution is also 
known as the FFT bin width or a line in the frequency domain.

• Therefore, the un-zero-padded decimated record length is: fS x the acquisition 
time (or 2 x max FFT freq x acquisition time).

• Also, the FFT length used after the zero-padding is: 2 x (maximum FFT 
frequency)/(FFT Resolution).

All this works the same with the precision analysis record, except that, instead of a 
62500 point record length, the record length is user-selectable between 100k 
points and 1M points.

For more information on FFT transformation, see Keysight Application Note 243, 
The Fundamentals of Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf.

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf
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5 Reference Waveforms

To save a waveform to a reference waveform location / 102
To display a reference waveform / 103
To display reference waveform information / 104
To scale and position reference waveforms / 105
To adjust reference waveform skew / 106
To save/recall reference waveform files / 107

Analog channel or math waveforms can be saved to one of two reference 
waveform locations in the oscilloscope. Then, a reference waveform can be 
displayed and compared against other waveforms. One reference waveform can be 
displayed at a time.

When the reference waveform information is displayed, you can click on the scale 
and offset values to adjust them. There is also a skew adjustment for reference 
waveforms.

Analog channel, math, or reference waveforms can be saved to a reference 
waveform file on the chassis controller PC. You can recall a reference waveform file 
into one of the reference waveform locations.
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To save a waveform to a reference waveform location

1 Choose Main Menu > Sources > Reference Waveforms to turn on reference 
waveforms.

2 In the Reference Waveform Menu, click Display Ref to select the desired 
reference waveform location you want to display. Then, click Display Ref again to 
display the selected reference waveform location.

3 Click the Source to select the source waveform.

4 Click Save to R1/R2 to save the waveform to the reference waveform location.

To clear a
reference

waveform location

1 Choose Main Menu > Sources > Reference Waveforms to turn on reference 
waveforms.

2 In the Reference Waveform Menu, click Display Ref to select the desired 
reference waveform location.

3 Click Clear R1/R2 to clear the reference waveform location.

Reference waveforms are also cleared by a Factory Default (see Chapter 18, 
“Save/Email/Recall (Setups, Screens, Data),” starting on page 293).

NOTE Reference waveforms are non-volatile — they remain after power cycling or performing a 
default setup.
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To display a reference waveform

1 Choose Main Menu > Sources > Reference Waveforms to turn on reference 
waveforms.

2 In the Reference Waveform Menu, click Display Ref to select the desired 
reference waveform location.

3 Then, click Display Ref again to enable/disable the reference waveform display.

One reference waveform can be displayed at a time.

Reference waveforms are always drawn as vectors (that is, lines between 
waveform data points) and may look different than waveforms drawn as dots (if 
that option is available in your oscilloscope).

See Also • "To display reference waveform information" on page 104
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To display reference waveform information

1 Choose Main Menu > Sources > Reference Waveforms to turn on reference 
waveforms.

2 In the Reference Waveform Menu, click Display Info to enable (or disable) 
reference waveform information on the oscilloscope display.
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To scale and position reference waveforms

1 Display the reference waveform information (see "To display reference 
waveform information" on page 104).

2 Click the scale value to adjust the reference waveform scale.

3 Click the offset value to adjust the reference waveform position.

You can also click the skew value to adjust it.
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To adjust reference waveform skew

Once reference waveforms are displayed, you can adjust their skew.

1 Display the desired reference waveform (see "To display a reference waveform" 
on page 103).

2 Click Skew and enter the reference waveform skew.
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To save/recall reference waveform files

Analog channel, math, or reference waveforms can be saved to a reference 
waveform file. See "To save reference waveform files" on page 299.

You can recall a reference waveform file into one of the reference waveform 
locations. See "To recall reference waveform files" on page 303.
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6 Serial Decode

Serial Decode Options / 110
Lister / 111
Searching Lister Data / 113

Triggering on
Serial Data

In some cases, such as when triggering on a slow serial signal (for example, I2C, 
SPI, CAN, LIN, etc.) it may be necessary to switch from the Auto trigger mode to 
the Normal trigger mode to prevent the oscilloscope from Auto-triggering and 
stabilize the display. You can change the trigger mode by choosing Main Menu > 
Trigger > Trigger Mode and Coupling Menu and clicking the Mode softkey button or by 
simply clicking the Run/Stop status in the upper-right corner of the display.

Also, the threshold voltage level must be set appropriately for each source 
channel. The threshold level for each serial signal can be set in the Signals Menu. 
Choose Main Menu > Analyze > Serial Decode, then click the Signals softkey button.
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Serial Decode Options

Keysight's hardware-accelerated serial decode options can be installed when the 
oscilloscope is manufactured, or added later. The following serial decodes are 
available:

To determine whether these licenses are installed on your oscilloscope, see "To 
display oscilloscope information" on page 315.

To order serial decode licenses, go to www.keysight.com and search for the 
product number (see "Licensed Options Available" on page 320) or contact your 
local Keysight Technologies representative (see 
www.keysight.com/find/contactus).

Licensed Serial Decode See:

CAN (Controller Area Network) and LIN (Local 
Interconnect Network) serial buses.

• "CAN/CAN FD Serial Decode" on 
page 341.

• "LIN Serial Decode" on page 351.

CXPI (Clock Extension Peripheral Interface) 
serial buses.

• "CXPI Serial Decode" on page 360.

I2C (Inter-IC) serial buses. • "I2C Serial Decode" on page 370.

UART (Universal Asynchronous 
Receiver/Transmitter) protocols including 
RS232 (Recommended Standard 232).

• "UART/RS232 Serial Decode" on 
page 426.

Manchester and NRZ serial buses. • "Manchester Serial Decode" on 
page 381.

• "NRZ Serial Decode" on page 389.

MIL-STD-1553 and ARINC 429 serial buses. • "MIL-STD-1553 Serial Decode" on 
page 396.

• "ARINC 429 Serial Decode" on page 404.

SENT (Single Edge Nibble Transmission) serial 
buses.

• "SENT Serial Decode" on page 416.

USB PD (Power Delivery) serial buses. • "USB PD Serial Decode" on page 435.

http://www.keysight.com/
http://www.keysight.com/find/contactus
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Lister

Lister is a powerful tool for investigating protocol failures. You can use Lister to 
view large amounts of packet-level serial data in a tabular format, including time 
tags and specific decoded values. When acquisitions are stopped, you can select a 
line in the Lister window and click the Zoom to Selection softkey label button to 
jump to the event.

To use the Lister:

1 Choose Main Menu > Analyze > Serial Decode and set up decode on the serial data 
signals to be analyzed.

2 Click Lister.

3 Click Window; then, select the size of the Lister window (Half-Screen or 
Full-Screen).

You can click the Lister down or up chevrons at the top right of the graticule to 
select the size of the Lister window.

4 Click Display; then, select Serial 1 or Serial 2 on which the serial bus signals are 
being decoded. (If you select All, the decode information for different buses is 
interleaved in time.)

Before you can select a row or navigate through the Lister data, oscilloscope 
acquisitions must be stopped.

5 Choose Main Menu > Single to stop acquisitions.
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A single acquisition instead of stopping running acquisitions fills the maximum 
memory depth.

When zoomed out and viewing a large number of packets, the Lister may not 
be able to display information for all packets. However, when you perform a 
single acquisition, the Lister will contain all on-screen serial decode 
information.

6 Use the scroll bar in the Lister window to scroll through the data.

Time tags in the Time column indicate the event time relative to the trigger 
point by default, and can optionally be configured to be relative to the previous 
row, as described in step 9 that follows. The time tags of events that are shown 
in the waveform display area are displayed with a dark background.

7 Click Zoom to Selection to center the waveform display at the time associated 
with the selected Lister row and automatically set the horizontal scale setting.

8 Click Undo Zoom to return to the horizontal scale and delay settings before the 
last Zoom to Selection.

9 Click Options to open the Lister Options Menu. In this menu, you can:

• Enable or disable the Track Time option. When enabled, as you select 
different Lister rows (when acquisitions are stopped), the horizontal delay 
changes to the Time of the selected row. Also, changing the horizontal delay 
will scroll the Lister.

• Click Time Ref to select whether the Time column in the Lister display shows 
times relative to the trigger or relative to the previous packet row.
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Searching Lister Data

To find and place marks on rows in the Lister (when serial decode and Lister are 
enabled):

1 Choose Main Menu > Analyze > Waveform Search.

2 Click the Search softkey button, and select Serial 1 or Serial 2.

3 Use the Search for softkey to specify events to find. It is similar to specifying 
protocol triggers.

Events that are found are marked in orange in the far left Lister column. The total 
number of events found is displayed above the softkeys.

Each serial decode option lets you find protocol-specific headers, data, errors, etc. 
See:

• "Searching for ARINC 429 Data in the Lister" on page 407

• "Searching for CAN Data in the Lister" on page 345

• "Searching for I2C Data in the Lister" on page 372

• "Searching for LIN Data in the Lister" on page 353

• "Searching for MIL-STD-1553 Data in the Lister" on page 399

• "Searching for SENT Data in the Lister" on page 420

• "Searching for UART/RS232 Data in the Lister" on page 429
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To set or clear persistence / 118
To clear the display / 120
To select the grid type / 121
To adjust the grid intensity / 122
To add an annotation / 123
To disable/enable antialiasing / 125
To freeze the display / 126
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To adjust waveform intensity

You can adjust the intensity of displayed waveforms to account for various signal 
characteristics, such as fast time/div settings and low trigger rates.

Increasing the intensity lets you see the maximum amount of noise and 
infrequently occurring events.

Reducing the intensity can expose more detail in complex signals as shown in the 
following figures.

1 Choose Main Menu > Setup > Waveform Intensity.

2 In the dialog box that appears, drag the Waveform Intensity slider.

Waveform intensity adjustment affects analog channel waveforms only (not math 
waveforms, reference waveforms, digital waveforms, etc.).

Figure 19 Amplitude Modulation Shown at 100% Intensity
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Figure 20 Amplitude Modulation Shown at 40% Intensity
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To set or clear persistence

With persistence, the oscilloscope updates the display with new acquisitions, but 
does not immediately erase the results of previous acquisitions. All previous 
acquisitions are displayed with reduced intensity. New acquisitions are shown in 
their normal color with normal intensity.

Waveform persistence is kept only for the current display area; you cannot pan and 
zoom the persistence display.

To use persistence:

1 Choose Main Menu > Setup > Display Menu.

2 Click Persistence; then, select between:

• Off — turns off persistence.

When persistence is off, you can click the Capture Waveforms softkey to 
perform a single-shot infinite persistence. A single acquisition's data is 
displayed with reduced intensity, and it remains on the display until you 
clear persistence or clear the display.

• ∞ Persistence — (infinite persistence) Results of previous acquisitions are 
never erased.

Use infinite persistence to measure noise and jitter, to see the worst-case 
extremes of varying waveforms, to look for timing violations, or to capture 
events that occur infrequently.

• Variable Persistence — Results of previous acquisitions are erased after a 
certain amount of time.

Variable persistence gives you a view of acquired data that is similar to 
analog oscilloscopes.

When variable persistence is selected, click the Time softkey and specify the 
amount of time that previous acquisitions are to be displayed.

• Adaptive Persistence —All previous acquisitions that have taken place in 
hardware since the last controller PC screen capture are displayed.

This is the default setting. Adaptive persistence mode should be used to see 
infrequent glitches on the graticule.

The display will begin accumulating multiple acquisitions.

3 To erase the results of previous acquisitions from the display, click Clear 
Persistence.

The oscilloscope will start to accumulate acquisitions again.
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4 To return the oscilloscope to the normal display mode, turn off persistence; 
then, click Clear Persistence.

Turning off persistence does not clear the display. The display is cleared if you 
click the Clear Display softkey or if you choose Main Menu > Autoscale (which also 
turns off persistence).

For another method of seeing worst-case extremes of varying waveforms, see 
"Glitch or Narrow Pulse Capture" on page 191.
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To clear the display

1 Choose Main Menu > Setup > Display Menu.

2 Click Clear Display.

You can also configure the Main Menu > Quick Action menu item to clear the display. 
See "Configuring the Quick Action Menu Item" on page 317.
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To select the grid type

When the Video trigger type is selected (see "Video Trigger" on page 158), and the 
vertical scaling of at least one displayed channel is 140 mV/div, the Grid softkey 
lets you select from these grid types:

• Full — the normal oscilloscope grid.

• mV — shows vertical grids, labeled on the left, from -0.3 V to 0.8 V.

• IRE — (Institute of Radio Engineers) shows vertical grids in IRE units, labeled on 
the left, from -40 to 100 IRE. The 0.35 V and 0.7 V levels from the mV grid are 
also shown and labeled at the right. When the IRE grid is selected, cursor values 
are also shown in IRE units. (Cursor values via the remote interface are not in 
IRE units.)

The mV and IRE grid values are accurate (and match Y cursor values) when the 
vertical scaling is 140 mV/division and the vertical offset is 245 mV.

To select the grid type:

1 Choose Main Menu > Setup > Display Menu.

2 Click Grid.

3 In the Grid Menu, click Grid softkey; then, select the grid type.
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To adjust the grid intensity

To adjust the display grid (graticule) intensity:

1 Choose Main Menu > Setup > Display Menu.

2 Click Grid.

3 In the Grid Menu, click Grid Intensity; then, enter the intensity of the displayed 
grid.

The intensity level is shown in the Intensity softkey and is adjustable from 0 to 
100%.

Each major vertical division in the grid corresponds to the vertical sensitivity 
shown in the status line at the top of the display.

Each major horizontal division in the grid corresponds to the time/div shown in the 
status line at the top of the display.
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To add an annotation

You can add annotations to the oscilloscope's display. Annotations are useful for 
documentation purposes, to add notes before capturing screens.

To add an annotation:

1 Choose Main Menu > Setup > Display Menu.

2 Click Annotations.

3 In the Annotations Menu, click the Display softkey button and select the desired 
annotation.

4 Then, click the Display softkey again to enable/disable the annotation display.

When enabled, you can drag the annotation anywhere in the graticule, or use 
the X1 and Y1 softkeys.

5 Click Edit.

6 In the Edit keypad dialog box, enter the annotation text.

7 When you are done entering text, select the dialog box's Enter or OK key or 
click the Edit softkey again.

The annotation text appears in the softkey.

8 Click Text Color to select the annotation color.

You can choose white, red, or colors that match analog channels, digital 
channels, math waveforms, reference waveforms, or markers.
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9 Click Background and select the annotation background:

• Opaque — the annotation has a solid background.

• Inverted — the annotation's foreground and background colors are switched.

See Also • "To save BMP or PNG image files" on page 295
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To disable/enable antialiasing

At slower sweep speeds, the sample rate is reduced and a proprietary display 
algorithm is used to minimize the likelihood of aliasing.

By default, Antialiasing is enabled. You should leave Antialiasing enabled unless 
there is a specific reason to switch it off.

Anti-aliasing is turned off automatically, even though the Antialiasing softkey 
appears to be enabled, when FFTs are on or when the Envelope or Differentiate 
math functions are on.

If you need to switch Antialiasing off, choose Main Menu > Setup > Display Menu and 
click the Antialiasing softkey button to switch the feature off. The displayed 
waveforms will be more susceptible to aliasing.
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To freeze the display

To freeze the display without stopping running acquisitions, you must configure 
the Main Menu > Quick Action menu item. See "Configuring the Quick Action Menu 
Item" on page 317.

1 Once the Main Menu > Quick Action menu item has been configured with the Quick 
Freeze Display action, choose this menu item to freeze the display.

2 To un-freeze the display, choose Main Menu > Quick Action again.

Manual cursors can be used on the frozen display.

Many activities, such as adjusting the trigger level, adjusting vertical or horizontal 
settings, or saving data will un-freeze the display.
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To turn the label display on or off / 128
To assign a predefined label to a channel / 129
To define a new label / 130
To load a list of labels from a text file you create / 131
To reset the label library to the factory default / 132

You can define labels and assign them to each analog input channel, or you can 
turn labels off to increase the waveform display area.
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To turn the label display on or off

1 Choose Main Menu > Setup > Channel Labels.

2 Click the Display Labels softkey button to turn the label display on.

This turns on labels for the displayed waveforms. Labels are displayed at the 
left edge of the displayed traces.

The figure below shows an example of displayed labels.

3 To turn the labels off, click Display Labels again.



Labels 8

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 129

 

To assign a predefined label to a channel

1 Choose Main Menu > Setup > Channel Labels.

2 Click the Channel softkey button, then select a channel for label assignment.

The figure above shows the list of channels and their default labels. The 
channel does not have to be turned on to have a label assigned to it.

3 Click Library, then select a predefined label from the library.

4 Click Apply New Label to assign the label to your selected channel.

5 Repeat the above procedure for each predefined label you want to assign to a 
channel.
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To define a new label

1 Choose Main Menu > Setup > Channel Labels.

2 Click the Channel softkey button; then, select a channel for label assignment.

The channel does not have to be turned on to have a label assigned to it. If the 
channel is turned on, its current label will be highlighted.

3 Click the New Label softkey button.

4 In the New Label keypad dialog, enter the label text.

5 When you are done entering text, select the dialog box's Enter or OK key or 
click the New Label softkey again.

The new label appears in the softkey.

6 Click Apply New Label to assign the label to your selected channel and to save 
the new label to the Library.

When you define a new label, it is added to the non-volatile label list.

Label Assignment
Auto-Increment

When you assign a label ending in a digit, such as ADDR0 or DATA0, the 
oscilloscope automatically increments the digit and displays the modified label in 
the "New label" field after you click Apply New Label. Therefore, you only need to 
select a new channel and click Apply New Label again to assign the label to the 
channel. Only the original label is saved in the label list. This feature makes it 
easier to assign successive labels to numbered control lines and data bus lines.
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To load a list of labels from a text file you create

It may be convenient to create a list of labels using a text editor, then load the 
label list into the oscilloscope. The list can have up to 75 labels. When loaded, 
labels are added to the beginning of the oscilloscope's list. If more than 75 labels 
are loaded, only the first 75 are stored.

To load labels from a text file into the oscilloscope:

1 Use a text editor to create each label. Each label can be up to 32 characters in 
length. Separate each label with a line feed.

2 Name the file labellist.txt and save it on the chassis controller PC.

3 Load the list into the oscilloscope using the File Explorer (choose Main Menu > 
Utilities > File Explorer Menu).

NOTE Label List Management

When you click the Library softkey button, you will see a list of the last 75 labels used. The list 
does not save duplicate labels. Labels can end in any number of trailing digits. As long as the 
base string is the same as an existing label in the library, the new label will not be put in the 
library. For example, if label A0 is in the library and you make a new label called A12345, the 
new label is not added to the library.

When you save a new user-defined label, the new label will replace the oldest label in the list. 
Oldest is defined as the longest time since the label was last assigned to a channel. Any time 
you assign any label to a channel, that label will move to the newest in the list. Thus, after you 
use the label list for a while, your labels will predominate, making it easier to customize the 
instrument display for your needs.

When you reset the label library list (see next topic), all of your custom labels will be deleted, 
and the label list will be returned to its factory configuration.
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To reset the label library to the factory default

1 Choose Main Menu > Utilities > User Options Menu.

2 In the User Options Menu, click Preferences.

3 In the User Preferences Menu, click Reset Library.

This will delete all user-defined labels from the library and set the labels in the 
library back to the factory default. However, this does not default the labels 
currently assigned to the channels (those labels that appear in the waveform 
area).

NOTE Clicking the Reset Library softkey will remove all user-defined labels from the library and set 
the labels back to the factory default. Once deleted, these user-defined labels cannot be 
recovered.

NOTE Defaulting labels without erasing the default library

Choosing Main Menu > Default Setup sets all channel labels back to the default labels but 
does not erase the list of user-defined labels in the library.
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Adjusting the Trigger Level / 135
Forcing a Trigger / 136
Edge Trigger / 137
Edge then Edge Trigger / 139
Pulse Width Trigger / 141
Pattern Trigger / 143
OR Trigger / 146
Rise/Fall Time Trigger / 148
Near Field Communication (NFC) Trigger / 150
Nth Edge Burst Trigger / 153
Runt Trigger / 154
Setup and Hold Trigger / 156
Video Trigger / 158
Serial Trigger / 170
Zone Qualified Trigger / 171
PXI Trigger (Coordinating Multiple PXIe Oscilloscope Modules) / 173

A trigger setup tells the oscilloscope when to acquire and display data. For 
example, you can set up to trigger on the rising edge of the analog channel 1 input 
signal.

You can adjust the vertical level used for analog channel edge detection by 
clicking the level value in the upper-right corner of the display.

In addition to the edge trigger type, you can also set up triggers on rise/fall times, 
Nth edge bursts, patterns, pulse widths, runt pulses, setup and hold violations, TV 
signals, and serial signals (if option licenses are installed).

You can use any input channel or the Ext Trig input (see "External Trigger Input" 
on page 182) as the source for most trigger types.
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Changes to the trigger setup are applied immediately. If the oscilloscope is 
stopped when you change a trigger setup, the oscilloscope uses the new 
specification when you start making acquisitions again. If the oscilloscope is 
running when you change a trigger setup, it uses the new trigger definition when it 
starts the next acquisition.

To acquire and display data when triggers are not occurring, you can choose 
Main Menu > Trigger > Force Trigger.

You can choose Main Menu > Trigger > Trigger Mode and Coupling Menu to set options 
that affect all trigger types (see Chapter 10, “Trigger Mode/Coupling,” starting on 
page 175).

You can save trigger setups along with the oscilloscope setup (see Chapter 18, 
“Save/Email/Recall (Setups, Screens, Data),” starting on page 293).

Triggers - General
Information

A triggered waveform is one in which the oscilloscope begins tracing (displaying) 
the waveform, from the left side of the display to the right, each time a particular 
trigger condition is met. This provides stable display of periodic signals such as 
sine waves and square waves, as well as nonperiodic signals such as serial data 
streams.

The figure below shows the conceptual representation of acquisition memory. You 
can think of the trigger event as dividing acquisition memory into a pre-trigger and 
post-trigger buffer. The position of the trigger event in acquisition memory is 
defined by the time reference point and the delay (horizontal position) setting (see 
"To adjust the horizontal delay (position)" on page 38).

Pre-Trigger Buffer Post-Trigger Buffer

Acquisition Memory

Trigger Event
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Adjusting the Trigger Level

The value of the analog channel trigger level is displayed in the upper-right corner 
of the display.

You can adjust the trigger level by clicking the level value. See "Access the Trigger 
Menu, Change the Trigger Mode, and Open the Trigger Level Dialog Box" on 
page 33.

The position of the trigger level for the analog channel is indicated by the trigger 
level icon  (if the analog channel is on) at the far left side of the display. You can 
adjust the trigger level by dragging the icon vertically.

T

NOTE You can also change the trigger level of all channels by choosing Main Menu > Analyze > 
Analyze Menu, clicking Features, and then selecting Trigger Levels.
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Forcing a Trigger

Choosing Main Menu > Trigger > Force Trigger causes a trigger (on anything) and 
displays the acquisition.

This is useful in the Normal trigger mode where acquisitions are made only when 
the trigger condition is met. In this mode, if no triggers are occurring (that is, the 
"Trig'd?" indicator is displayed), you can choose Main Menu > Trigger > Force Trigger 
to force a trigger and see what the input signals look like.

In the Auto trigger mode, when the trigger condition is not met, triggers are forced 
and the "Auto?" indicator is displayed.
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Edge Trigger

The Edge trigger type identifies a trigger by looking for a specified edge (slope) 
and voltage level on a waveform. You can define the trigger source and slope in 
this menu. The trigger type, source, and level are displayed in the upper-right 
corner of the display.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Edge.

3 Select the trigger source:

• Analog channel, 1 to the number of channels

• External — triggers on the Ext Trig signal.

• WaveGen — triggers at the 50% level of the rising edge of the waveform 
generator output signal. (Not available when the DC, Noise, or Cardiac 
waveforms are selected.)

• WaveGen Mod (FSK/FM) — when waveform generator FSK or FM modulation is 
used, triggers at the 50% level of the rising edge of the modulating signal.

You can choose a channel that is turned off (not displayed) as the source for the 
edge trigger.

The selected trigger source is indicated in the upper-right corner of the display 
next to the slope symbol:

• 1 or 2 = analog channels.

• E = External trigger input.

• W = Waveform generator.

4 Click the Slope softkey and select:

• Rising edge.

• Falling edge.

• Alternating edges — Useful when you want to trigger on both edges of a 
clock (for example, DDR signals).

• Either edge — Useful when you want to trigger on any activity of a selected 
source.

Rising and Falling edge modes operate up to the bandwidth of the 
oscilloscope. Other modes operate up to the bandwidth of the oscilloscope or 
1 GHz, whichever is smaller.

The selected slope is displayed in the upper-right corner of the display.
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Using Autoscale to
Set Up Edge

Triggers

The easiest way to set up an Edge trigger on a waveform is to use Autoscale. 
Simply choose Main Menu > Autoscale and the oscilloscope will attempt to trigger 
on the waveform using a simple Edge trigger type.

NOTE MegaZoom Technology Simplifies Triggering

With the built-in MegaZoom technology, you can simply Autoscale the waveforms, then stop 
the oscilloscope to capture a waveform. You can then pan and zoom through the data by 
adjusting the horizontal and vertical scale to find a stable trigger point. Autoscale often 
produces a triggered display.
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Edge then Edge Trigger

The Edge then Edge trigger mode triggers when the Nth edge occurs after an 
arming edge and a delay period.

The arm and trigger edges can be specified as  (Rising) or  (Falling) edges on 
analog channels.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Edge then 
Edge.

3 Click the Sources softkey.

4 In the Edge Then Edge Sources Menu:
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a Click the Arm A softkey, and select the channel on which the arming edge 
will occur.

b Click the Slope A softkey to specify which edge of the Arm A signal will arm 
the oscilloscope.

c Click the Trigger B softkey, and select the channel on which the trigger edge 
will occur.

d Click the Slope B softkey to specify which edge of the Trigger B signal will 
trigger the oscilloscope.

The value of the trigger level is displayed in the upper-right corner of the 
display.

Adjust the trigger level for the selected analog channel by clicking the level 
value.

5 Click the Back/Up softkey to return to the Trigger Menu.

6 Click the Delay softkey; then, enter the delay time between the Arm A edge and 
the Trigger B edge.

7 Click the Nth Edge B softkey; then, enter the Nth edge of the Trigger B signal to 
trigger on.
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Pulse Width Trigger

Pulse Width (glitch) triggering sets the oscilloscope to trigger on a positive or 
negative pulse of a specified width. If you want to trigger on a specific timeout 
value, use Pattern trigger in the Trigger Menu (see "Pattern Trigger" on page 143).

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Pulse 
Width.

3 Click the Source softkey; then, select a channel source for the trigger.

The channel you select is shown in the upper-right corner of the display next to 
the polarity symbol.

The source can be any analog channel available on your oscilloscope.

4 Adjust the trigger level.

The value of the trigger level is displayed in the upper-right corner of the 
display.

You can adjust the trigger level by clicking the level value.

5 Click the pulse polarity softkey to select positive ( ) or negative ( ) polarity 
for the pulse width you want to capture.

The selected pulse polarity is displayed in the upper-right corner of the display. 
A positive pulse is higher than the current trigger level or threshold and a 
negative pulse is lower than the current trigger level or threshold.
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When triggering on a positive pulse, the trigger will occur on the high to low 
transition of the pulse if the qualifying condition is true. When triggering on a 
negative pulse, the trigger will occur on the low to high transition of the pulse if 
the qualifying condition is true.

6 Click the qualifier softkey (< > ><) to select the time qualifier.

The Qualifier softkey can set the oscilloscope to trigger on a pulse width that is:

• Less than a time value (<).

For example, for a positive pulse, if you set t<10 ns:

• Greater than a time value (>).

For example, for a positive pulse, if you set t>10 ns:

• Within a range of time values (><).

For example, for a positive pulse, if you set t>10 ns and t<15 ns:

7 Click the qualifier time set softkey (< or >), then enter the pulse width qualifier 
time.

The qualifiers can be set as follows:

• 2 ns to 10 s for > or < qualifier (6 ns to 10 s for the 200 MHz and bandwidth 
model).

• 10 ns to 10 s for >< qualifier, with minimum difference of 5 ns between 
upper and lower settings.

Pulse width
trigger < qualifier

time set softkey

• When the less than (<) qualifier is selected, the oscilloscope triggers on a pulse 
width less than the time value displayed on the softkey.

• When the time range (><) qualifier is selected, use this softkey to set the upper 
time range value.

Pulse width
trigger > qualifier

time set softkey

• When the greater than (>) qualifier is selected, the oscilloscope triggers on a 
pulse width greater than the time value displayed on the softkey.

• When the time range (><) qualifier is selected, use this softkey to set the lower 
time range value.

10 ns 10 ns Trigger

10 ns 10 ns Trigger

10 ns 15 ns Trigger12 ns
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Pattern Trigger

The Pattern trigger identifies a trigger condition by looking for a specified pattern. 
This pattern is a logical AND combination of the channels. Each channel can have 
a value of 0 (low), 1 (high), or don't care (X). A rising or falling edge can be 
specified for one channel included in the pattern.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Pattern.

3 Click the Qualifier softkey; then, select from the pattern duration qualifier 
options:

• Entered – when the pattern is entered.

• < (Less Than) – when the pattern is present for less than a time value.

• > (Greater Than) – when the pattern is present for greater than a time value. 
The trigger occurs when the pattern exits (not when the > softkey time value 
is exceeded).

• Timeout – when the pattern is present for greater than a time value. In this 
case, the trigger occurs when the > softkey time value is exceeded (not 
when the pattern exits).

• >< (In Range) – when the pattern is present for a time within a range of 
values.

• <> (Out of Range) – when the pattern is present for a time outside of range of 
values.

Pattern durations are evaluated using a timer. The timer starts on the last edge 
that makes the pattern (logical AND) true. Except when the Timeout qualifier is 
selected, the trigger occurs on the first edge that makes the pattern false, 
provided the time qualifier criteria has been met.

The time values for the selected qualifier are set using the qualifier time set 
softkeys (< and >).

4 To set the analog channel patterns, click the Analog softkey and use the binary 
keypad dialog to enter:
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• 0 sets the pattern to zero (low) on the selected channel. A low is a voltage 
level that is less than the channel's trigger level or threshold level.

• 1 sets the pattern to 1 (high) on the selected channel. A high is a voltage 
level that is greater than the channel's trigger level or threshold level.

• X sets the pattern to don't care on the selected channel. Any channel set to 
don't care is ignored and is not used as part of the pattern. However, if all 
channels in the pattern are set to don't care, the oscilloscope will not 
trigger.

• The rising edge ( ) or falling edge ( ) softkey sets the pattern to an edge on 
the selected channel. Only one rising or falling edge can be specified in the 
pattern. When an edge is specified, the oscilloscope will trigger at the edge 
specified if the pattern set for the other channels is true.

If no edge is specified, the oscilloscope will trigger on the last edge that 
makes the pattern true.

The specified pattern is shown in the "Pattern =" line directly above the 
softkeys.

NOTE Specifying an Edge in a Pattern

You are allowed to specify only one rising or falling edge term in the pattern. If you define an 
edge term, then select a different channel in the pattern and define another edge term, the 
previous edge definition is changed to a don't care.
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5 Adjust the trigger levels for analog channels: chooseMain Menu > Analyze > 
Analyze Menu, click Features, and then select Trigger Levels.
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OR Trigger

The OR trigger mode triggers when any one (or more) of the specified edges on 
analog channels is found.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select OR.

3 Click the Slope softkey and select rising edge, falling edge, either edge, or don't 
care.

The selected slope is displayed in the upper-right corner of the display.

4 For each analog channel you want to include in the OR trigger, click the Channel 
softkey to select the channel.

As you click the Channel softkey, the channel you select is highlighted in the 
OR = line directly above the softkeys and in the upper-right corner of the 
display next to the OR gate symbol.

The value of the trigger level is displayed in the upper-right corner of the 
display.

Adjust the trigger level for the selected analog channel by clicking the trigger 
level value.

5 For each channel you select, click the Slope softkey and select  (Rising),  

(Falling),  (Either), or X (Don't Care). The selected slope is displayed above the 
softkeys.
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If all channels in the OR trigger are set to don't care, the oscilloscope will not 
trigger.

6 To set all analog channels to the edge selected by the Slope softkey, click the 
Set all Edges softkey.
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Rise/Fall Time Trigger

The Rise/Fall Time trigger looks for a rising or falling transition from one level to 
another level in greater than or less than a certain amount of time.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Rise/Fall 
Time.

3 Click the Source softkey, and select the input channel source.

4 Click the Rising Edge or Falling Edge softkey to toggle between edge types.

5 Click the Level Select softkey to select High; then, adjust the high level in the 
upper-right corner of the display.

6 Click the Level Select softkey to select Low; then, adjust the low level in the 
upper-right corner of the display.

High level

Low level

Rising edge time Falling edge time
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7 Click the Qualifier softkey to toggle between "greater than" or "less than".

8 Click the Time softkey, and enter the time.
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Near Field Communication (NFC) Trigger

NFC (Near Field Communication) triggering is used to capture waveforms used in 
NFC testing.

The NFC trigger type is license-enabled.

When the NFC trigger type is selected, there are softkeys for selecting the source, 
signaling technology standard, trigger event, and other settings:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Near Field 
Communication (NFC).

Table 2 NFC Triggering Characteristics

Standard: Trigger on: In "Arm & Trigger":

Arm on: Trigger on:

NFC-A • SENS_REQ

• ALL_REQ

• Either (SENS_REQ or ALL_REQ)

• SDD_REQ

• Arm & Trigger

• SENS_REQ

• ALL_REQ

• Either (SENS_REQ or ALL_REQ)

• SDD_REQ or Timeout1

NFC-B • SENSB_REQ

• ALLB_REQ

• Either (SENSB_REQ or 
ALLB_REQ)

• ATTRIB

• Arm & Trigger

• SENSB_REQ

• ALLB_REQ

• Either (SENB_REQ or 
ALLB_REQ)

• ATTRIB or Timeout1

NFC-F2 • SENSF_REQ

• ATR_REQ

• Preamble

• Arm & Trigger

• SENSF_REQ • ATR_REQ or Timeout1

Notes:

1 When using the Arm & Trigger selection, the oscilloscope arms on one event and then triggers on a second event or after 
a specified timeout period if the second event does not occur

2 Both NFC-F (212 kbps) and NFC-F (424 kbps) are supported.
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3 Click the Source softkey, and select an analog input channel source.

4 Click the Standard softkey to select the signaling technology used by the input 
signal.

5 Set the trigger level to capture transitions in the modulation envelope. Or at 
approximately 50% of the modulation depth. NFC-A uses 100% modulation, so 
the trigger level can be set in a wide range of values. NFC-B, NFC-F212, and 
NFC-F424 use 10% modulation, so the trigger level needs to be set to 
approximately 95% of the unmodulated carrier amplitude. Usually the actual 
modulation depth is greater than 10%, so the trigger level can be set 
accordingly.

The following image shows how the trigger level should be set. The Y2 marker 
is set for the unmodulated carrier amplitude or 123.3 mV. The Y1 marker is set 
for the maximum modulated amplitude or 97.8 mV. (Note that the actual 
modulation depth is close to 20%.) The midpoint of the modulation would be 
(123.3 mV + 97.8 mV) / 2.0 = 110.6 mV. The trigger level is set to 108 mV; 
slightly below the mid modulation level to account for trigger hysteresis.

6 Click the Trigger Event softkey; then, select the event to trigger on. Some of the 
events you can select are defined in the standards; other event options include:

• Either — With the NFC-A signaling technology, this option means either the 
SENS_REQ or ALL_REQ events will cause a trigger. With the NFC-B 
signaling technology, this option means either the SENSB_REQ or 
ALLB_REQ events will cause a trigger.

• Preamble — With the NFC-F signaling technologies, this option specifies the 
preamble sequence that begins a data frame.

• Arm & Trigger — This selection lets you arm the oscilloscope on one event and 
then trigger on a second event or after a specified timeout period if the 
second event does not occur.
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7 With the NFC-F standards, there is a Reverse Polarity softkey that enables the 
oscilloscope to trigger on "reverse" polarity signals. When disabled, the 
oscilloscope triggers on "obverse" polarity signals.

8 When the Arm & Trigger event is selected:

a Click the Arm Event softkey to select the event to arm on.

When the specified event arms, the signal on the Aux Out MMCX connector 
goes high. The oscilloscope waits until a second event is found or until the 
specified timeout period expires and then triggers.

• For NFC-A, the second event is SDD_REQ.

• For NFC-B, the second event is ATTRIB.

• For NFC-F, the second event is ATR_REQ.

When the oscilloscope triggers, the signal on Aux Out goes low.

b Click the Timeout softkey; then, enter the timeout period.
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Nth Edge Burst Trigger

The Nth Edge Burst trigger lets you trigger on the Nth edge of a burst that occurs 
after an idle time.

Nth Edge Burst trigger set up consists of selecting the source, the slope of the 
edge, the idle time, and the number of the edge:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Nth Edge 
Burst.

3 Click the Source softkey, and select the input channel source.

4 Click the Slope softkey to select the slope of the edge.

5 Click the Idle softkey; then, enter the idle time.

6 Click the Edge softkey; then, enter edge number to trigger on.
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Runt Trigger

The Runt trigger looks for pulses that cross one threshold but not another.

• A positive runt pulse crosses through a lower threshold but not an upper 
threshold.

• A negative runt pulse crosses through an upper threshold but not a lower 
threshold.

To trigger on runt pulses:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Runt.

3 Click the Source softkey, and select the input channel source.

4 Click the Positive, Negative, or Either Runt Pulse softkey to toggle between pulse 
types.

High level

Low level

Positive runt pulse Negative runt pulse
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5 Click the Level Select softkey to select High; then, adjust the high level in the 
upper-right corner of the display.

6 Click the Level Select softkey to select Low; then, adjust the low level in the 
upper-right corner of the display.

7 Click the Qualifier softkey to toggle between "less than", "greater than", or None.

This lets you specify that a runt pulse be less than or greater than a certain 
width.

8 If you selected the "less than" or "greater than" Qualifier, click the Time softkey; 
then, enter the time.
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Setup and Hold Trigger

The Setup and Hold trigger looks for setup and hold violations.

One oscilloscope channel probes the clock signal and another channel probes the 
data signal.

To trigger on setup and hold violations:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Setup and 
Hold.

3 Click the Clock softkey; then, select the input channel with the clock signal.

4 Set the appropriate trigger level for the clock signal.

5 Click the Rising Edge or Falling Edge softkey to specify the clock edge being used.

6 Click the Data softkey; then, select the input channel with the data signal.

7 Set the appropriate trigger level for the data signal.

8 Click the < Setup softkey, and enter the setup time.

Data

Clock
(rising
edge)

Setup time Hold time
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9 Click the < Hold softkey, and enter the hold time.
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Video Trigger

Video triggering can be used to capture the complicated waveforms of most 
standard analog video signals. The trigger circuitry detects the vertical and 
horizontal interval of the waveform and produces triggers based on the video 
trigger settings you have selected.

The oscilloscope's MegaZoom IV technology gives you bright, easily viewed 
displays of any part of the video waveform. Analysis of video waveforms is 
simplified by the oscilloscope's ability to trigger on any selected line of the video 
signal.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Video.

3 Click the Source softkey and select any analog channel as the video trigger 
source.

The selected trigger source is displayed in the upper-right corner of the display.

The trigger level must be set between the bottom of the sync pulse and the 
bottom of the color burst as shown below.

NOTE It is important, when using a 10:1 passive probe, that the probe is correctly compensated. The 
oscilloscope is sensitive to this and will not trigger if the probe is not properly compensated, 
especially for progressive formats.
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Trigger coupling is automatically set to DC in the Trigger Mode and Coupling 
Menu.

4 Click the sync polarity softkey to set the Video trigger to either positive ( ) or 

negative ( ) sync polarity.

5 Click the Settings softkey.

6 In the Video Trigger Menu, click the Standard softkey to set the video standard.

The oscilloscope supports triggering on the following television (TV) and video 
standards.

NOTE Provide Correct Matching

Many video signals are produced from 75 Ω sources. To provide correct matching to these 
sources, a 75 Ω terminator (such as a Keysight 11094B) should be connected to the 
oscilloscope input.

Standard Type Sync Pulse

NTSC Interlaced Bi-level

PAL Interlaced Bi-level

PAL-M Interlaced Bi-level

SECAM Interlaced Bi-level
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With the extended video triggering license, the oscilloscope additionally 
supports these standards:

The Generic selection lets you trigger on custom bi-level and tri-level sync video 
standards. See "To set up Generic video triggers" on page 162.

7 Click the Auto Setup softkey to automatically set up the oscilloscope for the 
selected Source and Standard:

• Source channel vertical scaling is set to 140 mV/div.

• Source channel offset is set to 245 mV.

• Source channel is turned on.

• Trigger type is set to Video.

• Video trigger mode is set to All Lines (but left unchanged if Standard is 
Generic).

• Display Grid type is set to IRE (when Standard is NTSC) or mV (see "To select 
the grid type" on page 121).

• Horizontal time/division is set to 10 µs/div for NTSC/PAL/SECAM standards 
or 4 µs/div for EDTV or HDTV standards (unchanged for Generic).

• Horizontal delay is set so that trigger is at first horizontal division from the 
left (unchanged for Generic).

You can also choose Main Menu > Analyze > Analyze Menu, click Features, and then 
select Video to quickly access the video triggering automatic set up and display 
options.

Standard Type Sync Pulse

Generic Interlaced/Progressive Bi-level/Tri-level

EDTV 480p/60 Progressive Bi-level

EDTV 567p/50 Progressive Bi-level

HDTV 720p/50 Progressive Tri-level

HDTV 720p/60 Progressive Tri-level

HDTV 1080p/24 Progressive Tri-level

HDTV 1080p/25 Progressive Tri-level

HDTV 1080p/30 Progressive Tri-level

HDTV 1080p/50 Progressive Tri-level

HDTV 1080p/60 Progressive Tri-level

HDTV 1080i/50 Interlaced Tri-level

HDTV 1080i/60 Interlaced Tri-level
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8 Click the Mode softkey to select the portion of the video signal that you would 
like to trigger on.

The Video trigger modes available are:

• Field1 and Field2 — Trigger on the rising edge of the first serration pulse of 
field 1 or field 2 (interlaced standards only).

• All Fields — Trigger on the rising edge of the first pulse in the vertical sync 
interval.

• All Lines — Trigger on all horizontal sync pulses.

• Line — Trigger on the selected line number (EDTV and HDTV standards only).

• Line: Field1 and Line:Field2 — Trigger on the selected line # in field 1 or field 2 
(interlaced standards only).

• Line: Alternate — Alternately trigger on the selected line # in field 1 and field 2 
(NTSC, PAL, PAL-M, and SECAM only).

9 If you select a line # mode, click the Line # softkey, then select the line number 
on which you want to trigger.

The following table lists the line (or count) numbers per field for each video 
standard.

The following table lists the line numbers for each EDTV/HDTV video standard 
(available with the extended video triggering license).

Video Triggering
Examples

The following are exercises to familiarize you with video triggering. These exercises 
use the NTSC video standard.

• "To trigger on a specific line of video" on page 162

Video standard Field 1 Field 2 Alt Field

NTSC 1 to 263 1 to 262 1 to 262

PAL 1 to 313 314 to 625 1 to 312

PAL-M 1 to 263 264 to 525 1 to 262

SECAM 1 to 313 314 to 625 1 to 312

EDTV 480p/60 1 to 525

EDTV 567p/50 1 to 625

HDTV 720p/50, 720p/60 1 to 750

HDTV 1080p/24, 1080p/25, 1080p/30, 
1080p/50, 1080p/60

1 to 1125

HDTV 1080i/50, 1080i/60 1 to 1125
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• "To trigger on all sync pulses" on page 163

• "To trigger on a specific field of the video signal" on page 164

• "To trigger on all fields of the video signal" on page 165

• "To trigger on odd or even fields" on page 166

To set up Generic video triggers

When Generic (available with the extended video triggering license) is selected as 
the Video trigger Standard, you can trigger on custom bi-level and tri-level sync 
video standards. The Video Trigger Menu changes as follows.

1 Click the Time > softkey; then, set the time to greater-than the sync-pulse width 
so that the oscilloscope synchronizes to the vertical sync.

2 Click the Edge # softkey; then, select the Nth edge after after vertical sync to 
trigger on.

3 To enable or disable the horizontal sync control, click the first Horiz Sync 
softkey.

• For interleaved video, enabling the Horiz Sync control and setting the 
Horiz Sync adjustment to the sync time of the probed video signal allows the 
Edge # function to count only lines and not double count during equalization. 
Additionally, the Field Holdoff can be adjusted so that the oscilloscope 
triggers once per frame.

• Similarly, for progressive video with a tri-level sync, enabling the Horiz Sync 
control and setting the Horiz Sync adjustment to the sync time of the probed 
video signal allows the Edge # function to count only lines and not double 
count during vertical sync.

When the horizontal sync control is enabled, click the second Horiz Sync softkey; 
then, set the minimum time the horizontal sync pulse must be present to be 
considered valid.

To trigger on a specific line of video

Video triggering requires greater than 1/2 division of sync amplitude with any 
analog channel as the trigger source.

One example of triggering on a specific line of video is looking at the vertical 
interval test signals (VITS), which are typically in line 18. Another example is closed 
captioning, which is typically in line 21.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Video.
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3 Click the Settings softkey, then click the Standard softkey to select the 
appropriate TV standard (NTSC).

4 Click the Mode softkey and select the TV field of the line you want to trigger on. 
You can choose Line:Field1, Line:Field2, or Line:Alternate.

5 Click the Line # softkey and select the number of the line you want to examine.

To trigger on all sync pulses

To quickly find maximum video levels, you could trigger on all sync pulses. When 
All Lines is selected as the Video trigger mode, the oscilloscope will trigger on all 
horizontal sync pulses.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Video.

3 Click the Settings softkey, then click the Standard softkey to select the 
appropriate TV standard.

4 Click the Mode softkey and select All Lines.

NOTE Alternate Triggering

If Line:Alternate is selected, the oscilloscope will alternately trigger on the selected line 
number in Field 1 and Field 2. This is a quick way to compare the Field 1 VITS and Field 2 VITS 
or to check for the correct insertion of the half line at the end of Field 1.

Figure 21 Example: Triggering on Line 136
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To trigger on a specific field of the video signal

To examine the components of a video signal, trigger on either Field 1 or Field 2 
(available for interleaved standards). When a specific field is selected, the 
oscilloscope triggers on the rising edge of the first serration pulse in the vertical 
sync interval in the specified field (1 or 2).

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Video.

3 Click the Settings softkey; then, click the Standard softkey to select the 
appropriate TV standard.

4 Click the Mode softkey and select Field1 or Field2.

Figure 22 Triggering on All Lines
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To trigger on all fields of the video signal

To quickly and easily view transitions between fields, or to find the amplitude 
differences between the fields, use the All Fields trigger mode.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Video.

3 Click the Settings softkey, then click the Standard softkey to select the 
appropriate TV standard.

4 Click the Mode softkey and select All Fields.

Figure 23 Triggering on Field 1
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To trigger on odd or even fields

To check the envelope of your video signals, or to measure worst case distortion, 
trigger on the odd or even fields. When Field 1 is selected, the oscilloscope 
triggers on color fields 1 or 3. When Field 2 is selected, the oscilloscope triggers 
on color fields 2 or 4.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey button, and select Video.

3 Click the Settings softkey, then click the Standard softkey to select the 
appropriate TV standard.

4 Click the Mode softkey and select Field1 or Field2.

The trigger circuits look for the position of the start of Vertical Sync to determine 
the field. But this definition of field does not take into consideration the phase of 
the reference subcarrier. When Field 1 is selected, the trigger system will find any 
field where the vertical sync starts on Line 4. In the case of NTSC video, the 
oscilloscope will trigger on color field 1 alternating with color field 3 (see the 
following figure). This setup can be used to measure the envelope of the reference 
burst.

Figure 24 Triggering on All Fields
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If a more detailed analysis is required, then only one color field should be selected 
to be the trigger. You can do this by using the Field Holdoff softkey in the Video 
Trigger Menu. Click the Field Holdoff softkey and adjust the holdoff in half-field 
increments until the oscilloscope triggers on only one phase of the color burst.

A quick way to synchronize to the other phase is to briefly disconnect the signal 
and then reconnect it. Repeat until the correct phase is displayed.

When holdoff is adjusted using the Field Holdoff softkey, the corresponding holdoff 
time will be displayed in the Trigger Mode and Coupling Menu.

Figure 25 Triggering on Color Field 1 Alternating with Color Field 3
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Table 3 Half-field holdoff time

Standard Time

NTSC 8.35 ms

PAL 10 ms

PAL-M 10 ms

SECAM 10 ms

Generic 8.35 ms

EDTV 480p/60 8.35 ms

EDTV 567p/50 10 ms

HDTV 720p/50 10 ms

HDTV 720p/60 8.35 ms

HDTV 1080p/24 20.835 ms

HDTV 1080p/25 20 ms

HDTV 1080p/30 20 ms

HDTV 1080p/50 16.67 ms

HDTV 1080p/60 8.36 ms

HDTV 1080i/50 10 ms

HDTV 1080i/60 8.35 ms
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Figure 26 Using Field Holdoff to Synchronize to Color Field 1 or 3 (Field 1 mode)
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Serial Trigger

With serial decode option licenses (see "Serial Decode Options" on page 110), you 
can enable serial trigger types. To set up these triggers, see:

• "ARINC 429 Triggering" on page 402

• "CAN/CAN FD Triggering" on page 338

• "CXPI Triggering" on page 357

• "I2C Triggering" on page 367

• "LIN Triggering" on page 349

• "Manchester Triggering" on page 379

• "MIL-STD-1553 Triggering" on page 395

• "NRZ Triggering" on page 387

• "SENT Triggering" on page 414

• "UART/RS232 Triggering" on page 424

• "USB PD Triggering" on page 433
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Zone Qualified Trigger

The zone qualified trigger feature gives you one or two rectangular areas, Zone 1 
and Zone 2, that a waveform must either intersect or not intersect in order for an 
acquisition to be displayed and stored in memory.

The zone qualified trigger feature works on top of the oscilloscope's hardware 
trigger, which determines the acquisitions whose waveforms are evaluated for 
zone intersection.

To set up a zone qualified trigger:

1 Click the upper-right corner to select the rectangle draw mode.

2 Drag across the screen to draw a rectangular zone that the waveform must 
either intersect or not intersect.

3 Release the mouse button.

4 In the popup menu, select whether the rectangle is Zone 1 or Zone 2 and 
whether it is a "Must Intersect" or "Must Not Intersect" zone.
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The Main Menu > Trigger > Zone Qualified Trigger menu item shows the zone 
qualified trigger feature is enabled.

5 In the Zone Qualified Trigger Menu, click the Source softkey and select the 
analog channel input source that both zones are associated with.

Zone colors match the selected analog input channel. "Must Not Intersect" 
zones are shaded differently than the solid "Must Intersect" zones.

The zone qualified trigger source does not have to be the same as the hardware 
trigger source.

6 You can use the Zone 1 On and Zone 2 On softkeys to disable or enable zones, 
and you can use the Zone 1 and Zone 2 softkeys to toggle between the "Must 
Intersect" and "Must Not Intersect" conditions.

Disabling both zones disables the zone qualified trigger feature. When the zone 
qualified trigger feature is enabled, at least one zone must be enabled.

You can choose Main Menu > Trigger > Zone Qualified Trigger to disable or re-enable 
the zone qualified trigger.

When two non-overlapping zones are used, their conditions are ANDed to become 
the final qualifying condition.

When two overlapping zones have the must intersect condition, the zones are 
ORed. When two overlapping zones have different conditions, Zone 1 takes 
precedence and Zone 2 is not used. In this case, Zone 2 will have no fill (that is, 
neither solid nor shaded) to indicate that it is not being used.

The zone qualified trigger feature is incompatible with, and will disable, the 
Averaging acquisition mode.

NOTE Keep in mind that the Aux Out signal comes from the oscilloscope's hardware trigger. The Aux 
Out signal indicates when there is a trigger (acquisition) that is evaluated for zone 
intersection, not when an acquisition meets the zone qualification and is plotted on the 
oscilloscope's display.
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PXI Trigger (Coordinating Multiple PXIe Oscilloscope Modules)

The PXI Trigger Menu (choose Main Menu > Trigger > PXI Trigger Menu) lets you set up 
coordinated arming and triggering to synchronize acquisitions between multiple 
M924xA oscilloscope modules. For more information, see the Keysight 
M9241/42/43A PXIe Oscilloscopes and M9240A AutoProbe Power Module Startup 
Guide.

When synchronize acquisitions between multiple M924xA oscilloscope modules, 
you must also synchronize the timebases of those modules. See "To synchronize 
instruments in a chassis" on page 309.
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To select the Auto or Normal trigger mode / 176
To select the trigger coupling / 178
To enable or disable trigger noise rejection / 179
To enable or disable trigger HF Reject / 180
To set the trigger holdoff / 181
External Trigger Input / 182

To access the Trigger Mode and Coupling Menu:

• Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

Noisy Signals If the signal you are probing is noisy, you can set up the oscilloscope to reduce the 
noise in the trigger path and on the displayed waveform. First, stabilize the 
displayed waveform by removing the noise from the trigger path. Second, reduce 
the noise on the displayed waveform.

1 Connect a signal to the oscilloscope and obtain a stable display.

2 Remove the noise from the trigger path by turning on high-frequency rejection 
("To enable or disable trigger HF Reject" on page 180), low-frequency 
rejection ("To select the trigger coupling" on page 178), or "To enable or 
disable trigger noise rejection" on page 179.

3 Use "Averaging Acquisition Mode" on page 193 to reduce noise on the 
displayed waveform.
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To select the Auto or Normal trigger mode

When the oscilloscope is running, the trigger mode tells the oscilloscope what to 
do when triggers are not occurring.

In the Auto trigger mode (the default setting), if the specified trigger conditions are 
not found, triggers are forced and acquisitions are made so that signal activity is 
displayed on the oscilloscope.

In the Normal trigger mode, triggers and acquisitions only occur when the specified 
trigger conditions are found.

To select the trigger mode:

1 Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

2 In the Trigger Mode and Coupling Menu, click the Mode softkey; then select 
either Auto or Normal.

You can also make this selection by clicking the Run/Stop status in the 
upper-right corner of the display. See "Access the Trigger Menu, Change the 
Trigger Mode, and Open the Trigger Level Dialog Box" on page 33.

See the following "When to Use Auto Trigger Mode" on page 177 and "When 
to Use Normal Trigger Mode" on page 177 descriptions.

You can also configure the Main Menu > Quick Action menu item to toggle between 
the Auto and Normal trigger modes. See "Configuring the Quick Action Menu 
Item" on page 317.

Triggering and the
Pre- and

Post-Trigger
Buffers

After the oscilloscope starts running (after choosing Main Menu > Run/Stop or 
Main Menu > Single or changing the trigger condition), the oscilloscope first fills the 
pre-trigger buffer. Then, after the pre-trigger buffer is filled, the oscilloscope starts 
searching for a trigger, and sampled data continues to flow data through the 
pre-trigger buffer in a first-in first-out (FIFO) manner.

When a trigger is found, the pre-trigger buffer contains the events that occurred 
just before the trigger. Then, the oscilloscope fills the post-trigger buffer and 
displays the acquisition memory. If the acquisition was initiated by Main Menu > 
Run/Stop, the process repeats. If the acquisition was initiated by choosing 
Main Menu > Single, the acquisition stops (and you can Pan and Zoom the 
waveform).

In either Auto or Normal trigger mode, a trigger may be missed if the event occurs 
while the pre-trigger buffer is being filled. This may be more likely, for example, 
when the horizontal scale is set to a slow time/div setting, such as 500 ms/div.

Trigger Indicator The trigger indicator at the top right of the display shows whether triggers are 
occurring.

In the Auto trigger mode, the trigger indicator can show:
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• Auto?— the trigger condition is not found (after the pre-trigger buffer has filled), 
and forced triggers and acquisitions are occurring.

• Auto — the trigger condition is found (or the pre-trigger buffer is being filled).

In the Normal trigger mode, the trigger indicator can show:

• Trig'd?— the trigger condition is not found (after the pre-trigger buffer has 
filled), and no acquisitions are occurring.

• Trig'd— trigger condition is found (or pre-trigger buffer is being filled).

When the oscilloscope is not running, the trigger indicator area shows Stop.

When to Use Auto
Trigger Mode

The Auto trigger mode is appropriate when:

• Checking DC signals or signals with unknown levels or activity.

• When trigger conditions occur often enough that forced triggers are 
unnecessary.

When to Use
Normal Trigger

Mode

The Normal trigger mode is appropriate when:

• You only want to acquire specific events specified by the trigger settings.

• Triggering on an infrequent signal from a serial bus (for example, I2C, CAN, LIN, 
etc.) or another signal that arrives in bursts. The Normal trigger mode lets you 
stabilize the display by preventing the oscilloscope from auto-triggering.

• Making single-shot acquisitions with Main Menu > Single.

Often with single-shot acquisitions, you must initiate some action in the device 
under test, and you do not want the oscilloscope to auto-trigger before that 
happens. Before initiating the action in the circuit, wait for the trigger condition 
indicator Trig'd? to display (this tells you the pre-trigger buffer is filled).

See Also • "Forcing a Trigger" on page 136

• "To set the trigger holdoff" on page 181

• "To position the time reference (left, center, right, custom)" on page 46
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To select the trigger coupling

1 Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

2 In the Trigger Mode and Coupling Menu, click the Coupling softkey; then, select:

• DC coupling — allows DC and AC signals into the trigger path.

• AC coupling — places a 10 Hz high-pass filter in the trigger path removing 
any DC offset voltage from the trigger waveform.

The high-pass filter in the External Trigger input path is 50 Hz for all models.

Use AC coupling to get a stable edge trigger when your waveform has a 
large DC offset.

• LF (low frequency) Reject coupling — adds a high-pass filter with the 3-dB 
point at 50 kHz in series with the trigger waveform.

Low frequency reject removes any unwanted low frequency components 
from a trigger waveform, such as power line frequencies, etc., that can 
interfere with proper triggering.

Use LF Reject coupling to get a stable edge trigger when your waveform has 
low frequency noise.

• Video coupling — is always grayed-out in the M9241/42/43A PXIe 
oscilloscopes.

Note that Trigger Coupling is independent of Channel Coupling (see "To specify 
channel coupling" on page 56).

Pass
Band

50 kHz

0 dB

3 dB down point

DC
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To enable or disable trigger noise rejection

Noise Rej adds additional hysteresis to the trigger circuitry. By increasing the 
trigger hysteresis band, you reduce the possibility of triggering on noise. However, 
this also decreases the trigger sensitivity so that a slightly larger signal is required 
to trigger the oscilloscope.

1 Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

2 In the Trigger Mode and Coupling Menu, click the Noise Rej softkey to enable or 
disable.
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To enable or disable trigger HF Reject

HF Reject adds a 50 kHz low-pass filter in the trigger path to remove high 
frequency components from the trigger waveform.

You can use HF Reject to remove high-frequency noise, such as AM or FM 
broadcast stations or noise from fast system clocks, from the trigger path.

1 Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

2 In the Trigger Mode and Coupling Menu, click the HF Reject softkey to enable or 
disable.

Pass
Band

50 kHzDC

0 dB

-3 dB
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To set the trigger holdoff

Trigger holdoff sets the amount of time the oscilloscope waits after a trigger 
before re-arming the trigger circuitry.

Use the holdoff to trigger on repetitive waveforms that have multiple edges (or 
other events) between waveform repetitions. You can also use holdoff to trigger on 
the first edge of a burst when you know the minimum time between bursts.

For example, to get a stable trigger on the repetitive pulse burst shown below, set 
the holdoff time to be >200 ns but <600 ns.

To set the trigger holdoff:

1 Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

2 In the Trigger Mode and Coupling Menu, click Holdoff.

3 In the Trigger Holdoff Menu, click the Random softkey to enable or disable the 
random trigger holdoff mode.

The random trigger holdoff mode ensures that the oscilloscope re-arms after 
each acquisition in a manner that minimizes or eliminates the likelihood of 
triggering at the beginning of a DDR burst. Randomizing the holdoff time 
increases the likelihood that the oscilloscope will trigger on different data 
phases of a multi-phase (8 data transfer) burst. This mode mixes up the traffic 
pattern the oscilloscope triggers on and is very effective when used on 
repeating patterns.

4 If random trigger holdoff is disabled, use the Holdoff softkey to enter the trigger 
holdoff time.

If random trigger holdoff is enabled, use the Min and Max softkeys to enter the 
minimum and maximum trigger holdoff times.

Trigger Holdoff
Operating Hints

The correct holdoff setting is typically slightly less than one repetition of the 
waveform. Set the holdoff to this time to generate a unique trigger point for a 
repetitive waveform.

Changing the time base settings does not affect the trigger holdoff time.

With Keysight's MegaZoom technology, you can stop acquisitions, then pan and 
zoom through the data to find where the waveform repeats. Measure this time 
using cursors; then, set the holdoff.

200 ns

Oscilloscope triggers hereHoldoff

600 ns
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External Trigger Input

The external trigger input can be used as a source in several of the trigger types. 
The external trigger MMCX input is labeled Ext Trig.

The external trigger input impedance is 1M Ohm. This lets you use passive probes 
for general-purpose measurements. The higher impedance minimizes the loading 
effect of the oscilloscope on the device under test.

To set the Ext Trig units and probe attenuation:

1 Choose Main Menu > Trigger > Trigger Mode and Coupling Menu.

2 In the Trigger Mode and Coupling Menu, click the External softkey.

3 In the External Trigger Menu, click the Units softkey to select between:

• Volts — for a voltage probe.

• Amps — for a current probe.

Measurement results, channel sensitivity, and the trigger level will reflect the 
measurement units you have selected.

4 Click the Probe softkey; then, enter the probe attenuation.

The attenuation factor can be set from 0.1:1 to 10000:1 in a 1-2-5 sequence.

The probe attenuation factor must be set properly for measurements to be 
made correctly.

CAUTION  Maximum voltage at oscilloscope external trigger input

30 Vrms, 60 Vdc

1M ohm input: For steady-state sinusoidal waveforms derate at 20 dB/decade above 
100 kHz to a minimum of 5 Vpk
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Running, Stopping, and Making Single Acquisitions (Run Control) / 184
Overview of Sampling / 186
Selecting the Acquisition Mode / 190
Realtime Sampling Option / 196
Acquiring to Segmented Memory / 197
Digitizer Mode / 200

This chapter shows how to use the oscilloscope's acquisition and run controls.
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Running, Stopping, and Making Single Acquisitions (Run Control)

There are keyboard shortcuts and main menu items for starting and stopping the 
oscilloscope's acquisition system.

The keyboard shortcuts are:

• F5 — Run

• F6 — Stop

• F10 — Single

The main menu items are:

• Main Menu > Run/Stop

• Main Menu > Single

The acquisition states work like this:

• When the oscilloscope is running, it is acquiring data when trigger conditions 
are met.

To stop acquiring data, choose Main Menu > Run/Stop (or F6 on the keyboard). 
When stopped, the last acquired waveform is displayed.

• When data acquisition is stopped, "Stop" is displayed next to the trigger type in 
the status line at the top of the display.

To start acquiring data, choose Main Menu > Run/Stop (or F5 on the keyboard).

• To capture and display a single acquisition (whether the oscilloscope is running 
or stopped), choose Main Menu > Single (or F10 on the keyboard).

Single acquisitions let you view single-shot events without subsequent 
waveform data overwriting the display. Make single acquisitions when you want 
maximum memory depth for pan and zoom.

When you start a single acquisition, the trigger mode is temporarily set to 
Normal (to keep the oscilloscope from auto-triggering immediately), the trigger 
circuitry is armed, and the oscilloscope waits until a trigger condition occurs 
before it displays a waveform.

When the oscilloscope triggers, the single acquisition is displayed and the 
oscilloscope is stopped. Choose Main Menu > Single (or F10 on the keyboard) 
again to acquire another waveform.

If the oscilloscope does not trigger, you can choose Main Menu > Trigger > 
Force Trigger to trigger on anything and make a single acquisition.

To display the results of multiple acquisitions, use persistence. See "To set or clear 
persistence" on page 118.

Single vs. Running
and Record Length

The maximum data record length is greater for a single acquisition than when the 
oscilloscope is running (or when the oscilloscope is stopped after running):
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• Single — Single acquisitions always use the maximum memory available — at 
least twice as much memory as acquisitions captured when running — and the 
oscilloscope stores at least twice as many samples. At slower time/div settings, 
because there is more memory available for a single acquisition, the acquisition 
has a higher effective sample rate.

• Running — When running (versus taking a single acquisition), the memory is 
divided in half. This lets the acquisition system acquire one record while 
processing the previous acquisition, dramatically improving the number of 
waveforms per second processed by the oscilloscope. When running, a high 
waveform update rate provides the best representation of your input signal.

To acquire data with the longest possible record length, choose Main Menu > Single.

For more information on settings that affect record length, see "Length Control" 
on page 297.
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Overview of Sampling

To understand the oscilloscope's sampling and acquisition modes, it is helpful to 
understand sampling theory, aliasing, oscilloscope bandwidth and sample rate, 
oscilloscope rise time, oscilloscope bandwidth required, and how memory depth 
affects sample rate.

Sampling Theory

The Nyquist sampling theorem states that for a limited bandwidth (band-limited) 
signal with maximum frequency fMAX, the equally spaced sampling frequency fS 
must be greater than twice the maximum frequency fMAX, in order to have the 
signal be uniquely reconstructed without aliasing.

fMAX = fS/2 = Nyquist frequency (fN) = folding frequency

Aliasing

Aliasing occurs when signals are under-sampled (fS < 2fMAX). Aliasing is the signal 
distortion caused by low frequencies falsely reconstructed from an insufficient 
number of sample points.

Oscilloscope Bandwidth and Sample Rate

An oscilloscope's bandwidth is typically described as the lowest frequency at 
which input signal sine waves are attenuated by 3 dB (-30% amplitude error).

Figure 27 Aliasing
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At the oscilloscope bandwidth, sampling theory says the required sample rate is fS 
= 2fBW. However, the theory assumes there are no frequency components above 
fMAX (fBW in this case) and it requires a system with an ideal brick-wall frequency 
response.

However, digital signals have frequency components above the fundamental 
frequency (square waves are made up of sine waves at the fundamental frequency 
and an infinite number of odd harmonics), and typically, for 500 MHz bandwidths 
and below, oscilloscopes have a Gaussian frequency response.

Figure 28 Theoretical Brick-Wall Frequency Response

Figure 29 Sample Rate and Oscilloscope Bandwidth

Limiting oscilloscope bandwidth (fBW) to 1/4 the sample rate (fS/4)
reduces frequency components above the Nyquist frequency (fN).
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So, in practice, an oscilloscope's sample rate should be four or more times its 
bandwidth: fS = 4fBW. This way, there is less aliasing, and aliased frequency 
components have a greater amount of attenuation.

Note that the M9241/42/43A PXIe oscilloscope models have a Gaussian response. 
To understand the characteristics of each type of oscilloscope frequency response, 
see Understanding Oscilloscope Frequency Response and Its Effect on Rise-Time 
Accuracy, Keysight Application Note 1420 
(http://literature.cdn.keysight.com/litweb/pdf/5988-8008EN.pdf).

See Also Evaluating Oscilloscope Sample Rates vs. Sampling Fidelity: How to Make the 
Most Accurate Digital Measurements, Keysight Application Note 1587 
(http://literature.cdn.keysight.com/litweb/pdf/5989-5732EN.pdf)

Oscilloscope Rise Time

Closely related to an oscilloscope's bandwidth specification is its rise time 
specification. Oscilloscopes with a Gaussian-type frequency response have an 
approximate rise time of 0.35/fBW based on a 10% to 90% criterion.

An oscilloscope's rise time is not the fastest edge speed that the oscilloscope can 
accurately measure. It is the fastest edge speed the oscilloscope can possibly 
produce.

Oscilloscope Bandwidth Required

The oscilloscope bandwidth required to accurately measure a signal is primarily 
determined by the signal's rise time, not the signal's frequency. You can use these 
steps to calculate the oscilloscope bandwidth required:

1 Determine the fastest edge speeds.

You can usually obtain rise time information from published specifications for 
devices used in your designs.

2 Compute the maximum "practical" frequency component.

From Dr. Howard W. Johnson's book, High-Speed Digital Design – A 
Handbook of Black Magic, all fast edges have an infinite spectrum of frequency 
components. However, there is an inflection (or "knee") in the frequency 
spectrum of fast edges where frequency components higher than fknee are 
insignificant in determining the shape of the signal.

fknee = 0.5 / signal rise time (based on 10% - 90% thresholds)

fknee = 0.4 / signal rise time (based on 20% - 80% thresholds)

3 Use a multiplication factor for the required accuracy to determine the 
oscilloscope bandwidth required.

http://literature.cdn.keysight.com/litweb/pdf/5988-8008EN.pdf
http://literature.cdn.keysight.com/litweb/pdf/5989-5732EN.pdf
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See Also Choosing an Oscilloscope with the Right Bandwidth for your Application, Keysight 
Application Note 1588 
(http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf)

Memory Depth and Sample Rate

The number of points of oscilloscope memory is fixed, and there is a maximum 
sample rate associated with oscilloscope's analog-to-digital converter; however, 
the actual sample rate is determined by the time of the acquisition (which is set 
according to the oscilloscope's horizontal time/div scale).

sample rate = number of samples / time of acquisition

For example, when storing 50 µs of data in 50,000 points of memory, the actual 
sample rate is 1 GSa/s.

Likewise, when storing 50 ms of data in 50,000 points of memory, the actual 
sample rate is 1 MSa/s.

The actual sample rate is displayed in the Summary box in the right-side 
information area.

The oscilloscope achieves the actual sample rate by throwing away (decimating) 
unneeded samples.

Required accuracy Oscilloscope bandwidth required

20% fBW = 1.0 x fknee

10% fBW = 1.3 x fknee

3% fBW = 1.9 x fknee

http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf
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Selecting the Acquisition Mode

When selecting the oscilloscope acquisition mode, keep in mind that samples are 
normally decimated at slower time/div settings.

At slower time/div settings, the effective sample rate drops (and the effective 
sample period increases) because the acquisition time increases and the 
oscilloscope's digitizer is sampling faster than is required to fill memory.

For example, suppose an oscilloscope's digitizer has a sample period of 1 ns 
(maximum sample rate of 1 GSa/s) and a 1 M memory depth. At that rate, memory 
is filled in 1 ms. If the acquisition time is 100 ms (10 ms/div), only 1 of every 100 
samples is needed to fill memory.

To select the acquisition mode:

1 Choose Main Menu > Setup > Acquire Menu.

2 In the Acquire Menu, click the Acq Mode softkey; then, select the acquisition 
mode.

The InfiniiVision oscilloscopes have the following acquisition modes:

• Normal — at slower time/div settings, normal decimation occurs, and there is 
no averaging. Use this mode for most waveforms. See "Normal Acquisition 
Mode" on page 190.

• Peak Detect — at slower time/div settings, the maximum and minimum 
samples in the effective sample period are stored. Use this mode for 
displaying narrow pulses that occur infrequently. See "Peak Detect 
Acquisition Mode" on page 191.

• Averaging — at all time/div settings, the specified number of triggers are 
averaged together. Use this mode for reducing noise and increasing 
resolution of periodic signals without bandwidth or rise time degradation. 
See "Averaging Acquisition Mode" on page 193.

• High Resolution — at slower time/div settings, all samples in the effective 
sample period are averaged and the average value is stored. Use this mode 
for reducing random noise. See "High Resolution Acquisition Mode" on 
page 195.

Normal Acquisition Mode

In Normal mode at slower time/div settings, extra samples are decimated (in other 
words, some are thrown away). This mode yields the best display for most 
waveforms.
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Peak Detect Acquisition Mode

In Peak Detect mode at slower time/div settings, minimum and maximum samples 
are kept in order to capture infrequent and narrow events (at the expense of 
exaggerating any noise). This mode displays all pulses that are at least as wide as 
the sample period.

For InfiniiVision M9241/42/43A PXIe oscilloscopes, which have a maximum 
sample rate of 5 GSa/s, a sample is taken every 200 ps (sample period).

See Also • "Glitch or Narrow Pulse Capture" on page 191

• "Using Peak Detect Mode to Find a Glitch" on page 192

Glitch or Narrow Pulse Capture

A glitch is a rapid change in the waveform that is usually narrow as compared to 
the waveform. Peak detect mode can be used to more easily view glitches or 
narrow pulses. In peak detect mode, narrow glitches and sharp edges are 
displayed more brightly than when in Normal acquire mode, making them easier 
to see.

To characterize the glitch, use the cursors or the automatic measurement 
capabilities of the oscilloscope.

Figure 30 Sine With Glitch, Normal Mode
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Using Peak Detect Mode to Find a Glitch

1 Connect a signal to the oscilloscope and obtain a stable display.

2 To find a glitch, choose Main Menu > Setup > Acquire Menu; then, click the 
Acq Mode softkey until Peak Detect is selected.

3 Choose Main Menu > Setup > Display Menu; then click the ∞ Persistence (infinite 
persistence) softkey.

Infinite persistence updates the display with new acquisitions but does not 
erase previous acquisitions. New sample points are shown at normal intensity 
while previous acquisitions are displayed at reduced intensity. Waveform 
persistence is not kept beyond the display area boundary.

Click the Clear Display softkey to erase previously acquired points. The display 
will accumulate points until ∞ Persistence is turned off.

4 Characterize the glitch with Zoom mode:

a Choose Main Menu > Setup > Zoom Mode.

b To obtain a better resolution of the glitch, expand the time base.

Adjust the horizontal position to pan through the waveform to set the expanded 
portion of the normal window around the glitch.

Figure 31 Sine With Glitch, Peak Detect Mode



Acquisition Control 11

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 193

 

Averaging Acquisition Mode

The Averaging mode lets you average multiple acquisitions together to reduce 
noise and increase vertical resolution (at all time/div settings). Averaging requires 
a stable trigger.

The number of averages can be set from 2 to 65536 in power-of-2 increments.

A higher number of averages reduces noise more and increases vertical resolution.

The higher the number of averages, the slower the displayed waveform responds 
to waveform changes. You must compromise between how quickly the waveform 
responds to changes and how much you want to reduce the displayed noise on the 
signal.

To use the Averaging mode:

1 Choose Main Menu > Setup > Acquire Menu.

2 In the Acquire Menu, click the Acq Mode softkey until the Averaging mode is 
selected.

3 Click the #Avgs softkey and enter the number of averages that best eliminates 
the noise from the displayed waveform. The number of acquisitions being 
averaged is displayed in the # Avgs softkey.

# Avgs Bits of resolution

2 8

4 9

16 10

64 11

≥ 256 12
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Figure 32 Random noise on the displayed waveform

Figure 33 128 Averages used to reduce random noise
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When the Averaging acquisition mode is enabled, a Single acquisition will perform 
the selected number of averages and then stop.

See Also • Chapter 10, “Trigger Mode/Coupling,” starting on page 175

• "Averaged Value" on page 90

High Resolution Acquisition Mode

In High Resolution mode, at slower time/div settings extra samples are averaged 
in order to reduce random noise, produce a smoother trace on the screen, and 
effectively increase vertical resolution.

High Resolution mode averages sequential sample points within the same 
acquisition. An extra bit of vertical resolution is produced for every factor of 2 
averages. Random noise is reduced by ½ for every factor of 4 averages. The 
number of extra bits of vertical resolution is dependent on the time per division 
setting (sweep speed) of the oscilloscope.

The slower the time/div setting, the greater the number of samples that are 
averaged together for each display point.

High Resolution mode can be used on both single-shot and repetitive signals and 
it does not slow waveform update because the computation is done in the 
MegaZoom custom ASIC. High Resolution mode limits the oscilloscope's real-time 
bandwidth because it effectively acts like a low-pass filter.

Sweep speed Bits of resolution

≤ 1 µs/div 8

2 µs/div 9

5 µs/div 10

10 µs/div 11

≥ 20 µs/div 12
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Realtime Sampling Option

With the M9241/42/43A PXIe oscilloscopes, realtime sampling is always on.

Realtime sampling specifies that the oscilloscope produce the waveform display 
from samples collected during one trigger event (that is, one acquisition).

Realtime sampling is good for capturing infrequent triggers, unstable triggers, or 
complex changing waveforms, such as eye diagrams.

When Realtime sampling is on:

• When less than 1000 samples can be collected in the time spanned by the 
screen, a sophisticated reconstruction filter is used to fill-in and enhance the 
waveform display.

• If you stop acquisitions and pan and zoom through the waveform using the 
Horizontal and Vertical controls, only the last trigger's acquisition will be 
displayed.

See Also • "Realtime Sampling and Oscilloscope Bandwidth" on page 196

Realtime Sampling and Oscilloscope Bandwidth

To accurately reproduce a sampled waveform, the sample rate should be at least 
2.5 times the highest frequency component of the waveform. If not, it is possible 
for the reconstructed waveform to be distorted or aliased. Aliasing is most 
commonly seen as jitter on fast edges.

The maximum sample rate for the M9241/42/43A PXIe oscilloscopes is 5 GSa/s for 
a single channel in a channel pair. Channels 1 and 2 constitute a channel pair. For 
example, the maximum sample rate of the 2-channel oscilloscope is 5 GSa/s when 
channels 1 or 2 are on.

Whenever both channels in a channel pair are on, the sample rate for all channels 
is halved. For example, when channels 1 and 2 are on, the maximum sample rate 
for all channels is 2.5 GSa/s.

When Realtime sampling is on, the bandwidth of the oscilloscope is limited 
because the bandwidth of the reconstruction filter is set to fs/4. For example, a 
M9243A (1 GHz) oscilloscope with channels 1 and 2 on has a bandwidth of 
625 MHz when Realtime sampling is on.

The sample rate is displayed in the sidebar Summary dialog.
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Acquiring to Segmented Memory

When capturing multiple infrequent trigger events it is advantageous to divide the 
oscilloscope's memory into segments. This lets you capture signal activity without 
capturing long periods of signal inactivity.

Each segment is complete with all analog channel and serial decode data.

When using segmented memory, use the Analyze Segments feature (see 
"Measurements, Statistics, and Infinite Persistence with Segmented Memory" on 
page 198) to show infinite persistence across all acquired segments. See also "To 
set or clear persistence" on page 118 for details.

To acquire to
segmented

memory

1 Set up a trigger condition. (See Chapter 9, “Triggers,” starting on page 133 for 
details.)

2 Choose Main Menu > Setup > Acquire Menu.

3 Click the Segmented softkey.

4 In the Segmented Memory Menu, click the Segmented softkey to enable 
segmented memory acquisitions.

5 Click the # of Segs softkey and enter the number of segments into which you 
would like to divide the oscilloscope's memory.

Memory can be divided into as few as two segments and as many as 1000 
segments.

6 Choose Main Menu > Run/Stop or Main Menu > Single to start the segmented 
memory acquisition.

The oscilloscope runs and fills a memory segment for each trigger event. When 
the oscilloscope is busy acquiring multiple segments, the progress is displayed on 
screen. The oscilloscope continues to trigger until memory is filled, then the 
oscilloscope stops.

If the signal you are measuring has more than about 1 s of inactivity, consider 
selecting the Normal trigger mode to prevent AutoTriggering. See "To select the 
Auto or Normal trigger mode" on page 176.

See Also • "Navigating Segments" on page 198

• "Measurements, Statistics, and Infinite Persistence with Segmented Memory" 
on page 198

• "Segmented Memory Re-Arm Time" on page 198

• "Saving Data from Segmented Memory" on page 199
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Navigating Segments

1 Click the Current Seg softkey and enter the desired segment number. The 
segment is displayed along with a time tag indicating the time from the first 
trigger event.

You can also navigate segments using the sidebar Navigate controls. See "To 
navigate segments" on page 50.

Measurements, Statistics, and Infinite Persistence with Segmented 
Memory

To perform measurements and view statistical information, choose Main Menu > 
Measure > Measurements and set up your desired measurements (see Chapter 13, 
“Measurements,” starting on page 211). Then, click Analyze Segments. Statistical 
data will be accumulated for the measurements you have chosen.

The Analyze Segments softkey appears when the acquisition is stopped and the 
segmented memory feature is on or when the serial Lister is enabled.

You can also turn on infinite persistence (in the Display Menu) and click the Analyze 
Segments softkey to create an infinite persistence display.

Segmented Memory Re-Arm Time

After each segment fills, the oscilloscope re-arms and is ready to trigger in about 
1 µs.
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Remember though, for example: if the horizontal time per division control is set to 
5 µs/div, and the Time Reference is set to Center, it will take at least 50 µs to fill all 
ten divisions and re-arm. (That is 25 µs to capture pre-trigger data and 25 µs to 
capture post-trigger data.)

Saving Data from Segmented Memory

You can save either the currently displayed segment (Save Segment - Current), or all 
segments (Save Segment - All) in the following data formats: CSV, ASCII XY, and 
BIN.

Be sure to set the Length control to capture enough points to accurately represent 
the captured data. When the oscilloscope is busy saving multiple segments, 
progress is displayed in the upper right area of the display.

For more information, see "To save CSV, ASCII XY, or BIN data files" on page 296.
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Digitizer Mode

Normally, when Digitizer mode is disabled, the oscilloscope's time per division 
setting determines the sample rate and memory depth so as to fill the waveform 
display with data while the oscilloscope is running (continuously making 
acquisitions). For single acquisitions, the time/division setting still determines the 
sample rate, but the maximum amount of acquisition memory is used.

In Digitizer mode, you choose the desired acquisition sample rate and memory 
depth, and the time/div setting is adjusted, if necesssary, to fill the display with 
data. The actual sample rate and memory depth used are displayed in the 
Summary box in the right-side information area.

Digitizer mode primarily aids external software that controls and combines data 
from multiple instruments.

To enable and use
Digitizer mode

1 Press the front panel [Acquire] key, or choose Main Menu > Setup > Acquire Menu.

2 Select the Digitizer softkey.

3 In the Digitizer Mode Menu, select the Digitizer softkey to enable (or disable) the 
mode.

Digitizer mode cannot be used along with these other oscilloscope features: XY 
and Roll time modes, horizontal Zoom display, time references other than 
Center, segmented memory, serial decode, digital channels, frequency 
response analysis, mask test, and the power application. In most cases, 
enabling one of these features when Digitizer mode is enabled will 
automatically disable Digitizer mode, and then disabling the feature will 
automatically reenable Digitizer mode.

Digitizer mode requires the Normal acquisition mode and real-time sampling 
(which is the default).

4 Select the Max Sample Rate softkey and turn the Entry knob or mouse scroll 
wheel (or select the softkey again and use a keypad dialog box) to select the 
desired acquisition sample rate.

The actual sample rate used is displayed in the Summary box in the right-side 
information area.

Only certain sample rates are available. If the sample rate you want is not 
possible, the next lower available sample rate is used.

5 Select the Max Memory Depth softkey and turn the Entry knob or mouse scroll 
wheel (or select the softkey again and use a keypad dialog box) to select the 
desired acquisition memory depth.

The actual memory depth used is displayed in the Summary box in the 
right-side information area.
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Single acquisitions usually give you the memory depth you want, unless the 
maximum amount of memory available has been halved because both channels 
in a pair are turned on. (Channels 1 and 2 are one pair, channels 3 and 4 are the 
other.)

When the oscilloscope is running (continuously making acquisitions), the actual 
memory depth used is always halved.

6 Press the front panel [Run] or [Single] keys, or choose Main Menu > Run/Stop or 
Main Menu > Single.
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To make cursor measurements / 205
Cursor Examples / 207

Cursors are horizontal and vertical markers that indicate X-axis values and Y-axis 
values on a selected waveform source. You can use cursors to make custom 
voltage, time, phase, or ratio measurements on oscilloscope signals.

Cursor information is displayed in the right-side information area.

Cursors are not always limited to the visible display. If you set a cursor, then pan 
and zoom the waveform until the cursor is off screen, its value will not be changed. 
It will still be there when you return to its original location.

X Cursors X cursors are vertical dashed lines that adjust horizontally and can be used to 
measure time (s), frequency (1/s), phase (°), and ratio (%).

The X1 cursor is the short-dashed vertical line, and the X2 cursor is the 
long-dashed vertical line.

When used with the FFT math function as a source, the X cursors indicate 
frequency.

In XY horizontal mode, the X cursors display channel 1 values (Volts or Amps).

The X1 and X2 cursor values for the selected waveform source are displayed in the 
softkey menu area.

The difference between X1 and X2 (ΔX) and 1/ΔX are displayed in the Cursors box 
in the right-side information area.

Y Cursors Y cursors are horizontal dashed lines that adjust vertically and can be used to 
measure Volts or Amps, dependent on the channel Probe Units setting, or they can 
measure ratios (%). When math functions are used as a source, the measurement 
units correspond to that math function.

The Y1 cursor is the short-dashed horizontal line and the Y2 cursor is the 
long-dashed horizontal line.

The Y cursors adjust vertically and typically indicate values relative to the 
waveform's ground point, except math FFT where the values are relative to 0 dB.
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In XY horizontal mode, the Y cursors display channel 2 values (Volts or Amps).

When active, the Y1 and Y2 cursor values for the selected waveform source are 
displayed in the softkey menu area.

The difference between Y1 and Y2 (ΔY) is displayed in the Cursors box in the 
right-side information area.
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To make cursor measurements

1 Connect a signal to the oscilloscope and obtain a stable display.

2 Choose Main Menu > Measure > Cursors.

The Cursors box in the right-side information area appears, indicating that 
cursors are "on". (Choose Main Menu > Measure > Cursors again when you want to 
turn cursors off.)

3 In the Cursors Menu, click Mode; then, select the desired mode:

• Manual — ΔX, 1/ΔX, and ΔY values are displayed. ΔX is the difference between 
the X1 and X2 cursors and ΔY is the difference between the Y1 and Y2 
cursors.

• Track Waveform — As you move a marker horizontally, the vertical amplitude 
of the waveform is tracked and measured. The time and voltage positions 
are shown for the markers. The vertical (Y) and horizontal (X) differences 
between the markers are shown as ΔX and ΔY values.

• Measure — When measurements are displayed, this mode shows the cursor 
locations used to make the measurement. When you add a measurement, it 
becomes the one that cursors are displayed for. You can use the 
Measurement softkey or click in the Meas sidebar dialog to select the 
measurement whose cursor locations are displayed.

• Binary — Logic levels of displayed waveforms at the current X1 and X2 cursor 
positions are displayed in the Cursor sidebar dialog in binary. The display is 
color coded to match the color of the related channel's waveform.

• Hex — Logic levels of displayed waveforms at the current X1 and X2 cursor 
positions are displayed in the Cursor sidebar dialog in hexadecimal.

Manual and Track Waveform modes can be used on waveforms that are displayed 
on the analog input channels (including math functions).

In Hex and Binary modes, a level can be displayed as 1 (higher than trigger 
level), 0 (lower than trigger level), indeterminate state (-), or X (don't care).
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In Binary mode, X is displayed if the channel is turned off.

In Hex mode, the channel is interpreted as 0 if turned off.

4 Click Source (or X1 Source, X2 Source in the Track Waveform mode); then, select 
the input source for cursor values.

5 Click the Cursors softkey; then, select the cursor(s) to be adjusted.

The X1 X2 linked and Y1 Y2 linked selections let you adjust both cursors at the 
same time, while the delta value remains the same. This can be useful, for 
example, for checking pulse width variations in a pulse train.

The currently selected cursor(s) display brighter than the other cursors.

When individual cursors are selected, click the softkey to disable or reenable 
the cursor display.

6 To change the cursor units, click the Units softkey.

In the Cursor Units Menu:

You can click the X Units softkey to select:

• Seconds (s).

• Hz (1/s).

• Phase (°) — when selected, use the Use X Cursors softkey to set the current X1 
location as 0 degrees and the current X2 location as 360 degrees.

• Ratio (%) — when selected, use the Use X Cursors softkey to set the current X1 
location as 0% and the current X2 location as 100%.

You can click the Y Units softkey to select:

• Base — the same units used for the source waveform.

• Ratio (%) — when selected, use the Use Y Cursors softkey to set the current Y1 
location as 0% and the current Y2 location as 100%.

For phase or ratio units, once the 0 and 360 degree or 0 and 100% locations are 
set, adjusting cursors will display measurements relative to the set locations.

7 Drag the cursor name handles to position them. See "Drag Cursors" on 
page 30.
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Cursor Examples

Figure 34 Cursors used to measure pulse widths other than middle threshold points

Figure 35 Cursors measure frequency of pulse ringing
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Expand the display with Zoom mode, then characterize the event of interest with 
the cursors.

Put the X1 cursor on one side of a pulse and the X2 cursor on the other side of the 
pulse.

Figure 36 Cursors track Zoom window



Cursors 12

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 209

 

Click the X1 X2 linked softkey and move the cursors together to check for pulse 
width variations in a pulse train.

Figure 37 Measuring pulse width with cursors
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Figure 38 Moving the cursors together to check pulse width variations
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To make automatic measurements / 213
To edit measurements / 215
Measurements Summary / 216
Voltage Measurements / 220
Time Measurements / 227
Count Measurements / 234
Mixed Measurements / 236
FFT Analysis Measurements / 237
Measurement Thresholds / 239
Measurement Window / 241
Measurement Statistics / 242
Measurement Limit Testing / 244
Precision Measurements and Math / 246

The Main Menu > Measure > Measurements menu lets you make automatic 
measurements on waveforms. Some measurements can only be made on analog 
input channels.

The results of the last eight selected measurements are displayed in the 
Measurements list dialog (which can be selected from the right-hand sidebar 
menu — see "Select Sidebar Information or Controls" on page 28 and "Undock 
Sidebar Dialog Boxes by Dragging" on page 29).

When you add a measurement, it appears at the bottom of the Measurements list 
dialog box, and cursors that show the portion of the waveform being measured are 
automatically displayed. You can change the measurement for which cursors are 
displayed by clicking the measurement in the list and choosing Track With Cursors in 
the popup menu or by selecting the measurement in the Cursors Menu.
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NOTE Post Acquisition Processing

In addition to changing display parameters after the acquisition, you can perform all of the 
measurements and math functions after the acquisition. Measurements and math functions 
will be recalculated as you pan and zoom and turn channels on and off. As you adjust the 
horizontal and vertical scale of a waveform, you affect the resolution of the display. Because 
measurements and math functions are performed on displayed data, you affect the resolution 
of functions and measurements.
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To make automatic measurements

1 Choose Main Menu > Measure > Measurements to display the Measurement Menu.

2 Click Add Meas to open the Add Measurements Menu.

3 If the Parameter softkey is available, select Source.

The Parameter softkey is available when there are multiple settings for a 
measurements.

4 Click the Source softkey to select the channel, running math function, or 
reference waveform to be measured.

Only channels, math functions, or reference waveforms that are displayed are 
available for measurements.

5 Click the Type: softkey; then, select a measurement to be made.

NOTE If a portion of the waveform required for a measurement is not displayed or does not display 
enough resolution to make the measurement (approximately 4% of full scale), the result will 
display "No Edges", "Clipped", "Low Signal" (not enough amplitude), "< value", or "> value", or 
a similar message to indicate that the measurement may not be reliable.
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You can click the "+" in the Measurements sidebar dialog to open the 
measurement type menu. See also "Click Softkeys and Menus On the Screen" 
on page 31.

For more information on the types of measurements, see "Measurements 
Summary" on page 216.

6 Click the Add Measurement softkey to display the measurement.

Cursors are turned on to show the portion of the waveform being measured for 
the most recently added measurement (bottom-most on the display). To view 
the cursors for a previously added measurement (but not the last one), add the 
measurement again.

By default, measurement statistics are displayed. See "Measurement 
Statistics" on page 242.

7 To turn off measurements, choose Main Menu > Measure > Measurements again.

Measurements are erased from the display.

8 To stop making one or more measurements, click the Clear Meas softkey in the 
Measurement Menu and select the measurement to clear, or click Clear All.

After all measurements have been cleared, choosing Main Menu > Measure > 
Measurements again, the default measurements will be Frequency and 
Peak-Peak.
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To edit measurements

When added measurements have parameters that can be edited (like the Delay, 
Phase, Occupied Bandwidth, ACPR, or THD measurements), you can edit the 
parameters of those measurements.

1 Choose Main Menu > Measure > Measurements to display the Measurement Menu.

2 Click Edit Meas to open the Edit Measurements Menu.

3 Click the Parameter softkey to select the parameter(s) you would like to edit; 
then, use the remaining softkeys to edit that parameter.
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Measurements Summary

The automatic measurements provided by the oscilloscope are listed in the 
following table. All measurements are available for analog channel waveforms. All 
measurements except Counter are available for reference waveforms and math 
waveforms other than FFT. A limited set of measurements is available for math FFT 
waveforms (as described in the following table).

Table 4 Measurements Summary

Measurement Valid for 
Math FFT*

Notes

"Snapshot All" on page 218

"Adjacent Channel Power Ratio 
(ACPR)" on page 237

Yes Measurement is valid for FFT Magnitude 
math waveforms only.

"Amplitude" on page 221

"Area" on page 236

"Average" on page 224 Yes, Full 
Screen

"Base" on page 222

"Bit Rate" on page 230

"Burst Width" on page 229

"Channel Power" on page 237 Yes Measurement is valid for FFT Magnitude 
math waveforms only.

"Counter" on page 228 Not valid for math waveforms.

"Delay" on page 231 Measures between two sources. Click 
Settings to specify the second source.

"Duty Cycle" on page 229

"Fall Time" on page 230

"Frequency" on page 228

"Maximum" on page 220 Yes

"Minimum" on page 221 Yes

"Rising Edge Count" on page 234

"Falling Edges Count" on 
page 235

"Positive Pulse Count" on 
page 234
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Power App
Measurements

Note that additional Power App measurements are available when the power 
measurement and analysis license is installed and the Power Application is 
enabled. For more information, see the Power Measurement Application User's 
Guide at www.keysight.com/manuals/M9241A or on the Documentation CD.

"Negative Pulse Count" on 
page 234

"Occupied Bandwidth" on 
page 237

Yes Measurement is valid for FFT Magnitude 
math waveforms only.

"Overshoot" on page 222

"Peak-Peak" on page 220 Yes

"Period" on page 227

"Phase" on page 232 Measures between two sources. Click 
Settings to specify the second source.

"Preshoot" on page 223

"Ratio" on page 226 Measures between two sources. Click 
Settings to specify the second source.

"Rise Time" on page 230

"Slew Rate" on page 236

"DC RMS" on page 224

"AC RMS" on page 225

"Time at Edge" on page 230

"Top" on page 221

"Total Harmonic Distortion 
(THD)" on page 238

Yes Measurement is valid for FFT Magnitude 
math waveforms only.

"+ Width" on page 229

"– Width" on page 229

"X at Max Y" on page 233 Yes The resultant units are in Hertz.

"X at Min Y" on page 233 Yes The resultant units are in Hertz.

"Y at X" on page 221 Yes With FFT waveforms, X is a frequency value.

* Use the cursors to make other measurements on FFT.

Table 4 Measurements Summary (continued)

Measurement Valid for 
Math FFT*

Notes

http://www.keysight.com/manuals/M9241A
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Dual-Channel
(N2820A Probe)

Measurements

Note that additional measurements are available with the N2820A high-sensitivity 
current probe when both the Primary and Secondary probe cables are used. 
Zoom In waveform data below the probe's clamp level is joined with Zoom Out 
waveform data above the probe's clamp level to create the waveform on which the 
measurement is made. These measurements are only valid for analog input 
channels.

When using the N2820A probe to make measurements on a battery-powered 
(floating) device, always connect the supplied ground lead between ground on 
your device and the probe's ground connector as shown in the following figure. 
Simply snap the end of the ground lead onto the probe's connector. Without the 
ground connection, the probe's common-mode input amplifier cannot properly 
display waveforms.

Snapshot All

The Snapshot All measurement type displays a popup containing a snapshot of all 
the single waveform measurements.

Dual-Channel (N2820A Probe) 
Measurement

Notes

Amplitude See "Amplitude" on page 221.

Charge Charge (in Amp-hours) is the measured area under 
the waveform. See "Area" on page 236.

Average See "Average" on page 224.

Base See "Base" on page 222.

Peak-Peak See "Peak-Peak" on page 220.

DC RMS See "DC RMS" on page 224.

AC RMS See "AC RMS" on page 225.

Figure 39 Measurements on Battery Powered Devices Using the N2820A Probe
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You can also configure the Main Menu > Quick Action menu item to display the 
Snapshot All popup. See "Configuring the Quick Action Menu Item" on page 317.
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Voltage Measurements

The following figure shows the voltage measurement points.

Measurement units for each input channel can be set to Volts or Amps using the 
channel Probe Units softkey. See "To specify the channel units" on page 61.

The units of math waveforms are described in "Units for Math Waveforms" on 
page 69.

• "Peak-Peak" on page 220

• "Maximum" on page 220

• "Minimum" on page 221

• "Amplitude" on page 221

• "Top" on page 221

• "Base" on page 222

• "Overshoot" on page 222

• "Preshoot" on page 223

• "Average" on page 224

• "DC RMS" on page 224

• "AC RMS" on page 225

• "Ratio" on page 226

Peak-Peak

The peak-to-peak value is the difference between Maximum and Minimum values. 
The Y cursors show the values being measured.

Maximum

Maximum is the highest value in the waveform display. The Y cursor shows the 
value being measured.

Amplitude

Maximum

Minimum
Base

Top

Peak-Peak
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Minimum

Minimum is the lowest value in the waveform display. The Y cursor shows the 
value being measured.

Y at X

Y at X measures the vertical value at a specified horizontal location on the specified 
source waveform. The horizontal location must be on the screen.

When the horizontal axis is time, the horizontal location is a time value referenced 
to the trigger event.

When the source is an FFT (Fast Fourier Transform) waveform, the horizontal axis 
is frequency instead of time, and the horizontal location is a frequency value.

Amplitude

The Amplitude of a waveform is the difference between its Top and Base values. 
The Y cursors show the values being measured.

Top

The Top of a waveform is the mode (most common value) of the upper part of the 
waveform, or if the mode is not well defined, the top is the same as Maximum. The 
Y cursor shows the value being measured.

See Also • "To isolate a pulse for Top measurement" on page 221

To isolate a pulse for Top measurement

The following figure shows how to use Zoom mode to isolate a pulse for a Top 
measurement.

You may need to change the measurement window setting so that the 
measurement is made in the lower, Zoom window. See "Measurement Window" 
on page 241.
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Base

The Base of a waveform is the mode (most common value) of the lower part of the 
waveform, or if the mode is not well defined, the base is the same as Minimum. 
The Y cursor shows the value being measured.

Overshoot

Overshoot is distortion that follows a major edge transition expressed as a 
percentage of Amplitude. The X cursors show which edge is being measured (edge 
closest to the trigger reference point).

Figure 40 Isolating area for Top measurement

Rising edge overshοot =
local Maximum − D Top

Amplitude
× 100

Falling edge overshοot = Base − D local Minimum
Amplitude

× 100
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Preshoot

Preshoot is distortion that precedes a major edge transition expressed as a 
percentage of Amplitude. The X cursors show which edge is being measured (edge 
closest to the trigger reference point).

Figure 41 Automatic Overshoot measurement

Overshoot
local Maximum

local Minimum

Base

Top

Overshoot

Rising edge preshοot =
local Maximum − D Top

Amplitude
× 100

Falling edge preshοot = Base − D local Minimum
Amplitude

× 100
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Average

Average is the sum of the levels of the waveform samples divided by the number of 
samples.

Where xi = value at ith point being measured, n = number of points in 
measurement interval.

The Full Screen measurement interval variation measures the value on all 
displayed data points.

The N Cycles measurement interval variation measures the value on an integral 
number of periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X cursors show what interval of the waveform is being measured.

DC RMS

DC RMS is the root-mean-square value of the waveform over one or more full 
periods.

Where xi = value at ith point being measured, n = number of points in 
measurement interval.

The Full Screen measurement interval variation measures the value on all 
displayed data points.

The N Cycles measurement interval variation measures the value on an integral 
number of periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X cursors show the interval of the waveform being measured.

Preshootlocal Maximum

local Minimum

Base

Top

Preshoot

Average =
∑ xi
n

RMS (dc) =
∑i=1

n
xi

2

n
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AC RMS

AC RMS is the root-mean-square value of the waveform, with the DC component 
removed. It is useful, for example, for measuring power supply noise.

The N Cycles measurement interval measures the value on an integral number of 
periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X cursors show the interval of the waveform being measured.

The Full Screen (Std Deviation) measurement interval variation is an RMS 
measurement across the full screen with the DC component removed. It shows the 
standard deviation of the displayed voltage values.

The standard deviation of a measurement is the amount that a measurement 
varies from the mean value. The Mean value of a measurement is the statistical 
average of the measurement.

The following figure graphically shows the mean and standard deviation. Standard 
deviation is represented by the Greek letter sigma: σ. For a Gaussian distribution, 
two sigma (± 1σ) from the mean, is where 68.3 percent of the measurement results 
reside. Six sigma (± 3σ) from is where 99.7 percent of the measurement results 
reside.

The mean is calculated as follows:

where:

• x = the mean.

• N = the number of measurements taken.

• xi = the ith measurement result.

-2σ -1σ 1σ 2σ-3σ 3σ

x̄ =
∑i=1

N xi
N



226 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

13 Measurements
 

The standard deviation is calculated as follows:

where:

• σ = the standard deviation.

• N = the number of measurements taken.

• xi = the ith measurement result.

• x = the mean.

Ratio

The Ratio measurement displays the ratio of the AC RMS voltages of two sources, 
expressed in dB. Press the Settings softkey to select the source channels for the 
measurement.

σ =
∑i=1

N
(xi − x̄)

2

N
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Time Measurements

The following figure shows time measurement points.

The default lower, middle, and upper measurement thresholds are 10%, 50%, and 
90% between Top and Base values. See "Measurement Thresholds" on page 239 
for other percentage threshold and absolute value threshold settings.

• "Period" on page 227

• "Frequency" on page 228

• "Counter" on page 228

• "+ Width" on page 229

• "– Width" on page 229

• "Burst Width" on page 229

• "Duty Cycle" on page 229

• "Bit Rate" on page 230

• "Rise Time" on page 230

• "Fall Time" on page 230

• "Delay" on page 231

• "Phase" on page 232

• "X at Min Y" on page 233

• "X at Max Y" on page 233

Period

Period is the time period of the complete waveform cycle. The time is measured 
between the middle threshold points of two consecutive, like-polarity edges. A 
middle threshold crossing must also travel through the lower and upper threshold 
levels which eliminates runt pulses. The X cursors show what portion of the 
waveform is being measured. The Y cursor shows the middle threshold point.

Rise Time

+ Width

Fall Time

- Width
Period

Middle
Upper

Thresholds

Lower
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Frequency

Frequency is defined as 1/Period. Period is defined as the time between the middle 
threshold crossings of two consecutive, like-polarity edges. A middle threshold 
crossing must also travel through the lower and upper threshold levels which 
eliminates runt pulses. The X cursors show what portion of the waveform is being 
measured. The Y cursor shows the middle threshold point.

See Also • "To isolate an event for frequency measurement" on page 228

To isolate an event for frequency measurement

The following figure shows how to use Zoom mode to isolate an event for a 
frequency measurement.

You may need to change the measurement window setting so that the 
measurement is made in the lower, Zoom window. See "Measurement Window" 
on page 241.

If the waveform is clipped, it may not be possible to make the measurement.

Counter

The InfiniiVision M9241/42/43A PXIe oscilloscopes have an integrated hardware 
frequency counter which counts the number of cycles that occur within a period of 
time (known as the gate time) to measure the frequency of a signal.

Figure 42 Isolating an event for Frequency measurement
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The gate time is the horizontal range of the oscilloscope but is limited to >= 0.1 s 
and <= 10 s. Unlike other measurements, the Zoom horizontal timebase window 
does not gate the Counter measurement.

The Counter measurement can measure frequencies up to the bandwidth of the 
oscilloscope. The minimum frequency supported is 2.0 / gateTime.

The hardware counter uses the trigger comparator output. Therefore, the counted 
channel's trigger level (or threshold for digital channels) must be set correctly.

Analog and digital channels can be selected as the source.

Only one Counter measurement can be displayed at a time.

See Also • "Counter" on page 264

+ Width

+ Width is the time from the middle threshold of the rising edge to the middle 
threshold of the next falling edge. The X cursors show the pulse being measured. 
The Y cursor shows the middle threshold point.

– Width

– Width is the time from the middle threshold of the falling edge to the middle 
threshold of the next rising edge. The X cursors show the pulse being measured. 
The Y cursor shows the middle threshold point.

Burst Width

The Burst Width measurement is the time from the first edge to the last edge on 
screen.

Duty Cycle

The duty cycle of a repetitive pulse train is the ratio of the pulse width to the 
period, expressed as a percentage. The X cursors show the time period being 
measured. The Y cursor shows the middle threshold point.

Burst width



230 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

13 Measurements
 

Bit Rate

The bit rate measurement measures all positive and negative pulse widths on the 
waveform, takes the minimum value found of either width type and inverts that 
minimum width to give a value in Hertz.

Rise Time

The rise time of a signal is the time difference between the crossing of the lower 
threshold and the crossing of the upper threshold for a positive-going edge. The X 
cursor shows the edge being measured. For maximum measurement accuracy, set 
the horizontal time/div as fast as possible while leaving the complete rising edge 
of the waveform on the display. The Y cursors show the lower and upper threshold 
points.

Fall Time

The fall time of a signal is the time difference between the crossing of the upper 
threshold and the crossing of the lower threshold for a negative-going edge. The X 
cursor shows the edge being measured. For maximum measurement accuracy, set 
the horizontal time/div as fast as possible while leaving the complete falling edge 
of the waveform on the display. The Y cursors show the lower and upper threshold 
points.

Time at Edge

Time at Edge measures the horizontal time of the edge location specified by the 
Source, Slope, and Edge # parameters.

The threshold voltage used for this measurement is the 50% point with a small 
amount of hysteresis added. (The "middle" measurement threshold setting for the 
source waveform does not affect this measurement.)

When the specified slope and edge number threshold crossing is found, the 
oscilloscope reports the time of that crossing in seconds, with the trigger point 
(time=zero) as the reference.

If the specified crossing cannot be found, that is, if the waveform does not cross 
the 50% vertical value, or if the waveform does not cross the 50% vertical value for 
the specific number of times at the slope specified, the oscilloscope reports "No 
edges".

+ Duty cycle = + Width
Period

× 100 − Duty cycle = − Width
Period

× 100
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When Auto is selected as the Edge #, the edge closest to the timebase reference 
point is used. When you specify an edge number, edges are counted from the left 
side of the display.

FFT (Fast Fourier Transform) waveforms cannot be selected as the source.

Delay

Delay measures the time difference from the specified source 1 edge that is closest 
to the center of the screen and the nearest specified source 2 edge using the 
specified threshold points on the waveforms.

Negative delay values indicate that the selected edge of source 1 occurred after 
the selected edge of source 2.

1 Choose Main Menu > Measure > Measurements.

2 In the Measurement Menu, click Add Meas.

3 In the Add Measurements Menu, click the Type: softkey; then, select Delay.

4 Click the Parameter softkey; then, select and specify the following parameters:

• Source 1, Source 2 — waveform source.

• Source 1 Slope, Source 2 Slope — rising edge or falling edge.

• Source 1 Edge #, Source 2 Edge # — edge number for the selected source.

When Auto is selected for the Source 1 Edge #, the edge closest to the 
timebase reference point is used. Auto is also automatically selected for the 
Source 2 Edge #, and cannot be changed. In this case, the source 2 edge 
closest to the source 1 edge is used.

When edge numbers are selected, edges are counted from the left side of 
the display for both sources.

• Source 1 Threshold, Source 2 Threshold — specifies whether the measurement 
should be made using the Upper, Middle, or Lower threshold level on the 
source.

5 Click the Add Measurement softkey to make the measurement.

The example below shows a delay measurement between the rising edge of 
channel 1 and the rising edge of channel 2.

Source 2

Source 1

Delay
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Phase

Phase is the calculated phase shift from source 1 to source 2, expressed in 
degrees. Negative phase shift values indicate that the rising edge of source 1 
occurred after the rising edge of source 2.

1 Choose Main Menu > Measure > Measurements.

2 In the Measurement Menu, click Add Meas.

3 In the Add Measurements Menu, click the Type: softkey; then, select Phase.

4 Click the Parameter softkey; then, select and specify the following parameters:

• Source 1

• Source 2

The default Phase settings measure from channel 1 to channel 2.

5 Click the Add Measurement softkey to make the measurement.

Phase =
Delay

Source 1 Period
× 360

Source 2

Source 1
Delay

Period
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The example below shows a phase measurement between the channel 1 and 
channel 2.

X at Min Y

X at Min Y is the X axis value (usually time) at the first displayed occurrence of the 
waveform Minimum, starting from the left-side of the display. For periodic signals, 
the position of the minimum may vary throughout the waveform. The X cursor 
shows where the current X at Min Y value is being measured.

X at Max Y

X at Max Y is the X axis value (usually time) at the first displayed occurrence of the 
waveform Maximum, starting from the left-side of the display. For periodic signals, 
the position of the maximum may vary throughout the waveform. The X cursor 
shows where the current X at Max Y value is being measured.

See Also • "To measure the peak of an FFT" on page 233

To measure the peak of an FFT

1 Select FFT as the Operator in the Waveform Math Menu.

2 Choose Math N as the source in the Add Measurements Menu.

3 Choose Maximum and X at Max Y measurements.

Maximum units are in dB and X at Max Y units are in Hertz for FFT.



234 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

13 Measurements
 

Count Measurements

• "Positive Pulse Count" on page 234

• "Negative Pulse Count" on page 234

• "Rising Edge Count" on page 234

• "Falling Edges Count" on page 235

Positive Pulse Count

The Positive Pulse Count measurement is a pulse count for the selected waveform 
source.

Negative Pulse Count

The Negative Pulse Count measurement is a pulse count for the selected waveform 
source.

Rising Edge Count

The Rising Edge Count measurement is an edge count for the selected waveform 
source.

This measurement is available for analog channels.

Positive pulse count

Negative pulse count
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Falling Edges Count

The Falling Edges Count measurement is an edge count for the selected waveform 
source.

This measurement is available for analog channels.
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Mixed Measurements

• "Area" on page 236

Area

Area measures the area between the waveform and the ground level. Area below 
the ground level is subtracted from area above the ground level.

The Full Screen measurement interval variation measures the value on all 
displayed data points.

The N Cycles measurement interval variation measures the value on an integral 
number of periods of the displayed signal. If less than three edges are present, the 
measurement shows "No edges".

The X cursors show what interval of the waveform is being measured.

Slew Rate

Slew Rate measures the change in vertical value (ΔY) divided by the change in 
horizontal value (ΔX) for the edge closest to the timebase reference point specified 
by the Source and Slope parameters.

The lower and upper thresholds for the measurement are specified by the 
measurement threshold setting for the source waveform.

FFT (Fast Fourier Transform) waveforms cannot be selected as the source.

T

Negative area
N cycles

Positive area
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FFT Analysis Measurements

• "Channel Power" on page 237

• "Occupied Bandwidth" on page 237

• "Adjacent Channel Power Ratio (ACPR)" on page 237

• "Total Harmonic Distortion (THD)" on page 238

Channel Power

Channel Power measures the spectral power across a frequency range.

The center frequency used in the measurement is the one defined for the FFT 
function, and the FFT span specifies the frequency range.

When this measurement is tracked with cursors, the cursors are at the far left and 
right edges of the graticule.

Occupied Bandwidth

Occupied Bandwidth measures the bandwidth (frequency range) containing some 
percent (usually 99%) of the total spectral power. While 99% is the industry norm, 
you can specify the percent you want to use in the measurement.

The center frequency used in the measurement is the one defined for the FFT 
function, and the FFT span represents the total spectral power.

When this measurement is tracked with cursors, the cursors show the measured 
bandwidth (frequency range).

Adjacent Channel Power Ratio (ACPR)

Adjacent Channel Power Ratio or just Adjacent Power Ratio (or channel leakage 
ratio) measures the ratio of the power contained in one or more sidebands to the 
power in the main frequency range.

The main range is specified by a channel width and a center frequency. The 
Channel Width is one of the measurement's parameters. The center frequency 
used in the measurement is the one defined for the FFT function.

Sidebands (with the same width as the main range) exist above and below the 
main range separated by the channel spacing width. The Channel Spacing width 
is another measurement parameter.
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The sideband used for the measurement is selected with the Channel Select 
parameter. You can select the first through fifth sidebands above or below the 
main range (1H through 5H above and 1L through 5L below). The full sideband 
must be in the graticule to be measured. Otherwise, the measurement results will 
be "Incomplete".

When this measurement is tracked with cursors, the cursors show the sideband 
being measured.

Total Harmonic Distortion (THD)

Total Harmonic Distortion (THD) is the ratio of power in the fundamental frequency to 
the power contained in the rest of the harmonics and noise. THD is a measure of 
signal purity.

Total Harmonic Distortion (THD) measures the power contained in the bands 
surrounding each harmonic and compares it to the power in the band surrounding 
the fundamental frequency. The width of the bands measured is the same for the 
fundamental frequency and each harmonic. That width is 1/2 of the fundamental 
frequency.

You can either enter the fundamental frequency as a measurement parameter and 
have the fundamental frequency and harmonics be tracked manually, or you can 
allow the fundamental frequency and harmonics to be tracked automatically, 
where the highest peak is assumed to be the fundamental frequency.

When this measurement is tracked with cursors, the cursors show the band 
surrounding the fundamental frequency that is being measured (at ±1/4 of the 
fundamental frequency).

Main 1H 2H 3H 4H 5H5L 4L 3L 2L 1L

WidthSpacing
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Measurement Thresholds

Setting measurement thresholds defines the vertical levels where measurements 
will be taken on an analog channel or math waveform.

1 From the Measurement Menu, click the Thresholds softkey to set analog channel 
measurement thresholds.

You can also open the Measurement Threshold Menu by choosing Main Menu > 
Analyze > Analyze Menu, clicking Features, and then selecting Measurement 
Thresholds.

2 Click the Source softkey to select the analog channel or math waveform source 
for which you want to change measurement thresholds.

Each analog channel and the math waveform can be assigned unique threshold 
values.

3 Click the Type softkey to set the measurement threshold to % (percentage of 
Top and Base value) or to Absolute (absolute value).

• Percentage thresholds can be set from 0% to 100%.

• The units for absolute threshold for each channel is set in the channel probe 
menu.

4 Click the Lower softkey; then, enter the lower measurement threshold value.

NOTE Changing default thresholds may change measurement results

The default lower, middle, and upper threshold values are 10%, 50%, and 90% of the value 
between Top and Base. Changing these threshold definitions from the default values may 
change the returned measurement results for Average, Delay, Duty Cycle, Fall Time, 
Frequency, Overshoot, Period, Phase, Preshoot, Rise Time, +Width, and -Width.

TIP Absolute threshold hints

• Absolute thresholds are dependent on channel scaling, probe attenuation, and probe units. Always 
set these values first before setting absolute thresholds.

• The minimum and maximum threshold values are limited to on-screen values.

• If any of the absolute threshold values are above or below the minimum or maximum waveform 
values, the measurement may not be valid.
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Increasing the lower value beyond the set middle value will automatically 
increase the middle value to be more than the lower value. The default lower 
threshold is 10% or 800 mV.

If threshold Type is set to %, the lower threshold value can be set from 0% to 
98%.

5 Click the Middle softkey; then, enter the middle measurement threshold value.

The middle value is bounded by the values set for lower and upper thresholds. 
The default middle threshold is 50% or 1.20 V.

• If threshold Type is set to %, the middle threshold value can be set from 1% 
to 99%.

6 Click the Upper softkey; then, enter the upper measurement threshold value.

Decreasing the upper value below the set middle value will automatically 
decrease the middle value to be less than the upper value. The default upper 
threshold is 90% or 1.50 V.

• If threshold Type is set to %, the upper threshold value can be set from 2% to 
100%.
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Measurement Window

You can choose whether measurements are made in the Main window portion of 
the display, the Zoom window portion of the display (when the zoomed time base 
is displayed), or gated by the X1 and X2 cursors.

1 Choose Main Menu > Measure > Measurements.

2 In the Measurement Menu, click the Meas Window softkey; then, select from:

• Auto Select — When the zoomed time base is displayed, the measurement is 
attempted in the lower, Zoom window; if it cannot be made there, or if the 
zoomed time base is not displayed, the Main window is used.

• Main — The measurement window is the Main window.

• Zoom — The measurement window is the lower, Zoom window.

• Gated by Cursors — The measurement window is between the X1 and X2 
cursors. When the zoomed time base is displayed, the X1 and X2 cursors in 
the Zoom window portion of the display are used.
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Measurement Statistics

To display measurement statistics:

1 Choose Main Menu > Measure > Measurements to display the Measurement Menu. 
By default, frequency and peak-to-peak voltage are measured on channel 1.

2 Select the measurements you desire for the channels you are using (see 
"Measurements Summary" on page 216).

3 From the Measurement Menu, click the Statistics softkey to enter the Statistics 
Menu.

4 Click the Display On softkey to enable the measurement statistics display.

The source channel of the measurement is shown in parenthesis after the 
measurement name. For example: "Freq(1)" indicates a frequency measurement 
on channel 1.

The following statistics are shown: Name of the measurement, current 
measured value, mean, minimum measured value, maximum measured value, 
standard deviation, and the number of times the measurement has been made 
(count). Statistics are based on the total number of captured waveforms 
(count).
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The standard deviation shown in Statistics is calculated using the same formula 
used for calculating the standard deviation measurement. The formula is shown 
in the section titled "AC RMS" on page 225.

You can click the Display On softkey again to disable the measurement statistics 
display. Statistics continue to accumulate even when the statistics display is 
disabled.

5 To reset the statistics measurements, click the Reset Statistics softkey. This 
resets all statistics and begins recording statistical data again.

Each time a new measurement (for example: frequency, period, or amplitude) is 
added the statistics are reset and accumulation of statistical data begins again.

6 To enable a relative standard deviation, click the Relative σ softkey.

When enabled, the standard deviation shown in measurement statistics 
becomes the standard deviation/mean.

7 To specify the number of values used when calculating measurement statistics, 
click the Max Count softkey and enter the desired value.

Other things to know about measurement statistics:

• When making a single acquisition, statistics are reset and a single 
measurement is done (count = 1). Successive single acquisitions accumulate 
statistical data (and the count is incremented).

• The Increment Statistics softkey appears only when the acquisition is stopped 
and the optional segmented memory feature is off. Choose : Main Menu > 
Run/Stop or Main Menu > Single to stop the acquisition. You can adjust the 
horizontal position to pan through the waveform. Active measurements will stay 
on screen, allowing you to measure various aspects of the captured waveforms. 
Click Increment Statistics to add the currently measured waveform to the 
collected statistical data.

• The Analyze Segments softkey is available when the acquisition is stopped and 
the optional segmented memory feature is on. After an acquisition has 
completed (and the oscilloscope is stopped), you can click the Analyze Segments 
softkey to accumulate measurement statistics for the acquired segments.

You can also turn on infinite persistence (in the Display Menu) and click the 
Analyze Segments softkey to create an infinite persistence display.
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Measurement Limit Testing

The Measurement Limit Test feature is enabled with any bundled software license 
that includes mask testing.

This feature lets you test measurement values to see whether they are inside or 
outside specified limits. You can display limit test results, and you can stop 
running oscilloscope acquisitions when there is a failure. You can specify whether 
measured values inside the limits or outside the limits are considered failures.

To enable measurement limit testing:

1 First, add the measurements whose limits you want to test.

2 Choose Main Menu > Analyze > Analyze Menu.

3 Click Features; then, select Measurement Limit Test.

4 Click Features again to enable measurement limit testing.

Measurement limit results are reset whenever Measurement Limit Test is 
switched on using the Limit softkey.

To add measurements to the limit test, specify limits, and specify whether failures 
are inside or outside the limits:

1 In the Analyze menu, click Setup.

2 In the Limit Test Setup menu, click Measurement; then, select the measurement 
you want to include. Click Measurement again or select the measurement again 
to enable it.

3 Use the Lower Limit and Upper Limit softkeys to enter the measurement limits.

You can set the limits as a margin of the measured minimum and maximum 
values by using the Copy Margin softkey to specify the percent margin; then, 
click Copy From Results to set the Lower Limit and Upper Limit values.

4 Use the Fail When softkey to select whether failures are Outside Limits or Inside 
Limits.

Repeate the previous steps for each measuremement you want to include in the 
limit test.

For each enabled measurement, these values are displayed:

• Measurement name (and source channel number)
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• The minimum measured value

• The maximum measured value

• The number of failures on the lower limit

• The number of failures on the upper limit

• The number of times the measurement has been made (count)

The source channel of the measurement is shown in parenthesis after the 
measurement name. For example, "Freq(1)" indicates a frequency measurement 
on channel 1.

Counts, failures, and minimum and maximum values continue to be accumulated 
whether the limit test information is displayed or not.

To stop running acquisitions when there are measurement limit test failures:

1 In the Analyze menu, click Stop On Failure to enable it.
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Precision Measurements and Math

Normally, after choosing Main Menu > Default Setup, the oscilloscope performs 
measurements and generates math waveforms using a 65535-point (maximum) 
measurement record. This measurement record is purposely small in order to 
provide high waveform update rates and minimal "dead time" between 
acquisitions to improve the probability of capturing infrequent events.

However, at the expense of waveform update rate, you can enable precision 
measurements and math waveforms that use a user-selectable 100k-point to 
1M-point (maximum) record. This mode gives you better resolution on 
measurements and math waveforms (including FFT).

To enable precision measurements and math:

1 Choose Main Menu > Analyze > Analyze Menu.

2 Click Features; then, select Precision.

3 Click Features again to enable precision measurements and math waveforms.

4 Click the Rec Length softkey and enter the length of the precision analysis 
record.

You can specify between 100k and 1M points.

Precision measurements and math are disabled in the same way, or you can 
disable them by choosing Main Menu > Default Setup.
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14 Mask Testing

To create a mask from a "golden" waveform (Automask) / 248
Mask Test Setup Options / 250
Mask Statistics / 252
To manually modify a mask file / 254
Building a Mask File / 257

One way to verify a waveform's compliance to a particular set of parameters is to 
use mask testing. A mask defines a region of the oscilloscope's display in which 
the waveform must remain in order to comply with chosen parameters. 
Compliance to the mask is verified point-by-point across the display. Mask test 
operates on displayed analog channels; it does not operate on channels that are 
not displayed.

Mask test is a license-enabled feature.
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To create a mask from a "golden" waveform (Automask)

A golden waveform meets all chosen parameters, and it is the waveform to which 
all others will be compared.

1 Configure the oscilloscope to display the golden waveform.

2 Choose Main Menu > Analyze > Analyze Menu.

3 Click Features; then, select Mask Test.

4 Click Features again to enable mask testing.

5 Click Automask.

6 In the Automask Menu, click the Source softkey and ensure the desired analog 
channel is selected.

7 Adjust the mask's horizontal tolerance (± Y) and vertical tolerance (± X). These 
are adjustable in graticule divisions or in absolute units (volts or seconds), 
selectable using the Units softkey.

8 Click the Create Mask softkey.

The mask is created and testing begins.
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Whenever the Create Mask softkey is clicked the old mask is erased and a new 
mask is created.

9 To clear the mask and switch off mask testing, click the Back/Up softkey to 
return to the Mask Test Menu, then click the Clear Mask softkey.

If infinite persistence display mode (see "To set or clear persistence" on page 118) 
is "on" when mask test is enabled, it stays on. If infinite persistence is "off" when 
mask test is enabled, it is switched on when mask test is switched on, then infinite 
persistence is switched off when mask test is switched off.

Troubleshooting
Mask Setup

If you click Create Mask and the mask appears to cover the entire screen, check the 
± Y and ± X settings in the Automask Menu. If these are set to zero the resulting 
mask will be extremely tight around the waveform.

If you click Create Mask and it appears that no mask was created, check the ± Y and 
± X settings. They may be set so large that the mask is not visible.
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Mask Test Setup Options

From the Mask Test Menu, click the Setup softkey to enter the Mask Setup Menu.

Run Until The Run Until softkey lets you specify a condition on which to terminate testing.

• Forever — The oscilloscope runs continuously. However, if an error occurs 
the action specified using the On Error softkey will occur.

• Minimum # of Tests — Choose this option and then use the # of Tests softkey 
to select the number of times the oscilloscope will trigger, display the 
waveform(s), and compare them to the mask. The oscilloscope will stop after 
the specified number of tests have been completed. The specified minimum 
number of tests may be exceeded. If an error occurs the action specified 
using the On Error softkey will occur. The actual number of tests completed 
is displayed above the softkeys.

• Minimum Time — Choose this option and then use the Test Time softkey to 
select how long the oscilloscope will run. When the selected time has passed 
the oscilloscope will stop. The specified time may be exceeded. If an error 
occurs the action specified using the On Error softkey will occur. The actual 
test time is displayed above the softkeys.

• Minimum Sigma — Choose this option and then use the Sigma softkey to 
select a minimum sigma. The mask test runs until enough waveforms are 
tested to achieve a minimum test sigma. (If an error occurs the oscilloscope 
will perform the action specified by the On Error softkey.) Note that this is a 
test sigma (the max achievable process sigma, assuming no defects, for a 
certain number of tested waveforms) as opposed to a process sigma (which 
is tied to the amount of failures per test). The sigma value may exceed the 
selected value when a small sigma value is chosen. The actual sigma is 
displayed.

On Error The On Error setting specifies the action(s) to take when the input waveform 
does not conform to the mask. This setting supersedes the Run Until setting.

• Stop — The oscilloscope will stop when the first error is detected (on the first 
waveform that does not conform to the mask). This setting supersedes the 
Minimum # of Tests and Minimum Time settings.

• Save — The oscilloscope saves the screen image when an error is detected. 
In the Save Menu (choose Main Menu > File > Save Menu), select an image 
format (*.bmp or *.png), destination, and file name (which can be 
auto-incrementing). If errors occur too frequently and the oscilloscope 
spends all its time saving images, choose Main Menu > Run/Stop to stop 
acquisitions.

• Measure — Measurements (and measurement statistics if your oscilloscope 
supports them) run only on waveforms that contain a mask violation. 
Measurements are not affected by passing waveforms. This mode is not 
available when the acquisition mode is set to Averaging.

You can also output a signal on the Aux Out MMCX connector when there is a 
mask test failure. See "Setting the Aux Out Source" on page 312.
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Source Lock When you turn on Source Lock using the Source Lock softkey, the mask is 
redrawn to match the source whenever you move the waveform. For example, if 
you change the horizontal timebase or the vertical gain the mask is redrawn 
with the new settings.

When you turn off Source Lock, the mask is not redrawn when horizontal or 
vertical settings are changed.

Source If you change the Source channel, the mask is not erased. It is re-scaled to the 
vertical gain and offset settings of the channel to which it is assigned. To create 
a new mask for the selected source channel, go back up in the menu hierarchy; 
then, click Automask, and click Create Mask.

The Source softkey in the Mask Setup Menu is the same as the Source softkey in 
the Automask Menu.

Test All When enabled, all displayed analog channels are included in the mask test. 
When disabled, just the selected source channel is included in the test.
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Mask Statistics

From the Mask Test Menu, click the Statistics softkey to enter the Mask Statistics 
Menu.

Show Stats When you enable Show Statistics the following information is displayed:

• Current mask, name of mask, Channel number, date and time.

• # of Tests (total number of mask tests executed).

• Status (Passing, Failing, or Untested).

• Accumulated test time (in hours, minutes, seconds, and tenths of seconds).

And for each analog channel:

• Number of failures (acquisitions in which the signal excursion went beyond 
the mask).

• Failure rate (percentage of failures).

• Sigma (the ratio of process sigma to maximum achievable sigma, based on 
number of waveforms tested).
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Reset Statistics Note that statistics are also reset when:

• Mask Test is switched on after being switched off.

• Clear Mask softkey is clicked.

• An Automask is created.

Additionally, the accumulated time counter is reset whenever the oscilloscope 
is run after the acquisition was stopped.

Clear Display Clears acquisition data from the oscilloscope display.
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To manually modify a mask file

You can manually modify a mask file that you created using the Automask 
function.

1 Follow the steps 1-7 in "To create a mask from a "golden" waveform 
(Automask)" on page 248. Do not clear the mask after creating it.

2 Choose Main Menu > File > Save Menu.

3 Click the Format softkey and select Mask.

4 Click the second softkey and select a destination folder on the chassis 
controller PC.

5 Click the Press to Save softkey. This creates an ASCII text file that describes the 
mask.

6 Open the .msk file your created using a text editor (such as Wordpad).

7 Edit, save, and close the file.

The mask file contains the following sections:

• Mask File Identifier.

• Mask Title.

• Mask Violation Regions.

• Oscilloscope Setup Information.

Mask File Identifier The Mask File Identifier is MASK_FILE_548XX.

Mask Title The Mask Title is a string of ASCII characters. Example: autoMask CH1 OCT 03 
09:40:26 2008

When a mask file contains the keyword "autoMask" in the title, the edge of the 
mask is passing by definition. Otherwise, the edge of the mask is defined as a 
failure.
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Mask Violation
Regions

Up to 8 regions can be defined for a mask. They can be numbered 1-8. They can 
appear in any order in the .msk file. The numbering of the regions must go from top 
to bottom, left to right.

An Automask file contains two special regions: the region "glued" to the top of the 
display, and the region that is "glued" to the bottom. The top region is indicated by 
y-values of "MAX" for the first and last points. The bottom region is indicated by 
y-values of "MIN" for the first and last points.

The top region must be the lowest numbered region in the file. The bottom region 
must be the highest numbered region in the file.

Region number 1 is the top mask region. The vertices in Region 1 describe points 
along a line; that line is the bottom edge of the top portion of the mask.

Similarly, the vertices in Region 2 describe the line that forms the top of the 
bottom part of the mask.

The vertices in a mask file are normalized. There are four parameters that define 
how values are normalized:

• X1

• ΔX

• Y1

• Y2

Region 1

Region 2
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These four parameters are defined in the Oscilloscope Setup portion of the mask 
file.

The Y-values (normally voltage) are normalized in the file using the following 
equation:

Ynorm = (Y - Y1)/ΔY

where ΔY = Y2 - Y1

To convert the normalized Y-values in the mask file to voltage:

Y = (Ynorm * ΔY) + Y1

where ΔY = Y2 - Y1

The X-values (normally time) are normalized in the file using the following 
equation:

Xnorm = (X - X1)/ΔX

To convert the normalized X-values to time:

X = (Xnorm * ΔX) + X1

Oscilloscope
Setup Information

The keywords "setup" and "end_setup" (appearing alone on a line) define the 
beginning and end of the oscilloscope setup region of the mask file. The 
oscilloscope setup information contains remote programming language 
commands that the oscilloscope executes when the mask file is loaded.

Any legal remote programming command can be entered in this section.

The mask scaling controls how the normalized vectors are interpreted. This in turn 
controls how the mask is drawn on the display. The remote programming 
commands that control mask scaling are:

:MTES:SCAL:BIND 0
:MTES:SCAL:X1 -400.000E-06
:MTES:SCAL:XDEL +800.000E-06
:MTES:SCAL:Y1 +359.000E-03
:MTES:SCAL:Y2 +2.35900E+00
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Building a Mask File

The following display shows a mask that uses all eight regions.

This mask is created by recalling the following mask file:

MASK_FILE_548XX

"All Regions"

/* Region Number */ 1
/* Number of vertices */ 4
-12.50, MAX
-10.00, 1.750
10.00, 1.750
12.50, MAX

/* Region Number */ 2
/* Number of vertices */ 5
-10.00, 1.000
-12.50, 0.500
-15.00, 0.500
-15.00, 1.500
-12.50, 1.500

/* Region Number */ 3
/* Number of vertices */ 6
-05.00, 1.000
-02.50, 0.500
02.50, 0.500
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05.00, 1.000
02.50, 1.500
-02.50, 1.500

/* Region Number */ 4
/* Number of vertices */ 5
10.00, 1.000
12.50, 0.500
15.00, 0.500
15.00, 1.500
12.50, 1.500

/* Region Number */ 5
/* Number of vertices */ 5
-10.00, -1.000
-12.50, -0.500
-15.00, -0.500
-15.00, -1.500
-12.50, -1.500

/* Region Number */ 6
/* Number of vertices */ 6
-05.00, -1.000
-02.50, -0.500
02.50, -0.500
05.00, -1.000
02.50, -1.500
-02.50, -1.500

/* Region Number */ 7
/* Number of vertices */ 5
10.00, -1.000
12.50, -0.500
15.00, -0.500
15.00, -1.500
12.50, -1.500

/* Region Number */ 8
/* Number of vertices */ 4
-12.50, MIN
-10.00, -1.750
10.00, -1.750
12.50, MIN

setup
:CHANnel1:RANGe +8.00E+00
:CHANnel1:OFFSet +2.0E+00
:CHANnel1:DISPlay 1
:TIMebase:MODE MAIN
:TIMebase:REFerence CENTer
:TIMebase:RANGe +50.00E-09
:TIMebase:POSition +10.0E-09
:MTESt:SOURce CHANnel1
:MTESt:ENABle 1
:MTESt:LOCK 1
:MTESt:SCALe:X1 +10.0E-09
:MTESt:SCALe:XDELta +1.0000E-09
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:MTESt:SCALe:Y1 +2.0E+00
:MTESt:SCALe:Y2 +4.00000E+00
end_setup

In a mask file, all region definitions need to be separated by a blank line.

Mask regions are defined by a number of (x,y) coordinate vertices (as on an 
ordinary x,y graph). A "y" value of "MAX" specifies the top of the graticule, and a 
"y" value of "MIN" specifies the bottom of the graticule.

The mask x,y graph is related to the oscilloscope graticule using the :MTESt:SCALe 
setup commands.

The oscilloscope's graticule has a time reference location (at the left, center, or 
right of the screen) and a trigger (t=0) position/delay value relative to the 
reference. The graticule also has a vertical ground 0 V reference (offset relative to 
the center of the screen) location.

The X1 and Y1 setup commands relate the mask region's x,y graph origin to the 
oscilloscope graticule's t=0 and V=0 reference locations, and the XDELta and Y2 
setup commands specify the size of the graph's x and y units.

• The X1 setup command specifies the time location of the x,y graph's x origin.

• The Y1 setup command specifies the vertical location of the x,y graph's y origin.

• The XDELta setup command specifies the amount of time associated with each 
x unit.

• The Y2 setup command is the vertical location of the x,y graph's y=1 value (so 
in effect, Y2 – Y1 is the YDELta value).

For example:

• With a graticule whose trigger position is 10 ns (before a center screen 
reference) and whose ground reference (offset) is 2 V below the center of the 
screen, to place the mask region's x,y graph's origin at center screen, you would 
set X1 = 10 ns and Y1 = 2 V.

• If the XDELta parameter is set to 5 ns and Y2 is set to 4 V, a mask region whose 
vertices are (-1, 1), (1, 1), (1, -1), and (-1, -1) goes from 5 ns to 15 ns and from 
0 V to 4 V.

• If you move the mask region's x,y graph origin to the t=0 and V=0 location by 
setting X1 = 0 and Y1 = 0, the same vertices define a region that goes from 
-5 ns to 5 ns and from -2 V to 2 V.

NOTE Although a mask can have up to 8 regions, in any given vertical column, it is only possible to 
define 4 regions. When there are 4 regions in a vertical column, one region must be tied to the 
top (using the MAX y value) and one must be tied to the bottom (using the MIN y value).
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How is mask testing done?

InfiniiVision oscilloscopes start mask testing by creating a database that is 200 x 
640 for the waveform viewing area. Each location in the array is designated as 
either a violation or a pass area. Each time a data point from a waveform occurs in 
a violation area a failure is logged. If Test All was selected, every active analog 
channel is tested against the mask database for each acquisition. Over 2 billion 
failures can be logged per-channel. The number of acquisitions tested is also 
logged and displayed as "# of Tests".

The mask file allows greater resolution than the 200 X 640 database. Some 
quantization of data occurs to reduce the mask file data for display on-screen.
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15 Digital Voltmeter and Counter

Digital Voltmeter / 262
Counter / 264

The Digital Voltmeter (DVM) and Counter analysis features are standard on the 
M9241/42/43A PXIe oscilloscopes.
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Digital Voltmeter

The digital voltmeter (DVM) analysis feature provides 3-digit voltage 
measurements on any analog channel. DVM measurements are asynchronous from 
the oscilloscope's acquisition system and are always acquiring.

The DVM display is a seven-segment readout like you would see on a digital 
voltmeter. It shows the selected mode as well as the units. Units are selected 
using the Units softkey in the channel's Probe Menu.

The DVM display also has a scale that is determined by the channel's vertical scale 
and reference level. The scale's blue triangle pointer shows the most recent 
measurement. The white bar above that shows the measurement extrema over the 
last 3 seconds.

The DVM makes accurate RMS measurements when the signal frequency is 
between 20 Hz and 100 kHz. When the signal frequency is outside this range, 
"<BW Limit?" or ">BW Limit?" appears in the DVM display to caution you about 
inaccurate RMS measurement results.

To use the digital voltmeter:

1 Choose Main Menu > Analyze > Analyze Menu.

2 Click Features; then, select Digital Voltmeter.

3 Click Features again to enable the DVM measurements.

4 Click the Source softkey and select the analog channel on which digital 
voltmeter (DVM) measurements are made.

The selected channel does not have to be on (displaying a waveform) in order 
for DVM measurements to be made.

5 Click the Mode softkey and select the digital voltmeter (DVM) mode:

• AC RMS — displays the root-mean-square value of the acquired data, with 
the DC component removed.

• DC — displays the DC value of the acquired data.

• DC RMS — displays the root-mean-square value of the acquired data.

6 If the selected source channel is not used in oscilloscope triggering, click Auto 
Range to disable or enable automatic adjustment of the DVM channel's vertical 
scale, vertical (ground level) position, and trigger (threshold voltage) level (used 
for the counter frequency measurement).

When enabled, Auto Range overrides attempted adjustments of the channel's 
vertical scale and position.
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When disabled, you can adjust the channel's vertical scale and position 
normally.
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Counter

The counter analysis feature provides frequency, period, or edge event (totalize) 
counter measurements on any analog channel.

The counter counts trigger level crossings within a certain amount of time (gate 
time) and displays the results on a seven-segment readout (like you would see on 
a standalone counter instrument).

For frequency and period counter measurements:

• The gate time is specified indirectly by the selected number of digits of 
resolution, from 3 to 8. For higher resolutions, the gate time is greater.

• Up to 1 GHz (1.2 GHz typical) frequencies can be measured. With 8 digits of 
resolution, the counter will saturate for signals greater than 470 MHz.

For totalize measurements:

• A running count of edges is kept. You can choose whether to count positive or 
negative edges, and when edge triggering on any analog channel, you can gate 
the count with a positive or negative pulse on a second analog channel.

• Edge events with up to 1 GHz (1.2 GHz typical) frequencies can be counted.

• When gating the count, the gating signal setup time is 0 ns typical and the hold 
time is 3.5 ns typical when using similar probes for the totalize source and the 
gate source.

The counter is asynchronous from the oscilloscope's acquisition system and is 
always acquiring.

To use the counter:

1 Choose Main Menu > Analyze > Analyze Menu.

2 Click Features; then, select Counter.

3 Click Features again to enable the counter.

4 Click the Source softkey and select the analog channel or Trigger Qualified Event 
signal to make counter measurements on.

With the Trigger Qualified Event source (available when the trigger mode is not 
Edge), you can see how often trigger events are detected. This can be more 
often than when triggers actually occur, due to the oscilloscope's acquisition 
time or update rate capabilities. The Aux Out signal can show when triggers 
actually occur. Remember that the oscilloscope's trigger circuitry does not 
re-arm until the holdoff time occurs and that the minimum holdoff time is 40 ns; 
therefore, the maximum trigger qualified event frequency that can be counted 
is 25 MHz.
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The selected channel does not have to be on (displaying a waveform) in order 
for counter measurements to be made.

5 Click the Auto Setup Threshold softkey to have the oscilloscope automatically 
determine and set the threshold voltage (trigger) level for the selected analog 
channel source.

6 Click the Measure softkey and select what the counter measures:

• Frequency — the cycles per second (Hz, kHz, or MHz) of the signal.

• Period — the time periods of the signal's cycles.

• Totalize — the count of edge events on the signal.

Frequency and
Period Counter

For frequency and period measurements, click the # of Digits softkey to specify the 
resolution of the counter. You can choose from 3 to 8 digit resolutions.

Higher resolutions require longer gate times, which cause the measurement times 
to be longer as well.

Totalize Counter For (edge event) totalize measurements, click the Clear Count softkey to zero the 
edge event counter.

Click the Totalize softkey to open the Counter Totalize Menu where you can:

• Click the Source softkey to change the analog channel on which counter 
measurements are made.

• Click the Event Slope softkey to choose whether positive or negative edge events 
are counted.

• Click the Gate softkey to enable or disable gating of the edge event count using 
a positive or negative level on a second analog channel.

When gating is enabled:

a Click the Gate Source softkey and select the analog channel that will supply 
the gating signal.

The selected channel does not have to be on (displaying a waveform).

b Click the polarity softkey to choose whether positive or negative levels are 
used to gate the edge event count.

The trigger level for the selected analog channel is used to determine the 
polarity of the signal.
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16 Frequency Response Analysis

To make connections / 268
To set up and run the analysis / 269
To view and save the analysis results / 271

Frequency Response Analysis (FRA) is a licensed feature.

The Frequency Response Analysis (FRA) feature controls the built-in waveform 
generator to sweep a sine wave across a range of frequencies while measuring the 
input to and output from a device under test (DUT). At each frequency, gain (A) 
and phase are measured and plotted on a frequency response Bode chart.

When the frequency response analysis completes, you can move a marker across 
the chart to see the measured gain and phase values at each frequency point. You 
can also adjust the chart's scale and offset settings for the gain and phase plots.
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To make connections

The waveform generator output is connected to a device under test (DUT). The 
input to the device and the output from the device are probed by the oscilloscope's 
input channels.

AutoProbe 
Support

Ext
Trig

Gen
Out

Aux
Out

Ref
I/O

1

2

M9243A

PXIe Oscilloscope
1GHz

DUT
(Transfer Function)
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Waveform
generator

Output



Frequency Response Analysis 16

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 269

 

To set up and run the analysis

1 Choose Main Menu > Analyze > Analyze Menu.

2 Click Features; then, select Frequency Response Analysis.

3 Click Features again to enable the feature.

4 Click the Open Dialog... softkey to open the Frequency Response Analysis dialog 
box.

5 Select the setup tab on the left side of the dialog box (gear icon).

There are settings for:

• The start and stop frequencies in the sweep, as well as the number of points 
per decade.

• The channels probing the input and output. (Click the help icon to view a 
connection diagram.)

• The waveform generator amplitude and expected output load impedance.

To specify different amplitudes for different decades, select Amplitude Profile.
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The output impedance of the Gen Out signal is fixed at 50 ohms. However, 
the output load selection lets the waveform generator display the correct 
amplitude and offset levels for the expected output load. If the actual load 
impedance is different than the selected value, the displayed amplitude and 
offset levels will be incorrect.

6 Click the Run Analysis softkey.
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To view and save the analysis results

If the Frequency Response Analysis dialog box is not open, click the Open Dialog... 
softkey.

Select the plot tab on the left side of the dialog box (plot icon) to view the analysis 
results in a Bode plot.

The plot shows both gain and phase measurements versus frequency. There are 
two markers that can be dragged to view actual values along the plot. There is a 
control in the upper right corner for enabling or disabling the gain or phase plots, 
adjusting the scale/offset of the plots, or autoscaling.

There are also Chart Controls softkeys for making chart adjustments using the Entry 
knob or keypad dialog boxes. You can use these softkeys to adjust the gain scale 
and offset, phase scale and offset, frequency scale (starting and ending 
frequencies), or marker 1 and marker 2 positions.

Select the table tab on the left side of the dialog box (table icon) to view the 
analysis results in table form.

The table shows: the data point number, the frequency, the waveform generator 
output amplitude, the measured gain, and the measured phase. You can scroll the 
data. There is a menu control in the upper right corner for enabling or disabling 
the gain or phase table data.
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You can save (or e-mail) the analysis results by choosing Main Menu > File > 
Save Menu, clicking Format, and selecting the Frequency Response Analysis data (*.csv) 
option.
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17 Waveform Generator

To select generated waveform types and settings / 274
To edit arbitrary waveforms / 277
Output Settings / 283
To use waveform generator logic presets / 285
To add noise to the waveform generator output / 286
To add modulation to the waveform generator output / 287
To restore waveform generator defaults / 291

A waveform generator is built into the oscilloscope. It is enabled by the 
M9240AWGA upgrade license. The waveform generator gives you an easy way to 
provide input signals when testing circuitry with the oscilloscope.

Waveform generator settings can be saved and recalled with oscilloscope setups. 
See Chapter 18, “Save/Email/Recall (Setups, Screens, Data),” starting on page 
293.



274 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

17 Waveform Generator
 

To select generated waveform types and settings

1 To access the Waveform Generator Menu and enable or disable the waveform 
generator output on the front panel Gen Out MMCX connector, choose 
Main Menu > Sources > Waveform Generator.

The waveform generator output is always disabled when the instrument is first 
turned on.

The waveform generator output is automatically disabled if excessive voltage is 
applied to the Gen Out MMCX connector.

2 In the Waveform Generator Menu, click the Waveform softkey and select the 
waveform type.

3 Depending on the selected waveform type, use the remaining softkeys to set 
the waveform's characteristics.
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Waveform 
Type

Characteristics Frequency 
Range

Max. 
Amplitude 
(High-Z)1

Offset 
(High-Z)1

Arbitrary Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, and Offset/Low-Level 
softkeys to set the arbitrary waveform signal 
parameters.

Use the Edit Waveform softkey to define the 
arbitrary waveform shape. See "To edit arbitrary 
waveforms" on page 277.

100 mHz to 
12 MHz

20 mVpp to 
5 Vpp

±2.50 V

Sine Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, and Offset/Low-Level 
softkeys to set the sine signal parameters.

100 mHz to 
20 MHz

20 mVpp to 
5 Vpp

±2.50 V

Square Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, Offset/Low-Level, and 
Duty Cycle softkeys to set the square wave signal 
parameters.

The duty cycle can be adjusted from 20% to 80%.

100 mHz to 
10 MHz

20 mVpp to 
5 Vpp

±2.50 V

Ramp Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, Offset/Low-Level, and 
Symmetry softkeys to set the ramp signal 
parameters.

Symmetry represents the amount of time per cycle 
that the ramp waveform is rising and can be 
adjusted from 0% to 100%.

100 mHz to 
200 kHz

20 mVpp to 
5 Vpp

±2.50 V

Pulse Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, Offset/Low-Level, and 
Width/Width Fine softkeys to set the pulse signal 
parameters.

The pulse width can be adjusted from 20 ns to the 
period minus 20 ns.

100 mHz to 
10 MHz.

20 mVpp to 
5 Vpp

±2.50 V

DC Use the Offset softkey to set the DC level. n/a n/a ±5.00 V

Noise Use the Amplitude/High-Level and 
Offset/Low-Level to set the noise signal 
parameters.

n/a 20 mVpp to 
5 Vpp

±2.50 V

Sine Cardinal Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude, and Offset softkeys to set the sinc 
signal parameters.

100 mHz to 
1 MHz

20 mVpp to 
5 Vpp

±1.25 V

Exponential 
Rise

Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, and Offset/Low-Level 
softkeys to set the exponential rise signal 
parameters.

100 mHz to 
5 MHz

20 mVpp to 
5 Vpp

±2.50 V
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Clicking a signal parameter softkey can open a menu for selecting the type of 
adjustment. For example, you can choose to enter amplitude and offset values, 
or you can choose to enter high-level and low-level values. Or, you can choose 
to enter frequency values or period values. Keep clicking the softkey to select 
the type of adjustment.

The Settings softkey opens the Waveform Generator Settings Menu which lets you 
make other settings related to the waveform generator.

See:

• "To output the waveform generator sync pulse" on page 284

• "To specify the expected output load" on page 283

• "To use waveform generator logic presets" on page 285

• "To add modulation to the waveform generator output" on page 287

• "To add noise to the waveform generator output" on page 286

• "To restore waveform generator defaults" on page 291

Exponential 
Fall

Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude/High-Level, and Offset/Low-Level 
softkeys to set the exponential fall signal 
parameters.

100 mHz to 
5 MHz

20 mVpp to 
5 Vpp

±2.50 V

Cardiac Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude, and Offset softkeys to set the 
cardiac signal parameters.

100 mHz to 
200 kHz

20 mVpp to 
5 Vpp

±1.25 V

Gaussian Pulse Use the Frequency/Frequency Fine/Period/Period 
Fine, Amplitude, and Offset softkeys to set the 
Gaussian pulse signal parameters.

100 mHz to 
5 MHz

20 mVpp to 
4 Vpp

±1.25 V

1When the output load is 50 Ω, these values are halved.

Waveform 
Type

Characteristics Frequency 
Range

Max. 
Amplitude 
(High-Z)1

Offset 
(High-Z)1
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To edit arbitrary waveforms

1 When Arbitrary is selected as the generated waveform type (see "To select 
generated waveform types and settings" on page 274), click the Edit Waveform 
softkey to open the Edit Waveform Menu.

When you open the Edit Waveform Menu, you see the existing arbitrary 
waveform definition. The voltage and time period you see in the diagram are 
the bounding parameters — they come from the frequency and amplitude 
settings in the main Waveform Generator Menu.

2 Use the softkeys in the Edit Waveform Menu to define the shape of the arbitrary 
waveform:
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The New Waveform Menu is opened by clicking Create New in the Edit Waveform 
Menu.

To create a new arbitrary waveform:

1 In the New Waveform Menu, click Initial Pts; then, select the initial number of 
points in the new waveform.

The new waveform will be a square wave with the number of points you specify. 
The points are evenly spaced over the time period.

2 Use the Frequency/Frequency Fine/Period/Period Fine softkey to set the time period 
bounding parameter (repetition frequency) of the arbitrary waveform.

3 Use the Amplitude/High-Level and Offset/Low-Level softkeys to set the voltage 
bounding parameter of the arbitrary waveform.

4 When you are ready to create the new arbitrary waveform, click Apply & Edit.

Softkey Description

Create New Opens the New Waveform Menu. See "Creating New Arbitrary Waveforms" on 
page 278.

Edit Existing Opens the Edit Waveform Points Menu. See "Editing Existing Arbitrary Waveforms" on 
page 279.

Interpolate Specifies how lines are drawn between arbitrary waveform points.

When enabled, lines are drawn between points in the waveform editor. Voltage levels change 
linearly between one point and the next.

When disabled, all line segments in the waveform editor are horizontal. The voltage level of 
one point remains until the next point.

Source Selects the analog channel or reference waveform to be captured and stored to the arbitrary 
waveform. See "Capturing Other Waveforms to the Arbitrary Waveform" on 
page 282.

Store Source to Arb Captures the selected waveform source and copy it to the arbitrary waveform. See 
"Capturing Other Waveforms to the Arbitrary Waveform" on page 282.

NOTE Choose Main Menu > File > Save Menu and use the Save Menu to save arbitrary waveforms 
that you can recall later. See "To save arbitrary waveforms" on page 299 and "To recall 
arbitrary waveforms" on page 303.
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The new waveform is created and the Edit Waveform Points menu is opened. 
See "Editing Existing Arbitrary Waveforms" on page 279.

Note that you can also create a new arbitrary waveform by capturing another 
waveform. See "Capturing Other Waveforms to the Arbitrary Waveform" on 
page 282.

Editing Existing Arbitrary Waveforms

Using the Mouse
to Edit Existing

Waveforms

To select a point, click or drag in the upper, full waveform display:

For fine points selection, click the previous point or next point arrows:

To adjust the value of a point, drag the voltage level handle up or down:

CAUTION When you create a new arbitrary waveform, the existing arbitrary waveform definition 
is overwritten. Note that you can choose Main Menu > File > Save Menu and use the 
Save Menu to save arbitrary waveforms that you can recall later. See "To save 
arbitrary waveforms" on page 299 and "To recall arbitrary waveforms" on 
page 303.
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To select a points region, drag across the upper or lower waveform display:

For fine adjustment of the region selection (or to clear the selection), click the edit 
tab, and use the Selected Region controls:

To perform points operations, click the Operation controls drop-down, select the 
operation, and use the controls for the selected operation:

• Cut/Copy selected points regions to the clipboard and Paste points from the 
clipboard.
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When pasting points from the clipboard, you can paste at the beginning, end, 
cursor location (currently selected point), or you can replace the currently 
selected points region.

• Insert New points.

You can specify the number of new points and their voltage.

• Replace a selected points region with new points.

• Delete a selected points region.

To navigate the arbitrary waveform (and select points), drag the point selection 
handle left or right across the display area:

Using Softkeys to
Edit Existing
Waveforms

The Edit Waveform Points Menu is opened by clicking Edit Existing in the Edit 
Waveform Menu or by clicking Apply & Edit when creating a new arbitrary 
waveform.
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To specify the voltage values of points:

1 Click Point #; then, select the point whose voltage value you wish to set.

2 Click Voltage; then, set the point's voltage value.

To insert a point:

1 Click Point #; then, select the point after which the new point will be inserted.

2 Click Insert Point.

All points are adjusted to maintain uniform time spacing between points.

To remove a point:

1 Click Point #; then, select the point you want to remove.

2 Click Remove Point.

All points are adjusted to maintain uniform time spacing between points.

Capturing Other Waveforms to the Arbitrary Waveform

The Edit Waveform Menu is opened by clicking Edit Waveform in the main 
Waveform Generator Menu.

To capture another waveform to the arbitrary waveform:

1 Click Source; then, select the analog channel, math, or reference location whose 
waveform you wish to capture.

2 Click Store Source to Arb.

The source waveform is decimated into 8192 (maximum) or fewer arbitrary 
waveform points.

CAUTION When you create a new arbitrary waveform, the existing arbitrary waveform definition 
is overwritten. Note that you can choose Main Menu > File > Save Menu and use the 
Save Menu to save arbitrary waveforms that you can recall later. See "To save 
arbitrary waveforms" on page 299 and "To recall arbitrary waveforms" on 
page 303.

NOTE If the source waveform frequency and/or voltage exceed the capabilities of the waveform 
generator, the arbitrary waveform will be limited to the capabilities of the waveform generator. 
For example, a 20 MHz waveform captured as the arbitrary waveform, becomes a 12 MHz 
waveform.
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Output Settings

• "To specify the expected output load" on page 283

• "To invert the waveform generator output" on page 283

• "To output a single-shot waveform" on page 284

• "To output the waveform generator sync pulse" on page 284

To specify the expected output load

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Output Settings softkey.

4 In the Waveform Generator Output Settings Menu, click the Output Load softkey 
and select:

• 50 Ω

• High-Z

The output impedance of the Gen Out MMCX is fixed at 50 ohms. However, the 
output load selection lets the waveform generator display the correct amplitude 
and offset levels for the expected output load.

If the actual load impedance is different than the selected value, the displayed 
amplitude and offset levels will be incorrect.

To invert the waveform generator output

You can invert the shape of the generated waveform output:

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Output Settings softkey.

4 In the Waveform Generator Output Settings Menu, click the Invert Output 
softkey to enable or disable an inverted output.

The waveform's offset is not inverted.
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To output a single-shot waveform

You can set up the waveform generator to output one cycle of the defined 
waveform:

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Output Settings softkey.

4 In the Waveform Generator Output Settings Menu, click the Output Mode softkey 
and select Single-Shot.

5 Click the Transmit Single-Shot softkey.

This will output one cycle of the defined waveform.

Clicking this softkey multiple times will interrupt a slow signal output before its 
cycle is completed.

Note that the transmit single-shot action can also be mapped to the Main Menu 
> Quick Action menu item (see "Configuring the Quick Action Menu Item" on 
page 317) or as a control in the sidebar Controls dialog box (see "Select Sidebar 
Information or Controls" on page 28).

To return to normal waveform generator output, click the Output Mode softkey and 
select Normal.

To output the waveform generator sync pulse

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Output Settings softkey.

4 In the Waveform Generator Output Settings Menu, click the Aux Out softkey and 
select Waveform Generator Sync Pulse.

Waveform Type Sync Signal Characteristics

All waveforms except 
DC, Noise, and Cardiac

The Sync signal is a TTL positive pulse that occurs when the waveform 
rises above zero volts (or the DC offset value).

DC, Noise, and Cardiac N/A
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To use waveform generator logic presets

With logic level presets, you can easily set the output voltage to TTL, CMOS (5.0V), 
CMOS (3.3V), CMOS (2.5V), or ECL compatible Low and High levels.

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Logic Presets softkey.

4 In the Waveform Generator Logic Level Presets Menu, click one of the softkeys 
to set the generated signal's Low and High voltages to logic compatible levels:

Softkey (logic levels) Low level High level

TTL 0 V +5 V (or a TTL-compatible 
high level if +5 V cannot 
be reached)

CMOS (5.0V) 0 V +5 V

CMOS (3.3V) 0 V +3.3 V

CMOS (2.5V) 0 V +2.5 V

ECL -1.7 V -0.9 V



286 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

17 Waveform Generator
 

To add noise to the waveform generator output

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Add Noise softkey and 
select the amount of white noise to add to the waveform generator output.

Note that adding noise affects edge triggering on the waveform generator source 
(see "Edge Trigger" on page 137) as well as the waveform generator sync pulse 
output signal (which can be sent to Aux Out, see "Setting the Aux Out Source" on 
page 312). This is because the trigger comparator is located after the noise 
source.
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To add modulation to the waveform generator output

Modulation is where an original carrier signal is modified according to the 
amplitude of a second modulating signal. The modulation type (AM, FM, or FSK) 
specifies how the carrier signal is modified.

Modulated waveforms are available on the WaveGen1 output.

To enable and set up modulation for the waveform generator output:

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Modulation softkey.

4 In the Waveform Generator Modulation Menu:

• Click the Modulation softkey to enable or disable modulated waveform 
generator output.

You can enable modulation for all waveform generator function types except 
arbitrary, square, pulse, DC, noise, and Gaussian pulse.

• Click the Type softkey and select the modulation type:

• Amplitude Modulation (AM) — the amplitude of the original carrier signal is 
modified according to the amplitude of the modulating signal. See "To 
set up Amplitude Modulation (AM)" on page 287.

• Frequency Modulation (FM) — the frequency of the original carrier signal is 
modified according to the amplitude of the modulating signal. See "To 
set up Frequency Modulation (FM)" on page 288.

• Frequency-Shift Keying Modulation (FSK) — the output frequency "shifts" 
between the original carrier frequency and a "hop frequency" at the 
specified FSK rate. The FSK rate specifies a digital square wave 
modulating signal. See "To set up Frequency-Shift Keying Modulation 
(FSK)" on page 290.

To set up Amplitude Modulation (AM)

In the Waveform Generator Modulation Menu (choose Main Menu > Sources > 
Waveform Generator, then click Settings > Modulation):

1 Click the Type softkey and select Amplitude Modulation (AM).

2 Click the Waveform softkey and select the shape of the modulating signal:

• Sine
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• Square

• Ramp

When the Ramp shape is selected, a Symmetry softkey appears so that you can 
specify the amount of time per cycle that the ramp waveform is rising.

3 Click the AM Freq softkey and enter the frequency of the modulating signal.

4 Click the AM Depth softkey and enter the amount of amplitude modulation.

AM Depth refers to the portion of the amplitude range that will be used by the 
modulation. For example, a depth setting of 80% causes the output amplitude 
to vary from 10% to 90% (90% – 10% = 80%) of the original amplitude as the 
modulating signal goes from its minimum to maximum amplitude.

The following screen shows an AM modulation of a 100 kHz sine wave carrier 
signal.

To set up Frequency Modulation (FM)

In the Waveform Generator Modulation Menu (choose Main Menu > Sources > 
Waveform Generator, then click Settings > Modulation):

1 Click the Type softkey and select Frequency Modulation (FM).

2 Click the Waveform softkey and select the shape of the modulating signal:

• Sine

• Square
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• Ramp

When the Ramp shape is selected, a Symmetry softkey appears so that you can 
specify the amount of time per cycle that the ramp waveform is rising.

3 Click the FM Freq softkey and enter the frequency of the modulating signal.

4 Click the FM Dev softkey and enter the frequency deviation from the original 
carrier signal frequency.

When the modulating signal is at its maximum amplitude, the output frequency 
is the carrier signal frequency plus the deviation amount, and when the 
modulating signal is at its minimum amplitude, the output frequency is the 
carrier signal frequency minus the deviation amount.

The frequency deviation cannot be greater than the original carrier signal 
frequency.

Also, the sum of the original carrier signal frequency and the frequency 
deviation must be less than or equal to the maximum frequency for the selected 
waveform generator function plus 100 kHz.

The following screen shows an FM modulation of a 100 kHz sine wave carrier 
signal.
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To set up Frequency-Shift Keying Modulation (FSK)

In the Waveform Generator Modulation Menu (choose Main Menu > Sources > 
Waveform Generator, then click Settings > Modulation):

1 Click the Type softkey and select Frequency-Shift Keying Modulation (FSK).

2 Click the Hop Freq softkey and enter the "hop frequency".

The output frequency "shifts" between the original carrier frequency and this 
"hop frequency".

3 Click the FSK Rate softkey and enter the rate at which the output frequency 
"shifts".

The FSK rate specifies a digital square wave modulating signal.

The following screen shows an FSK modulation of a 100 kHz sine wave carrier 
signal.
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To restore waveform generator defaults

1 If the Waveform Generator Menu is not currently displayed on the 
oscilloscope's softkeys, choose Main Menu > Sources > Waveform Generator.

2 In the Waveform Generator Menu, click the Settings softkey.

3 In the Waveform Generator Settings Menu, click the Default Wave Gen softkey.

The waveform generator factory default settings (1 kHz sine wave, 500 mVpp, 
0 V offset, High-Z output load) are restored.
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18 Save/Email/Recall (Setups, 
Screens, Data)

Saving Setups, Screen Images, or Data / 294
Emailing Setups, Screen Images, or Data / 301
Recalling Setups, Masks, or Data / 302
Recalling Default Setups / 304

Oscilloscope setups, reference waveforms, and mask files can be saved to files on 
the chassis controller PC and recalled later. You can also recall default or factory 
default setups.

Oscilloscope screen images can be saved in BMP or PNG formats.

Acquired waveform data can be saved in comma-separated value (CSV), ASCII XY, 
and binary (BIN) formats.

Files can also be e-mailed over the network.
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Saving Setups, Screen Images, or Data

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select the type of file you want to save:

• Setup (*.scp) — The oscilloscope's horizontal timebase, vertical sensitivity, 
trigger mode, trigger level, measurements, cursors, and math function 
settings that tell the oscilloscope how to make a particular measurement. 
See "To save setup files" on page 295.

• 8-bit Bitmap image (*.bmp) — The complete screen image in a reduced color 
(8-bit) bitmap format. See "To save BMP or PNG image files" on page 295.

• 24-bit Bitmap image (*.bmp) — The complete screen image in a 24-bit color 
bitmap format. See "To save BMP or PNG image files" on page 295.

• 24-bit image (*.png) — The complete screen image in a 24-bit color PNG 
format that uses lossless compression. Files are much smaller than the BMP 
format. See "To save BMP or PNG image files" on page 295.

• CSV data (*.csv) — This creates a file of comma-separated values of all 
displayed channels and math waveforms. This format is suitable for 
spreadsheet analysis. See "To save CSV, ASCII XY, or BIN data files" on 
page 296.

• ASCII XY data (*.csv) — This creates separate files of comma-separated values 
for each displayed channel. This format is also suitable for spreadsheets. 
See "To save CSV, ASCII XY, or BIN data files" on page 296.

• Binary data (*.bin) — This creates a binary file, with a header, and data in the 
form of time and voltage pairs. This file is much smaller than the ASCII XY 
data file. See "To save CSV, ASCII XY, or BIN data files" on page 296.

• Lister data (*.csv) — This is a CSV format file containing serial decode row 
information with commas separating the columns. See "To save Lister data 
files" on page 298.

• Reference Waveform data (*.h5) — Saves waveform data in a format that can be 
recalled to one of the oscilloscope's reference waveform locations. See "To 
save reference waveform files" on page 299.

• Multi Channel Waveform data (*.h5) — Saves multiple channels of waveform 
data in a format that can be opened by the N8900A Infiniium Offline 
oscilloscope analysis software. You can recall the first Analog or Math 
channel from a multi channel waveform data file.

• Mask (*.msk) — This creates a mask file in a Keysight proprietary format that 
can be read by Keysight InfiniiVision oscilloscopes. A mask data file includes 
some oscilloscope setup information, but not all setup information. To save 
all setup information including the mask data file, choose "Setup (*.scp)" 
format instead. See "To save masks" on page 299.
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• Arbitrary Waveform data (*.csv) — This creates a file of comma-separated 
values for the arbitrary waveform points' time and voltage values. See "To 
save arbitrary waveforms" on page 299.

• Analysis Results (*.csv) — A file of comma-separated values is saved for the 
analysis types selected using the Analysis Select softkey.

• Current Harmonics data (*.csv), Power Supply Rejection Ration (PSRR) data (*.csv) , 
Control Loop Response (Bode) data (*.csv) — When the power analysis 
application is licensed, these options create a file of comma-separated 
values for the different types of analysis results. See the Power 
Measurement Application User's Guide for more information.

• Frequency Response Analysis data (*.csv) — This creates a file of 
comma-separated values for the Frequency Response Analysis results table 
values. In the saved file, there are three data columns: frequency (Hz), gain 
(dB), and phase (degrees). See "To view and save the analysis results" on 
page 271.

You can also configure the Main Menu > Quick Action menu item to save setups, 
screen images, or data. See "Configuring the Quick Action Menu Item" on 
page 317.

To save setup files

Setup files can be saved to the chassis controller PC's file system.

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select Setup (*.scp).

3 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

4 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

Setup files have the extension SCP. These extensions appear when using the File 
Explorer (see "File Explorer" on page 306), but they do not appear when using the 
Recall Menu.

To save BMP or PNG image files

Image files can be saved to the chassis controller PC's file system.

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select 8-bit Bitmap image (*.bmp), 24-bit 
Bitmap image (*.bmp), or24-bit image (*.png).

3 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

4 Click the Settings softkey.
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In the File Settings Menu, you have these softkeys and options:

• Setup Info — setup information (vertical, horizontal, trigger, acquisition, math, 
and display settings) is also saved in a separate file with a TXT extension.

5 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

See Also • "To add an annotation" on page 123

To save CSV, ASCII XY, or BIN data files

Data files can be saved to the chassis controller PC's file system.

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select CSV data (*.csv), ASCII XY data (*.csv), 
or Binary data (*.bin).

3 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

4 Click the Settings softkey.

In the File Settings Menu, you have these softkeys and options:

• Setup Info — when enabled, setup information (vertical, horizontal, trigger, 
acquisition, math, and display settings) is also saved in a separate file with a 
TXT extension.

• Max Length — when enabled, the maximum number of waveform points is 
saved.

• Length — sets the number of data points that will be output to the file. For 
more information, see "Length Control" on page 297.

• Save Seg — when data is acquired to segmented memory, you can specify 
whether the currently displayed segment is saved or all acquired segments 
are saved. (See also "Saving Data from Segmented Memory" on page 199.)

5 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

NOTE When saving screen images, the oscilloscope uses the last menu visited before choosing 
Main Menu > File > Save Menu. This lets you save any relevant information within the softkey 
menu area.

To save a screen image showing the Save/Recall Menu at the bottom, choose Main Menu > 
File > Save Menu twice before saving the image.
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CSV Data When the CSV data (*.csv) file format is selected, comma-separated values for 
each displayed waveform are saved as multiple columns in a single file. Math FFT 
waveforms, whose values are in the frequency domain, are appended at the 
bottom of the .csv file. Waveform labels are used as column headers. This format is 
suitable for spreadsheet analysis.

For CSV data, length "N" value-at-time measurements are performed across the 
entire screen (using the measurement record data) for each active source. 
Interpolation between measurement record data points is performed as needed.

ASCII XY Data When the ASCII XY data (*.csv) file format is selected, comma-separated value 
files for each displayed waveform and serial bus are saved. An underscore and the 
waveform's label are appended.

If the oscilloscope acquisition is stopped, data from the raw acquisition record 
(which has more points than the measurement record) can be written. Choose 
Main Menu > Single to obtain maximum memory depth with current settings. If 
enabled, serial decode data is saved.

When you want to save less than the maximum number of data points, a 1-of-N 
decimation is performed to produce an output whose length is less than or equal 
to the requested length. For example, if there are 100k points of data, and you 
specify a length of 2k, 1 of every 50 data points is saved.

See Also • "Binary Data (.bin) Format" on page 323

• "CSV and ASCII XY files" on page 330

• "Minimum and Maximum Values in CSV Files" on page 330

Length Control

The Length control is available when saving data to CSV, ASCII XY, or BIN format 
files. It sets the number of data points that will be output to the file. Only displayed 
data points are saved.

When Max Length is enabled, the maximum number of waveform data points is 
saved.

The maximum number of data points depends on these things:

• Whether acquisitions are running. When stopped, data comes from the raw 
acquisition record. When running, data comes from the smaller measurement 
record or the precision analysis record if enabled (see "Precision Measurements 
and Math" on page 246).

• Whether the oscilloscope was stopped during a running acquisition or after a 
single acquisition. Running acquisitions split memory to provide fast waveform 
update rates. Single acquisitions use full memory.

• Whether only one channel of a pair is turned on. (Channels 1 and 2 are one 
pair.) Acquisition memory is divided among the channels in a pair.
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• Whether reference waveforms are on. Displayed reference waveforms consume 
acquisition memory.

• Whether segmented memory is on. Acquisition memory is divided by the 
number of segments.

• The horizontal time/div (sweep speed) setting. At faster settings, fewer data 
points appear on the display.

• When saving to a CSV format file, the maximum number of data points is 64K.

When necessary, the Length control performs a "1 of n" decimation of the data . 
For example: if the Length is set to 1000, and you are displaying a record that is 
5000 data points in length, four of each five data points will be decimated, creating 
an output file 1000 data points in length.

When saving waveform data, the save times depend on the chosen format:

See Also • "Binary Data (.bin) Format" on page 323

• "CSV and ASCII XY files" on page 330

• "Minimum and Maximum Values in CSV Files" on page 330

To save Lister data files

Lister data files can be saved to the chassis controller PC's file system.

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select Lister data (*.csv).

3 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

4 Click the Settings softkey.

In the File Settings Menu, you have these softkeys and options:

• Setup Info — when enabled, setup information (vertical, horizontal, trigger, 
acquisition, math, and display settings) is also saved in a separate file with a 
TXT extension.

5 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

Data File Format Save Times

BIN fastest

ASCII XY medium

CSV slowest
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To save reference waveform files

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select Reference Waveform data (*.h5).

3 Click the Source softkey and select the source waveform.

4 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

5 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

To save masks

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select Mask (*.msk).

3 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

4 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

Mask files have the extension MSK.

See Also • Chapter 14, “Mask Testing,” starting on page 247

To save arbitrary waveforms

Arbitrary waveform files can be saved to the chassis controller PC's file system.

1 Choose Main Menu > File > Save Menu.

2 In the save menu, click Format; then, select Arbitrary Waveform data (*.csv).

3 Click the softkey in the second position and navigate to the save location. See 
"To navigate storage locations" on page 300.

4 Finally, click the Press to Save softkey.

A message indicating whether the save was successful is displayed.

See Also • "To edit arbitrary waveforms" on page 277

NOTE Masks are also saved as part of setup files. See "To save setup files" on page 295.
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To navigate storage locations

When saving or recalling files, the softkey in the second position of the Save Menu 
or Recall Menu is used to navigate to storage locations. The storage locations are 
on the chassis controller PC.

The softkey in the second position can have these labels:

• Press to go — when you can click the button to navigate to a new folder or 
storage location.

• Location — when you have navigated to the current folder location (and are not 
saving files).

• Save to — when you can save to the selected location.

• Load from — when you can recall from the selected file.

When saving files:

• The proposed file name is shown in the Save to file = line above the softkeys.

• To overwrite an existing file, browse to that file and select it. To create a new file 
name, see "To enter file names" on page 300.

To enter file names

To create new file names when saving files:

1 In the Save Menu, click the File Name softkey.

2 In the File Name Menu, click the File Name softkey.

3 In the File Name keypad dialog, you can enter file names using a keyboard or by 
clicking keypad dialog box keys with a mouse.

4 When you are done entering the file name, click the dialog's Enter or OK key or 
click the File Name softkey again.

The file name appears in the softkey.

5 When available, the Increment softkey can be used to enable or disable 
automatically incremented file names. Auto increment adds a numeric suffix to 
your file name and increments the number with each successive save. It will 
truncate characters as necessary when the file name length is at maximum and 
more digits are required for the numeric portion of the file name.
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Emailing Setups, Screen Images, or Data

You can send oscilloscope files over the network via e-mail. You can e-mail any file 
that can be saved.

To e-mail a setup, screen image, or data file:

1 Choose Main Menu > File > Email Menu.

2 In the Email Menu, click Format; then, select the type of file you want to send.

You can select from the same formats that are available when saving files. 
Settings for the selected format are also the same. See "Saving Setups, Screen 
Images, or Data" on page 294.

3 Click the Attachment Name softkey and use the keypad dialog to enter the name 
of the attachment file that will be sent.

4 In the e-mail configuration dialog box, click the To, From, Server, and Subject 
fields and use the keypad dialog to enter the appropriate strings.

You can also enter these strings by clicking the Config Email softkey and clicking 
the To, From, Server, and Subject softkeys in the Configure Email Menu.

You can specify multiple e-mail addresses by separating each address by a 
semi-colon.

The Server name is the name of your mail server running the Simple Mail 
Transfer Protocol (SMTP). If you do not know this name, ask your Network 
Administrator.

5 Finally, click the Press to Send Email softkey.

You can also configure the Main Menu > Quick Action menu item to e-mail setups, 
screen images, or data. See "Configuring the Quick Action Menu Item" on 
page 317.
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Recalling Setups, Masks, or Data

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select the type of file you want to recall:

• Setup (*.scp) — See "To recall setup files" on page 302.

• Mask (*.msk) — See "To recall mask files" on page 302.

• Reference Waveform data (*.h5) — See "To recall reference waveform files" on 
page 303.

• Arbitrary Waveform data (*.csv) — See "To recall arbitrary waveforms" on 
page 303.

• CAN Symbolic data (*.dbc) — For CAN serial decode.

• LIN Symbolic data (*.ldf) — For LIN serial decode.

You can also recall setups and mask files by loading them using the File Explorer. 
See "File Explorer" on page 306.

You can also configure the Main Menu > Quick Action menu item to recall setups, 
masks, or reference waveforms. See "Configuring the Quick Action Menu Item" on 
page 317.

To recall setup files

Setup files can be recalled from the chassis controller PC's file system.

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select Setup (*.scp).

3 Click the softkey in the second position and navigate to the file to recall. See 
"To navigate storage locations" on page 300.

4 Click the Press to Recall softkey.

A message indicating whether the recall was successful is displayed.

5 If you would like to clear the display, click Clear Display.

To recall mask files

Mask files can be recalled from the chassis controller PC's file system.

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select Mask (*.msk).

3 Click the softkey in the second position and navigate to the file to recall. See 
"To navigate storage locations" on page 300.

4 Click the Press to Recall softkey.

A message indicating whether the recall was successful is displayed.



Save/Email/Recall (Setups, Screens, Data) 18

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 303

 

5 If you would like to clear the display or clear the recalled mask, click Clear 
Display or Clear Mask.

To recall reference waveform files

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select Reference Waveform data (*.h5).

3 Click the To Ref: softkey and select the desired reference waveform location.

4 Click the softkey in the second position and navigate to the file to recall. See 
"To navigate storage locations" on page 300.

5 Click the Press to Recall softkey.

A message indicating whether the recall was successful is displayed.

6 If you would like to clear the display of everything except the reference 
waveform, click Clear Display.

To recall arbitrary waveforms

Arbitrary waveform files can be recalled from the chassis controller PC's file 
system.

When recalling arbitrary waveforms that were not saved from the oscilloscope, be 
aware that:

• If the file contains two columns, the second column is automatically chosen.

• If the file contains more than two columns, you are prompted to select which 
column to load. Up to five columns are parsed by the oscilloscope; columns 
above the fifth are ignored.

• The oscilloscope uses a maximum of 8192 points for an arbitrary waveform. For 
more efficient recalls, make sure your arbitrary waveforms are 8192 points or 
less.

To recall an arbitrary waveform:

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select Arbitrary Waveform data (*.csv).

3 Click the softkey in the second position and navigate to the file to recall. See 
"To navigate storage locations" on page 300.

4 Click the Press to Recall softkey.

A message indicating whether the recall was successful is displayed.

5 If you would like to clear the display, click Clear Display.

See Also • "To edit arbitrary waveforms" on page 277
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Recalling Default Setups

1 Choose Main Menu > File > Default Menu.

2 In the Default Menu, click one of these softkeys:

• Default Setup— recalls the oscilloscope's default setup. This is the same as 
choosing Main Menu > Default SetupMenu.

Some user settings are not changed when recalling the default setup.

• Factory Default— recalls the oscilloscope's factory default settings.

You must confirm the recall because there are no user settings that are left 
unchanged.
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This chapter explains oscilloscope utility functions.
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File Explorer

The File Explorer lets you navigate the chassis controller PC's file system from 
which you can load setup files, mask files, label files, etc. Also, you can delete files.

To use the File Explorer:

1 Choose Main Menu > File > File Explorer Menu.

2 In the File Explorer Menu, click the softkey in the first position to navigate.

The softkey in the first position can have these labels:

• Press to go — when you can click the softkey to navigate to a new folder or 
storage location.

• Location — when pointing to a directory that is currently selected.

• Selected — when pointing to a file that can be loaded or deleted.

When this label appears, you can click the Load File or Delete File softkeys to 
take the action.

See Also • Chapter 18, “Save/Email/Recall (Setups, Screens, Data),” starting on page 293
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Setting Oscilloscope Preferences

The User Preferences Menu (choose Main Menu > Utilities > User Options Menu then 
click Preferences) lets you specify oscilloscope preferences.

• "To choose "expand about" center or ground" on page 307

• "To set Autoscale preferences" on page 307

To choose "expand about" center or ground

When you change a channel's volts/division setting, the waveform display can be 
set to expand (or compress) about the signal ground level or the center of the 
display.

To set the waveform expansion reference point:

1 Choose Main Menu > Utilities > User Options Menu.

2 In the User Options Menu, click Preferences.

3 In the User Preferences Menu, click Expand and select:

• Ground— The displayed waveform will expand about the position of the 
channel's ground. This is the default setting.

The ground level of the signal is identified by the position of the ground level 
( ) icon at the far-left side of the display.

The ground level will not move when you adjust the vertical sensitivity 
(volts/division) control.

If the ground level is off screen, the waveform will expand about the top or 
bottom edge of the screen based on where the ground is off screen.

• Center— The displayed waveform will expand about the center of the display.

To set Autoscale preferences

1 Choose Main Menu > Utilities > User Options Menu.

2 In the User Options Menu, click Preferences.

3 In the User Preferences Menu, click Autoscale.

4 In the Autoscale Preferences Menu, you can:

• Click the Fast Debug softkey enable/disable this type of autoscale.

When fast debug is enabled, autoscale lets you make quick visual 
comparisons to determine whether the signal being probed is a DC voltage, 
ground, or an active AC signal.

Channel coupling is maintained to allow easy viewing of oscillating signals.

• Click the Channels softkey and specify the channels to be autoscaled:
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• All Channels — The next time you choose Main Menu > Autoscale, all 
channels that meet the requirements of Autoscale will be displayed.

• Only Displayed Channels — The next time you choose Main Menu > Autoscale, 
only the channels that are turned on will be examined for signal activity. 
This is useful if you only want to view specific active channels after 
Autoscale.

• Click the Acq Mode softkey and select whether the acquisition mode should 
be preserved during autoscale:

• Normal — to make the oscilloscope switch to Normal acquisition mode 
whenever you Autoscale. This is the default mode.

• Preserve — to make the oscilloscope remain in the currently selected 
acquisition mode when you Autoscale.
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Setting the Reference Signal Mode

The PXIe chassis provides a 100 MHz clock so you can:

• Synchronize the timebase of instruments in the chassis. See "To synchronize 
instruments in a chassis" on page 309.

The Ref I/O MMCX connector is provided so you can:

• Supply a more accurate external sample clock signal to the oscilloscope. See 
"To use an external sample clock" on page 309.

• Synchronize the timebase of external instruments. See "To output the 
oscilloscope's system clock" on page 311.

To synchronize instruments in a chassis

To have the PXIe oscilloscope module use the PXIe chassis 100 MHz clock:

1 Choose Main Menu > Utilities > User Options Menu.

2 In the User Options Menu, click Auxiliary I/O.

3 In the Auxiliary I/O Menu, click 10MHz Ref Signal and select PXIe 100MHz.

See also "PXI Trigger (Coordinating Multiple PXIe Oscilloscope Modules)" on 
page 173.

To use an external sample clock

1 Connect a 10 MHz square or sine wave to the MMCX connector labeled Ref I/O. 
The amplitude must be from -5 dBm to 17 dBm (356 mVpp to 4.48 Vpp).

2 Choose Main Menu > Utilities > User Options Menu.

3 In the User Options Menu, click Auxiliary I/O.

4 In the Auxiliary I/O Menu, click 10MHz Ref Signal and select Input On.

A locked padlock icon appears at the top of the display.

CAUTION  Maximum input voltage at Ref I/O connector

Do not apply more than 20 dBm Max (6.32 Vpp Max) at the Ref I/O MMCX connector 
or damage to the instrument may occur.
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If the externally supplied sample clock signal is lost, a hard unlock will occur. The 
lock symbol in the upper right part of the display will become an unlocked padlock 
icon and the oscilloscope will stop acquiring data. The oscilloscope will resume 
sampling when the externally supplied sample clock becomes stable again.

Sample clock and
frequency counter

accuracy

The oscilloscope's timebase uses a built-in reference that has an accuracy of 
15 ppm. This is sufficient for most uses. However, if you are looking at a window 
that is very narrow compared to the selected delay (for example, looking at a 15 ns 
pulse with the delay set to 1 ms), significant error can be introduced.

Using the built-in sample clock, the oscilloscope's hardware frequency counter is 
a 5-digit counter.

When you supply an external timebase reference, the hardware frequency counter 
is automatically changed to an 8-digit counter. In this case, the frequency counter 
(Main Menu > Measure > Measurements, Type: Counter) is as accurate as the external 
clock.

For more information on the hardware frequency counter, see "Counter" on 
page 228.
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To output the oscilloscope's system clock

The oscilloscope can output its 10 MHz system clock for the purpose of 
synchronization with external instruments.

1 Connect a cable to the MMCX connector labeled Ref I/O on the oscilloscope.

2 Connect the other end of the cable to the instrument(s) that will accept the 
10 MHz reference signal.

The amplitude of this 10 MHz reference output signal is 5 Vpp into a high 
impedance or 2.5 Vpp into 50 Ohms. It is capable of driving into lower 
impedances, but the output will be reduced because of the 50 Ohm source 
impedance.

3 Choose Main Menu > Utilities > User Options Menu.

4 In the User Options Menu, click Auxiliary I/O.

5 In the Auxiliary I/O Menu, click 10MHz Ref Signal and select Output On.
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Setting the Aux Out Source

You can choose the source of the Aux Out MMCX connector on the oscilloscope:

1 Choose Main Menu > Utilities > User Options Menu.

2 In the User Options Menu, click Auxiliary I/O.

3 In the Auxiliary I/O Menu, click Aux Out and select from:

• Off — Nothing is output to the Aux Out connector.

• Triggers— Each time the oscilloscope triggers, a rising edge occurs on 
Aux Out. The rising edge is delayed 30 ns from the oscilloscope's trigger 
point. The output level is 0-5 V into an open circuit, and 0-2.5 V into 50 Ω. 
See Chapter 9, “Triggers,” starting on page 133.

• Mask— The pass/fail status is evaluated periodically. When the evaluation of 
the testing period results in a failure, the trigger output pulses high (+5 V). 
Otherwise, the trigger output remains at low (0 V). See Chapter 14, “Mask 
Testing,” starting on page 247.

• Waveform Generator Sync Pulse— All of the waveform generator output 
functions (except DC, Noise, and Cardiac) have an associated Sync signal:

The Sync signal is a TTL positive pulse that occurs when the waveform rises 
above zero volts (or the DC offset value).

See Chapter 17, “Waveform Generator,” starting on page 273.

• Trigger Source— The raw trigger signal from the oscilloscope's trigger circuit 
is output to Trig Out. It produces a rising edge whenever the input source 
would cause a trigger, even though that might occur multiple times within 
the time of a single acquisition. The trigger source can be a front panel 
analog input channel or an external trigger input. The output level is 0-5 V 
into an open circuit, and 0-2.5 V into 50 Ω. This option is not available in all 
trigger modes.

The Aux Out connector also provides the User Calibration signal. See "To perform 
user calibration" on page 314.
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Enabling Remote Command Logging

When remote command logging is enabled, remote commands sent to the 
instrument (and results returned by the instrument) can be logged to the screen, 
to a text file, or to both the screen and a text file.

To enable remote command logging:

1 Choose Main Menu > Utilities > User Options Menu.

2 In the User Options Menu, click Remote Log to open the Remote Log Menu:

3 Click Enable to enable or disable the remote command logging feature.

When remote logging is enabled, additional debug information can be included 
in the returned error string. If the error is detected by the SCPI command 
parser, such as a header error or other syntax error, the extra debug 
information is generated and included. But if the error is detected by the 
oscilloscope system, such as when an out-of-range value is sent, then no extra 
debug information is included.

4 Click Destination to select whether remote commands are logged to a text file, 
logged to the screen, or both.

5 Click Write Mode to specify whether logged commands will be created in a new 
list or appended to existing logged commands.

Your selection takes effect when remote command logging is enabled.

This option applies to both screen and file logging.

6 Click File Name to open the Remote Log Filename Menu where you can specify 
the name of the file to which remote commands are logged.

7 Click Display On to enable or disable the screen display of logged remote 
commands and their return values (if applicable).
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Performing Service Tasks

The Service Menu (choose Main Menu > Utilities > Service Menu) lets you perform 
service-related tasks:

• "To perform user calibration" on page 314

• "To perform hardware self test" on page 315

• "To display oscilloscope information" on page 315

• "To display the user calibration status" on page 315

For other information related to oscilloscope maintenance and service, see:

• "To check warranty and extended services status" on page 316

• "To contact Keysight" on page 316

• "To return the instrument" on page 316

To perform user calibration

Perform user-calibration:

• Every two years or after 4000 hours of operation.

• If the ambient temperature is >10° C from the calibration temperature.

• If you want to maximize the measurement accuracy.

The amount of use, environmental conditions, and experience with other 
instruments help determine if you need shorter User Calibration intervals.

User Calibration performs an internal self-alignment routine to optimize the signal 
path in the oscilloscope. The routine uses internally generated signals to optimize 
circuits that affect channel sensitivity, offset, and trigger parameters.

Performing User Calibration will invalidate your Certificate of Calibration. If NIST 
(National Institute of Standards and Technology) traceability is required, perform 
the "Performance Verification" procedure in the Service Guide using traceable 
sources.

To perform user calibration:

1 Disconnect all inputs from the front panel and allow the oscilloscope to warm 
up before performing this procedure.

A powered-on chassis is not sufficient for the oscilloscope module to reach its 
operating temperature. The oscilloscope module must be enabled by 
connecting a driver (like the Soft Front Panel) and running with a default setup 
for at least 30 minutes to stabilize the operating temperature.
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2 From the Aux Out output, connect a MMCX-to-BNC cable to a BNC tee 
adapter.

3 From the tee adapter, connect equal length cables to the channel 1 and 
channel 2 inputs.

4 Turn off calibration protection (Main Menu > Utilities > Service Menu, Cal Protect).

5 Click Start User Calibration to begin the user calibration.

To perform hardware self test

In the Service Menu (choose Main Menu > Utilities > Service Menu), clicking Hardware 
Self Test performs a series of internal procedures to verify that the oscilloscope is 
operating properly.

It is recommended you run Hardware Self Test:

• After experiencing abnormal operation.

• For additional information to better describe an oscilloscope failure.

• To verify proper operation after the oscilloscope has been repaired.

Successfully passing Hardware Self Test does not guarantee 100% of the 
oscilloscope's functionality. Hardware Self Test is designed to provide an 80% 
confidence level that the oscilloscope is operating properly.

To display oscilloscope information

To display information about your oscilloscope:

1 Choose Main Menu > Help Menu.

2 In the Help Menu, click About Oscilloscope. In the resulting dialog box, the 
following information is displayed:

• Model number.

• Serial number.

• Bandwidth.

• Module installed.

• Software version.

• Installed licenses. See also "Installing Licenses and Displaying License 
Information" on page 320.

To display the user calibration status

In the Service Menu (choose Main Menu > Utilities > Service Menu), clicking User 
Calibration Status displays the summary results of the previous User Calibration, 
and the status of probe calibrations for probes that can be calibrated. Note that 



316 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

19 Utility Settings
 

passive probes do not need to be calibrated, but InfiniiMax probes can be 
calibrated. For more information about calibrating probes see "To calibrate a 
probe" on page 63.

To check warranty and extended services status

To learn the warranty status of your oscilloscope:

1 Point your web browser to: www.keysight.com/find/warrantystatus

2 Enter your product's model number and serial number. The system will search 
for the warranty status of your product and display the results. If the system 
cannot find your product's warranty status, select Contact Us and speak with a 
Keysight Technologies representative.

To contact Keysight

Information on contacting Keysight Technologies can be found at: 
www.keysight.com/find/contactus

To return the instrument

Before shipping the oscilloscope to Keysight Technologies, contact your nearest 
Keysight Technologies sales or service office for additional details. Information on 
contacting Keysight Technologies can be found at: 
www.keysight.com/find/contactus

1 Write the following information on a tag and attach it to the oscilloscope.

• Name and address of owner.

• Model number.

• Serial number.

• Description of service required or failure indication.

2 Remove accessories from the oscilloscope.

Only return accessories to Keysight Technologies if they are associated with the 
failure symptoms.

3 Package the oscilloscope.

You can use the original shipping container, or provide your own materials 
sufficient to protect the instrument during shipping.

4 Seal the shipping container securely, and mark it FRAGILE.

http://www.keysight.com/find/warrantystatus
http://www.keysight.com/find/contactus
http://www.keysight.com/find/contactus
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Configuring the Quick Action Menu Item

The Main Menu > Quick Action menu item lets you perform common, repetitive 
actions.

To configure the Main Menu > Quick Action menu item:

1 Choose Main Menu > Utilities > Quick Action Menu.

2 Click Action; then, select the action that should be performed:

• Off — disables the Main Menu > Quick Action menu item.

• Quick Measure All — displays a popup containing a snapshot of all the single 
waveform measurements. The Source softkey lets you select the waveform 
source (which also becomes the source selection in the Add Measurements 
Menu). See Chapter 13, “Measurements,” starting on page 211.

• Quick Measure Statistics Reset — resets all measurement statistics and the 
measurement count. See "Measurement Statistics" on page 242.

• Quick Mask Statistics Reset — resets mask statistics and counters. See "Mask 
Statistics" on page 252.

• Quick Save — saves the current image, waveform data, or setup. Click Settings 
to set up the save options. See Chapter 18, “Save/Email/Recall (Setups, 
Screens, Data),” starting on page 293.

• Quick Email — e-mails the current setup, screen image, or data file. Press 
Settings to set up the e-mail options. See "Emailing Setups, Screen Images, 
or Data" on page 301.

• Quick Recall — recalls a setup, mask, or reference waveform. Click Settings to 
set up the recall options. See Chapter 18, “Save/Email/Recall (Setups, 
Screens, Data),” starting on page 293.

• Quick Freeze Display — freezes the display without stopping running 
acquisitions or un-freezes the display if currently frozen. For more 
information, see "To freeze the display" on page 126.

• Quick Trigger Mode — toggles the trigger mode between Auto and Normal, 
see "To select the Auto or Normal trigger mode" on page 176.

• Quick Clear Display — clears the display, see "To clear the display" on 
page 120.

Once the Main Menu > Quick Action menu item is configured, you simply choose it to 
perform the selected action.
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Installing Licenses and Displaying License Information

Licenses are managed using the Keysight License Manager.

Installed license information is displayed with other oscilloscope information (see 
"To display oscilloscope information" on page 315).

For more information about the licenses and other oscilloscope options available, 
see:

• "Licensed Options Available" on page 320

• "Other Options Available" on page 321

Licensed Options Available

The following licensed options can be easily installed without returning the 
oscilloscope to a Service Center. See data sheets for details.

Table 5 Licensed Options Available

License Description Upgrade model number, notes

M9240AERB Aerospace Software for M924xA Oscilloscopes 

Replaces licenses AERO, VID, MASK, and FRA.

Order M9240AERB (replaces M9240AROA, 
M9240VIDA, M9240MSKA, and 
M9240FRAA).

M9240AUTB Automotive Software for M924xA Oscilloscopes 

Replaces licenses AUTO, MASK, SENSOR, NRZ, CXPI, 
and FRA.

Order M9240AUTB (replaces M9240ATOA, 
M9240MSKA, M9240SNSA, M9240NRZA, 
M9240CXPA, M9240FRAA).

M9240BDLB Ultimate Bundle Software for M924xA Oscilloscopes Order M9240BDLB.

M9240GENB Embedded Software for M924xA Oscilloscopes 

Replaces licenses EMBD, COMP, VID, MASK, USBPD, and 
FRA.

Order M9240GENB (replaces M9240EMBA, 
M9240CMPA, M9240VIDA, M9240MSKA, 
M9240UPDA, and M9240FRAA).

M9240NFCB Near Field Communications (NFC) Software for M924xA 
Oscilloscopes 

Replaces license NFC.

Order M9240NFCB (replaces M9240NFCA).

M9240PWRB Power Supply Test Software for M924xA Oscilloscopes 

Replaces licenses PWR, USBPD, MASK, and FRA.

Order M9240PWRB (replaces M9240PWRA, 
M9240UPDA, M9240MSKA, and 
M9240FRAA).

AERO MIL-STD-1553 and ARINC 429 Serial Triggering and 
Analysis.

Order M9240AERB (replaces M9240AROA 
and others).

AUTO Automotive Serial Triggering and Analysis (CAN, LIN). Order M9240AUTB (replaces M9240ATOA 
and others).

CANFD Automotive Serial Triggering and Analysis (CAN-FD). Order M9240AUTB (replaces M9240ATOA 
and others).
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Other Options Available

COMP Computer Serial Triggering and Analysis 
(RS232/422/485/UART).

Provides trigger and decode capability for many UART 
(Universal Asynchronous Receiver/Transmitter) protocols 
including RS232 (Recommended Standard 232).

Order M9240GENB (replaces M9240CMPA 
and others).

CXPI CXPI (Clock Extension Peripheral Interface) Serial 
Triggering and Analysis.

Order M9240AUTB (replaces M9240CXPA 
and others).

EMBD Embedded Serial Triggering and Analysis (I2C). Order M9240GENB (replaces M9240EMBA 
and others).

FRA Frequency Response Analysis. Order M9240GENB, M9240AUTB, 
M9240AERB, or M9240PWRB (which 
include and replace M9240FRAA).

MASK Mask Limit Test

Lets you create a mask and test waveforms to determine 
whether they comply to the mask.

Order M9240GENB, M9240AUTB, 
M9240AERB, or M9240PWRB (which 
include and replace M9240MSKA).

NFC Near Field Communication (NFC) Trigger. Order M9240NFCB (replaces M9240NFCA).

NRZ Manchester/NRZ (Non Return to Zero) Triggering and 
Analysis.

Order M9240AUTB (replaces M9240NRZA 
and others).

PWR Power Measurement and Analysis. Order M9240PWRB (replaces M9240PWRA 
and others).

You can find the Power Measurement 
Application User's Guide at 
www.keysight.com/manuals/M9241A 
or on the product CD.

SENSOR SENT (Single Edge Nibble Transmission) Triggering and 
Analysis.

Order M9240AUTB (replaces M9240SNSA 
and others).

USBPD USB PD (Power Delivery) Serial Triggering and Decode. Order M9240GENB (replaces M9240UPDA 
and others).

VID Extended Video Triggering and Analysis. Order M9240GENB (replaces M9240VIDA 
and others).

WAVEGEN Waveform Generator. Order M9240AWGA.

Table 5 Licensed Options Available (continued)

License Description Upgrade model number, notes

Table 6 Calibration Option

Option Order

A6J ANSI Z540 Compliant Calibration

http://www.keysight.com/manuals/M9241A
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Software and Firmware Updates

From time to time Keysight Technologies releases software and firmware updates 
for its products. To search for firmware updates for your oscilloscope, direct your 
web browser to www.keysight.com/support/M9241.

To view the currently installed software and firmware, see "To display oscilloscope 
information" on page 315.

http://www.keysight.com/support/M9241A
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Binary Data (.bin) Format

The binary data format stores waveform data in binary format and provides data 
headers that describe that data.

Because the data is in binary format, the size of the file is approximately 5 times 
smaller than the ASCII XY format.

If more than one source is on, all displayed sources will be saved, except math 
functions.

When using segmented memory, each segment is treated as a separate waveform. 
All segments for a channel are saved, then all segments of the next (higher 
numbered) channel are saved. This continues until all displayed channels are 
saved.

When the oscilloscope is in the Peak Detect acquisition mode, the minimum and 
maximum value waveform data points are saved to the file in separate waveform 
buffers. The minimum value data points are saved first; then, the maximum value 
data points are saved.

BIN data - using
segmented

memory

When saving all segments, each segment has its own waveform header (see 
"Binary Header Format" on page 324).

In BIN file format, data are presented as follows:

• Channel 1 data (all segments)

• Channel 2 data (all segments)

• Channel 3 data (all segments)

• Channel 4 data (all segments)

• Digital channel data (all segments)

• Math waveform data (all segments)

When not saving all segments, the number of waveforms is equivalent to the 
number of active channels (including math and digital channels, with up to seven 
waveforms for each digital pod). When saving all segments, the number of 
waveforms is equal to the number of active channels multiplied by the number of 
segments acquired.

Binary Data in MATLAB

Binary data from an InfiniiVision oscilloscope can be imported to The MathWorks 
MATLAB. You can download the appropriate MATLAB functions from the Keysight 
Technologies web site at www.keysight.com/find/M924x-examples.

Keysight provides the .m files, which need to be copied into the work directory for 
MATLAB. The default work directory is C:\MATLAB7\work.

http://www.keysight.com/find/M924x-examples
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Binary Header Format

File Header There is only one file header in a binary file. The file header consists of the 
following information.

Waveform Header It is possible to store more than one waveform in the file, and each waveform 
stored will have a waveform header. When using segmented memory, each 
segment is treated as a separate waveform. The waveform header contains 
information about the type of waveform data that is stored following the waveform 
data header.

Cookie Two byte characters, AG, that indicate the file is in the Keysight Binary Data file 
format.

Version Two bytes that represent the file version.

File Size A 32-bit integer that is the number of bytes that are in the file.

Number of 
Waveforms

A 32-bit integer that is the number of waveforms that are stored in the file.

Header Size A 32-bit integer that is the number of bytes in the header.

Waveform Type A 32-bit integer that is the type of waveform stored in the file:

• 0 = Unknown.

• 1 = Normal.

• 2 = Peak Detect.

• 3 = Average.

• 4 = Not used in InfiniiVision oscilloscopes.

• 5 = Not used in InfiniiVision oscilloscopes.

• 6 = Logic.

Number of 
Waveform 
Buffers

A 32-bit integer that is the number of waveform buffers required to read the 
data.

Points A 32-bit integer that is the number of waveform points in the data.

Count A 32-bit integer that is the number of hits at each time bucket in the waveform 
record when the waveform was created using an acquisition mode like 
averaging. For example, when averaging, a count of four would mean every 
waveform data point in the waveform record has been averaged at least four 
times. The default value is 0.

X Display Range A 32-bit float that is the X-axis duration of the waveform that is displayed. For 
time domain waveforms, it is the duration of time across the display. If the value 
is zero then no data has been acquired.
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Waveform Data
Header

A waveform may have more than one data set. Each waveform data set will have a 
waveform data header. The waveform data header consists of information about 
the waveform data set. This header is stored immediately before the data set.

X Display Origin A 64-bit double that is the X-axis value at the left edge of the display. For time 
domain waveforms, it is the time at the start of the display. This value is treated 
as a double precision 64-bit floating point number. If the value is zero then no 
data has been acquired.

X Increment A 64-bit double that is the duration between data points on the X axis. For time 
domain waveforms, this is the time between points. If the value is zero then no 
data has been acquired.

X Origin A 64-bit double that is the X-axis value of the first data point in the data record. 
For time domain waveforms, it is the time of the first point. This value is treated 
as a double precision 64-bit floating point number. If the value is zero then no 
data has been acquired.

X Units A 32-bit integer that identifies the unit of measure for X values in the acquired 
data:

• 0 = Unknown.

• 1 = Volts.

• 2 = Seconds.

• 3 = Constant.

• 4 = Amps.

• 5 = dB.

• 6 = Hz.

Y Units A 32-bit integer that identifies the unit of measure for Y values in the acquired 
data. The possible values are listed above under X Units.

Date A 16-byte character array, left blank in InfiniiVision oscilloscopes.

Time A 16-byte character array, left blank in the InfiniiVision oscilloscopes.

Frame A 24 byte character array that is the model number and serial number of the 
oscilloscope in the format of: MODEL#:SERIAL#.

Waveform Label A 16 byte character array that contains the label assigned to the waveform.

Time Tags A 64-bit double, only used when saving multiple segments (requires segmented 
memory option). This is the time (in seconds) since the first trigger.

Segment Index A 32-bit unsigned integer. This is the segment number. Only used when saving 
multiple segments.
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Example Program for Reading Binary Data

To find an example program for reading binary data, direct your web browser to 
www.keysight.com/find/M924x-examples, and select "Example Program for 
Reading Binary Data".

Examples of Binary Files

Single Acquisition
Multiple Analog

Channels

The following picture shows a binary file of a single acquisition with multiple 
analog channels.

Waveform Data 
Header Size

A 32-bit integer that is the size of the waveform data header.

Buffer Type A 16-bit short that is the type of waveform data stored in the file:

• 0 = Unknown data.

• 1 = Normal 32-bit float data.

• 2 = Maximum float data.

• 3 = Minimum float data.

• 4 = Not used in InfiniiVision oscilloscopes.

• 5 = Not used in InfiniiVision oscilloscopes.

• 6 = Digital unsigned 8-bit char data (for digital channels).

Bytes Per Point A 16-bit short that is the number of bytes per data point.

Buffer Size A 32-bit integer that is the size of the buffer required to hold the data points.

http://www.keysight.com/find/M924x-examples
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Single Acquisition

All Pods Logic
Channels

The following picture shows a binary file of a single acquisition with all pods for the 
logic channels saved.

File Header
12 bytes

Number of Waveforms = N

Number of Waveform Buffers = 1

Buffer Type = 1 (floating point)
Bytes per Point = 4

Waveform Header 1
140 bytes

Waveform Data
Header 1
12 bytes

Voltage Data 1
buffer size

Waveform Header 2
140 bytes

Waveform Data
Header 2
12 bytes

Voltage Data 2
buffer size

Waveform Header N
140 bytes

Waveform Data
Header N
12 bytes

Voltage Data N
buffer size

Number of Waveform Buffers = 1

Buffer Type = 1 (floating point)
Bytes per Point = 4

Number of Waveform Buffers = 1

Buffer Type = 1 (floating point)
Bytes per Point = 4
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Segmented
Memory

Acquisition on One
Analog Channel

The following picture shows a binary file of a segmented memory acquisition on 
one analog channel.

File Header
12 bytes

Waveform Header 2
140 bytes

Waveform Data
Header 1
12 bytes

Pod 1 Timing Data
buffer size

Waveform Data
Header 2
12 bytes

Pod 2 Timing Data
buffer size

Number of Waveforms = 2

Number of Waveform Buffers = 1

Buffer Type = 6 (unsigned char)
Bytes per Point = 1

Buffer Type = 6 (unsigned char)
Bytes per Point = 1

Waveform Header 1
140 bytes

Number of Waveform Buffers = 1
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File Header
12 bytes

Waveform Header 1
140 bytes

Waveform Data
Header 1
12 bytes

Voltage Data 1
buffer size

Waveform Header 2
140 bytes

Waveform Data
Header 2
12 bytes

Voltage Data 2
buffer size

Waveform Header N
140 bytes

Waveform Data
Header N
12 bytes

Voltage Data N
buffer size

Number of Waveforms = N = Number of Segments

Number of Waveform Buffers = 1
Index = 1
Time Tag = 0.0

Buffer Type = 1 (floating point)
Bytes per Point = 4

Number of Waveform Buffers = 1
Index = 2
Time Tag = time between segment 1 and 2

Buffer Type = 1 (floating point)
Bytes per Point = 4

Number of Waveform Buffers = 1
Index = N
Time Tag = time between segment 1 and N

Buffer Type = 1 (floating point)
Bytes per Point = 4
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CSV and ASCII XY files

• "CSV and ASCII XY file structure" on page 330

• "Minimum and Maximum Values in CSV Files" on page 330

• "Frequency Data in CSV Files" on page 331

CSV and ASCII XY file structure

In CSV or ASCII XY format the Length control selects the number of points per 
segment. All segments are contained in the CSV file or in each ASCII XY data file.

For example: If the Length control is set to 1000 points, there will be 1000 points 
(rows in the spreadsheet) per segment. When saving all segments there are three 
header rows, so the data for the first segment starts at row 4. The second 
segment's data starts at row 1004. The time column shows the time since the 
trigger on the first segment. The top row shows the selected number of points per 
segment.

BIN files are a more efficient data transfer format than CSV or ASCII XY. Use this 
file format for fastest data transfer.

Minimum and Maximum Values in CSV Files

If you are running a Minimum or Maximum measurement, the minimum and 
maximum values shown in the measurement display may not appear in the CSV 
file.

Explanation: When the oscilloscope's sample rate is 4 GSa/s, a sample will be taken every 
250 ps. If the horizontal scale is set to 10 us/div, there will be 100 us of data 
displayed (because there are ten divisions across the screen). To find the total 
number of samples the oscilloscope will take:

100 us x 4 GSa/s = 400K samples

The oscilloscope is required to display those 400K samples using 640 pixel 
columns. The oscilloscope will decimate the 400K samples to 640 pixel columns, 
and this decimation keeps track of the min and max values of all the points that 
are represented by any given column. Those min and max values will be displayed 
in that screen column.

A similar process is used to reduce the acquired data to produce a record usable 
for various analysis needs such as measurements and CSV data. This analysis 
record (or measurement record) is much larger than 640 and may in fact contain 
up to 65536 points. Still, once the # of acquired points > 65536, some form of 
decimation is required. The decimator used to produce a CSV record is configured 
to provide a best-estimate of all the samples that each point in the record 
represents. Therefore, the min and max values may not appear in the CSV file.
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Frequency Data in CSV Files

When data for multiple frequency sources is saved to a CSV file, this data is saved 
as one set (with multiple columns) using a horizontal (X) range that covers all 
sources.
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Third party software acknowledgements and licenses for version 7.30 of these 
InfiniiVision X-Series oscilloscopes are located at 
www.keysight.com/find/InfiniiVision-third-party-software-0730.

http://www.keysight.com/find/InfiniiVision-third-party-software-0730
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Setup for CAN/CAN FD Signals

Setup consists of connecting the oscilloscope to a CAN signal, using the Signals 
Menu to specify the signal source, threshold voltage level, baud rate, and sample 
point.

Connect the oscilloscope to a CAN signal that has a dominant-low polarity. If you 
are connecting to the CAN signal using a differential probe, connect the probe's 
positive lead to the dominant-low CAN signal and connect the negative lead to the 
dominant-high CAN signal.

To set up the oscilloscope to capture CAN signals:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

3 Click the Mode softkey; then, select CAN.

4 Click the Signals softkey to open the CAN Signals Menu.

5 Click Source; then, select the channel for the CAN signal.

The label for the CAN source channel is automatically set.

6 Click the Threshold softkey; then, enter the CAN signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected serial decode slot.

7 Click the Std. Rate Settings softkey to open the CAN Standard Rate Settings 
Menu.

a Click the Baud softkey; then, select the baud rate that matches match your 
CAN bus signal.

The CAN baud rate can be set to predefined baud rates from 10 kb/s up to 
5 Mb/s or a user-defined baud rate from 10.0 kb/s to 4 Mb/s in increments 
of 100 b/s. Fractional user-defined baud rates between 4 Mb/s and 5 Mb/s 
are not allowed.

The default baud rate is 125 kb/s
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If none of the pre-defined selections match your CAN bus signal, select User 
Defined; then, click the User Baud softkey and enter the baud rate.

b Click the Sample Point softkey; then, select the point between phase 
segments 1 and 2 where the state of the bus is measured. This controls the 
point within the bit's time where the bit value is captured.

c Click the Back/Up softkey to return to the CAN Signals Menu.

8 When decoding CAN FD, click the FD Rate Settings softkey to open the CAN FD 
Rate Settings Menu.

a Click the Baud softkey; then, match the CAN FD baud rate of the signal from 
your device under test.

If the desired baud rate is not shown in the list, select User Defined and use 
the User Baud softkey to set the baud rate.

The CAN FD baud rate can be set to predefined baud rates from 1-10 Mb/s 
or a user-defined baud rate from 10.0 kb/s to 10 Mb/s in increments of 
100 b/s.

If the baud rate you select does not match the CAN FD baud rate, false 
triggers and decoding may occur.

b Click the Sample Point softkey; then, select the sample point.

The sample point is the point during the bit time where the bit level is 
sampled to determine whether it is dominant or recessive. The sample point 
represents the percentage of time between the beginning of the bit time to 
the end of the bit time.

60%
70%

80%
Sample Point

One Bit

NOTE For standard CAN, only the Standard Rate Settings must be set correctly. For CAN FD, both the 
Standard Rate Settings and the FD Rate Settings must be set correctly.
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You may need to adjust the sample point to get a reliable trigger and 
decode, depending on your CAN FD network topology and where the 
oscilloscope probe is located in the network.

c Click the Standard softkey to select the standard that will be used when 
decoding or triggering on FD frames, ISO, or non-ISO.

This setting has no effect on the processing of non-FD (classical) frames.

d Click the Back/Up softkey to return to the CAN Signals Menu.

9 Click the Signal softkey and select the type and polarity of the CAN signal. This 
also automatically sets the channel label for the source channel.

• CAN_H — The actual CAN_H differential bus.

• Differential (H-L) — The CAN differential bus signals connected to an analog 
source channel using a differential probe. Connect the probe's positive lead 
to the dominant-high CAN signal (CAN_H) and connect the negative lead to 
the dominant-low CAN signal (CAN_L).

Dominant low signals:

• Rx — The Receive signal from the CAN bus transceiver.

• Tx — The Transmit signal from the CAN bus transceiver.

• CAN_L — The actual CAN_L differential bus signal.

• Differential (L-H) — The CAN differential bus signals connected to an analog 
source channel using a differential probe. Connect the probe's positive lead 
to the dominant-low CAN signal (CAN_L) and connect the negative lead to 
the dominant-high CAN signal (CAN_H).
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Loading and Displaying CAN Symbolic Data

When you load (recall) a CAN DBC communication database (*.dbc) file into the 
oscilloscope, its symbolic information can be:

• Displayed in the decode waveform and Lister window.

• Used when setting up CAN triggering.

• Used when searching for CAN data in the decode.

To recall a DBC file into the oscilloscope:

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select CAN Symbolic data (*.dbc).

3 Click Press to go and navigate to the DBC file.

4 Click Load to: and select which serial decode (S1 or S2) the symbolic information 
will be used with.

5 Click Press to Recall.

The DBC file remains in the oscilloscope until it is overwritten or a secure erase is 
performed.

To display CAN symbolic data:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Display softkey and select Symbolic (instead of Hexadecimal).

Your choice affects both the decode waveform and the Lister window.

NOTE For CAN FD frames, symbolic decoding is limited to the first eight bytes.
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CAN/CAN FD Triggering

To set up the oscilloscope to capture a CAN signal, see "Setup for CAN/CAN FD 
Signals" on page 334.

The Controller Area Network (CAN) trigger allows triggering on CAN version 2.0A, 
2.0B, and CAN FD (Flexible Data-rate) signals.

A CAN message frame in CAN_L signal type is shown below:

After setting up the oscilloscope to capture a CAN signal:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select Serial 1 or 
Serial 2 on which the CAN signal is being decoded.

3 Click the Trigger on: softkey; then, select the trigger condition:

• SOF - Start of Frame — triggers at the start bit for both data and overload 
frames.

• EOF - End of Frame — triggers at the end of any frame. *

• Frame ID — triggers on any standard CAN (data or remote) or CAN FD frame 
at the end of the 11- or 29-bit ID field.

• Data Frame ID (non-FD) — triggers on standard CAN data frames at the end of 
the 11- or 29-bit ID field.

• Data Frame ID and Data (non-FD) — triggers on any standard CAN data frame at 
the end of the last data byte defined in the trigger. The DLC of the packet 
must must match the number of bytes specified.

• Data Frame ID and Data (FD) — triggers on CAN FD frames at the end of the last 
data byte defined in the trigger. You can trigger on up to 8 bytes of data 
anywhere within the CAN FD data, which can be up to 64 bytes long.

• Remote Frame ID — triggers on standard CAN remote frames at the end of the 
11- or 29-bit ID field.

• Error Frame — triggers after 6 consecutive 0s while in a data frame, at the 
EOF. *

Arbitration
Field

Bus
Idle

Data
Field

SOF edge

Control
Field

ACK
Field

IntermissionCRC
Field

EOF
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• Acknowledge Error — triggers on the acknowledge bit if the polarity is 
incorrect. *

• Form Error — triggers on reserved bit errors. *

• Stuff Error — triggers on 6 consecutive 1s or 6 consecutive 0s, while in a 
non-error or non overload frame. *

• CRC Field Error — triggers when the calculated CRC does not match the 
transmitted CRC. In addition, for FD frames, will also trigger if the Stuff 
Count is in error. *

• Spec Error (Ack or Form or Stuff or CRC) — triggers on Ack, Form, Stuff, or CRC 
errors. *

• All Errors — triggers on all Spec errors and error frames. *

• BRS Bit (FD) — triggers on the BRS bit of CAN FD frames. *

• CRC Delimiter Bit (FD) — triggers on the CRC delimiter bit in CAN FD frames. *

• ESI Bit Active (FD) — triggers on the ESI bit if set active. *

• ESI Bit Passive (FD) — triggers on the ESI bit if set passive. *

• Overload Frame — triggers on an overload frame.

* You can optionally qualify the trigger for frames whose ID you specify.

When CAN symbolic data is loaded into the oscilloscope (see "Loading and 
Displaying CAN Symbolic Data" on page 337), you can trigger on:

• Message — a symbolic message.

• Message and Signal (non-FD) — a symbolic message and a signal value.

• Message and Signal (FD, first 8 bytes only) — a symbolic message and a signal 
value, limited to the first 8 bytes of FD data.

Symbolic messages, signals, and values are defined in the DBC communication 
database file.

A message is the symbolic name for a CAN frame ID, a signal is the symbolic 
name for a bit or set of bits within the CAN data, and a value can be a symbolic 
representation of the signal bit values or it can be a decimal number with units.

4 If you select a condition that lets you qualify by ID or trigger on ID or data 
values, use the Filter by ID softkey, or the Bits softkey and the CAN Bits Menu, 
and the remaining softkeys to specify those values.

For details about using the remaining softkeys to enter values, click and hold 
the mouse button over the softkey in question to display the built-in help.

You can use the Zoom mode for easier navigation of the decoded data.

NOTE If the setup does not produce a stable trigger, the CAN signal may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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NOTE To display CAN serial decode, see "CAN/CAN FD Serial Decode" on page 341.
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CAN/CAN FD Serial Decode

To set up the oscilloscope to capture CAN signals, see "Setup for CAN/CAN FD 
Signals" on page 334.

To set up CAN serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

3 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the decoded data.

See Also • "Interpreting CAN/CAN FD Decode" on page 342

• "CAN Totalizer" on page 343

• "Interpreting CAN Lister Data" on page 344

• "Searching for CAN Data in the Lister" on page 345

NOTE For CAN triggering set up see "CAN/CAN FD Triggering" on page 338.

NOTE If the setup does not produce a stable trigger, the CAN signal may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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Interpreting CAN/CAN FD Decode

The CAN decode display is color coded as follows:

• Blue angled waveforms show an active bus (inside a packet/frame).

• Blue mid-level lines show an idle bus.

• Frame ID — yellow.

• Data bytes — white hex digits.

• CAN frame type and Data Length Code (DLC) — blue for data frames, green for 
remote frames. The DLC is always a decimal value. CAN frame types can be:

• FD — a CAN FD frame whose bit rate does not switch during the data phase.

• BRS — a CAN FD frame whose bit rate switches during the data phase.

• RMT — a standard CAN remote frame.

• Data — a standard CAN data frame.

The status of the Error State Indicator (ESI) flag is shown in the "Type" column 
of the Lister. If the ESI bit is recessive, indicating error passive, the background 
of the "Type" column will be yellow. If the ESI bit indicates error active, the 
"Type" column's background will be unshaded.

The DLC field will always be displayed in decimal, and will indicate the number 
of bytes in the frame. So for example, for an FD frame that has the DLC code 
0xF, which represents a packet with 64 bytes, "DLC=64" will be displayed on 
the decode line, and "64" will be displayed in the DLC column of the Lister.
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• Overload frame — blue with the text "OVRLD". An overload condition may occur 
before an end of frame condition. If so, the frame is closed and opened with 
blue brackets at the start of the overload condition.

• Stuff Count — green hex digit when valid, red when error detected. The hex digit 
shows the gray-coded with parity bit stuff count.

• CRC — blue hex digits when valid, red when error detected.

• Red angled waveforms — Unknown or error condition.

• Flagged error frames — red with "ERR FRAME", "STUFF ERR", "FORM ERR", 
"ACK ERR", "GLITCH ERR", or "?" (unknown).

• Pink vertical bars — Expand horizontal scale (and run again) to see decode.

• Red Dot — More information is available. Decoded text is truncated to fit. 
Expand the horizontal scale to view the information.

CAN Totalizer

The CAN totalizer provides a direct measure of bus quality and efficiency. The CAN 
totalizer measures total CAN frames, Specification error counter, flagged error 
frames, and bus utilization.

The totalizer is always running (counting frames and calculating percentages) and 
is displayed whenever CAN decode is displayed. The totalizer counts even when 
the oscilloscope is stopped (not acquiring data). Stopping acquisitions does not 
affect the totalizer. When an overflow condition occurs, the counter displays 
OVERFLOW. The counters can be reset to zero by clicking the Reset CAN Counters 
softkey.

Types of Frames • Active error frames are CAN frames in which a CAN node recognizes an error 
condition during a data or remote frame and issues an active error flag.

• A partial frame occurs when the oscilloscope detects any error condition during 
a frame that is not followed by an active error flag. Partial frames are not 
counted.

Counters • The FRAMES counter gives the total number of completed remote, data, 
overload, and active error frames.

• The SPEC counter gives the total number of Specification errors. This counter 
tracks the number of Acknowledge, Form, Stuff, and CRC errors. If a packet has 
more than one type of error, that packet will increment the counter by the total 
number of errors in the packet.

• The ERR FR counter gives the total number of completed active error frames 
and their percentage of the total number of frames.
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• The LOAD (bus load) indicator measures the percentage of time the bus is 
active. The calculation is done on 330 ms periods, approximately every 400 ms.

Example: If a data frame contains an active error flag, both the FRAMES counter 
and the ERR FR counter will be incremented. If a data frame contains an error that 
is not an active error it is considered a partial frame and no counters are 
incremented.

Interpreting CAN Lister Data

In addition to the standard Time column, the CAN Lister contains these columns:

• ID — frame ID. Can be displayed as hex digits or symbolic information (see 
"Loading and Displaying CAN Symbolic Data" on page 337).

• Type — frame type (RMT remote frame or Data).

• DLC — data length code.

• Data — data bytes. Can be displayed as hex digits or symbolic information.

• CRC — cyclic redundancy check.

• Errors — highlighted in red. Errors can be Acknowledge (Ack, A), Form (Fo), or 
Frame (Fr). Different kinds of errors can be combined like "Fo,Fr" in the above 
example.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.
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Searching for CAN Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
CAN data in the Lister. You can use the sidebar Navigate controls to navigate 
through the marked rows.

1 With CAN selected as the serial decode mode, choose Main Menu > Analyze > 
Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2 on 
which the CAN signal is being decoded.

3 Click Search for; then, select from these options:

• Frame ID — Finds remote or data frames matching the specified ID.

• Data Frame ID — Finds data frames matching the specified ID.

• Data Frame ID and Data — Finds data frames matching the specified ID and 
data.

• Remote Frame ID — Finds remote frames with the specified ID.

• Error Frame — Finds CAN active error frames.

• Acknowledge Error — Finds the acknowledge bit if the polarity is incorrect.

• Form Error — Finds reserved bit errors.

• Stuff Error — Finds 6 consecutive 1s or 6 consecutive 0s, while in a non-error 
or non overload frame.

• CRC Field Error — Finds when the calculated CRC does not match the 
transmitted CRC.

• All Errors — Finds any form error or active error.

• Overload Frame — Finds CAN overload frames.

When CAN symbolic data is loaded into the oscilloscope (see "Loading and 
Displaying CAN Symbolic Data" on page 337), you can search for:

• Message — a symbolic message.

• Message and Signal — a symbolic message and a signal value.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.
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Setup for LIN Signals

LIN (Local Interconnect Network) signal setup consists of connecting the 
oscilloscope to a serial LIN signal, specifying the signal source, threshold voltage 
level, baud rate, sample point, and other LIN signal parameters.

To set up the oscilloscope to capture LIN signals:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

3 Click the Mode softkey; then, select LIN.

4 Click the Signals softkey to open the LIN Signals Menu.

5 Click the Source softkey to select the channel connected to the LIN signal line.

The label for the LIN source channel is automatically set.

6 Click the Threshold softkey; then, set the LIN signal threshold voltage level to 
the middle of the LIN signal.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected serial decode slot.

7 Click the Baud Rate softkey to open the LIN Baud Rate Menu.

8 Click the Baud softkey; then, select the baud rate that matches match your LIN 
bus signal.

The default baud rate is 19.2 kb/s.

If none of the pre-defined selections match your LIN bus signal, select User 
Defined; then, click the User Baud softkey and enter the baud rate.

You can set the LIN baud rate from 2.4 kb/s to 625 kb/s in increments of 
100 b/s.

9 Click the Back/Up softkey to return to the LIN Signals Menu.

10 Click the Sample Point softkey; then, select the sample point at which the 
oscilloscope will sample the bit value.

60%
70%

80%
Sample Point

One Bit
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11 Click the Standard softkey; then, select the LIN standard you are measuring:

• LIN 1.3

• LIN 1.3 (no length control) — Select this for systems where length control is not 
used and all nodes have knowledge of the data packet size. In LIN 1.3, the 
ID may or may not be used to indicate the number of bytes. (In LIN 2.X, there 
is no length control.)

• LIN 2.X

For LIN 1.2 signals, use the LIN 1.3 setting. The LIN 1.3 setting assumes the 
signal follows the "Table of Valid ID Values" as shown in section A.2 of the LIN 
Specification dated December 12, 2002. If your signal does not comply with the 
table, use the LIN 2.X setting.

12 Click the Sync Break softkey and select the minimum number of clocks that 
define a sync break in your LIN signal.
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Loading and Displaying LIN Symbolic Data

When you load (recall) a LIN description file (*.ldf) into the oscilloscope, its 
symbolic information can be:

• Displayed in the decode waveform and Lister window.

• Used when setting up LIN triggering.

• Used when searching for LIN data in the decode.

To recall a LIN description file into the oscilloscope:

1 Choose Main Menu > File > Recall Menu.

2 In the Recall Menu, click Recall:, then, select LIN Symbolic data (*.ldf).

3 Click Press to go and navigate to the LIN description file.

4 Click Load to: and select which serial decode (S1 or S2) the symbolic information 
will be used with.

5 Click Press to Recall.

The LIN description file remains in the oscilloscope until it is overwritten or a 
secure erase is performed.

To display LIN symbolic data:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Display softkey and select Symbolic (instead of Hexadecimal).

Your choice affects both the decode waveform and the Lister window.
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LIN Triggering

To set up the oscilloscope to capture a LIN signal, see "Setup for LIN Signals" on 
page 346.

LIN triggering can trigger on the rising edge at the Sync Break exit of the LIN 
single-wire bus signal (that marks the beginning of the message frame), the 
Frame ID, or the Frame ID and Data.

A LIN signal message frame is shown below:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select Serial 1 or 
Serial 2 on which the LIN signal is being decoded.

3 Click the Trigger on: softkey; then, select the trigger condition:

• Sync (Sync Break) — The oscilloscope triggers on the rising edge at the Sync 
Break exit of the LIN single-wire bus signal that marks the beginning the 
message frame.

• ID (Frame ID) — The oscilloscope triggers when a frame with an ID equal to 
the selected value is detected. Enter the value for the Frame ID.

• ID & Data (Frame ID and Data) — The oscilloscope triggers when a frame with 
an ID and data equal to the selected values is detected. When triggering on 
a frame ID and data:

• To enter the frame ID value, click the Frame ID softkey.

Note that you can enter a "don't care" value for the frame ID and trigger 
on data values only.

• To set up the number of data bytes and enter their values (in hexadecimal 
or binary), use the remaining softkeys.

• Parity Error — The oscilloscope triggers on parity errors.

• Checksum Error — The oscilloscope triggers on checksum errors.

When a LIN description file (*.ldf) is loaded (recalled) into the oscilloscope (see 
"Loading and Displaying LIN Symbolic Data" on page 348), you can trigger on:

• Frame (Symbolic) — a symbolic frame value.

Sync
Break

Identifier
Break

Sync Break Exit

Sync
Field

Checksum
Field

Data
Fields
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• Frame and Signal — a symbolic frame value and a signal value.

Symbolic frames, signals, and values are defined in the LIN description file.

A frame is the symbolic name for a LIN frame ID, a signal is the symbolic name 
for a bit or set of bits within the LIN data, and a value can be a symbolic 
representation of the signal bit values or it can be a decimal number with units.

NOTE For details about using the LIN Bits Menu softkeys, click and hold the mouse button over the 
softkey in question to display the built-in help.

NOTE For LIN decode information see "LIN Serial Decode" on page 351.
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LIN Serial Decode

To set up the oscilloscope to capture LIN signals, see "Setup for LIN Signals" on 
page 346.

To set up LIN serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 Choose whether to include the parity bits in the identifier field.

a If you want to mask the upper two parity bits, ensure that the box under the 
Show Parity softkey is not selected.

b If you want to include the parity bits in the identifier field, ensure that the 
box under the Show Parity softkey is selected.

3 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

4 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the decoded data.

See Also • "Interpreting LIN Decode" on page 352

• "Interpreting LIN Lister Data" on page 353

• "Searching for LIN Data in the Lister" on page 353

NOTE For LIN triggering setup see "LIN Triggering" on page 349.

NOTE If the setup does not produce a stable trigger, the LIN signal may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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Interpreting LIN Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• The hexadecimal ID and parity bits (if enabled) appear in yellow. If a parity error 
is detected the hexadecimal ID and parity bits (if enabled) appear in red.

• Decoded hexadecimal data values appear in white.

• The checksum appears in blue if correct, or red if incorrect.

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.

• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• Red dots in the decode line indicate that there is data that is not being 
displayed. Scroll or expand the horizontal scale to view the information.

• Unknown bus values (undefined or error conditions) are drawn in red.

• If there is an error in the synch field, SYNC will appear in red.

• If the header exceeds the length specified in the standard, THM will appear red.

• If the total frame count exceeds the length specified in the standard, TFM will 
appear red (LIN 1.3 only).

• For LIN 1.3 a wakeup signal is indicated by WAKE in blue. If the wakeup signal 
is not followed by a valid wakeup delimiter a wakeup error is detected and 
displayed as WUP in red.
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Interpreting LIN Lister Data

In addition to the standard Time column, the LIN Lister contains these columns:

• ID — frame ID. Can be displayed as hex digits or symbolic information (see 
"Loading and Displaying LIN Symbolic Data" on page 348).

• Data — data bytes. Can be displayed as hex digits or symbolic information.

• Checksum.

• Errors — highlighted in red.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for LIN Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
LIN data in the Lister. You can use the sidebar Navigate controls to navigate 
through the marked rows.

1 With LIN selected as the serial decode mode, choose Main Menu > Analyze > 
Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2 on 
which the LIN signal is being decoded.

3 Click Search for; then, select from these options:

• ID — Finds frames with the specified ID. Click the Frame ID softkey to select 
the ID.



354 Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide

21 CAN/LIN Triggering and Serial Decode
 

• ID & Data — Finds frames with the specified ID and data. Click the Frame ID 
softkey to select the ID. Click the Bits softkey to enter the data value.

• Errors — Finds all errors.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.
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Setup for CXPI Signals / 356
CXPI Triggering / 357
CXPI Serial Decode / 360

The CXPI (Clock Extension Peripheral Interface) triggering and serial decode 
option is license-enabled.
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Setup for CXPI Signals

To set up the oscilloscope to capture CXPI signals:

1 Connect an oscilloscope channel to the signal in the device under test.

Analog channels can be used.

2 Choose Main Menu > Analyze > Serial Decode.

3 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

4 Click the Mode softkey; then, select CXPI.

5 Click the Bus Config softkey to open the CXPI Bus Configuration Menu.

a Click the Source softkey; then, select the channel for the signal.

b Click the Threshold softkey; then, enter the signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode 
(Serial 1 or Serial 2).

c Click the Tolerance softkey; then, enter the tolerance as a percentage of the 
Tbit width.

d Click the Baud Rate softkey; then, enter the baud rate that matches the CXPI 
signal from your device under test.

The CXPI baud rate can be set from 9600 b/s to 40000 b/s in 100 b/s 
increments.

You must set the baud rate to match your device under test.

The default baud rate is 20 kb/s.

e Select Show Parity to include the parity bit in the identifier field.

When Show Parity is not selected, the upper bit is masked. The parity is still 
checked, but it is not displayed unless a parity error occurs.

Parity errors are shown in red.

f Click the Back/Up softkey to return to the CXPI Serial Decode Menu.
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CXPI Triggering

To set up the oscilloscope to capture CXPI signals, see "Setup for CXPI Signals" 
on page 356.

When CXPI (Clock Extension Peripheral Interface) is selected as one of the serial 
bus decodes, you can trigger on CXPI signals.

CXPI frames have the following format:

• DLC = Data Length Code

• NM = Network Management

• CT = Counter

To set up a CXPI trigger condition:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select the serial decode 
(Serial 1 or Serial 2) of the CXPI signal.

3 Click the Trigger on: softkey and select the CXPI trigger type:

• SOF - Start of Frame — triggers at the start bit of any frame.

• EOF - End of Frame — triggers at the end of any frame.

• PTYPE — triggers on any frame that starts with the special PTYPE byte.

PTYPE frames begins with an extra PID byte with a Frame ID of 0000000b 
(reserved for only PTYPE frames). The PTYPE PID byte is then followed by a 
regular PID byte and the rest of the normal frame. The extra PTYPE byte is 
never included in the CRC calculation.

Parity 
(1 bit)

Frame ID 
(7 bits)

DLC 
(4 bits)

NM 
(2 bits)

wakeup sleep

CT 
(2 bits)

Data 
(0-12 bytes)

CRC 
(1 byte)

Frame Info 
(1 byte)

PID 
(1 byte)

Normal frame

Long frame

Parity 
(1 bit)

Frame ID 
(7 bits)

DLC 
(4 bits, 
= 0xF)

NM 
(2 bits)

wakeup sleep

CT 
(2 bits)

Data 
(0-255 bytes)

CRC 
(2 bytes)

Frame Info 
(2 bytes)

PID 
(1 byte)

Extension 
DLC 

(1 byte)
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• Frame ID — triggers on a user-defined Frame ID at the end of the PID byte. 
The Frame ID value is user-defined, 7 bits, and has bitwise don't-cares. You 
can specify whether to trigger on PTYPE present or no PTYPE present.

• Frame ID, Info and Data — triggers on CXPI frames at the end of the last data 
byte defined in the trigger. In addition to the PID value, you can specify the 
contents of the Frame Info byte with bitwise don't-cares. You can specify up 
to 12 data bytes on which to trigger with bitwise don't-cares.

• Frame ID, Info and Data (Long Frame) — triggers on CXPI frames at the end of the 
last data byte defined in the trigger. The standard DLC field will be locked to 
1111b. You can specify up to 12 bytes of data on which to trigger and 
specify the start byte number as an offset. The offset can be up to 123 bytes 
when PTYPE is present or 124 bytes when PTYPE is not present.

• CRC Field Error — triggers when the calculated CRC does not match the 
transmitted CRC. You can optionally filter by Frame ID and PTYPE as in the 
Frame ID trigger.

• Parity Error — triggers when the parity bit in the PID or PTYPE field is not 
correct.

• Inter-Byte Space Error — triggers when there are more than 9 bits between 
consecutive bytes in a frame. You can optionally filter by Frame ID and 
PTYPE as in the Frame ID trigger.

• Inter-Frame Space Error — triggers when there are fewer than 10 idle bits 
before a new frame begins.

• Framing Error — triggers when the stop bit of a byte is not logical 1. You can 
optionally filter by Frame ID and PTYPE as in the Frame ID trigger.

• Data Length Error — triggers when there are more data bytes in a frame than is 
indicated by the DLC or Extended DLC field. You can optionally filter by 
Frame ID and PTYPE as in the Frame ID trigger.

• Sample Error — triggers when 10 consecutive logical 0s are detected.

• All Errors — triggers on all CRC, Parity, IBS, Stop Bit, Data Length, and 
Sample errors.

• Sleep Frame — triggers when a normal frame is transmitted matching the 
definition of a sleep frame in the CXPI specification.

• Wakeup Pulse — triggers when a wakeup pulse is detected.

4 For the trigger types that let you trigger on data, click the Bits softkey. In the 
CXPI Bits Menu, you can specify ID, Frame Info, and Data values to trigger on:

• Define — this softkey selects what you want to specify (ID, Frame Info, or 
Data) and in what format (Hex, or Binary). The remaining softkeys in the 
menu let you enter values.

• PTYPE — when specifying ID values, this softkey specifies whether you want 
to trigger when the special PTYPE byte is present or not present.
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• DLC — when specifying Frame Info or Data values, this softkey specifies the 
data length code to trigger on. This will also affect the number of data bytes 
you can specify in the trigger.

• # of Bytes — this softkey specifies the number of bytes of data to trigger on. It 
is limited by the specified DLC value but can be smaller.

• Start Byte # — when triggering on long frames, the maximum number of bytes 
of data you can trigger on is 12, but those 12 bytes can be located at an 
offset within the data. This softkey specifies the offset starting byte. The 
starting byte can be up to 123 when PTYPE is present or up to 124 when 
PTYPE is not present.

5 When triggering on CRC Field Errors, Inter-Byte Space Errors, Framing Errors, 
or Data Length Errors, there is a Filter by ID softkey that you can enable to 
modify the trigger so that it occurs only for a specified ID.

NOTE If the setup does not produce a stable trigger, the CXPI signals may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.

NOTE To display CXPI serial decode, see "CXPI Serial Decode" on page 360.
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CXPI Serial Decode

To set up the oscilloscope to capture CXPI signals, see "Setup for CXPI Signals" 
on page 356.

To set up CXPI serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

3 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the acquired data.

See Also • "Interpreting CXPI Decode" on page 361

• "Interpreting CXPI Lister Data" on page 362

NOTE For CXPI triggering setup see "CXPI Triggering" on page 357.

NOTE If the setup does not produce a stable trigger, the CXPI signals may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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Interpreting CXPI Decode

The CXPI decode display is color coded as follows:

• Blue angled waveforms show an active bus (inside a packet/frame).

• Blue mid-level lines show an idle bus.

• For PTYPE frames, the text "PTYPE" is shown in the decode before the Frame 
ID. If the parity bit in the PTYPE field is in error, the "PTYPE" text is displayed in 
red.

• Packet/Frame ID — yellow hex digits. The packet/frame ID can optionally show 
or omit the leading parity bit.

• Data Length Code (DLC) — cyan. The DLC is always a decimal value.

• Network Management (NM) — green. Binary value, two bits.

• Counter (CT) — yellow. Binary value, two bits.

• Data bytes — white text formatted as a pair of hexadecimal nibbles for each 
byte. These hexadecimal bytes are shown with MSB at the left..

• CRC — cyan hex digits when valid, red when error detected.

• Red angled waveforms — Unknown or error condition.

• Flagged error frames — red, with:

• "IBS ERR" — Inter-Byte Space error. When the space between bytes in a 
frame is greater than 9 bits.

• "IFS ERR" — Inter-Frame Space error. When there are fewer than 10 bits 
present in the idle state before a new frame starts.
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• "FRAME ERR" — Framing error. When the stop bit is not a logical 1.

• "LEN ERR" — Data Length error. If the frame has more data bytes than are 
indicated in the DLC field.

• "SAMP ERR" — Sample error. If 10 logical 0s are detected consecutively.

• "?" — (unknown)

• Pink vertical bars — Expand horizontal scale (and run again) to see decode.

• Red Dot — More information is available. Decoded text is truncated to fit. 
Expand the horizontal scale to view the information.

When the bus goes into sleep conditions, special frames are drawn:

• SLEEP frame — orange. Displayed 2.5 ms after the bus goes idle-high. In the 
Lister, the fixed hex data values in the Data column are replaced by the text 
"SLEEP FRAME".

• WAKE frame — blue. When a low pulse of 250-2500 µs is detected, it is a 
wakeup pulse, and a blue WAKE frame will be drawn. After that pulse will be an 
orange line. The decode line will turn blue/idle after the first 10 clock ticks are 
detected (but not before).

Interpreting CXPI Lister Data

In addition to the standard Time column, the CXPI Lister contains these columns:

• ID — value in Hex.

• DLC — (Data Length Code) values in Decimal.
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• NM/CT — (Network Management/Counter) values in Binary.

• Data — values in Hex.

For sleep frames, data values are replaced by the text "SLEEP FRAME". 

• CRC — value in Hex.

• Errors — string value that displays the type of error detected:

• CRC — CRC Error.

• Parity Error.

• IBS — IBS Error.

• Fr — Frame Error.

• LEN — LENGTH Error.

• SAMP — SAMPLE Error.
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Setup for I2C Signals / 366
I2C Triggering / 367
I2C Serial Decode / 370

The I2C triggering and serial decode option is license-enabled.
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Setup for I2C Signals

I2C (Inter-IC bus) signals setup consists of connecting the oscilloscope to the 
serial data (SDA) line and the serial clock (SCL) line and then specifying the input 
signal threshold voltage levels.

To set up the oscilloscope to capture I2C signals, use the Signals softkey which 
appears in the Serial Decode Menu:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

3 Click the Mode softkey; then, select I2C.

4 Click the Signals softkey to open the I2C Signals Menu.

5 For both the SCL (serial clock) and SDA (serial data) signals:

a Connect an oscilloscope channel to the signal in the device under test.

b Click the SCL or SDA softkey; then, select the channel for the signal.

c Click the corresponding Threshold softkey; then, enter the signal threshold 
voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode slot.

Data must be stable during the whole high clock cycle or it will be 
interpreted as a start or stop condition (data transitioning while the clock is 
high).

The SCL and SDA labels for the source channels are automatically set.
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I2C Triggering

To set up the oscilloscope to capture I2C signals, see "Setup for I2C Signals" on 
page 366.

After the oscilloscope has been set up to capture I2C signals, you can trigger on a 
stop/start condition, a restart, a missing acknowledge, an EEPROM data read, or 
on a read/write frame with a specific device address and data value.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select the Serial 1 or 
Serial 2 on which the I2C signals are being decoded.

3 Click the Trigger on: softkey; then, select the trigger condition:

• Start Condition— The oscilloscope triggers when SDA data transitions from 
high to low while the SCL clock is high. For triggering purposes (including 
frame triggers), a restart is treated as a start condition.

• Stop Condition— The oscilloscope triggers when data (SDA) transitions from 
low to high while the clock (SCL) is high.

• Missing Acknowledge— The oscilloscope triggers when SDA data is high 
during any Ack SCL clock bit.

• Address with no Ack— The oscilloscope triggers when the acknowledge of the 
selected address field is false. The R/W bit is ignored.

• Restart— The oscilloscope triggers when another start condition occurs 
before a stop condition.

• EEPROM Data Read— The trigger looks for EEPROM control byte value 1010xxx 
on the SDA line, followed by a Read bit and an Ack bit. It then looks for the 
data value and qualifier set by the Data softkey and the Data is softkey. When 
this event occurs, the oscilloscope will trigger on the clock edge for the Ack 
bit after the data byte. This data byte does not need to occur directly after 
the control byte.

Stop
Condition

R/Start
Condition

AckAck DataAddress
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• Frame (Start: Addr7: Read: Ack: Data) or Frame (Start: Addr7: Write: Ack: Data)— The 
oscilloscope triggers on a read or write frame in 7-bit addressing mode on 
the 17th clock edge if all bits in the pattern match. For triggering purposes, 
a restart is treated as a start condition.

• Frame (Start: Addr7: Read: Ack: Data: Ack: Data2) or Frame (Start: Addr7: Write: Ack: 
Data: Ack: Data2)— The oscilloscope triggers on a read or write frame in 7-bit 
addressing mode on the 26th clock edge if all bits in the pattern match. For 
triggering purposes, a restart is treated as a start condition.

• 10-bit Write — The oscilloscope triggers on a 10-bit write frame on the 26th 
clock edge if all bits in the pattern match. The frame is in the format:

Frame (Start: Address byte 1: Write: Address byte 2: Ack: Data)

For triggering purposes, a restart is treated as a start condition.

Control
byte

Read

R/ Ack Data Ack
Trigger point

Start or
Restart

Condition

Stop 
Condition

Start or
Restart

Condition
Trigger point

17th clock edge

Address

Read Write

R/ Ack Data Ack

Read Write

Start
Condition

Address R/W Ack Data Ack Data 2

Trigger point
26th clock edge

Ack Stop
Condition
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4 If you have set the oscilloscope to trigger on an EEPROM Data Read condition:

Click the Data is softkey to set the oscilloscope to trigger when data is = (equal 
to), ≠ (not equal to), < (less than), or > (greater than) the data value set in the 
Data softkey.

The oscilloscope will trigger on the clock edge for the Ack bit after the trigger 
event is found. This data byte does not need to occur directly after the control 
byte. The oscilloscope will trigger on any data byte that meets the criteria 
defined by the Data is and Data softkeys during a current address read or a 
random read or a sequential read cycle.

5 If you have set the oscilloscope to trigger on a 7-bit address read or write frame 
condition or a 10-bit write frame condition:

a Click the Address softkey and select the 7-bit or 10-bit device address.

You can select from an address range of 0x00 to 0x7F (7-bit) or 0x3FF 
(10-bit) hexadecimal. When triggering on a read/write frame, the 
oscilloscope will trigger after the start, address, read/write, acknowledge, 
and data events occur.

If don't care is selected (0xXX or 0xXXX) for the address, the address will be 
ignored. The trigger will always occur on the 17th clock for 7-bit addressing 
or 26th clock for 10-bit addressing.

b Click the Data value softkey and select the 8-bit data pattern on which to 
trigger.

You can select a data value in the range of 0x00 to 0xFF (hexadecimal). The 
oscilloscope will trigger after the start, address, read/write, acknowledge, 
and data events occur.

If don't care (0xXX) is selected for data, the data will be ignored. The trigger 
will always occur on the 17th clock for 7-bit addressing or 26th clock for 
10-bit addressing.

c If you have selected a three-byte trigger, click the Data2 value softkey and 
select the 8-bit data pattern on which to trigger.

Stop
Condition

Start or
Restart

Condition
Trigger point

26th clock edge

Address
1st byte

R/ Ack1 AckAddress
2nd byte

Write

Ack2 Data

NOTE To display I2C serial decode, see "I2C Serial Decode" on page 370.
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I2C Serial Decode

To set up the oscilloscope to capture I2C signals, see "Setup for I2C Signals" on 
page 366.

To set up I2C serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 Choose 7-bit or 8-bit address size. Use 8-bit address size to include the R/W 
bit as part of the address value, or choose 7-bit address size to exclude the 
R/W bit from the address value.

3 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

4 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the acquired data.

See Also • "Interpreting I2C Decode" on page 371

• "Interpreting I2C Lister Data" on page 372

• "Searching for I2C Data in the Lister" on page 372

NOTE For I2C triggering setup see "I2C Triggering" on page 367.

NOTE If the setup does not produce a stable trigger, the I2C signals may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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Interpreting I2C Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• In the decoded hexadecimal data:

• Address values appear at the start of a frame.

• Write addresses appear in light-blue along with the "W" character.

• Read addresses appear in yellow along with the "R" character.

• Restart addresses appear in green along with the "S" character.

• Data values appear in white.

• "a" indicates Ack (low), "~a" indicates No Ack (high).

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.

• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• Red dots in the decode line indicate that more data can be displayed. Scroll or 
expand the horizontal scale to view the data.

• Aliased bus values (undersampled or indeterminate) are drawn in pink.

• Unknown bus values (undefined or error conditions) are drawn in red.
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Interpreting I2C Lister Data

In addition to the standard Time column, the I2C Lister contains these columns:

• Restart — indicated with an "X".

• Address — colored blue for writes, yellow for reads.

• Data — data bytes.

• Missing Ack — indicated by an "X", highlighted in red if an error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for I2C Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
I2C data in the Lister. You can use the sidebar Navigate controls to navigate 
through the marked rows.

1 With I2C selected as the serial decode mode, choose Main Menu > Analyze > 
Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2 on 
which the I2C signal is being decoded.

3 Click Search for; then, select from these options:

• Missing Acknowledge — finds SDA data is high during any Ack SCL clock bit.
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• Address with no Ack — finds when the acknowledge of the selected address 
field is false. The R/W bit is ignored.

• Restart — finds when another start condition occurs before a stop condition.

• EEPROM Data Read — finds EEPROM control byte value 1010xxx on the SDA 
line, followed by a Read bit and an Ack bit. It then looks for the data value 
and qualifier set by the Data is softkey and the Data softkeys.

• Frame(Start:Address7:Read:Ack:Data) — finds a read frame on the 17th clock 
edge if all bits in the pattern match.

• Frame(Start:Address7:Write:Ack:Data) — finds a write frame on the 17th clock 
edge if all bits in the pattern match.

• Frame(Start:Address7:Read:Ack:Data:Ack:Data2) — finds a read frame on the 26th 
clock edge if all bits in the pattern match.

• Frame(Start:Address7:Write:Ack:Data:Ack:Data2) — finds a write frame on the 
26th clock edge if all bits in the pattern match.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.
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The Manchester/NRZ triggering and serial decode option is license-enabled.

The Manchester/NRZ triggering and decode solutions support generic 
Manchester- or NRZ-encoded serial buses.
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Setup for Manchester Signals

Manchester signal setup consists of first connecting the oscilloscope to a 
Manchester-encoded serial bus signal, then specifying the signal, bus 
configuration, and other settings.

To set up the oscilloscope to capture Manchester signals:

1 Press [Serial].

2 Press the Serial softkey and choose the serial decode (Serial 1 or Serial 2) to 
use; then, press the softkey again to enable decode.

3 Press the Mode softkey; then, select the Manchester decode mode.

4 Press the Signals softkey to open the Manchester Signals Menu.

In the Manchester Signals Menu:

a Press the Source softkey to select the channel connected to the Manchester 
signal line.

The label for the Manchester source channel is automatically set.

b Press the Threshold softkey; then, enter the trigger threshold voltage level.

The threshold voltage level is used in decoding and will become the trigger 
level when the trigger type is set to the Manchester serial decode.

c Press the Baud softkey; then, enter the baud rate of the Manchester signal 
from your device under test.

The baud rate can be set from 2 kb/s to 5 Mb/s in 100 b/s increments.

You must set the baud rate to match your device under test.

The default baud rate is 125 kb/s.

d Press the Tolerance softkey to specify the tolerance for the Manchester 
signal. Valid values range from 5% to 30% in terms of percentage of the bit 
period.

e Press the Back/Up key to return to the Serial Decode Menu.

5 Press the Bus Config softkey to open the Manchester Bus Configuration Menu.

Back
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In the Manchester Bus Configuration Menu:

a Press the Display Format softkey and select the display format:

• Word — lets you break the frame into sync, header, data, and trailer fields.

In Word format, you can select between hexadecimal, unsigned decimal, 
and ASCII decode bases. The base setting is used for both the Lister and 
the decode line and applies to the data field only. The header and trailer 
fields are always displayed in hex.

• Bit — displays the entire content of the frame as a string of bits.

In Bit format, the entire frame is always displayed in binary.

6 If the Word display format is selected:

a Press the Sync Size softkey and enter the sync field size, from 0 to 255 bits.

b Press the Header Size softkey and enter the header size, from 0 to 32 bits.

c Press the # of Words softkey and enter the number of words in the data field, 
from 1 to 255.

When the Trailer Size is set to 0, the <auto> option becomes available. In 
<auto> mode, any number of words can be supported.

d Press the Data Word Size softkey and enter the data word size, from 2 to 32 
bits.

e Press the Trailer Size softkey and enter the trailer size, from 0 to 32 bits.

7 If the Bits display format is selected:

a Press the Sync Size softkey and enter the sync field size, from 0 to 255 bits.

8 Press the Back/Up key to return to the Serial Decode Menu.

9 Press the Settings softkey to open the Manchester Settings Menu.

In the Manchester Settings Menu:

a Press the Start Edge # softkey and enter the starting edge of the Manchester 
signal, from 1 to 256.

b Press the Polarity softkey and select the Manchester signal's logic type:

• Rising — specifies that a rising edge is used to encode a bit value of logic 
1 (and a falling edge encodes a bit value of logic 0).

• Falling — specifies that a falling edge is used to encode a bit value of 
logic 1 (and a rising edge encodes a bit value of logic 0).

c Press the Bit Order softkey and select the bit order, either most significant bit 
first (MSB) or least significant bit first (LSB).

Back
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The selected order is used when displaying data in the serial decode 
waveform and in the Lister.

This softkey is available when the Word display format is selected in the 
Manchester Bus Configuration Menu.

d Press the Idle Bits softkey and enter the minimum idle time/inter-frame gap 
time of the Manchester bus in terms of the bit width.

Framing is determined by idle time.

e Use the Decode Base softkey to select between hexadecimal, unsigned 
decimal, or ASCII display of the decoded data.

The decode base setting is used for the display of the data field in both the 
decode line and in the Lister.

When the Bit display format is selected in the Manchester Bus Configuration 
Menu, this softkey is unavailable and the decode base is forced to Binary.

f Press the Back/Up key to return to the Serial Decode Menu.Back
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Manchester Triggering

To set up the oscilloscope to capture a Manchester signal, see "Setup for 
Manchester Signals" on page 376.

To set up a Manchester trigger:

1 Press [Trigger].

2 In the Trigger Menu, press the Trigger Type softkey; then, select the Manchester 
decode (Serial 1 or Serial 2).

3 Press the Trigger softkey; then, select the trigger condition:

• SOF - Start of Frame — triggers after the starting edge, between the starting 
edge and the sync field.

• Value — triggers on a value you specify, up to 128 bits, after the sync field 
(starting with header bits).

Note that the trigger value is always for bits as they arrive (that is, MSB 
first).

When the decode bit order (specified in the serial decode settings menu) is 
MSB first, the decoded value bit order matches the trigger value bit order.

When the serial decode bit order is LSB first, the decoded value bit order is 
opposite of the trigger value bit order.

When Value is selected:

i Press the #Bits softkey and set the number of bits in the serial data value, 
from 4 bits to 128 bits.

The serial data value is displayed in the Value string in the waveform 
area.

ii Press the Value softkey and use the keypad dialog box to enter the data 
value.

Note that the trigger value is always for bits as they arrive (that is, MSB 
first).

When the decode bit order (specified in the serial decode settings menu) 
is MSB first, the decoded value bit order matches the trigger value bit 
order.

When the serial decode bit order is LSB first, the decoded value bit order 
is opposite of the trigger value bit order.

• Manchester Error — triggers if a Manchester encoding error is detected.
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You can use the Zoom mode for easier navigation of the decoded data.

NOTE For Manchester decode information see "Manchester Serial Decode" on page 381.
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Manchester Serial Decode

To set up the oscilloscope to capture Manchester signals, see "Setup for 
Manchester Signals" on page 376.

To set up Manchester serial decode:

1 Press [Serial] to display the Serial Decode Menu.

2 If the decode line does not appear on the display, press the [Serial] key to turn it 
on.

3 If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

You can use the horizontal Zoom window for easier navigation of the decoded data.

See Also • "Interpreting Manchester Decode" on page 381

• "Interpreting Manchester Lister Data" on page 383

Interpreting Manchester Decode

To display serial decode information, you must press [Run] or [Single] after 
switching on serial decode.

NOTE For Manchester triggering setup see "Manchester Triggering" on page 379.

NOTE If the setup does not produce a stable trigger, the Manchester signal may be slow enough that 
the oscilloscope is AutoTriggering. Press the [Mode/Coupling] key, then press the Mode 
softkey to set the trigger mode from Auto to Normal.
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The Manchester decode display is color coded as follows:

• In Word format:

• Header (yellow)

• Data (white)

• Trailer (blue)

• In Bit format:

• Value (white)

The decode display shows a blue idle line until the specified starting edge # is 
reached, at which point the start of frame angle bracket is drawn in blue.

In Word format, no value is associated with the sync field. The first value displayed 
on the decoded bus is associated with the header field if you select a header size > 
0. Otherwise, the first value displayed is associated with the data field. The end of 
frame angle bracket is drawn in blue at the end of the trailer field, or data field if 
the trailer size is 0, followed by a blue idle line.

In Bit format, the frame is not divided into fields. All bits in the frame are displayed 
as soon as the starting edge occurs. Each bit is displayed on the decoded bus, 
time-aligned with the corresponding Manchester signal.

The only type of error that will be reported in the Manchester decode is 
Manchester Error. When this occurs, a red error frame is drawn with the text 
"MANCH" in red inside the error frame. Any previously valid frame before the error 
is terminated with a blue closing > angle bracket. Because all data is assumed 
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invalid following a Manchester Error, the red error frame is drawn until a valid idle 
signal is detected. In the sync field, any bit value errors are ignored. Manchester 
errors are reported anywhere in the frame.

Interpreting Manchester Lister Data

In addition to the standard Time column, the Manchester Lister contains these 
columns:

• In Word format:

• Header (hex)

• Data (hex, unsigned decimal, or ASCII)

• Trailer (hex)

• Errors

• In Bit format:

• Value (binary)

• Errors

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.
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Setup for NRZ Signals

NRZ signal setup consists of first connecting the oscilloscope to a NRZ-encoded 
serial bus signal, then specifying the signal, bus configuration, and other settings.

To set up the oscilloscope to capture NRZ signals:

1 Press [Serial].

2 Press the Serial softkey and choose the serial decode (Serial 1 or Serial 2) to 
use; then, press the softkey again to enable decode.

3 Press the Mode softkey; then, select the NRZ decode mode.

4 Press the Signals softkey to open the NRZ Signals Menu.

In the NRZ Signals Menu:

a Press the Source softkey to select the channel connected to the NRZ signal 
line.

The label for the NRZ source channel is automatically set.

b Press the Threshold softkey; then, enter the trigger threshold voltage level.

The threshold voltage level is used in decoding and will become the trigger 
level when the trigger type is set to the NRZ serial decode.

c Press the Baud softkey; then, enter the baud rate of the NRZ signal from your 
device under test.

The baud rate can be set from 5 kb/s to 5 Mb/s in 100 b/s increments.

You must set the baud rate to match your device under test.

The default baud rate is 125 kb/s.

d Press the Back/Up key to return to the Serial Decode Menu.

5 Press the Bus Config softkey to open the NRZ Bus Configuration Menu.

In the NRZ Bus Configuration Menu:

a Press the Display Format softkey and select the display format:

• Word — lets you break the frame into header, data, and trailer fields.

Back
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In Word format, you can select between hexadecimal, unsigned decimal, 
and ASCII decode bases. The base setting is used for both the Lister and 
the decode line and applies to the data field only. The header and trailer 
fields are always displayed in hex.

• Bit — displays the entire content of the frame as a string of bits.

In Bit format, the entire frame is always displayed in binary.

6 If the Word display format is selected:

a Press the # Start Bits softkey and enter the number of starting bits, from 0 to 
255 bits.

b Press the Header Size softkey and enter the header size, from 0 to 32 bits.

c Press the # of Words softkey and enter the number of words in the data field, 
from 1 to 255.

d Press the Data Word Size softkey and enter the data word size, from 2 to 32 
bits.

e Press the Trailer Size softkey and enter the trailer size, from 0 to 32 bits.

7 If the Bits display format is selected:

a Press the # Start Bits softkey and enter the number of starting bits, from 0 to 
255 bits.

b Press the Frame Size softkey and enter the total frame size of the NRZ signal, 
from 2 to 255 bits.

This would be equivalent to the sum of the number of bits in the header, 
data, and trailer fields in Word display format.

8 Press the Back/Up key to return to the Serial Decode Menu.

9 Press the Settings softkey to open the NRZ Settings Menu.

In the NRZ Settings Menu:

a Press the Polarity softkey and select the NRZ signal's logic type:

• High — specifies that a positive voltage is used to encode a bit value of 
logic 1 (and a negative voltage encodes a bit value of logic 0).

• Low — specifies that a negative voltage is used to encode a bit value of 
logic 1 (and a positive voltage encodes a bit value of logic 0).

b Press the Bit Order softkey and select the bit order, either most significant bit 
first (MSB) or least significant bit first (LSB).

Back
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The selected order is used when displaying data in the serial decode 
waveform and in the Lister.

c Press the Idle State softkey and choose the idle state of the NRZ bus, either 
Low or High.

d Press the Idle Bits softkey and enter the minimum idle time/inter-frame gap 
time of the NRZ bus in terms of the bit width.

Framing is determined by idle time.

e Use the Decode Base softkey to select between hexadecimal, unsigned 
decimal, or ASCII display of the decoded data.

The decode base setting is used for the display of the data field in both the 
decode line and in the Lister.

f Press the Back/Up key to return to the Serial Decode Menu.Back
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NRZ Triggering

To set up the oscilloscope to capture a NRZ signal, see "Setup for NRZ Signals" 
on page 384.

To set up a NRZ signal:

1 Press [Trigger].

2 In the Trigger Menu, press the Trigger Type softkey; then, select the NRZ decode 
(Serial 1 or Serial 2).

3 Press the Trigger softkey; then, select the trigger condition:

• SOF - Start of Frame — triggers after the starting edge, at the start of a NRZ 
frame.

• Value — triggers on a value you specify, up to 128 bits, after the specified 
number of starting bits.

Note that the trigger value is always for bits as they arrive (that is, MSB 
first).

When the decode bit order (specified in the serial decode settings menu) is 
MSB first, the decoded value bit order matches the trigger value bit order.

When the serial decode bit order is LSB first, the decoded value bit order is 
opposite of the trigger value bit order.

When Value is selected:

i Press the #Bits softkey and set the number of bits in the serial data value, 
from 4 bits to 128 bits.

The serial data value is displayed in the Value string in the waveform 
area.

ii Press the Value softkey and use the keypad dialog box to enter the data 
value.

Note that the trigger value is always for bits as they arrive (that is, MSB 
first).

When the decode bit order (specified in the serial decode settings menu) 
is MSB first, the decoded value bit order matches the trigger value bit 
order.

When the serial decode bit order is LSB first, the decoded value bit order 
is opposite of the trigger value bit order.

You can use the Zoom mode for easier navigation of the decoded data.
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NOTE To display NRZ serial decode, see "NRZ Serial Decode" on page 389.
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NRZ Serial Decode

To set up the oscilloscope to capture NRZ signals, see "Setup for NRZ Signals" on 
page 384.

To set up NRZ serial decode:

1 Press [Serial] to display the Serial Decode Menu.

2 If the decode line does not appear on the display, press the [Serial] key to turn it 
on.

3 If the oscilloscope is stopped, press the [Run/Stop] key to acquire and decode 
data.

You can use the horizontal Zoom window for easier navigation of the decoded data.

See Also • "Interpreting NRZ Decode" on page 390

• "Interpreting NRZ Lister Data" on page 391

NOTE For NRZ triggering set up see "NRZ Triggering" on page 387.

NOTE If the setup does not produce a stable trigger, the NRZ signal may be slow enough that the 
oscilloscope is AutoTriggering. Press the [Mode/Coupling] key, then press the Mode softkey 
to set the trigger mode from Auto to Normal.
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Interpreting NRZ Decode

The NRZ decode display is color coded as follows:

• Word format

• Header (yellow)

• Data (white)

• Trailer (blue)

• Bit format

• Value (white)

The decode display shows a blue idle line until the start of frame, at which point, 
the start of frame angle bracket is drawn in blue.

In Word format, the first value displayed on the decoded bus is associated with the 
header field if you select a header size > 0. Otherwise, the first value displayed is 
associated with the data field. The end of frame angle bracket is drawn in blue at 
the end of the trailer field, or data field if the trailer size is 0, followed by a blue idle 
line.

In Bit format, the frame is not divided into fields. All bits in the frame are displayed 
as soon as the start of frame occurs. Each bit is displayed on the decoded bus, 
time-aligned with the corresponding NRZ signal.
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Interpreting NRZ Lister Data

In addition to the standard Time column, the NRZ Lister contains these columns:

• In Word format:

• Header (hex)

• Data (hex, unsigned decimal, or ASCII)

• Trailer (hex)

• In Bit format:

• Value (binary)

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.
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The MIL-STD-1553/ARINC 429 triggering and serial decode option is 
license-enabled.

The MIL-STD-1553 triggering and decode solution supports bi-phase 
MIL-STD-1553 signaling by using dual threshold triggering. The solution supports 
the standard 1553 Manchester II encoding, data rate of 1 Mb/s, and word length 
of 20 bits.
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Setup for MIL-STD-1553 Signals

MIL-STD-1553 signal setup consists of first connecting the oscilloscope to a serial 
MIL-STD-1553 signal using a differential active probe (the Keysight N2791A is 
recommended), specifying the signal source, and specifying the high and low 
trigger threshold voltage levels.

To set up the oscilloscope to capture MIL-STD-1553 signals:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

3 Click the Mode softkey; then, select MIL-STD-1553.

4 Click the Signals softkey to open the MIL-STD-1553 Signals Menu.

5 Click the Source softkey to select the channel connected to the MIL-STD-1553 
signal line.

The label for the MIL-STD-1553 source channel is automatically set.

6 Click the Back/Up softkey to return to the Serial Decode Menu.

7 Click the Auto Setup softkey which performs these actions:

• Sets the probe attenuation factor of the input Source channel to 10:1.

• Sets upper and lower thresholds to a voltage value equal to ±1/3 division 
based on the current V/div setting.

• Turns off trigger noise reject.

• Turns on Serial Decode.

• Sets the trigger type to MIL-1553.

8 If the upper and lower thresholds are not set correctly by Auto Setup, Click the 
Signals softkey to return to the MIL-STD-1553 Signals Menu. Then:

• Click the High Threshold softkey; then, enter the high trigger threshold 
voltage level.

• Click the Low Threshold softkey; then, enter the low trigger threshold voltage 
level.

The threshold voltage levels are used in decoding and will become the trigger 
levels when the trigger type is set to the selected serial decode slot.
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MIL-STD-1553 Triggering

To set up the oscilloscope to capture a MIL-STD-1553 signal, see "Setup for 
MIL-STD-1553 Signals" on page 394.

To set up a MIL-STD-1553 trigger:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select Serial 1 or 
Serial 2 on which the MIL-STD-1553 signal is being decoded.

3 Click the Trigger softkey; then, select the trigger condition:

• Data Word Start — triggers on the start of a Data word (at the end of a valid 
Data Sync pulse).

• Data Word Stop — triggers on the end of a Data word.

• Command/Status Word Start — triggers on the start of Command/Status word 
(at the end of a valid C/S Sync pulse).

• Command/Status Word Stop — triggers on the end of a Command/Status word.

• Remote Terminal Address — triggers if the RTA of the Command/Status word 
matches the specified value.

When this option is selected, the RTA softkey becomes available and lets you 
select the hex Remote Terminal Address value to trigger on. If you select 
0xXX (don't cares), the oscilloscope will trigger on any RTA.

• Remote Terminal Address + 11 Bits — triggers if the RTA and the remaining 11 
bits match the specified criteria.

When this option is selected, these softkeys become available:

• The RTA softkey lets you select the hex Remote Terminal Address value.

• The Bit Time softkey lets you select the bit time position.

• The 0 1 X softkey lets you set the bit time position value as a 1, 0, or X 
(don't care).

• Parity Error — triggers if the (odd) parity bit is incorrect for the data in the 
word.

• Sync Error — triggers if an invalid Sync pulse is found.

• Manchester Error — triggers if a Manchester encoding error is detected.

NOTE For MIL-STD-1553 decode information see "MIL-STD-1553 Serial Decode" on page 396.
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MIL-STD-1553 Serial Decode

To set up the oscilloscope to capture MIL-STD-1553 signals, see "Setup for 
MIL-STD-1553 Signals" on page 394.

To set up MIL-STD-1553 serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 Use the Base softkey to select between hexadecimal and binary display of the 
decoded data.

The base setting is used for the display of the remote terminal address and the 
data, in both the decode line and in the Lister.

3 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

4 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the decoded data.

See Also • "Interpreting MIL-STD-1553 Decode" on page 396

• "Interpreting MIL-STD-1553 Lister Data" on page 398

• "Searching for MIL-STD-1553 Data in the Lister" on page 399

Interpreting MIL-STD-1553 Decode

To display serial decode information after turning on serial decode, you must 
choose Main Menu > Run/Stop to start making acquisitions or Main Menu > Single to 
make a single acquisition.

NOTE For MIL-STD-1553 triggering setup see "MIL-STD-1553 Triggering" on page 395.
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The MIL-STD-1553 decode display is color coded as follows:

• Command and Status decoded data is colored green, with the Remote Terminal 
Address (5 bits of data) being displayed first, then the text "C/S:", followed by 
the value of the remaining 11 bits of a Command/Status word.

• Data word decoded data is colored white, preceded by the text "D:".

• Command/Status or Data words with a Parity error have the decode text 
displayed in red instead of green or white.

• SYNC errors are displayed with the word "SYNC" within red angle brackets.

• Manchester encoding errors are displayed with the word "MANCH" within blue 
angle brackets (blue instead of red because a valid Sync pulse started the 
word).
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Interpreting MIL-STD-1553 Lister Data

In addition to the standard Time column, the MIL-STD-1553 Lister contains these 
columns:

• RTA — displays the Remote Terminal Address for Command/Status words, 
nothing for Data words.

• Word Type — "Cmd/Status" for Command/Status words, "Data" for Data words. 
For Command/Status words the background color is green to match the 
decode text color.

• Data — the 11 bits after the RTA for Command/Status words, or the 16 bits of a 
Data word.

• Errors — "Sync", "Parity", or "Manchester" errors as appropriate. The 
background color is red to indicate an error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.
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Searching for MIL-STD-1553 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
MIL-STD-1553 data in the Lister. You can use the sidebar Navigate controls to 
navigate through the marked rows.

1 With MIL-STD-1553 selected as the serial decode mode, choose Main Menu > 
Analyze > Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2 on 
which the MIL-STD-1553 signal is being decoded.

3 Click Search for; then, select from these options:

• Data Word Start — finds the start of a Data word (at the end of a valid Data 
Sync pulse).

• Command/Status Word Start — finds the start of Command/Status word (at the 
end of a valid C/S Sync pulse).

• Remote Terminal Address — finds the Command/Status word whose RTA 
matches the specified value. The value is specified in hex.

When this option is selected, the RTA softkey becomes available and lets you 
select the hex Remote Terminal Address value to find.

• Remote Terminal Address + 11 Bits — finds the RTA and the remaining 11 bits 
that match the specified criteria.

When this option is selected, these softkeys become available:

• The RTA softkey lets you select the hex Remote Terminal Address value.

• The Bit Time softkey lets you select the bit time position.

• The 0 1 X softkey lets you set the bit time position value as a 1, 0, or X 
(don't care).

• Parity Error — finds (odd) parity bits that are incorrect for the data in the word.

• Sync Error — finds invalid Sync pulses.

• Manchester Error — finds Manchester encoding errors.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.
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Setup for ARINC 429 Signals

Setup consists of first connecting the oscilloscope to a ARINC 429 signal using a 
differential active probe (the Keysight N2791A is recommended), then using the 
Signals Menu to specify the signal source, the high and low trigger threshold 
voltage levels, the signal speed, and the signal type.

To set up the oscilloscope to capture ARINC 429 signals:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

3 Click the Mode softkey; then, select ARINC 429.

4 Click the Signals softkey to open the ARINC 429 Signals Menu.

5 Click Source; then, select the channel for the ARINC 429 signal.

The label for the ARINC 429 source channel is automatically set.

6 Click the Speed softkey to open the ARINC 429 Speed Menu.

7 In the ARINC429 Speed Menu, click the Speed softkey and specify the speed of 
the ARINC 429 signal:

• High — 100 kb/s.

• Low — 12.5 kb/s.

• User Defined — click the User Baud softkey and enter the user-defined speed 
value.

8 Click the Back/Up softkey to return to the ARINC 429 Signals Menu.

9 Click the Signal Type softkey and specify the signal type of the ARINC 429 signal:

• Line A (non-inverted).

• Line B (inverted).

• Differential (A-B).

10 Click the Auto Setup softkey to automatically set these options for decoding and 
triggering on ARINC 429 signals:

• High Trigger Threshold: 3.0 V.
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• Low Trigger Threshold: -3.0 V.

• Noise Reject: Off.

• Probe Attenuation: 10.0.

• Vertical Scale: 4 V/div.

• Serial Decode: On.

• Base: Hex.

• Word Format: Label/SDI/Data/SSM.

• Trigger: currently active serial bus.

• Trigger Mode: Word Start.

11 If the high and low thresholds are not set correctly by Auto Setup:

• Click the High Threshold softkey; then, enter the high trigger threshold 
voltage level.

• Click the Low Threshold softkey; then, enter the low trigger threshold voltage 
level.

The threshold voltage levels are used in decoding and will become the trigger 
levels when the trigger type is set to the selected serial decode slot.
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ARINC 429 Triggering

To set up the oscilloscope to capture a ARINC 429 signal, see "Setup for 
ARINC 429 Signals" on page 400.

After setting up the oscilloscope to capture a ARINC 429 signal:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select Serial 1 or 
Serial 2 on which the ARINC 429 signal is being decoded.

3 Click the Trigger: softkey; then, select the trigger condition:

• Word Start — triggers on the start of a word.

• Word Stop — triggers at the end of a word.

• Label — triggers on the specified label value.

• Label + Bits — triggers on the label and the other word fields as specified.

• Label Range — triggers on a label following in a min/max range.

• Parity Error — triggers on words with a parity error.

• Word Error — triggers on an intra-word coding error.

• Gap Error — triggers on an inter-word gap error.

• Word or Gap Error — triggers on either a Word or Gap Error.

• All Errors — triggers on any of the above errors.

• All Bits (Eye) — triggers on any bit, which will therefore form an eye diagram.

• All 0 Bits — triggers on any bit with a value of zero.

• All 1 Bits — triggers on any bit with a value of one.

4 If you select the Label or Label + Bits condition, use the Label softkey to specify 
the label value.

Label values are always displayed in octal.

5 If you select the Label + Bits condition, use the Bits softkey and submenu to 
specify the bit values:

Click the Data, SSM, and/or SSM softkeys and use the binary keypad dialog to 
enter the 0, 1, or X (don't care) values.
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The SDI or SSM selections may not be available, depending on word format 
selection in the Serial Decode Menu.

6 If you select the Label Range condition, use the Label Min and Label Max softkeys 
to specify the ends of the range.

Again, label values are always displayed in octal.

You can use the Zoom mode for easier navigation of the decoded data.

NOTE To display ARINC 429 serial decode, see "ARINC 429 Serial Decode" on page 404.
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ARINC 429 Serial Decode

To set up the oscilloscope to capture ARINC 429 signals, see "Setup for 
ARINC 429 Signals" on page 400.

To set up ARINC 429 serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 In the submenu accessed by the Settings softkey, you can use the Base softkey 
to select between hexadecimal and binary display of the decoded data.

The base setting is used for data display in both the decode line and in the 
Lister.

Label values are always displayed in octal, and SSM and SDI values are always 
displayed in binary.

3 Click the Word Format softkey and specify the word decode format:

• Label/SDI/Data/SSM:

• Label - 8 bits.

• SDI - 2 bits.

• Data - 19 bits.

• SSM - 2 bits.

• Label/Data/SSM:

• Label - 8 bits.

• Data - 21 bits.

• SSM - 2 bits.

• Label/Data:

• Label - 8 bits.

• Data - 23 bits.

4 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

5 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

NOTE For ARINC 429 triggering set up see "ARINC 429 Triggering" on page 402.
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You can use the horizontal Zoom window for easier navigation of the decoded data.

See Also • "Interpreting ARINC 429 Decode" on page 405

• "ARINC 429 Totalizer" on page 406

• "Interpreting ARINC 429 Lister Data" on page 407

• "Searching for ARINC 429 Data in the Lister" on page 407

Interpreting ARINC 429 Decode

Depending on the selected word decode format, the ARINC 429 decode display is 
color coded as follows:

• When the decode format is Label/SDI/Data/SSM:

• Label (yellow) (8 bits) – displayed in octal.

• SDI (blue) (2 bits) – displayed in binary.

• Data (white, red if parity error) (19 bits) – displayed in the selected Base.

• SSM (green) (2 bits) – displayed in binary.

• When the decode format is Label/Data/SSM:

• Label (yellow) (8 bits) – displayed in octal.

NOTE If the setup does not produce a stable trigger, the ARINC 429 signal may be slow enough that 
the oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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• Data (white, red if parity error) (21 bits) – displayed in the selected Base.

• SSM (green) (2 bits) – displayed in binary.

• When the decode format is Label/Data:

• Label (yellow) (8 bits) – displayed in octal.

• Data (white, red if parity error) (23 bits) – displayed in the selected Base.

The Label bits are displayed in the same order as they are received on the wire. For 
the Data, SSM, and SDI bits, the fields are displayed in the order received; 
however, the bits within those fields are displayed in reverse order. In other words, 
the non-Label fields are displayed in the ARINC 429 Word Format, while the bits 
for those fields have the opposite transfer order on the wire.

ARINC 429 Totalizer

The ARINC 429 totalizer measures the total ARINC 429 words and errors.

The totalizer is always running, counting words and errors, and is displayed 
whenever ARINC 429 decode is displayed. The totalizer counts even when the 
oscilloscope is stopped (not acquiring data).

Stopping acquisitions does not affect the totalizer.

When an overflow condition occurs, the counter displays OVERFLOW.

The counters can be reset to zero by clicking the Reset ARINC 429 Counters softkey 
(in the decode Settings menu).
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Interpreting ARINC 429 Lister Data

In addition to the standard Time column, the ARINC 429 Lister contains these 
columns:

• Label — the 5-bit label value in octal format.

• SDI — the bit values (if included in the word decode format).

• Data — the data value in binary or hex, depending on the base setting.

• SSM — the bit values (if included in the word decode format).

• Errors — highlighted in red. Errors can be Parity, Word, or Gap.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for ARINC 429 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
ARINC 429 data in the Lister. You can use the sidebar Navigate controls to navigate 
through the marked rows.

1 With ARINC 429 selected as the serial decode mode, choose Main Menu > 
Analyze > Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2 on 
which the ARINC 429 signal is being decoded.

3 Click Search; then, select from these options:
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• Label — finds the specified label value.

Label values are always displayed in octal.

• Label + Bits — finds the label and the other word fields as specified.

• Parity Error — finds words with a parity error.

• Word Error — finds an intra-word coding error.

• Gap Error — finds an inter-word gap error.

• Word or Gap Error — finds either a Word or Gap Error.

• All Errors — finds any of the above errors.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.



409

 

Keysight M9241/42/43A PXIe Oscilloscopes 
SFP User's Guide

26 SENT Triggering and Serial 
Decode

Setup for SENT Signals / 410
SENT Triggering / 414
SENT Serial Decode / 416

The SENT (Single Edge Nibble Transmission) triggering and serial decode option is 
license-enabled.
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Setup for SENT Signals

To set up the oscilloscope to capture SENT signals:

1 Connect an oscilloscope channel to the signal in the device under test.

Analog channels can be used.

2 Choose Main Menu > Analyze > Serial Decode.

3 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

4 Click the Mode softkey; then, select SENT.

5 Click the Source softkey to open the SENT Source Menu.

a Click the Source softkey; then, select the channel for the signal.

b Click the Threshold softkey; then, select the signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode 
(Serial 1 or Serial 2).

c Click the Back/Up softkey to return to the SENT Serial Decode Menu.

6 Click the Bus Config softkey to open the SENT Bus Configuration Menu.

a Click the Clock Period softkey; then, specify the nominal clock period (tick) 
time.

b Click the Tolerance softkey; then, specify the percent tolerance for 
determining whether the sync pulse is valid for decoding the data.

If the measured time of the sync pulse is within the percent tolerance of the 
nominal clock period setting, the decode proceeds; otherwise, the sync 
pulse is in error, and the data is not decoded.

c Click the # of Nibbles softkey; then, specify the number of nibbles in a Fast 
Channel Message.

d Click the Idle State softkey to specify the idle state of the SENT signal.

e Click the CRC Format softkey to specify the CRC format that will be used in 
calculating the correctness of the CRCs.
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Enhanced Serial Message CRCs are always calculated using the 2010 
format, but for the Fast Channel Messages, and for Short Serial Message 
CRCs, the chosen setting is used.

f Click the Pause Pulse softkey to specify whether there is a pause pulse 
between Fast Channel Messages.

• Off — There is no pause pulse between Fast Channel Messages.

Note that a SENT serial bus with no pause pulse is never idle. This means, 
during normal operation, the fast channel decode line will show a 
continuous stream of packets, with a new packet opening as soon as the 
previous one has closed.

• On — Pause pulses are added between Fast Channel Messages so that 
frames come at a regular interval.

If there is a pause pulse (and Pause Pulse is on), idle time is shown 
between messages.

• SPC (Short PWM Code) — In SENT SPC, there are no pause pulses. 
Instead, the message event is triggered by the master when it wants to 
receive data. SENT SPC ends the transmission after the CRC so it almost 
appears as if there is a pause pulse from the end until the next master 
trigger.

g Click the Back/Up softkey to return to the SENT Serial Decode Menu.

7 Click the Settings softkey to open the SENT Settings Menu.

a Click the Message Format softkey to select the message decode/triggering 
format:

• Fast Nibbles (All) — displays the raw transmitted nibble values.

• Fast Signals — displays Fast Channel Message Signals.

• Fast + Short Serial — displays both Fast and Slow Messages (Short format) 
simultaneously.

• Fast + Enhanced Serial — displays both Fast and Slow Messages (Enhanced 
format) simultaneously.

• Short Serial — displays Slow Channel Messages in Short format.

• Enhanced Serial — displays Slow Channel Messages in Enhanced format.

This selection affects both decoding and triggering. The decode is affected 
both in how the system interprets the data, and what will be displayed. The 
trigger is affected in that the trigger hardware needs to be configured to 
trigger on serial messages correctly.
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You can specify the nibble display order for Fast Channel Message Signals 
(under the Fast Signals softkey). Raw transmitted nibble values are displayed 
in the order received.

Slow Channel Serial Messages are always displayed as defined by the SENT 
specification.

b Click the Display softkey to select between hexadecimal, unsigned decimal, 
or "transfer function" display of Fast Channel nibbles, signals, and CRC 
values, as well as Slow Channel IDs, data, and CRC values. (The S&C value is 
always displayed in binary.)

Your selection is used for both the Lister and the decode line displays.

When Transfer Function is selected (for message formats that include fast 
signals), Fast Channel Signals display a calculated physical value based on 
the specified Multiplier and Offset (under the Fast Signals softkey):

• PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

When Transfer Function is selected, the CRC and Slow Channel information is 
displayed in hex.

8 When a fast signals message decode/triggering is selected, click the Fast 
Signals softkey to open the SENT Signals Menu where you can define and 
specify the display of up to six Fast Signals.

a Click the Fast Signals softkey and select the Fast Signal to be defined.

Once a Fast Signal is selected, click the softkey again to enable or disable 
decode for that signal.

b Click the Start Bit # (MSB) softkey to specify the starting bit for the selected 
signal.

c Click the # of Bits softkey to specify the number of bits in the selected signal.

d Click the Nibble Order softkey to specify the nibble display order as either 
most significant nibble (MSN) or least significant nibble (LSN) first.

e When the display mode setting is Transfer Function (see the SENT Settings 
Menu), click the Multiplier or Offset softkeys; then, specify the value.

The multiplier and offset values are used in calculating a physical value 
displayed for the Fast Signal:

NOTE For the Slow Channel, the proper format, Short or Enhanced, must be chosen for proper 
decoding and triggering to occur.
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• PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Here are some Fast Signal definition examples:

Example 1: Start Bit # = 13, # of bits = 8, Nibble Order = LSN First

15

Result bits:

Message data:

Example 2: Start Bit # = 10, # of bits = 5, Nibble Order = MSN First

14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

13 1211 10 9 87 6

15

Result bits:

Message data: 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

10 9 8 7 6
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SENT Triggering

To set up the oscilloscope to capture SENT signals, see "Setup for SENT Signals" 
on page 410.

To set up a SENT trigger condition:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select the serial decode 
(Serial 1 or Serial 2) of the SENT signal.

3 Click the Trigger on: softkey and select the SENT trigger condition:

• Start of Fast Channel Message — triggers on the start of any Fast Channel 
Message (after 56 Synchronization/Calibration ticks).

• Start of Slow Channel Message — trigger on the start of any Slow Channel 
Message.

• Fast Channel SC & Data — triggers on a Fast Channel Message when the 
Status & Communication nibble and the data nibbles match the values 
entered using additional softkeys.

• Slow Channel Message ID — triggers when a Slow Channel Message ID 
matches the value entered using additional softkeys.

• Slow Channel Message ID & Data — triggers when a Slow Channel Message ID 
and Data field both match the values entered using additional softkeys.

• Tolerance Violation — triggers when the sync pulse width varies from the 
nominal value by greater than the entered percentage.

• Fast Channel CRC Error — triggers on any Fast Channel Message CRC error.

• Slow Chanel CRC Error — triggers on any Slow Channel Message CRC error.

• All CRC Errors — triggers on any CRC error, Fast or Slow.

• Pulse Period Error — triggers if a nibble is either too wide or too narrow (for 
example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, 
or checksum pulse periods are checked.

• Successive Sync Pulses Error — triggers on a sync pulse whose width varies 
from the previous sync pulse's width by greater than 1/64 (1.5625%, as 
defined in the SENT specification).
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4 If you choose the Fast Channel SC & Data trigger condition:

a Click the Base softkey to choose between Hex or Binary data value entry.

Use the Binary method if you need to enter "don't care" bits (X) within a 
nibble. If all bits in a nibble are "don't care", the hex nibble is displayed as 
"don't care" (X). When all bits in a nibble are 1s or 0s, the hex value is shown. 
Hex nibbles that contain a mix of 0/1 bits and "don't care" bits are displayed 
as "$".

b Click the SC & Data softkey and use the keypad dialog to enter the data 
value.

The S&C nibble is the left most nibble entered in the string of numbers, 
followed by the data nibbles.

5 If you choose the Slow Channel Message ID or Slow Channel Message ID & Data 
trigger condition:

a Click the Configuration softkey to select the desired packet ID for the selected 
packet type.

When an Enhanced Serial message format is specified (see "Setup for SENT 
Signals" on page 410), click this softkey to select which enhanced format 
configuration is being used:

• 16-Bit Data, 4-Bit ID

• 12-Bit Data, 8-Bit ID

b Click the Slow Message ID softkey and specify the Slow Message ID.

c If you choose the Slow Channel Message ID & Data trigger condition, click the 
Slow Data softkey and specify the Slow Message data.

6 If you choose the Tolerance Violation trigger condition, click the Tolerance softkey 
and specify the tolerance variation that is considered a violation.

The percentage entered must be less than the percent tolerance specified in 
the decode bus configuration settings.

NOTE If the setup does not produce a stable trigger, the SENT signals may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.

NOTE To display SENT serial decode, see "SENT Serial Decode" on page 416.
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SENT Serial Decode

To set up the oscilloscope to capture SENT signals, see "Setup for SENT Signals" 
on page 410.

To set up SENT serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

3 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the acquired data.

See Also • "Interpreting SENT Decode" on page 416

• "Interpreting SENT Lister Data" on page 419

• "Searching for SENT Data in the Lister" on page 420

Interpreting SENT Decode

The fields of the Fast and Slow Channels are displayed as follows. Note that the 
Slow Channel has three different variants. The colors noted below indicate the 
color of the text:

• Fast Channel:

NOTE For SENT triggering setup see "SENT Triggering" on page 414.

NOTE If the setup does not produce a stable trigger, the SENT signals may be slow enough that the 
oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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• Status & Communication (S&C) Nibble (green) (4 bits):

• 2 Application bits and 2 Serial Message bits will be displayed, in all 
formats.

• Data Nibbles (white) (4 bits, but may be combined into Signals, based on 
format):

• "Fast Nibbles (All)" format — each nibble displayed as hex or decimal 
number.

• "Fast Signals", "Fast + Short Serial", or "Fast + Enhanced Serial" formats — If 
any fast signals are enabled, signals are displayed like:

• S1:<value>;S2:<value>.

• Unused nibbles are not displayed (example, when 6th nibble is an 
inverted copy of the 1st nibble).

• CRC Nibble (blue when valid, red when error detected) (4 bits).

• Slow Channel – Short Serial Message:

• Message ID (yellow) (4 bits).

• Data Byte (white) (8 bits).

• CRC (blue when valid, red when error detected) (4 bits).
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• Slow Channel – Enhanced Serial Message:

• CRC (blue when valid, orange if end of message is off screen, red when error 
detected) (6 bits).

• Message ID (yellow) (4 or 8 bits).

• Data Field (white) (16 or 12 bits).

Enhanced Serial Message CRCs will be displayed in orange if the data to calculate 
the CRC is off-screen to the right. Serial messages will also be shown with a 
leading idle line in orange and an opening brace in orange if the starting location 
cannot be precisely determined due to that data being off screen to the left.

The decode will also indicate errors where a nibble's pulse is too wide or too 
narrow. This will be indicated by a ">" or "<" in red, as well as the rest of the 
packet's outline and closing brace being in red, as well as an orange idle line until 
the next valid sync. At the time of the valid sync, there will be an orange opening 
brace.
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Interpreting SENT Lister Data

Each Fast or Slow Channel message is represented on its own row. The start time 
of Slow Channel messages determines their order relative to the Fast Channel 
messages. Therefore, a Slow Channel message appears before most of the Fast 
Channel messages that it was built from. This is due to the "Time" column holding 
the start time of a packet.

In addition to the standard Time column, the following columns are used to 
support both the Fast Channel and the Slow Channel simultaneously, and these 
columns are displayed for all Message Format modes except Fast Nibbles (All):

• S&C — (Fast Channel Only) (binary).

• ID — (Slow Channel Only) (Hex or Decimal).

• Data — (Hex or Decimal):

• Fast Channel:

• <value> (value in Hex or Decimal) (Raw Decode Format).

• S1:<value>;S2:<value> (values are in Hex or Decimal) (other formats).

• Slow Channel: Hex or Decimal display of a single value.

• CRC — (value in Hex or Decimal).

• Pause Ticks (ticks will be displayed in orange if the uncertainty of the 
measurement is > 25%).

• Errors.
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When the Message Format is set to Fast Nibbles (All), the following columns are 
displayed:

• Sync Width.

• S&C — (Fast Channel Only) (binary).

• Data — (Hex or Decimal).

• CRC — (value in Hex or Decimal).

• Errors.

When the selected Message Format contains both Fast and Slow Channel 
Messages, the S&C Lister field (populated for Fast Messages) has a green 
background, and the ID Lister field (populated for Slow Messages) has a yellow 
background.

Slow Channel CRC values that cannot be confirmed as valid or invalid due to data 
used in the calculation being off screen to the right, will have an orange 
background in the Lister.

Searching for SENT Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
SENT data in the Lister. You can use the sidebar Navigate controls to navigate 
through the marked rows.

1 With SENT selected as the serial decode mode, choose Main Menu > Analyze > 
Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2, 
where the SENT signals is being decoded.

3 In the Search Menu, click Search for; then, select from these options:

• Fast Channel Data — finds Fast Channel data nibbles that match the values 
entered using additional softkeys.

• Slow Channel Message ID — finds Slow Channel Message IDs that match the 
value entered using additional softkeys.

• Slow Channel Message ID & Data — finds Slow Channel Message IDs and Data 
that match the values entered using additional softkeys.

• All CRC Errors — finds any CRC error, Fast or Slow.

• Pulse Period Error — finds where a nibble is either too wide or too narrow (for 
example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, 
or checksum pulse periods are checked.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.
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The UART/RS232 triggering and serial decode option is license-enabled.
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Setup for UART/RS232 Signals

To set up the oscilloscope to capture UART/RS232 signals:

1 Choose Main Menu > Analyze > Serial Decode.

2 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

3 Click the Mode softkey; then, select UART/RS232.

4 Click the Signals softkey to open the UART/RS232 Signals Menu.

5 For both the Rx and Tx signals:

a Connect an oscilloscope channel to the signal in the device under test.

b Click the Rx or Tx softkey; then, select the channel for the signal.

c Click the corresponding Threshold softkey; then, select the signal threshold 
voltage level.

The threshold voltage level is used in decoding, and it will become the 
trigger level when the trigger type is set to the selected serial decode slot.

The RX and TX labels for the source channels are automatically set.

6 Click the Back/Up softkey to return to the Serial Decode Menu.

7 Click the Bus Config softkey to open the UART/RS232 Bus Configuration Menu.

Set the following parameters.

a #Bits — Set the number of bits in the UART/RS232 words to match your 
device under test (selectable from 5-9 bits).

b Parity — Choose odd, even, or none, based on your device under test.

c Baud — Click the Baud Rate softkey, then click the Baud softkey and select a 
baud rate to match the signal in your device under test. You can select baud 
rates from 1.2 kb/s to 12 Mb/s.
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If the desired baud rate is not listed, select User Defined on the Baud softkey; 
then, select the desired baud rate using the User Baud softkey. You can set 
the user-defined UART baud rate from 100 b/s to 8.0000 Mb/s.

d Polarity — Select idle low or idle high to match your device under test's state 
when at idle. For RS232 select idle low.

e Bit Order — Select whether the most significant bit (MSB) or the least 
significant bit (LSB) is presented after the start bit in the signal from your 
device under test. For RS232 select LSB.

NOTE In the serial decode display, the most significant bit is always displayed on the left regardless 
of how Bit Order is set.
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UART/RS232 Triggering

To set up the oscilloscope to capture UART/RS-232 signals, see "Setup for 
UART/RS232 Signals" on page 422.

To trigger on a UART (Universal Asynchronous Receiver/Transmitter) signal 
connect the oscilloscope to the Rx and Tx lines and set up a trigger condition. 
RS232 (Recommended Standard 232) is one example of a UART protocol.

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select Serial 1 or 
Serial 2 on which the UART/RS232 signals are being decoded.

3 Click the Trigger Setup softkey to open the UART/RS232 Trigger Setup Menu.

4 Click the Base softkey to select Hex or ASCII as the base displayed on the Data 
softkey in the UART/RS232 Trigger Setup Menu.

Note that the setting of this softkey does not affect the selected base of the 
decode display.

5 Click the Trigger softkey and set up the desired trigger condition:

• Rx Start Bit — The oscilloscope triggers when a start bit occurs on Rx.

• Rx Stop Bit — Triggers when a stop bit occurs on Rx. The trigger will occur on 
the first stop bit. This is done automatically whether the device under test 
uses 1, 1.5, or 2 stop bits. You do not need to specify the number of stop bits 
used by the device Under test.

• Rx Data — Triggers on a data byte that you specify. For use when the device 
under test data words are from 5 to 8 bits in length (no 9th (alert) bit).

• Rx 1:Data — For use when the device under test data words are 9 bits in 
length including the alert bit (the 9th bit). Triggers only when the 9th (alert) 
bit is 1. The specified data byte applies to the least significant 8 bits 
(excludes the 9th (alert) bit).

• Rx 0:Data — For use when the device under test data words are 9 bits in 
length including the alert bit (the 9th bit). Triggers only when the 9th (alert) 
bit is 0. The specified data byte applies to the least significant 8 bits 
(excludes the 9th (alert) bit).
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• Rx X:Data — For use when the device under test data words are 9 bits in 
length including the alert bit (the 9th bit). Triggers on a data byte that you 
specify regardless of the value of the 9th (alert) bit. The specified data byte 
applies to the least significant 8 bits (excludes the 9th (alert) bit).

• Similar choices are available for Tx.

• Rx or Tx Parity Error — Triggers on a parity error based on the parity you have 
set in the Bus Configuration Menu.

6 If you choose a trigger condition that includes "Data" in its description (for 
example: Rx Data), then click the Data is softkey, and choose an equality 
qualifier. You can choose equal to, not equal to, less than, or greater than a 
specific data value.

7 Use the Data softkey to choose the data value for your trigger comparison. This 
works in conjunction with the Data is softkey.

8 Optional: The Burst softkey lets you trigger on the Nth frame (1-4096) after an 
idle time you select. All trigger conditions must be met for the trigger to occur.

9 If Burst is selected, an idle time (1 µs to 10 s) can be specified so that the 
oscilloscope will look for a trigger condition only after the idle time has past. 
Click the Idle softkey and set an idle time.

NOTE If the setup does not produce a stable trigger, the UART/RS232 signals may be slow enough 
that the oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of 
the display, and change the trigger mode from Auto to Normal.

NOTE To display UART/RS232 serial decode, see "UART/RS232 Serial Decode" on page 426.
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UART/RS232 Serial Decode

To set up the oscilloscope to capture UART/RS232 signals, see "Setup for 
UART/RS232 Signals" on page 422.

To set up UART/RS232 serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 Click Settings.

3 In the UART/RS232 Settings Menu, click the Base softkey to select the base 
(hex, binary, or ASCII) in which decoded words are displayed.

• When displaying words in ASCII, the 7-bit ASCII format is used. Valid ASCII 
characters are between 0x00 and 0x7F. To display in ASCII you must select 
at least 7 bits in the Bus Configuration. If ASCII is selected and the data 
exceeds 0x7F, the data is displayed in hex.

• When #Bits is set to 9 in the UART/RS232 Bus Configuration Menu, the 9th 
(alert) bit is displayed directly to the left of the ASCII value (which is derived 
from the lower 8 bits).

4 Optional: Click the Framing softkey and select a value. In the decode display, the 
chosen value will be displayed in light blue. However, if a parity error occurs the 
data will be displayed in red.

5 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

6 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the acquired data.

NOTE For UART/RS232 triggering setup see "UART/RS232 Triggering" on page 424.

NOTE If the setup does not produce a stable trigger, the UART/RS232 signals may be slow enough 
that the oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of 
the display, and change the trigger mode from Auto to Normal.
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See Also • "Interpreting UART/RS232 Decode" on page 427

• "UART/RS232 Totalizer" on page 428

• "Interpreting UART/RS232 Lister Data" on page 428

• "Searching for UART/RS232 Data in the Lister" on page 429

Interpreting UART/RS232 Decode

• Angled waveforms show an active bus (inside a packet/frame).

• Mid-level blue lines show an idle bus.

• When using 5-8 bit formats, the decoded data is displayed in white (in binary, 
hex, or ASCII).

• When using the 9 bit format, all data words are displayed in green, including 
the 9th bit. The 9th bit is displayed on the left.

• When a data word value is selected for framing, it is displayed in light blue. 
When using 9-bit data words, the 9th bit will also be displayed in light blue.

• Decoded text is truncated at the end of the associated frame when there is 
insufficient space within frame boundaries.

• Pink vertical bars indicate you need to expand the horizontal scale (and run 
again) to see decode.

• When the horizontal scale setting does not permit the display of all available 
decoded data, red dots will appear in the decoded bus to mark the location of 
hidden data. Expand the horizontal scale to allow the data to display.
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• An unknown (undefined) bus is shown in red.

• A parity error will cause the associated data word to be shown in red, which 
includes the 5-8 data bits and the optional 9th bit.

UART/RS232 Totalizer

The UART/RS232 totalizer consists of counters that provide a direct measure of 
bus quality and efficiency. The totalizer appears on screen whenever UART/RS232 
Decode is ON in the Serial Decode Menu.

The totalizer is running, counting frames and calculating the percentage of error 
frames, even when the oscilloscope is stopped (not acquiring data).

The ERR (error) counter is a count of Rx and Tx frames with parity errors. The TX 
FRAMES and RX FRAMES counts include both normal frames and frames with 
parity errors. When an overflow condition occurs, the counter displays OVERFLOW.

The counters can be reset to zero by clicking the Reset UART Counters softkey in the 
UART/RS232 Settings Menu.

Interpreting UART/RS232 Lister Data
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In addition to the standard Time column, the UART/RS232 Lister contains these 
columns:

• Rx — receive data.

• Tx — transmit data.

• Errors — highlighted in red, Parity Error or Unknown Error.

Aliased data is highlighted in pink. When this happens, decrease the horizontal 
time/div setting and run again.

Searching for UART/RS232 Data in the Lister

The oscilloscope's search capability lets you search for (and mark) certain types of 
UART/RS232 data in the Lister. You can use the sidebar Navigate controls to 
navigate through the marked rows.

1 With UART/RS232 selected as the serial decode mode, choose Main Menu > 
Analyze > Waveform Search.

2 In the Search Menu, click the Search softkey; then, select Serial 1 or Serial 2 on 
which the UART/RS232 signals are being decoded.

3 In the Search Menu, click Search; then, select from these options:

• Rx Data — Finds a data byte that you specify. For use when the DUT data 
words are from 5 to 8 bits in length (no 9th (alert) bit).

• Rx 1:Data — For use when the DUT data words are 9 bits in length including 
the alert bit (the 9th bit). Finds only when the 9th (alert) bit is 1. The 
specified data byte applies to the least significant 8 bits (excludes the 9th 
(alert) bit)

• Rx 0:Data — For use when the DUT data words are 9 bits in length including 
the alert bit (the 9th bit). Finds only when the 9th (alert) bit is 0. The 
specified data byte applies to the least significant 8 bits (excludes the 9th 
(alert) bit).

• Rx X:Data — For use when the DUT data words are 9 bits in length including 
the alert bit (the 9th bit). Finds a data byte that you specify regardless of the 
value of the 9th (alert) bit. The specified data byte applies to the least 
significant 8 bits (excludes the 9th (alert) bit).

• Similar choices are available for Tx.

• Rx or Tx Parity Error — Finds a parity error based on the parity you have set in 
the Bus Configuration Menu.

• Rx or Tx Any Error — Finds any error.

For more information on searching data, see "Searching Lister Data" on page 113.

For more information on using the sidebar Navigate controls, see "Navigating the 
Time Base" on page 49.
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The USB PD (Power Delivery) triggering and serial decode option is 
license-enabled.
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Setup for USB PD Signals

To set up the oscilloscope to capture USB PD signals:

1 Connect an oscilloscope channel to the signal in the device under test.

Analog channels can be used.

2 Choose Main Menu > Analyze > Serial Decode.

3 Click the Serial softkey, select Serial 1 or Serial 2, and click the softkey again to 
enable decode.

4 Click the Mode softkey; then, select USB PD.

5 Click the Source softkey; then, select the channel for the signal.

6 Click the Threshold softkey; then, enter the signal threshold voltage level.

The threshold voltage level is used in decoding, and it will become the trigger 
level when the trigger type is set to the selected serial decode (Serial 1 or 
Serial 2).



USB PD Triggering and Serial Decode 28

Keysight M9241/42/43A PXIe Oscilloscopes SFP User's Guide 433

 

USB PD Triggering

To set up the oscilloscope to capture USB PD signals, see "Setup for USB PD 
Signals" on page 432.

When USB PD (Power Delivery) is selected as one of the serial bus decodes, you 
can trigger on USB PD signals.

To set up a USB PD trigger condition:

1 Choose Main Menu > Trigger > Trigger Menu.

2 In the Trigger Menu, click the Trigger Type softkey; then, select the serial decode 
(Serial 1 or Serial 2) of the USB PD signal.

3 Click the Trigger softkey and select the USB PD trigger mode:

• Preamble Start — triggers at the start of a preamble, which starts with 0.

• EOP — triggers at the end of packet.

• SOP — triggers on ordered set Sync-1, Sync-1, Sync-1, Sync-2.

• SOP' — triggers on ordered set Sync-1, Sync-1, Sync-3, Sync-3.

• SOP'' — triggers on ordered set Sync-1, Sync-3, Sync-1, Sync-3.

• SOP' Debug — triggers on ordered set Sync-1, RST-2, RST-2, Sync-3.

• SOP'' Debug — triggers on ordered set Sync-1, RST-2, Sync-3, Sync-2.

• Hard Reset — triggers on ordered set RST-1, RST-1, RST-1, RST-2.

• Cable Reset — triggers on ordered set RST-1, Sync-1, RST-1, Sync-3.

• CRC Error — triggers when an error is detected on a 32-bit CRC.

• Preamble Error — triggers when an error is detected on a 64-bit sequence of 
alternating 0 and 1.

• Header Content — triggers on a user-defined 16-bit value.

In this mode, additional softkeys let you further set up the trigger mode.

4 When the Header Content trigger mode is selected, click the Header Type softkey 
to select the header type:

• Control Message — triggers on control message types (0 data object). Click 
the Message Type softkey to select the control message.

• Data Message — triggers on data message types (1 or more data objects). 
Click the Message Type softkey to select the data message.

• Extended Message — triggers on extended message types (bit 15 is set). Click 
the Message Type softkey to select the extended data message.
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• Value — triggers on a user-defined header value. Click the Base softkey to 
specify the number base, and click the Header softkey to enter the value.

5 Also when the Header Content trigger mode is selected, there is a Qualifier 
softkey that can further qualify the trigger:

• None — There is no additional qualifier for the trigger.

• SOP — The trigger occurs on Sync-1, Sync-1, Sync-1, Sync-2 ordered sets 
only.

• SOP' — The trigger occurs on Sync-1, Sync-1, Sync-3, Sync-3 ordered sets 
only.

• SOP'' — The trigger occurs on Sync-1, Sync-3, Sync-1, Sync-3 ordered sets 
only.

NOTE If the setup does not produce a stable trigger, the USB PD signals may be slow enough that 
the oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.

NOTE To display USB PD serial decode, see "USB PD Serial Decode" on page 435.
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USB PD Serial Decode

To set up the oscilloscope to capture USB PD signals, see "Setup for USB PD 
Signals" on page 432.

To set up USB PD serial decode:

1 Choose Main Menu > Analyze > Serial Decode to display the Serial Decode Menu.

2 If the decode line does not appear on the display, choose Main Menu > Analyze > 
Serial Decode again to turn it on.

3 If the oscilloscope is stopped, choose Main Menu > Run/Stop to acquire and 
decode data.

You can use the horizontal Zoom window for easier navigation of the acquired data.

See Also • "Interpreting USB PD Decode" on page 436

• "Interpreting USB PD Lister Data" on page 437

NOTE For USB PD triggering setup see "USB PD Triggering" on page 433.

NOTE If the setup does not produce a stable trigger, the USB PD signals may be slow enough that 
the oscilloscope is AutoTriggering. Click the Run/Stop status in the upper-right corner of the 
display, and change the trigger mode from Auto to Normal.
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Interpreting USB PD Decode

The USB PD decode is displayed as a single bus, with one decode line positioned 
at the bottom of the waveform area, time-aligned with the associated physical 
signal. Above the decode line is abbreviated symbolic decode information, shown 
in white, that describes the header's port power role (bit 8), port data role (bit 5), 
and message type (bits 4-0).

The decode line shows a blue idle line until the preamble is reached, at which point 
the start of frame angle bracket (<) is drawn in blue. The end of frame angle 
bracket (>) is drawn in blue at the end of the EOP, followed by a blue idle line. The 
fields and hex data within a packet are distinguished by color:

• SOP* (blue)

• Message Header (yellow)

• Extended Message Header (yellow)

• Data (white)

• CRC (green)

• EOP (blue)

When errors occur, a red error frame is drawn until a valid idle signal is detected. 
For CRC errors, the decoded text is shown in red. For preamble errors, "PError" is 
shown in red.
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Interpreting USB PD Lister Data

In addition to the standard Time column, the USB PD Lister contains these 
columns:

• ORD Set — the ordered set type.

• Header — the header type and value.

• Data — the data or extended message.

• CRC — value in Hex.

• Errors — string value that displays the type of error detected.
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Index

Symbols

(-) Width measurement, 229
(+) Width measurement, 229

Numerics

1 M ohm input impedance, 57
50 ohm input impedance, 57

A

About Oscilloscope, 315
absolute value math function, 85
AC channel coupling, 56
AC RMS - Full Screen measurement, 225
AC RMS - N Cycles measurement, 225
accessories, 20
acquire, 183
acquisition memory, 134
acquisition memory, saving, 297
acquisition mode, 190
acquisition mode, averaging, 193
acquisition mode, high resolution, 195
acquisition mode, normal, 190
acquisition mode, peak detect, 191
acquisition mode, preserve during 

Autoscale, 308
acquisition modes, 183
active serial bus, 352, 371, 427
actual sample rate, 189
adaptive persistence, 118
adding measurements, 213
addition math function, 70
address with no ack condition, I2C 

trigger, 367
adjacent channel power ratio (ACPR) FFT 

analysis measurement, 237
AERO license, 320
aliasing, 186
aliasing, FFT, 82
alternating edge trigger, 137
AM (amplitude modulation), waveform 

generator output, 287
Amplitude measurement, 221
amplitude modulation (AM), waveform 

generator output, 287
analog channel, probe attenuation, 61
analog channel, setup, 51
analog filters, adjusting, 76

analysis results, saving, 295
Analyze Segments, 197, 198, 243
annotation, adding, 123
antialiasing, disabling/enabling, 125
arbitrary generated waveforms, 

editing, 277
arbitrary waveform generator output, 275
arbitrary waveforms, copying from other 

sources, 282
arbitrary waveforms, creating new, 278
arbitrary waveforms, editing existing, 279
Area - Full Screen measurement, 236
Area - N Cycles measurement, 236
ARINC 429 serial decode, 404
ARINC 429 totalizer, 406
ARINC 429 trigger, 402
ARINC 429 words/errors counter, 406
ARINC 429 decode, signal speed, 400
ARINC 429 decode, signal type, 400
ARINC 429 decode, word format, 404
ASCII file format, 294
ASCII XY data, 297
attenuation, probe, 61
attenuation, probe, external trigger, 182
attenuators, 63
Auto Increment, 300
AUTO license, 320
Auto Setup, FFT, 78
Auto trigger mode, 176
Auto? trigger indicator, 177
automatic measurements, 211, 216
AutoProbe interface, 57
Autoscale, 20
Autoscale preferences, 307
Aux Out connector, 312
Aux Out signal and zone qualified 

trigger, 172
Average - Full Screen measurement, 224
Average - N Cycles measurement, 224
average measurement trend, 94
averaged value math function, 90
averaging acquire mode, 190, 193
Ax + B math function, 84

B

band pass filter math function, 90
bandwidth, 315
bandwidth limit, 58
bandwidth required, oscilloscope, 188
bandwidth, oscilloscope, 186
bandwidth, realtime sampling, 196

Bartlett FFT window, 77
base 10 exponential math function, 87
Base measurement, 222
BIN file format, 294
binary data (.bin), 323
binary data file examples, 326
binary data in MATLAB, 323
binary data, example program for 

reading, 326
binary mode cursors, 205
bit rate measurement, 230
Blackman Harris FFT window, 77
blanking, 42
BMP file format, 294
Bode plot, frequency response 

analysis, 271
brick-wall frequency response, 187
built-in help, 21
burst width measurements, 229
burst, capture signal bursts, 197
BW Limit? in DVM display, 262

C

calibrate probe, 63
calibration, 314
CAN decode, source channels, 334
CAN FD standard, 336
CAN frame counter, 343
CAN serial decode, 341
CAN symbolic data, 337
CAN totalizer, 343
CAN trigger, 338
CANFD license, 320
capture signal bursts, 197
cardiac waveform generator output, 276
Center, FFT, 76
channel labels, 127
channel power FFT analysis 

measurement, 237
channel, analog, 51
channel, bandwidth limit, 58
channel, coupling, 56
channel, fine adjustment, 59
channel, invert, 60
channel, position, 55
channel, probe external scaling, 62
channel, probe units, 61
channel, skew, 63
channel, vertical sensitivity, 54
characteristics, 20
chart serial signal math function, 95
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clear display, 120, 192
clear display, Quick Clear Display, 317
clear persistence, 118
Clock Extension Peripheral Interface (CXPI) 

serial analysis, license, 321
common logarithm math function, 86
COMP license, 321
compensate passive probes, 20
connections for frequency response analysis 

(FRA), 268
copyright, 2
counter, 264
Counter measurement, 228
counter, ARINC 429 words/errors, 406
counter, CAN frame, 343
counter, UART/RS232 frame, 428
coupling, channel, 56
coupling, trigger, 178
crosstalk problems, 76
CSV data, 297
CSV file format, 294
CSV files, minimum and maximum 

values, 330
cursor measurements, 203
cursor units, 206
cursors, binary, 205
cursors, gated measurement window, 241
cursors, hex, 205
cursors, manual, 205
cursors, measure mode, 205
cursors, track waveform, 205
custom location, time reference, 46
CXPI decode, interpreting, 361
CXPI decode, signal setup, 356
CXPI license, 321
CXPI Lister data, 362
CXPI serial decode, 360
CXPI trigger, 357
Czech user interface, 22

D

d/dt math function, 72
DC channel coupling, 56
DC offset correction for integrate 

waveform, 74
DC RMS - Full Screen measurement, 224
DC RMS - N Cycles measurement, 224
DC signals, checking, 177
DC waveform generator output, 275
DDR burst, random trigger holdoff, 181
dead time (re-arm), 198
decaying average approximation, 91
decibels, FFT vertical units, 77
decimating samples, 189
decimation, for measurement record, 330
decimation, for screen, 330
default setup, 20, 304
defaults, waveform generator, 291
Delay measurement, 216, 231
delay time indicator, 46

delay, adjusting, 38
delayed sweep, 43
delete file, 306
depth, AM modulation, 288
detection type, FFT (Magnitude), 77
deviation, FM modulation, 289
differentiate math function, 72
digital voltmeter (DVM), 262
Digitizer mode, 200
digits, counter resolution, 265
display multiple acquisitions, 184
display, clear, 120
display, interpreting, 20
display, persistence, 118
display, signal detail, 116
displayed channels Autoscale, 307
distortion problems, 76
Divide math function, 71
dual-channel (N2820A probe) 

measurements, 218
Duty cycle measurement, 229
duty cycle measurement trend, 94
DVM (digital voltmeter), 262

E

edge speeds, 188
edge then edge triggering, 139
edge triggering, 137
editing measurements, 215
EEPROM data read, I2C trigger, 367
either edge trigger, 137
e-mail setups, images, or data, 301
e-mail, Quick Email, 317
EMBD license, 321
energy of a pulse, 73
English user interface and Quick Help, 22
envelope math function, 91
envelope, max/min, 93
environmental characteristics, 20
event table, 111
expand about, 54, 307
expand about center, 307
expand about ground, 307
exponential fall waveform generator 

output, 276
exponential math function, 87
exponential rise waveform generator 

output, 275
exporting waveform, 293
EXT TRIG IN as Z-axis input, 42
external scaling, probe, 62
external trigger, 182
external trigger, input impedance, 182
external trigger, probe attenuation, 182
external trigger, probe units, 182

F

factory default settings, 304

Fall time measurement, 230
fall time measurement trend, 94
falling edges count measurements, 235
fast debug Autoscale, 307
FFT (Magnitude) detection type, 77
FFT aliasing, 82
FFT analysis measurements, 237
FFT DC value, 81
FFT gating, 77
FFT magnitude math function, 75
FFT measurement hints, 80
FFT peaks, searching, 79
FFT phase math function, 75
FFT resolution, 80
FFT spectral leakage, 83
FFT units, 81
FFT vertical units, 77
FFT window, 76
file explorer, 306
file format, ASCII, 294
file format, BIN, 294
file format, BMP, 294
file format, CSV, 294
file format, PNG, 294
file name, new, 300
file, save, recall, load, 306
filter math function, averaged value, 90
filter math function, band pass, 90
filter math function, envelope, 91
filter math function, high pass and low 

pass, 89
filter math function, smoothing, 91
filters, math, 89
fine adjustment, channel, 59
fine adjustment, horizontal scale, 45
firmware updates, 322
Flat top FFT window, 76
FM (frequency modulation), waveform 

generator output, 288
folding frequency, 186
forcing a trigger, 136
FRA (frequency response analysis), 267
FRA license, 321
frame trigger, I2C, 368
frame, LIN symbolic, 350
freeze display, 317
freeze display, Quick Freeze Display, 317
French user interface and Quick Help, 22
frequency counter, 265
frequency data in CSV files, 331
frequency deviation, FM modulation, 289
Frequency measurement, 228
frequency measurement trend, 94
frequency modulation (FM), waveform 

generator output, 288
frequency peaks, searching, 79
frequency response analysis (FRA), 267
frequency response analysis data, 

save, 272
frequency, Nyquist, 186
frequency-shift keying modulation (FSK), 

waveform generator output, 290
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FSK (frequency-shift keying modulation), 
waveform generator output, 290

G

gated by cursors measurement 
window, 241

gating, FFT, 77
Gaussian frequency response, 187
Gaussian pulse waveform generator 

output, 276
Generic video trigger, 162
German user interface and Quick Help, 22
glitch capture, 191
glitch trigger, 141
golden waveform test, 247
graphical user interface language, 22
graticule intensity, 122
graticule type, 121
grid intensity, 122
grid type, 121
ground level, 52

H

Hanning FFT window, 76
hardware self test, 315
help, built-in, 21
hex mode cursors, 205
HF Reject, 180
high pass filter math function, 89
high-frequency noise rejection, 180
high-resolution mode, 190, 195
holdoff, 181
hop frequency, FSK modulation, 290
Horizontal controls, 40
horizontal position, adjusting, 38
horizontal scale fine adjustment, 45

I

I2C serial decode, 370
I2C trigger, 367
idle serial bus, 352, 371, 427
Impedance softkey, 57
increment statistics, 243
indeterminate state, 205
infinite persistence, 118, 184, 191
input impedance, analog channel input, 57
installed licenses, 315
instantaneous slope of a waveform, 72
Integrate math function, 73
intensity control, 116
interpolate, arbitrary waveform option, 278
invert waveform, 60
invert waveform generator output, 283
Italian user interface and Quick Help, 22

J

Japanese user interface and Quick Help, 22

K

keyboard shortcuts for 
run/stop/single, 184

Korean user interface and Quick Help, 22

L

label list, 131
label list, loading from text file, 131
labels, 127
labels, auto-increment, 130
labels, reset library, 132
language, user interface, 22
length control, 297
length softkey, 296
level, trigger, 135
LF Reject, 178
library, labels, 129
licenses, 320
limit testing, measurement, 244
LIN serial decode, 351
LIN symbolic data, 348
LIN trigger, 349
Lister, 111
load file, 306
Load from, 300
Location, 300
Location, File Explorer softkey label, 306
logging remote commands, 313
logic presets, waveform generator, 285
low pass filter math function, 89
low-frequency noise rejection, 178

M

M9240AERB license, 320
M9240AUTB license, 320
M9240BDLB license, 320
M9240GENB license, 320
M9240NFCB license, 320
M9240PWRB license, 320
magnify math function, 92
Manchester serial decode, 381
Manchester trigger, 379
Manchester/NRZ serial analysis, 

license, 321
mask files, recall, 302
MASK license, 321
mask statistics, quick reset, 317
mask test, trigger output, 250, 312
mask testing, 247
mask, Aux Out signal, 312
math filters, 89

math functions, cascaded, 66
math operators, 70
math transforms, 72
math visualizations, 92
math, 1*2, 71
math, 1/2, 71
math, addition, 70
math, differentiate, 72
math, divide, 71
math, FFT magnitude/phase, 75
math, functions, 65
math, integrate, 73
math, multiply, 71
math, offset, 68
math, scale, 68
math, subtract, 70
math, units, 68, 69
math, using waveform math, 66
MATLAB binary data, 323
max envelope, 93
max hold math function, 93
maximum math function, 93
Maximum measurement, 220
maximum sample rate, 189
measure mode cursors, 205
measure statistics, quick reset, 317
measure, Quick Measure All, 317
measurement definitions, 216
measurement limit testing, 244
measurement record, 297
measurement statistics, 242
measurement thresholds, 239
measurement trend math function, 93
measurement window, 241
measurements, 216
measurements, add, 213
measurements, automatic, 211
measurements, delay, 216
measurements, edit, 215
measurements, overshoot, 217
measurements, phase, 217
measurements, preshoot, 217
measurements, time, 227
measurements, voltage, 220
MegaZoom IV, 3
memory depth and sample rate, 189
memory, segmented, 197
message, CAN symbolic, 339
MIL-STD-1553 serial decode, 396
MIL-STD-1553 trigger, 395
min envelope, 93
min hold math function, 93
minimum math function, 93
Minimum measurement, 221
missing acknowledge condition, I2C 

trigger, 367
Mode/Coupling key, trigger, 175
model number, 315
modulation, waveform generator 

output, 287
module installed, 315
modules, installing, 20
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multiple PCIe oscilloscope modules, 
coordinating, 173

Multiply math function, 71

N

N2820A high-sensitivity current probe, 218
N8900A Infiniium Offline oscilloscope 

analysis software, 294
natural logarithm math function, 86
navigate files, 306
navigating the time base, 49
Near Field Communication (NFC) trigger, 

license, 321
Near Field Communication (NFC) 

triggering, 150
negative pulse width measurement 

trend, 94
new label, 130
NFC license, 321
NFC triggering, 150
noise rejection, 179
noise waveform generator output, 275
noise, adding to waveform generator 

output, 286
noise, high-frequency, 180
noise, low-frequency, 178
noisy signals, 175
normal acquire mode, 190
normal mode, 190
Normal trigger mode, 176
notices, 2
NRZ license, 321
NRZ serial decode, 389
NRZ trigger, 387
Nth edge burst trigger, 153
Nth edge burst triggering, 153
number of negative pulses 

measurements, 234
number of positive pulses 

measurements, 234
Nyquist frequency, 82
Nyquist sampling theory, 186

O

occupied bandwidth FFT analysis 
measurement, 237

offset (DC) correction for integrate 
waveform, 74

operators, math, 70
OR trigger, 146
oscilloscope bandwidth, 186
oscilloscope bandwidth required, 188
oscilloscope rise time, 188
oscilloscope sample rate, 188
output load expected, waveform 

generator, 283
output settings, waveform generator, 283
output, trigger, 312

Overshoot measurement, 217, 222

P

pan and zoom, 37
passive probes, compensating, 20
pattern trigger, 143
peak detect mode, 190, 191
peak-peak math function, 93
Peak-peak measurement, 220
period counter, 265
Period measurement, 227
period measurement trend, 94
persistence, 118
persistence, clearing, 118
persistence, infinite, 184
Phase measurement, 217, 232
phase X cursor units, 206
PNG file format, 294
points per span, FFT (Magnitude), 78
Polish user interface and Quick Help, 22
Portuguese user interface and Quick 

Help, 22
position, analog, 55
positive pulse width measurement 

trend, 94
post-processing, 212
post-trigger information, 38
Power App measurements, 217
precision analysis record, 297
precision measurements and math, 246
predefined labels, 129
Preshoot measurement, 217, 223
Press to go, 300
Press to go, File Explorer softkey label, 306
pre-trigger information, 38
probe attenuation, 61
probe attenuation, external trigger, 182
probe external scaling, 62
probe head, 63
probe units, 61
probe, calibrate, 63
probes, 20
probes, connecting, 20
probes, passive, compensating, 20
PTYPE frames, CXPI, 357
pulse polarity, 141
pulse waveform generator output, 275
pulse width trigger, 141
PWR license, 321
PXI Triggger Menu, 173

Q

qualifier, pulse width, 142
Quick Action menu item, 317
Quick Clear Display, 317
Quick Email, 317
Quick Freeze Display, 317
Quick Help, 21

Quick Mask Statistics Reset, 317
Quick Measure All, 317
Quick Measure Statistics Reset, 317
Quick Recall, 317
Quick Save, 317
Quick Trigger Mode, 317

R

ramp waveform generator output, 275
random noise, 175
random trigger holdoff, 181
ratio measurement, 226
ratio measurement trend, 94
ratio X cursor units, 206
ratio Y cursor units, 206
raw acquisition record, 297
realtime sampling and oscilloscope 

bandwidth, 196
realtime sampling option, 196
re-arm time, 198
recall, 317
recall mask files, 302
recall setups, 302
recall, Quick Recall, 317
Rectangular FFT window, 77
Ref I/O connector, 309
reference point, waveform, 307
reference signal mode, 309
reference waveforms, 101
remote commands, logging, 313
required oscilloscope bandwidth, 188
reset label library, 132
restart condition, I2C trigger, 367
results, frequency response analysis 

(FRA), 271
return instrument for service, 316
Rise time measurement, 230
rise time measurement trend, 94
rise time, oscilloscope, 188
rise time, signal, 188
rise/fall time triggering, 148
rising edge count measurements, 234
RMS - AC measurement trend, 94
roll mode, 40
RS232 trigger, 424
runt pulses, 227
runt triggering, 154
Russian user interface and Quick Help, 22

S

sample rate, 3
sample rate and memory depth, 189
sample rate, current rate displayed, 36
sample rate, oscilloscope, 187, 188
sampling theory, 186
sampling, overview, 186
save, 317
save file, 306
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save segment, 296
save setup files, 295
save times, data, 298
Save to, 300
save, Quick Save, 317
saving data, 293
SCL, I2C trigger, 366
SDA, 366
SDA, I2C trigger, 366
segmented memory, 197
segmented memory, re-arm time, 198
segmented memory, saving segments, 296
segmented memory, statistical data, 198
Selected, File Explorer softkey label, 306
self test, hardware, 315
SENSOR license, 321
SENT data, searching, 420
SENT decode, interpreting, 416
SENT decode, signal setup, 410
SENT fast signals definition, 412
SENT Lister data, 419
SENT serial decode, 416
SENT trigger, 414
serial clock, I2C trigger, 366
serial data, 366
serial data, I2C trigger, 366
serial number, 315
serial signal chart, 95
service functions, 314
setup and hold triggering, 156
setup files, saving, 295
setup, frequency response analysis 

(FRA), 269
setups, recall, 302
shipping precautions, 316
shortcuts (keyboard) for 

run/stop/single, 184
Sigma, minimum, 250
signal, CAN symbolic, 339
signal, inputting, 20
signal, LIN symbolic, 350
Simplified Chinese user interface and Quick 

Help, 22
sinc waveform generator output, 275
sine waveform generator output, 275
single-shot acquisitions, 177
single-shot events, 184
single-shot, waveform generator, 284
skew, analog channel, 63
Slew Rate measurement, 236
slope trigger, 137
smoothing math function, 91
Snapshot All measurements, 218
snapshot all, quick action, 317
soft front panel (SFP), opening, 20
soft front panel (SFP), using, 21
softkey label buttons, 6
software updates, 322
software version, 315
software, installing, 20
Span, FFT, 76
Spanish user interface and Quick Help, 22

specifications, 20
spectral leakage, FFT, 83
square math function, 85
square root, 83
square waveform generator output, 275
square waves, 187
start condition, I2C, 367
Start Freq, FFT, 76
startup guide information, 20
statistics, increment, 243
statistics, mask test, 252
statistics, measurement, 242
statistics, using segmented memory, 198
status, User Cal, 315
Std Deviation measurement, 225
stop condition, I2C, 367
Stop Freq, FFT, 76
storage locations, navigate, 300
subtract math function, 70
sweep frequencies, frequency response 

analysis, 269
symbolic data, CAN, 337
symbolic data, LIN, 348
sync pulse, waveform generator, 284

T

test, mask, 247
Thai user interface and Quick Help, 22
theory, sampling, 186
threshold, analog channel 

measurements, 239
Time at Edge measurement, 230
time measurements, 227
time reference indicator, 46
time, re-arm, 198
timebase, 40
times for saving data, 298
Top measurement, 221
total harmonic distortion (THD) FFT analysis 

measurement, 238
totalize counter, 265
totalizer, ARINC 429, 406
totalizer, CAN, 343
totalizer, UART/rs232, 428
tracking cursors, 205
Traditional Chinese user interface and Quick 

Help, 22
transforms, math, 72
transmit single-shot, waveform 

generator, 284
Trig'd trigger indicator, 177
Trig'd? trigger indicator, 177
trigger coupling, 178
trigger indicator, Auto?, 177
trigger indicator, Trig'd, 177
trigger indicator, Trig'd?, 177
trigger level, 135
trigger mode, auto or normal, 176
trigger mode, Quick Trigger Mode, 317
trigger output, 312

trigger output, mask test, 250, 312
trigger qualified event signal, 

counting, 264
trigger signal, raw, 312
trigger type, ARINC 429, 402
trigger type, CAN, 338
trigger type, CXPI, 357
trigger type, edge, 137
trigger type, edge then edge, 139
trigger type, glitch, 141
trigger type, I2C, 367
trigger type, LIN, 349
trigger type, Manchester, 379
trigger type, MIL-STD-1553, 395
trigger type, NFC, 150
trigger type, NRZ, 387
trigger type, Nth edge burst, 153
trigger type, OR, 146
trigger type, pattern, 143
trigger type, pulse width, 141
trigger type, rise/fall time, 148
trigger type, RS232, 424
trigger type, runt, 154
trigger type, SENT, 414
trigger type, setup and hold, 156
trigger type, slope, 137
trigger type, UART, 424
trigger type, USB PD, 433
trigger type, video, 158
trigger types, 133
trigger, definition, 134
trigger, external, 182
trigger, forcing a, 136
trigger, general information, 134
trigger, holdoff, 181
trigger, mode/coupling, 175
trigger, source, 137
trigger, zone qualified, 171
triggers, Aux Out signal, 312
Turkish user interface, 22

U

UART totalizer, 428
UART trigger, 424
UART/RS232 frame counter, 428
UART/RS232 license, 321
UART/RS232 serial decode, 426
under-sampled signals, 186
units, cursor, 206
units, external trigger probe, 182
units, math, 68, 69
units, probe, 61
updating software and firmware, 322
upgrade options, 320
USB PD decode, interpreting, 436
USB PD decode, signal setup, 432
USB PD Lister data, 437
USB PD serial analysis, license, 321
USB PD serial decode, 435
USB PD trigger, 433
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USBPD license, 321
user cal, 314
user calibration, 314
user interface language, 22
utilities, 305

V

V RMS, FFT vertical units, 77
variable persistence, 118
vertical expansion, 54
vertical offset, 55
vertical position, 55
vertical sensitivity, 54
Vertical Units, FFT, 77
VID license, 321
video trigger, 158
video trigger, custom Generic, 162
visualizations, math, 92
voltage measurements, 220

W

warranty, 2, 316
waveform generator, 273
waveform generator amplitude, frequency 

response analysis, 270
waveform generator defaults, 

restoring, 291
waveform generator expected output 

load, 283
waveform generator logic presets, 285
waveform generator output settings, 283
waveform generator sync pulse, 284
waveform generator sync pulse, Aux Out 

signal, 312
waveform generator, arbitrary 

waveforms, 277
waveform generator, invert output, 283
waveform generator, output 

single-shot, 284
waveform generator, waveform type, 274
waveform type, waveform generator, 274
waveform, cursor tracking, 205
waveform, intensity, 116
waveform, reference point, 307
waveform, saving/exporting, 293
WAVEGEN license, 321
white noise, adding to waveform generator 

output, 286
Width - measurement, 229
Width + measurement, 229
Window, FFT, 76

X

X at Max Y measurement, 233
X at Max Y on FFT, 217
X at Min Y measurement, 233

X at Min Y on FFT, 217
XY mode, 40

Y

Y at X measurement, 221

Z

Z-axis blanking, 42
zero phase reference, FFT (Phase), 78
zone qualified trigger, 171
zoom and pan, 37
zoom display measurement window, 241
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